Forum Replies Created

Viewing 22 posts - 1 through 22 (of 22 total)
  • Posted in:
  • 23. Juli 2018 at 21:39 #36745

    It still would be possible how it got this screwed up.
    What is able to crash avahi? I tried to install and uninstall bluetooth audio serveral times without success. Perhaps it was caused by that.

    22. Juli 2018 at 16:41 #36725

    I also like it when I can solve and answer my own issues 😉
    I copied over the and files from my working Raspi to my non working Raspi. Directory is /usr/lib/arm-linux-gnueabihf
    Restarted samba. And it’s working again.

    22. Juli 2018 at 16:21 #36724

    I got the idea on checking the SMB service.
    sudo sercice smbd status
    is telling me:
    smbd.service – LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: failed (Result: exit-code) since So 2018-07-22 07:02:14 CEST; 8h ago
    Process: 3257 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)

    When I do a
    systemctl status smbd.service
    sudo service smbd restart
    it’s telling me:

    Jul 22 15:42:47 medien smbd[1990]: Starting SMB/CIFS daemon: smbd/usr/sbin/smbd: error while loading shared libraries: cannot… directory
    Jul 22 15:42:47 medien smbd[1990]: failed!
    Jul 22 15:42:47 medien systemd[1]: smbd.service: control process exited, code=exited status=1
    Jul 22 15:42:47 medien systemd[1]: Failed to start LSB: start Samba SMB/CIFS daemon (smbd).
    Jul 22 15:42:47 medien systemd[1]: Unit smbd.service entered failed state.

    Even if I do the following:
    sudo apt-get install –reinstall samba-libs
    there are errors

    Job for smbd.service failed. See ’systemctl status smbd.service‘ and ‚journalctl -xn‘ for details.
    invoke-rc.d: initscript smbd, action „start“ failed.
    dpkg: Fehler beim Bearbeiten des Paketes samba (–configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:

    So samba seems to be pretty screwed up. At least somewhat’s wrong with – can I reinstall it somehow else? I’m really lost when it comes to libraries.
    Many thanks and best regards

    12. Dezember 2017 at 17:55 #32907

    Hi Heiner,
    I hope, you are well again. I’m suffering a cold too atm – but what gives me time for my raspi 😉
    I disabled the Wifi via the raspberry settings: „Disable Default WiFi Interface WLAN0 on RPI3“ and in the section „WLAN & LAN“ the „Load WLAN interface“ is ticked off.
    Have that been all/the right places to deactivatve Wifi? Because if I try to install Bluetooth now, the same thing happens: Nothing.

    I freshly installed M2P 2.45 on another Raspberry Pi 3 and installed Bluetooth there and it works at once. I recognizes, the installation process need way longer time and goes through way more routines than on the other Pi where it does not work.
    On the Pi where installation fails, the only output in the yellow box is:

    Bluetooth Installation gestartet
    Installation gestartet – Diese Meldung zeigt den aktuellen Status der Installation aller 3 Sekunden an. Wenn diese abgeschlossen ist verschwindet die Meldung und der Server läuft.
    Get:7 jessie/main Translation-en_GB [323 B]
    Get:8 jessie/main Translation-en [320 B]
    Get:9 jessie/main Translation-en_GB [323 B]
    Ign jessie/main Translation-en_GB
    Get:10 jessie/main Translation-en [320 B]
    Ign jessie/main Translation-en
    Ign jessie/main Translation-en_GB
    Ign jessie/main Translation-en
    Ign jessie/ui Translation-en_GB
    Ign jessie/ui Translation-en
    Ign jessie/contrib Translation-en_GB
    Ign jessie/contrib Translation-en
    Ign jessie/main Translation-en_GB
    Ign jessie/main Translation-en
    Ign jessie/non-free Translation-en_GB
    Ign jessie/non-free Translation-en
    Ign jessie/rpi Translation-en_GB
    Ign jessie/rpi Translation-en
    You need to choose pulse as audio output for your audioplayer AND run a X-Server (e.g. Jivelite – workaround for pulseaudio)
    Finished – now connect the Bluetooth dongle or Reboot Click here to reboot now


    • This reply was modified 3 years, 9 months ago by  muhackl.
    12. Dezember 2017 at 11:53 #32888

    when trying to install the Bluetooth support, nothing happens.
    After rebooting, the Bluetooth settings to add bluetooth devices does not show up. The Bluetooth page again just shows the button to „install bluetooth“.

  • Raspberry Pi 3
  • M2P 2.45 – IQaudiO
  • Squeezelite and Shareport disabled
  • Wifi enabled but Pi connected via LAN cable
  • Built in audio disabled
  • Booting into desktop
  • Squeezebox server installed
  • What other infos could be interesting?
    What log would be interesting for analysation?

    Many thanks and best regards.

11. Juli 2017 at 18:42 #29888

I contacted Hifiberry support.
To get this to work, you have to add/change the following to/in the /etc/mpd.conf

audio_output {
type „alsa“
name „sysdefault:CARD=sndrpihifiberry“
mixer_type „software“

As the Hifiberry Mini Amp does not support either Digital or Hardware (or Master) volume control via ALSA.

2. März 2017 at 17:27 #27412

I managed getring it to work by setting the internal wifi to WLAN1 and adding a wifi stick as WLAN0. It connects at once via WPS. So I really don’t think it’s my router (AVM Fritz Box 7390, one of the most sold in Germany).

1. März 2017 at 21:41 #27383

Hi Mohammad,
I’m sorry, but this did not work.

  • Burned 2.41 on micro sd
    First boot – did not activate WPS on my router
    Waited until second boot after expansion of file system
    Activated WPS on router
    Did not connect
    Activated WPS on router again
    Rebooted Pi
    Did not connect
  • Any other ideas I could try? Can I use a external wifi stick and deactivate the internal wifi module?

    8. Februar 2017 at 21:35 #26766

    Hi Mohammad,
    sadly, the message does not disappear after reboot. I’m not using a Raspberry Pi, but an Allo Sparky. Also, there is no firmware folder.
    At least, when using the Volumio image, there is the firmware folder with according sub-folders.
    Changing volume also works as expected.
    You will have to put some work in your software to be satisfying – having to change subwoofer level seperately can be considered a usability fault.
    To be able to change it separately and the whole volume level adjusts relatively to it would be a great feature.

    4. Dezember 2016 at 16:35 #24537

    nope, sorry – still does not work. I gave up.


    10. November 2016 at 23:47 #23870

    thanks for the hints.
    – The SD card is not full.
    – The VNC client is not responsible.
    I figured out that I get a black screen, after I rebooted via terminal shutdown input.
    As soon as I reboot via M2P web interface, VNC works perfectly.


    23. Oktober 2016 at 16:47 #23527

    my experience so far: I works perfectly with the raspberry pi zero. Just select the hifiberry dac as soundcard. Totally comatible.
    Best regards

    20. Oktober 2016 at 11:23 #23465

    I’m using the same constellation. But I am not able to get the touchscreen working with jivelite. As soon as I install the touch drivers, jivelite no longer starts – an error message is showing.

    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen

    JiveLite 0.1.0
    [0;33m20161017 16:40:29.920 INFO jivelite – JiveMain.lua:267 JiveLite version 0.1.0[0m
    [0;33m20161017 16:40:29.921 INFO jivelite.ui.draw – jiveL_initSDL:227 initSDL[0m
    [0;31m20161017 16:40:29.936 ERROR jivelite.ui.draw – jiveL_initSDL:234 SDL_Init(V|T|A): Unable to open a console terminal

    This is what the driver script is trying to do:
    for lines in cat ./boot/mark
    case ${i} in
    1) var1=${lines};;
    i=expr ${i} + 1
    #echo “$var1”

    if test “$var1” = “0”;then
    sudo mkdir /etc/X11/xorg.conf.d
    echo “1” > ./boot/mark

    if test “$1” = “0” -o “$#” = “0”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt /boot/config.txt
    echo “LCD configrue 0”
    elif test “$1” = “90”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-90 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-90 /boot/config.txt
    echo “LCD configrue 90”
    elif test “$1” = “180”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-180 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-180 /boot/config.txt
    echo “LCD configrue 180”
    elif test “$1” = “270”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-270 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-270 /boot/config.txt
    echo “LCD configrue 270”

    sudo cp ./cmdline.txt /boot/
    sudo cp ./inittab /etc/
    sudo cp -rf ./usr/share/X11/xorg.conf.d/99-fbturbo.conf-HDMI /usr/share/X11/xorg.conf.d/99-fbturbo.conf

    if test “$#” = “0” -o “$1” = “0” -o “$1” = “90” -o “$1” = “180” -o “$1” = “270”; then
    sudo reboot
    echo “reboot now”
    echo “Invalid parameter,Usage:LCD5-show [0] [90] [180] [270]”

    Have you been able to get this screen with touch functionality to work together with jivelite? And if yes – how?

    Many thanks and best regards

    20. Oktober 2016 at 11:21 #23464

    and thanks a lot. I also hav been able to resolve the solution issue.
    The problem – the same as for martin-s – the touch capability for the screen won’t work unless you install the drivers. But after installing the drivers, jivelite no longer starts.
    I try to contact martin-s via his post – maybe he got the solution in the meanwhile.

    13. Oktober 2016 at 19:07 #23409

    I just wanted to come back to this issue and ask, if there are any news or new ideas?
    I really loved to have just one single power supply.
    I tried removing the WIFI stick. Also I removed the overclocking. Nothing helped.
    The Pi even reboots at the moment I plug in a external harddrive.
    I would really appreciate if there was any solution because the way I want to use the Pi with M2P and display is its absolute origin.
    Many thanks and best regards

    8. Oktober 2016 at 9:30 #23317

    Dear Christoph,
    I was happy to see the new features of this plugin and becaus of Siri integration and Home Kit I wanted to give it a try.
    I installed the plugin after updating M2P to 2.37.
    After the installation an reboot, the Sppech Control Plugin Page is showing me this:

    Enable speech communication for your Max2Play device!
    This plugin is still in development. Make sure no audioplayer is running while using Jasper.

    This happens on installation:

    Jasper Framework gets installed and configured
    The TextToSpeech Engine ESpeak gets installed and configured
    SpeachToText Engine SphinxBase and Pocketsphinx get installed

    Install Speech Control on this device. You need a microphone connected to your device (probably with USB).

    Ne settings. No clue of it beeing installed.
    Except the debug info. It is telling me the following:

    #### JASPER Installed ####

    #### ESPEAK Installed ####
    #### POCKETSPHINX Installed ####

    #### JASPER Running ####

    It is a Raspberry Pi 3. I used the standard M2P image – I think I started with version 2.34 on this machine.
    I have no oher plugins except Hifiberry and Kodi installed and active.
    I recognized I had the audioplayer (squeezelite) running while and after first installation.
    I stopped it and prevented it from starting after boot. Then started installation of speech recognition again. Did not change a thing.
    I even attached an USB microphone.
    The Home-App on iOS 10 (iPhone 7 Plus) does not find the Raspberry Pi.

    Do you have a clue what could be wrong?

    Meanwhile I tested the same thing on a Raspberry Pi 2 (M2P 2.37). Also with Hifiberry and Kodi but with audioplayer disabled before installing it for the first time. Here, installation of the plugin worked. BUT: Obviously the service doea not start. When I klick the start button, the message above reads: Install Jasper, Google STT, ESpeak TTS. Something went wrong on the last installation attempt. Delete installation files and try again.

    Many thanks and best regards

    29. August 2016 at 13:29 #22694

    Hi Christoph,

    I’m sorry I forgot to mention in my second post too, that I already activated max usb current (and even checkt it in the config.txt).

    Regarding the additional 2,5A power supply I’m a little bit confused. Where exactly should I plug it in?
    At the moment, I am powering the display via GPIO jumpers / cables. 5V+- from the pi GPIOs to the power input pins of the display board.
    Wouldn’t it make more sense to power the display separately? The official raspberry pi page is talking about 500 mA that are needed´(
    I think, I’ll try this one first. But it really would be a pitty if I needed two seperate power supplies as I am planning to integrate the display and the amp in a box and just wanted one single cable to plug into an power inlet.

    I’m looking forward to any further ideas and hope we will get the display and the harddrive powered by one supply.


    28. August 2016 at 17:20 #22679

    Hi Christoph,
    I’m sorry, but this is not true. To test it, I set up a new Raspberry Pi 2 with a Hifiberry Amp + and Max2Play latest version.
    I’m using a Editmax Wifi stick. The only thing that differs from the system described above is the display. I did not use or attach a display.
    I used the same harddrive as above. Works perfectly!
    So I assume the power supply has got to do with the display. As it does not consume this much power, I’m really hoping I can use a harddrive additionally.
    Appreciate any help how to make this possible.
    Many tanks and best regards

    13. August 2016 at 13:53 #22245

    well – as it sometimes happenes, problems almost solve themselves.
    I installed LMS 7.8 nightly. After that installed 7.9 nightly. And then it worked. Server is coming up.
    Fine. Whyever. But it works.
    Best regards

    2. August 2016 at 19:45 #21978

    if I do so, it tells me:
    5 S 0 458 1 0 80 0 – 454 hrtime ? 00:00:03 hd-idle
    What does it mean?
    Many thanks and best regards

    27. März 2016 at 16:26 #19474

    So if anybody is facing the same issue: Just select „IQaudio Pi-DAC+“. This works because this sound card is built the same way than the Pi-DAC Zero. Would be nice if the Max2Play Documentation would mention this. Also activiating this sound card in the IQaudIO menu or ins the „Raspberry settings“ did not make it selectable in the „Audioplayer“ menu out of the box. I had to ad the entry „dtoverlay=iqaudio-dacplus“ to the /boot/config.txt of the raspberry pi. After that, the sound card was selectable in the „Audioplayer“ menu.

    10. Oktober 2015 at 15:18 #16262

    Too easy. The Pi did not get along with the option „nobootwait“ when trying to mount. Deleted it in fstab. Auto mounts perfectly!

    • This reply was modified 5 years, 11 months ago by  muhackl.
    Viewing 22 posts - 1 through 22 (of 22 total)