Black screen after VNC connection

Max2Play Home Forums Max2Play Add-ons Black screen after VNC connection

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • 1. November 2016 at 16:55 #23629

    Hi dear M2P forum,
    I am using the following setup:
    Raspberry Pi3, M2P 2.37, IqaudiO Amp, Squeezelite as audioplayer, LAN connection. NO Kodi!
    I am autostarting the desktop.
    I installed VNC 0.9.13-1.2 and start it with the following parameters: -forever -noxdamage
    I connect to it via (Real) VNC Viewer 5.3.0 (r15303) x64 on my mac.
    It worked for a while and I even got a full screen image that used the resolution of my monitor (1920 x 1080).
    One day, I wanted to connect to the Raspberry Pi via VNC but it just showed a black screen. Rebooting the Pi or stopping and starting the VNC server has no effect. When I connect a display to the HDMI port, the desktop shows and works fine.
    Any idea what could have gone wrong?
    Many thanks and best regards

    9. November 2016 at 16:16 #23836

    Dear muhackl,

    Please check the following:

    – Is the SD card already full? You can check this in the menu Settings / Restart.

    – Please check that it is not on the VNC viewer is. We use the TightVNC Viewer here.

    If you can exclude all this, please go to the Raspberry settings and adjust your display resolution under the HDMI settings. Set a hook for HDMI Force Hotplug and select the HDMI mode.

    Than reboot your device and try it again.

    Best Regards

    10. November 2016 at 23:47 #23870

    thanks for the hints.
    – The SD card is not full.
    – The VNC client is not responsible.
    I figured out that I get a black screen, after I rebooted via terminal shutdown input.
    As soon as I reboot via M2P web interface, VNC works perfectly.


Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here