5" HDMI Touch Display ?

Tagged: 

This topic contains 6 replies, has 4 voices, and was last updated by  muhackl 1 month, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 14. August 2016 at 13:38 #22256

    Hallo zusammen,
    bin vor kurzem von Squeezeplug auf max2play “umgestiegen” und habe die Möglichkeiten entdeckt, max2play auch mit einem Display zu betreiben. Ich habe hier zwar ein 2.8″ Display, welches mir aber ehrlich gesagt zu klein ist. Ich habe von einer anderen Spielerei noch ein 5″ Display für den Pi B hier, das auch einwandfrei funktioniert… vorausgesetzt, man installiert die “beiligenden” Einstellungen usw, die in einem fertigen Image enthalten sind, welches beim Display dabei war. Dann funktioniert alles bestens. Wenn ich nun max2play für das 7″ Display installiere bekomme ich auch ein Bild, logischerweise passt die Grösse noch nicht, aber das ist das kleinere Problem.

    Ich wüsste nun gerne, ob sich jemand schonmal mit einem 5″ Display an max2play gewagt hat und evtl die unsaubere Anzeige schon behoben hat ?

    Ecktdaten :
    5 inch Display,
    XPT2046 Touch Controller,
    Anschluss über HDMI Port und GPIO-Ports
    Hersteller Waveshare

    Wie gesagt, max2play läuft komplett, Anzeige ist da aber halt nicht angepasst an die 5″
    Touch funktioniert auch noch nicht…

    Gruss
    Martin

    14. August 2016 at 14:49 #22257

    Moin,
    so, dann führe ich hier mal ein Selbstgespräch. Wer also ein Waveshare 5″ Display mit Touch laufen lassen will, hier der Weg dahin (zumindest, daß es läuft und Touch funktioniert). Bei der Standardinstallation des Pi erscheint bei dem besagten Display ein schwarzer, senkrechter viel zu breiter Balken im Display, den man aber mit ein paar Einstellungen in der config.txt verscheuchen kann.

    Ihr braucht einen SSH-Zugriff auf den Pi (Login pi und password raspberry).

    Dann den Root-User (Master of Alles) freischalten mit “sudo passwd” und ein neues Passwort für den King-Dingeling eingeben (und merken)

    Nun könnt ihr euch mit “su” als root anmelden und Unfug treiben… (bitte erkundigt euch, wenn ihr es noch nicht wisst, was der root genau ist !! Ihr könnt mit diesem Account ein komplettes Linux System schlachten !!!)

    Als root führt ihr dann folgendes auf der Kommandozeile aus :

    cd /boot
    nano config.txt

    Die Datei config.txt im Verzeichnis /boot erhält dann folgende Zeilen zusätzlich, damit beim Boot das Display und der Touchcontroller aktiviert werden :

    gpu_mem=32 (könnt Ihr auf dem Wert stehen lassen, den Max2Play da eingetragen hatte, bei mir 128)
    framebuffer_ignore_alpha=1
    framebuffer_swap=1
    disable_overscan=1
    init_uart_clock=16000000
    hdmi_group=2
    hdmi_mode=1
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0
    dtparam=spi=on
    dtoverlay=ads7846,penirq=25,speed=10000,penirq_pull=2,xohms=150

    Mit CTRL-X und einem “y” als Bestätigung, daß die Datei gespeichert werden soll, gehts zurück auf die Konsole (Kommandozeile)

    Nachdem ihr diese Werte eingetragen habt,bootet den Pi über das Max2Play Menu neu, nicht von der Kommandozeile !!

    Es kann sein, daß der Pi beim ersten Reboot irgendwo hängen bleibt, aber schon per Webinterface erreichbar ist. Dann einfach nochmal
    reboot und dann hats zumindest bei mir funktioniert…

    Nun forsche ich weiter nach Einzelheiten um das Ganze sauber laufen zu lassen…

    – Kalibration des Touchcontrollers
    – Anpassung der Auflösung bzw der Anzeige (aktuell wird irgendwie die 2.8″ Version angezeigt)

    Gruss
    Martin

    • This reply was modified 3 months, 3 weeks ago by  martin-s. Reason: Ergänzung
    14. August 2016 at 22:28 #22266

    Nächster Schritt in die richtige Richtung.

    Das JiveLite Ding ist scheinbar von einem Menschen aus den USA gebaut und hier integriert worden. Also auf seiner Seite ein wenig gestöbert und siehe da : In der JiveLite Oberfläche auf dem Pi kann man ein Skin namens Joggler Skin auswählen und siehe da, das passt perfekt zur Auflösung des 5″ Displays. Wie dafür gemacht.

    Das Thema Auflösung… erledigt !

    Nun noch das Thema Kalibration des Touchcontrollers, da im Randbereich extrem ungenau

    26. August 2016 at 12:47 #22611

    Hello martin-s,

    Thank you for your engagement. We added this into our new Max2Play Update. You can see it in changelog.

    https://www.max2play.com/en/changelog-max2play/

    26. August 2016 at 21:51 #22668

    Ok,

    thanks for that reply. Sounds good…

    Although I could not fix the problem with the touchscreen unless searching google several times for a solution. But I guess, that it is not a max2play issue more than an issue of debian… will report further when I found a solution.

    28. August 2016 at 17:56 #22680

    Hi! I have the Waveshare 5″, I need to install the propietary drivers from the Waveshare website?

    For the moment I only changed de “size” paramiters from the config.txt file as root user, but I would like to have the touch screen functionality too.

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    max_usb_current=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0

    Thanks
    Bull

    20. October 2016 at 11:23 #23465

    Hi,
    I’m using the same constellation. But I am not able to get the touchscreen working with jivelite. As soon as I install the touch drivers, jivelite no longer starts – an error message is showing.

    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen

    JiveLite 0.1.0
    [0;33m20161017 16:40:29.920 INFO jivelite – JiveMain.lua:267 JiveLite version 0.1.0[0m
    [0;33m20161017 16:40:29.921 INFO jivelite.ui.draw – jiveL_initSDL:227 initSDL[0m
    [0;31m20161017 16:40:29.936 ERROR jivelite.ui.draw – jiveL_initSDL:234 SDL_Init(V|T|A): Unable to open a console terminal
    [0m

    This is what the driver script is trying to do:
    i=1
    for lines in cat ./boot/mark
    do
    case ${i} in
    1) var1=${lines};;
    esac
    i=expr ${i} + 1
    done
    #echo “$var1”

    if test “$var1” = “0”;then
    sudo mkdir /etc/X11/xorg.conf.d
    echo “1” > ./boot/mark
    fi

    if test “$1” = “0” -o “$#” = “0”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt /boot/config.txt
    echo “LCD configrue 0”
    elif test “$1” = “90”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-90 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-90 /boot/config.txt
    echo “LCD configrue 90”
    elif test “$1” = “180”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-180 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-180 /boot/config.txt
    echo “LCD configrue 180”
    elif test “$1” = “270”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-270 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-270 /boot/config.txt
    echo “LCD configrue 270”
    fi

    sudo cp ./cmdline.txt /boot/
    sudo cp ./inittab /etc/
    sudo cp -rf ./usr/share/X11/xorg.conf.d/99-fbturbo.conf-HDMI /usr/share/X11/xorg.conf.d/99-fbturbo.conf

    if test “$#” = “0” -o “$1” = “0” -o “$1” = “90” -o “$1” = “180” -o “$1” = “270”; then
    sudo reboot
    echo “reboot now”
    else
    echo “Invalid parameter,Usage:LCD5-show [0] [90] [180] [270]”
    fi

    Have you been able to get this screen with touch functionality to work together with jivelite? And if yes – how?

    Many thanks and best regards
    Muhackl

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here