M2P 2.40 + RPi3 + Hifiberry Amp = no Wifi and WPS not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI M2P 2.40 + RPi3 + Hifiberry Amp = no Wifi and WPS not working

This topic contains 8 replies, has 4 voices, and was last updated by  Mbydeen 8 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 28. February 2017 at 23:11 #27355

    Hi,
    I’ve got the following set up:
    – Raspberry Pi3
    – Hifiberry Amp
    – M2P 2.40 really freshly flashed image on 8 GB SanDisk SDHC card
    – No LAN cable connected
    – 12V 6A power supply
    – HDMI monitor connected
    – nothing else connected (e.g. to USB)
    – especially no other WiFi USB dongle connected – I want to use the internal Wifi chip
    – FritzBox Fon WLAN 7390 Wifi router with WPS

    I do the following:
    – Activate WPS push button method on FritzBox router
    – First boot of Raspberry Pi just one second after starting WPS on router
    – Raspberry Pi boots up
    – Does not connect to Wifi via WPS
    – Boots a second time – I assume because of file system expansion
    – Also this time on second boot – no connection to router via WPS (that is still running)

    After thinking about how to disassembly the Pi the most viciously way, I rather try a second time:
    – Start WPS on FritzBox again
    – Reboot Raspberry Pi
    – Boots to OS without connecting to network

    Third try after updating to 2.41. Same thing

    As there is no browser preinstalled with which I would be able to enter the web interface via localhost, I have to give up and connect a LAN cable.
    The interface is telling me: WIFI adapter is active but connection is not.
    I can use WPS only if the LAN cable is not connected. Paradox!
    I click “start automatic wifi setup” and get the error message:
    Using for WPS
    ERROR creating connection
    Selected interface ‘wlan0’ OK

    I start a scan. My network cannot be found, even when the Pi resides 1 m next to my router. It just finds my neighbours Wifi.
    Load Wifi interface is not ticked. So I tick it, save, and get this message:
    Debug: Saving WPA-Supplicant (FAIL OK )
    Files saved

    Aaaaand Wifi interface is gone (Debug info: No more WLAN0). Because I loaded it? Pure logic.

    After a reboot and getting my WLAN0 back, I entered the network name and password manually. After saving, I get this:
    Debug: Saving WPA-Supplicant (Successfully initialized wpa_supplicant ctrl_iface exists and seems to be in use – cannot override it Delete ‘/var/run/wpa_supplicant/wlan0’ manually if it is not used anymore Failed to initialize control interface ‘/var/run/wpa_supplicant’. You may have another wpa_supplicant process already running or the file was left by an unclean termination of wpa_supplicant in which case you will need to manually remove this file before starting wpa_supplicant again. )

    Sorry folks, but something here is implemented terribly wrong!

    How can I get the RPi3 get to work with hifiberry amp, m2p 2.41 and internal Wifi?

    After putting the same micro sd card (no fresh install) in a Raspberry Pi 2 with a Hifiberry Amp on top and using a Wifi stick, WPS worked at once! On first try. So veeery obviously there is something wrong with the combination internal Wifi of RPi3 and Hifiberry Amp and WPS. But what exactly?

    Many thanks and best regards
    Muhackl

    1. March 2017 at 13:35 #27369

    Hi muhackl

    Please try to burn new image with latest version of Max2Play, which is 2.41, then try to boot the first time without initializing WPS, because the RPI3 requires time to expand the filesystem, then in the second boot you can activate the WPS. Moerover, Hifiberry does not impact the WPS process.

    Regards,
    Mohammad Mbydeen

    1. March 2017 at 21:41 #27383

    Hi Mohammad,
    I’m sorry, but this did not work.

  • Burned 2.41 on micro sd
    First boot – did not activate WPS on my router
    Waited until second boot after expansion of file system
    Activated WPS on router
    Did not connect
    Activated WPS on router again
    Rebooted Pi
    Did not connect
  • Any other ideas I could try? Can I use a external wifi stick and deactivate the internal wifi module?
    Regards
    Muhackl

2. March 2017 at 12:49 #27395

Hi muhackl

Please check the router settings or try another one, we have tested WPS in our lab and it works fine.

Regards,
Mohammad Mbydeen

2. March 2017 at 17:27 #27412

I managed getring it to work by setting the internal wifi to WLAN1 and adding a wifi stick as WLAN0. It connects at once via WPS. So I really don’t think it’s my router (AVM Fritz Box 7390, one of the most sold in Germany).
Regards
Muhackl

6. March 2017 at 13:03 #27464

Hi muhackl,

Usually you do not need an external WiFi stick to get WPS working, but Its good to know that your solved your problem.

Regards,
Mohammad Mbydeen

12. March 2017 at 17:52 #27603

Kind of same problem, ‘M2P 2.40’ + RPi3 + JustBoomDac = ‘no wifi’
I have put a checkmark in ‘Load WiFi Interface’ and pressed ‘save all settings’ which gives a wierd error message of ‘Fail OK’.

I have tried M2P version 2.41, same problem/result..

By disabling ‘WPS’ and press ‘save’, i’ve got a message reffering a problem with /var/run/wpa_supplicant/wlan0 wich lead me to the solution.
The path ‘/var/run/wpa_supplicant’ is not existing, so by creating a directory ‘wpa_supplicant’ in ‘/var/run/’ i got wifi working..
(then i went to the web interface for wifi and redid the checkmark in ‘load Wifi interface’ and clicked ‘save all settings’ and then the result was ‘OK’ and wifi started to work.)

Created the directory by executing ‘mkdir /var/run/wpa_supplicant’ in a root terminal.

-> Max2Play: Could you pls. make sure the directory exist in you next release please, thanks..

  • This reply was modified 8 months, 2 weeks ago by  realsurfer.
13. March 2017 at 6:18 #27613

Hi muhackl,

Can you manage to recognize Hifiberry AMP+ sound card?
I’ve set up the same with you:
– Raspberry Pi3
– Hifiberry Amp+
– M2P 2.4164 GB SanDisk SDHC card
– 12V tested with old PC’Power Supply

On Max2Play, no hifiberry sound card display 🙁
Can you share your installation, i’ll really appreciate.

Thanks,

13. March 2017 at 12:55 #27643

Hi huy

Please make sure that you have installed the sound correctly on the RPI and you have configured the correct settings on ausdioplayer plugin and raspberry pi plugin. also it could be a hardware problem.

Regards,
Mohammad Mbydeen

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here