Waveshare 5 Inch touchscreen – driver not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Waveshare 5 Inch touchscreen – driver not working

This topic contains 4 replies, has 3 voices, and was last updated by  muhackl 4 days, 13 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 17. October 2016 at 19:48 #23434

    Hi,
    I’m using a Raspberry Pi 2, M2P 2.37, fresh install with no add ons.
    I also added a 5 inch touchscreen from Waveshare and installed it like decribed here: http://www.waveshare.com/wiki/5inch_HDMI_LCD
    Without installing the drivers, the display works perfectly except the touchscreen functionality of course.
    When I install the drivers as described, the desktop won’t start. The Pi boots into terminal mode.
    When I try to start Jivelite, it’s telling me:
    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen

    JiveLite 0.1.0
    [0;33m20161017 16:40:29.920 INFO jivelite – JiveMain.lua:267 JiveLite version 0.1.0[0m
    [0;33m20161017 16:40:29.921 INFO jivelite.ui.draw – jiveL_initSDL:227 initSDL[0m
    [0;31m20161017 16:40:29.936 ERROR jivelite.ui.draw – jiveL_initSDL:234 SDL_Init(V|T|A): Unable to open a console terminal
    [0m

    The driver install script “LCD5-show” does the following – I hope you can determine what goes wrong:

    i=1
    for lines in cat ./boot/mark
    do
    case ${i} in
    1) var1=${lines};;
    esac
    i=expr ${i} + 1
    done
    #echo “$var1”

    if test “$var1” = “0”;then
    sudo mkdir /etc/X11/xorg.conf.d
    echo “1” > ./boot/mark
    fi

    if test “$1” = “0” -o “$#” = “0”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt /boot/config.txt
    echo “LCD configrue 0”
    elif test “$1” = “90”; then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-90 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-90 /boot/config.txt
    echo “LCD configrue 90”
    elif test “$1” = “180”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-180 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-180 /boot/config.txt
    echo “LCD configrue 180”
    elif test “$1” = “270”;then
    sudo cp -rf ./etc/X11/xorg.conf.d/99-calibration.conf-5-270 /etc/X11/xorg.conf.d/99-calibration.conf
    sudo cp ./boot/config-5.txt-270 /boot/config.txt
    echo “LCD configrue 270”
    fi

    sudo cp ./cmdline.txt /boot/
    sudo cp ./inittab /etc/
    sudo cp -rf ./usr/share/X11/xorg.conf.d/99-fbturbo.conf-HDMI /usr/share/X11/xorg.conf.d/99-fbturbo.conf

    if test “$#” = “0” -o “$1” = “0” -o “$1” = “90” -o “$1” = “180” -o “$1” = “270”; then
    sudo reboot
    echo “reboot now”
    else
    echo “Invalid parameter,Usage:LCD5-show [0] [90] [180] [270]”
    fi

    Many thanks and best regards
    Muhackl

    20. October 2016 at 10:34 #23463

    Hello muhackl,

    Please take a look into this topic. Maybe it is a help for you.

    Best Regards

    20. October 2016 at 11:21 #23464

    Hi,
    and thanks a lot. I also hav been able to resolve the solution issue.
    The problem – the same as for martin-s – the touch capability for the screen won’t work unless you install the drivers. But after installing the drivers, jivelite no longer starts.
    I try to contact martin-s via his post – maybe he got the solution in the meanwhile.
    Regards
    Muhackl

    4. December 2016 at 16:07 #24536

    Hello,

    Did you get this working? I have the same problem…

    regards

    Paul

    4. December 2016 at 16:35 #24537

    Hi,
    nope, sorry – still does not work. I gave up.

    Regards
    Muhackl

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here