[SOLVED] YMPD Rpi Zero Hifiberry Mini Amp: Volume problem

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] YMPD Rpi Zero Hifiberry Mini Amp: Volume problem

This topic contains 14 replies, has 3 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • 10. Juli 2017 at 7:19 #29864

    Hi dear M2P community,
    I’m using a Rpi Zero with a Hifiberry mini Amp.
    Fresh install of the latest M2P version.
    YMPD as Player.
    When trying to change the volume, the error „problems setting volume“ occurrs.
    I found several posts to this topic in this forum but none solved the problem.

    Settings in M2P and mpd.conf say:
    Soundcard: default – snd_rpi_hifiberry_dac
    Aufioformat: 192000:24:2
    Mixer device: hw:1
    Mixer: Digital (I also tried Software)

    alsamixer says: „This device has no mixer“ – sounds a little disturbing for me.

    How can I solve the issue?

    Many thanks and best regards
    Muhackl

    11. Juli 2017 at 18:42 #29888

    Hi,
    I contacted Hifiberry support.
    To get this to work, you have to add/change the following to/in the /etc/mpd.conf

    audio_output {
    type „alsa“
    name „sysdefault:CARD=sndrpihifiberry“
    mixer_type „software“
    }

    As the Hifiberry Mini Amp does not support either Digital or Hardware (or Master) volume control via ALSA.
    Regards
    Muhackl

    12. Juli 2017 at 20:39 #29899

    Hi muhackl,

    Thanks for the quick follow-up and for sharing the solution in detail!

    Regards
    Heiner

    1. Februar 2018 at 0:17 #33783

    Hi,

    I’m having the same problem using a Raspberry Pi Zero W + HiFiBerry MiniAmp. There’s no sound coming out of the attached speaker (Tivoli Dual Alarm). I chose „HiFiBerry Dac+ Light“ as the Hifi Berry driver and also configured the MPD player as stated above. MPD players says „problems setting volume“. I have no clue what to do next. Actually, I only want to use the hardware as a shairport player. If there is no support from your side, I will probably change to the piCorePlayer which is recommended in the original article on the HifiBerry site. Still, helpm is appreciated.

    Here’s the debug output:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    LMSIP=192.168.178.23
     
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=sndrpihifiberry   - snd_rpi_hifiberry_dac,  - Default Audio Device
      sysdefault:CARD=sndrpihifiberry - snd_rpi_hifiberry_dac,  - Default Audio Device
      dmix:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Direct sample mixing device
      dsnoop:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Direct sample snooping device
      hw:CARD=sndrpihifiberry,DEV=0  - snd_rpi_hifiberry_dac,  - Direct hardware device without any conversions
      plughw:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Hardware device with all software conversions
    
     
    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr
     
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    #### OUTPUT SOUND DETAILS CARD 1 ####

    Greets, macpac

    1. Februar 2018 at 13:01 #33789

    Hi macpac,

    The miniamp does not support hw volume controlso MPD does not have dynamic volume config.

    But you need shairport as your player anyways if you prefer AirPlay. Just select „simple airplay“ in the HiFiBerry plugin, reboot and you should see max2play as an AirPlay device.

    1. Februar 2018 at 23:31 #33793

    Hello Heiner,

    I tried this way before and only had a look at the MPD player to check whether the MiniAmp works. Anyway, I now followed your advice and chose the „simple airplay“ configuration. I then activated squeezelite and shairport in the Audioplayer menu and synchronized this player with my other one which runs on the same Raspberry Pi as the squeezebox server in the server’s menu. Shairtunes2 is not installed/activated. Still no sound. I switched the output channels‘ connection to the speaker but still no sound. What now?

    Herw’s the debugging info from the audioplayer menu:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    LMSIP=192.168.178.23
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=sndrpihifiberry   - snd_rpi_hifiberry_dac,  - Default Audio Device
      sysdefault:CARD=sndrpihifiberry - snd_rpi_hifiberry_dac,  - Default Audio Device
      dmix:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Direct sample mixing device
      dsnoop:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Direct sample snooping device
      hw:CARD=sndrpihifiberry,DEV=0  - snd_rpi_hifiberry_dac,  - Direct hardware device without any conversions
      plughw:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_dac,  - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####

    Greets, macpac

    2. Februar 2018 at 15:24 #33815

    Hi macpac,

    If you have a Squeezebox Server running, do you not use shairtunes2?

    In any case, you have the same output for both players, so they cannot run simultaneously. Try selecting default_hifiberry for one of them.

    If there’s still no sound, select „none“ in HiFiBerry, reboot, reselect the light and reboot.

    4. Februar 2018 at 23:14 #33840

    Hi Heiner,

    I tried your tips but as they still didn’t work out, I used the piCorePlayer. Here its’s the same problem.

    So, it must be a hardware problem with the speaker… As I understood, the speaker needs no extra power but only needs to be attached to the MiniAmp? MiniAmp + Raspberry Zero work with 5V, 2A.

    5. Februar 2018 at 16:04 #33866

    Hi macpac,

    The power supply is probably too weak. We recommend using a 5V 2.5A PS for the Raspberry Pi 3 with a sound card HAT in general. For the MiniAmp it might even be recommendable to use 3A.

    Also, make sure the speakers you use are only around 3W each as that is the maximum capacity of the miniamp. What wattage do your speakers have?

    5. Februar 2018 at 18:07 #33867

    Hi Heiner,

    well, I only use the Raspberry Pi Zero W model + MiniAmp as described in the guide. The recommendation there is to use 1.5-2.0 A. The speaker is only described as a ‚3″ full range driver‘ but according to the guide the 2A should be sufficient to power the Raspberry Pi Zero W model + MiniAmp + 2 speakers! I will test the speaker next with another amplifier…

    13. Februar 2018 at 0:08 #33965

    Hello Heiner,

    meanwhile I found out the following: The speaker needs 5W and it works fine when being attached to my stereo’s amp. But what can I do now with my light configuration which hasn’t sufficient power? As I only need a mono signal on the speaker, would it help to use both channels to double the power? Any other idea?

    Regards, macpac

    13. Februar 2018 at 15:57 #33984

    Hi macpac,

    Sorry about that, but with 5W you should at least get some output from the MiniAmp. If possible, I would advise you to try out another speaker in the same range to make sure they are not the whole problem.

    18. Februar 2018 at 21:11 #34042

    Hello Heiner, I tried another speaker. There is still no sound, just a cracking sound when connecting…

    24. Februar 2018 at 15:42 #34078

    Hello again,

    the problem was solved. Opposite to what the construction guide says, soldering (not just fixing) a header on the Raspberry Zero W seems to be required. I bought a Raspberry Zero WH instead and everything works fine now. 🙂

    Regards, macpac

    27. Februar 2018 at 17:25 #34114

    Hi macpac,

    Thank you for the follow-up. I am glad your setup is working now 🙂

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Register here