SMB not working any more

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI SMB not working any more

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 2 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 22. Juli 2018 at 10:46 #36721

    Hi,
    I’m using Max2Play on a Raspberry Pi for many years now.
    I alway also used the possibility to have data access to the Pi via SMB – everything nicely configurable via M2P.
    Now something happened that no computer in my network can access the Pi via SMB any more.
    Here some stats/test/settings:
    – Raspberry Pi 3; m2p 2.46; activated plugins: squeezebox server, VNC (also not working any longer, perhaps another story, perhaps not), DLNA-server; connected via LAN to a FritzBox 7380, fixed IP address configured in M2P settings and on FritzBox, several attached and mounted external hard drives
    – Used computers:
    – MacBook Pro, OSX 10.13.6, no access via smb (Pi ist showing up with its correct name in finder -> network) – even not when entering IP address, error message (Beim Verbinden mit dem Server „medien“ is ein Fehler aufgetreten. Möglicherweise ist der Server nicht vorhanden oder derzeit nicht verfügbar…). Connection to the squeezebox-server via squeezeplay client, SFTP, SSH – everything works fine!
    – PC, Windows 10 (1803), entering the IP or hostname in explorer, also error message: „Auf \\medien konnte nicht zugegriffen werden“…
    – Odroid C2 with LibreElec/Kodi, formerly also working perfectly with access via SMB to media files stored on the Pi’s harddrives; error message: „connection time out“ when trying to access via SMB to the perfectly shown hostname and even if I try to connect via IP address
    – iPad mini via FileExplorer app and SMB – no connection possible. But connection via iPeng app to squeezebox working.
    – Used troubleshooting
    – I set up another Pi3 with M2P and mounted and shared the storage and it instantly worked to get SMB access to it on the machines mentioned above.
    – I looked after that Wifi is not connected so host name resolving won’t get confused
    – I deleted and added the SMB shares in filesystem mount settings in M2P
    – There is also a share for the local SD card and not only the connected harddrive
    It’s like there is something wrong especially with the SMB settings on this Pi and I can’t figure out, where I screwed it up. Can you please help me what to check and how to troubleshoot this?
    I really want to solve it without re-setting up the machine again.

    As I mentioned above VNC is not working any longer too. The VNC server does not start automatically any more. When I start it manually it tells me it started successfully. But when I refresh the page, the VNC server is again not running any longer. Connection can not be established. I don’t know, if it has something to do with my main problem, but I wanted to mention it.

    Regards
    Muhackl

    22. Juli 2018 at 16:21 #36724

    Hi,
    I got the idea on checking the SMB service.
    sudo sercice smbd status
    is telling me:
    smbd.service – LSB: start Samba SMB/CIFS daemon (smbd)
    Loaded: loaded (/etc/init.d/smbd)
    Active: failed (Result: exit-code) since So 2018-07-22 07:02:14 CEST; 8h ago
    Process: 3257 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)

    When I do a
    systemctl status smbd.service
    after
    sudo service smbd restart
    it’s telling me:

    Jul 22 15:42:47 medien smbd[1990]: Starting SMB/CIFS daemon: smbd/usr/sbin/smbd: error while loading shared libraries: libavahi-common.so.3: cannot… directory
    Jul 22 15:42:47 medien smbd[1990]: failed!
    Jul 22 15:42:47 medien systemd[1]: smbd.service: control process exited, code=exited status=1
    Jul 22 15:42:47 medien systemd[1]: Failed to start LSB: start Samba SMB/CIFS daemon (smbd).
    Jul 22 15:42:47 medien systemd[1]: Unit smbd.service entered failed state.

    Even if I do the following:
    sudo apt-get install –reinstall samba-libs
    there are errors

    Job for smbd.service failed. See ’systemctl status smbd.service‘ and ‚journalctl -xn‘ for details.
    invoke-rc.d: initscript smbd, action „start“ failed.
    dpkg: Fehler beim Bearbeiten des Paketes samba (–configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
    samba

    So samba seems to be pretty screwed up. At least somewhat’s wrong with libavahi-common.so.3 – can I reinstall it somehow else? I’m really lost when it comes to libraries.
    Many thanks and best regards
    Muhackl

    22. Juli 2018 at 16:41 #36725

    Hi,
    I also like it when I can solve and answer my own issues 😉
    I copied over the libavahi-common.so.3 and libavahi-common.so.3.5.3 files from my working Raspi to my non working Raspi. Directory is /usr/lib/arm-linux-gnueabihf
    Restarted samba. And it’s working again.
    Regards
    Muhackl

    23. Juli 2018 at 16:22 #36740

    Hi muhackl,

    Thanks for updating your progress so quickly and sharing your process! 🙂

    23. Juli 2018 at 21:39 #36745

    It still would be possible how it got this screwed up.
    What is able to crash avahi? I tried to install and uninstall bluetooth audio serveral times without success. Perhaps it was caused by that.
    Regards
    Muhackl

    25. Juli 2018 at 16:18 #36756

    I will try to recreate the setup and see if the issue is universal.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here