flysurfer

Forum Replies Created

Viewing 30 posts - 91 through 120 (of 266 total)
  • 13. Dezember 2016 at 12:39 #24816

    Hi yoja,

    the X-Server is used to start the Pulseaudio server (that is used for the Bluetooth connection). As some may use Jivelite or other visualisations and therefor need the X-Server anyway, it is the easiest way to make this mandatory and have only one Pulseaudio instance.

    The running X-Server should not make much of a difference on current Pi (2/3) setups – but yes, on Pi 1 it may take longer to start.

    Support for multiple Bluetooth Adapters may not be too difficult, but the audioquality suffers from bad bluetooth connections and player synchronisation with Bluetooth is also not as good as with normal soundcards (delay between players due to BT-connection). It won’t be possible to stream bluetooth with the normal BT-Dongles through walls…

    Multisqueeze for Multiroom audio is best used with the build-in audiochip (headphone jack on Pi), an additional audiocard like the AMP+ from hifiberry / iqaudio / justboom and maybe one BT-Speaker. With this you can stream to 2 or 3 rooms with just one device wich works great for me.

    Stefan

    5. Dezember 2016 at 17:02 #24564

    @oli: streaming in both directions at a time is not possible. I did not have the opportunity to test with the latest android running on Pixel phone. But I tested Android on Samsung S7, HTC and iPhone running iOS 10 without problems. In case you did not modify your Debug log, there are „**“ symbols behind every MAC-Address, so this might be causing the error. You may try to load the latest BETA from Max2Play on the Settings Page, Reboot and try to connect again.


    @rttm
    : Der Lautsprecher scheint korrekt verbunden, allerdings ist die Audio-Ausgabe über Pulseaudio nicht korrekt erstellt. Kannst du es mal mit der neusten Beta und einem Neustart versuchen? Hast du die Soundkarte für die Audioplayer auf „Pulse“ umgestellt, bzw. die Audioplayer (oder Kodi) auf dem Gerät deaktiviert? Aus irgendeinem Grund scheint die Soundkarte schon von einem anderen Player belegt zu sein. Probier nach dem Beta-Update auch noch mal den Bluetooth-Lautsprecher aus der Liste zu entfernen und neu zu suchen.

    All the Best
    Stefan

    • This reply was modified 7 years, 7 months ago by flysurfer.
    1. Dezember 2016 at 16:10 #24467

    Hi,

    thanks for your detailed debug info. I found a bug in Bluetooth, that prevented some speakers from working (Pulseaudio Bluetooth drivers Bluez5 vs Bluez4) and I built a workaround during connect and added better information to the message output on the connection status.

    If you had problems connecting your speakers until now, get the latest Beta on the Settings Page of Max2Play, remove your speakers from the Bluetooth page, Scan again and click Reconnect next to your speakers.

    @stefano: is your smartphone is indicated green (connected)? Can you post the output messages when clicking “Install Squeezebox Server Streaming”?

    30. November 2016 at 11:14 #24363

    Hi,

    everything looks good from the log you posted. Your Squeezebox Server is running on the same device, right? Did you click the „Install Squeezebox Server Streaming“ after the pairing of your Smartphone was successful (this will add the Bluetooth Device to Favorites)?
    One more Point: please enable the Autostart in the Squeezebox Server Bluetooth Streaming Options at the bottom of the Bluetooth page. With this enabled you don’t even need to do anything in your Squeezebox Server and Bluetooth will stream automatically once your Smartphone starts playing.

    29. November 2016 at 12:43 #24301

    Hi,

    maybe something went wrong during the installation of Bluetooth. Also, your Bluetooth Dongle seems not to be recognized correctly. To skip all possible errors I recommend that you try a new SD-Card with a fresh Max2Play Image (download the current version).

    28. November 2016 at 15:17 #24289

    Hi Simon,

    please have a look at the video-walkthrough on our Plugin page for Bluetooth: https://www.max2play.com/en/portfolio/plugin-bluetooth-2/

    You may also post the Debug Output from the bottom of the Bluetooth Page here, if anything is not working as expected. A little more information is also usefull to help you better: version of Max2Play / downloaded SD-Card Image?

    23. November 2016 at 15:53 #24128

    @castalla: great to hear it’s working finally :). If your FireTV gets connected via Bluetooth, it should work like streaming from your phone.


    @smiling-stefano
    : did you click reconnect in the web interface next to your phone? A popup should appear on your phones display for pairing after clicking the reconnect button. You may have to do this twice. Castalla had a similar problem – solved it with another BT-dongle.

    22. November 2016 at 18:00 #24103

    So you did the reconnect and there is no popup on your phone that asks for you to confirm the connection (you tried at least 2 times). Maybe you have an other phone for testing? The HUAWEI phone might be part of the problem or maybe security settings on your phone that don’t let any device connect.

    22. November 2016 at 17:46 #24099

    @castalla: please open the bluetooth page on your smartphone (the one that shows devices – this should also show Max2Play) and do not click on anything. Now click reconnect in the web interface. Do this again, if no message appears on your smartphone.

    On every smartphone I tried (Samsung Galaxy, HTC, iPhone), this worked without problems. Your phone should also say „connected“ on the Bluetooth page after this.

    • This reply was modified 7 years, 8 months ago by flysurfer.
    22. November 2016 at 17:29 #24095

    Hi castalla,

    once more: After you click „reconnect“ in the web interface, does your smartphone show a window with „Do you want to connect to Max2Play?“ AND did you confirm this message with „OK“?

    After the first initial setup you just need to choose „Max2Play“ from your smartphone (Bluetooth Settings) to connect.

    • This reply was modified 7 years, 8 months ago by flysurfer.
    22. November 2016 at 15:48 #24085

    We will make a video for this to clarify – but the text on the bluetooth page explains everything. There are just 4 buttons to click to install and setup…

    First click: install bluetooth

    Second click: scan for devices

    Third click (where you struggle): When your phone appears after the scan in red, you need to connect to it by clicking „reconnect“ button. Then your phone will ask you to open the connection. After you confirm this your phone will be indicated as connected and green on the bluetooth page.

    Fourth click: at the bottom of the bluetooth plugin page click „Install Bluetooth Streaming for Squeezebox Server“ and optionally enable „Autostart“ below it.

    Everything together takes about 2 minutes of time…

    21. November 2016 at 17:35 #24069

    Yeah – right. No audioplayer settings need to be edited. The Bluetooth Streaming to Squeezebox Server works like a radio stream and is fully integrated into Squeezbox Server.

    The Bluetooth Plugin Page might be a little confusing at first, as it offers multiple options, depending on what you want to achieve.

    If the Bluetooth Plugin does not install, there must be something wrong with the system. Maybe the SD-Card had an error on installing.

    21. November 2016 at 17:23 #24067

    Hi – the 2.38 should work fine.

    If it cannot install Bluetooth, maybe you forgot to expand the filesystem and the SD-Card is full? After installing Squeezebox Server this might be the problem. You can check this in the DEBUG at the Settings Page.

    21. November 2016 at 17:07 #24064

    Hi Castalla,

    it should be really easy – maybe you missed the part where you couple your smartphone with Max2Play? This must be done just once after you installed the Bluetooth plugin and before clicking the „install Bluetooth Streaming to Squeezebox Server“ at the bottom of the Bluetooth Plugin (this really needs to know your smartphone as otherwise it will not start streaming).

    After this you should see the Bluetooth device in your LMS in favorites.

    Errors may occure when:
    – no space left on SD-Card when installing
    – no Bluetooth Connection to your Smartphone (indicated as green)

    Hope this helps – Stefan

    21. November 2016 at 15:15 #24049

    Hi Castalla,

    the bluetooth streaming is only supported with the Debian Jessie version of Max2Play on Raspberry Pi (this is the base operating system). When it says „Wheezy Image is not supported“ this indicates, that you are using the older Debian Wheezy System. The jump from Wheezy to Jessie was around 6 month ago. Please flash a new SD-Card with the current download of Max2Play to use Bluetooth streaming to Squeezebox Server.

    Regards,
    Stefan

    15. November 2016 at 17:44 #23914

    Hi Hilary,

    please choose „Master“ as mpd mixer control in the MPD settings.

    Regards,
    Stefan

    10. November 2016 at 11:39 #23853

    @southafricanrob: there is a setting for this to switch off / on squeezelite player by connection status of bluetooth speakers on the bluetooth page. See also the instruction on this page how to set up.

    9. November 2016 at 17:00 #23840

    Hi LowTech,

    dein Grundproblem im Setup mit Squeezelite scheint zu sein, dass standardmäßig beim Abspielen auf die USB-Soundkarte „sysdefault-USB PnP Sounddevice“ wohl nicht direkt auf Hardware abgespielt wird (Mixer Device hängt dazwischen).

    Wenn du direkt auf die Hardware abspielen willst, funktioniert das in der Regel über den genannten Parameter „-o hw:0“, der in den Kommandozeilenparametern von Squeezelite eingefügt wird. Wichtig ist dabei, dass kein anderer Audioplayer oder Kodi aktiv ist, der ggf. das Audiointerface schon exklusiv für sich beansprucht und keine sonstigen Parameter in diesem Feld stehen.
    Falls das nicht geht, gibt es eventuell eine Soundkartenoption, die etwas wie „hardware“ oder „direct hardware output“ im Namen enthält und gewählt werden kann.

    Weitere Möglichkeiten:
    – ein regelmäßger Reboot, um dem Audioproblem zuvor zu kommen (ggf. erstelle ich hierfür mal ein Plugin). Aktuell müsste der Reboot in die Crontab eingetragen werden (z.B. für 6 Uhr morgens)

    # Crontab Editieren über crontab -e
    0 6 * * * sudo /sbin/reboot
    

    – Nutzung von HifiBerry / IQAudIO / Justboom Karten, die alle fehlerfrei funktionieren statt der USB-Soundkarte (ggf. liegt es auch am USB selbst oder an der Stromzufuhr)
    – Umstellen der Audioausgabe auf Pulseaudio (Autostart Desktop aktivieren und Audioausgabe auf Soundkarte „Pulse“/“Pulseaudio“ setzen)

    8. November 2016 at 16:59 #23775

    Hallo,

    gibt es einen Grund, warum du nicht einfach „Pause“ im Player drückst, um die Wiedergabe zu unterbrechen?

    8. November 2016 at 16:07 #23772

    Hi Georges,

    das Script zum Deaktivieren der Protection muss ausgeführt werden als user root:
    /var/www/max2play/application/plugins/sdcardprotection/scripts/uninstall_sdcardprotection.sh

    Normalerweise sollte das Plugin fehlerfrei funktionieren, solange Max2Play nur als Audioplayer verwendet wird.

    Viele Grüße
    Stefan

    4. November 2016 at 12:06 #23662

    Hi jnile1, hi Marc,

    sorry, but the new feature in the Max2Play-Beta to change the build-in wifi interface in Raspberry Pi Settings had a minor bug. Just load the latest Max2Play-Beta and uncheck the Checkbox „Disable Default WiFi Interface WLAN0 on RPI3“ -> click save -> check it again and save.

    After a Restart the build in Wifi will be at position wlan1 and the other stick will have wlan0 and be default.

    3. November 2016 at 18:33 #23658

    Update: I just added a switch to the „Raspberry Pi Settings“ Page, to change the default Wifi from wlan0 to wlan1. You may just use this setting and your wifi-stick should work. You need to do a Beta-Update on the „Reboot/Settings“ Page to get this feature, as it is not released yet.

    Stefan

    3. November 2016 at 15:48 #23649

    Hi,

    you have to edit a file and add a rule for your Wifi Stick to make sure it gets named wlan0:

    Login per SSH as user pi and do
    sudo nano /etc/udev/rules.d/70-persistent-net.rules

    now add a new line and edit the old line that it looks like this:

    
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="[MAC-ADDRESS-OF-YOUR-DEVICE]", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"
    

    Change the part [MAC-ADDRESS-OF-YOUR-DEVICE] with your Mac-address of your wifi stick and change the name of the existing entry to wlan1.

    This should do the trick.

    All the Best,
    Stefan

    • This reply was modified 7 years, 8 months ago by flysurfer.
    11. Oktober 2016 at 17:31 #23374

    Hi Bjardne,

    very good so far 🙂

    If you really like to change the volume steps, this is a little more difficult, as we just use the file from IQAudIO. If you know how to compile a file and log in with SSH on the Pi, you can do it this way:

    1. get the file from https://github.com/iqaudio/tools/blob/master/IQ_rot.c and edit lines
    currentVolume = currentVolume + 10;
    and
    currentVolume = currentVolume - 10;
    to the step you like – e.g. „5“ or „2“ to use smaller steps.

    2. complile the file with
    gcc IQ_rot.c -oIQ_rot -lwiringPi -lasound

    3. change the existing file in /opt/IQ_rot with the one you just compiled

    4. set file permissions with chmod 777 /opt/IQ_rot

    This should do the trick…

    All the Best,
    Stefan

    10. Oktober 2016 at 12:30 #23335

    Hi Mike / hi Simon,

    the fix for the wolfson/cirrus logic card in the current version of Max2Play (version 2.37) uses a newer Kernel that fits the latest Max2Play-Image and uses a renamed Device Tree Overlay for the card.

    This definitly works when using the latest Max2Play-Image -> Install Wolfson-Card on Raspberry Settings Tab -> Reboot -> choose Card in Audioplayer Tab (advanced Settings) and set prefered Audio-Output on Raspberry Settings Tab.

    Older Max2Play-Images should still work, as the Bugfix just targets the latest Max2Play-Image based on Kernel 4.4.y


    @Mike
    : After installing the Wolfson-Card with the Kernelchange, the change of the installed soundcard to „none“ doesn’t change the Kernel back to the original one. But it removes the DTOverlay entry to load the card on boot. If your card won’t work after the next reboot, make sure to select it again.

    All the Best
    Stefan

    10. Oktober 2016 at 11:45 #23333

    Hi,

    to get the Rotary Encoder on IQAudio-Cards working with Synchronisation of volume with Squeezebox Server (control with App / webinterface / rotary encoder) you need to add following to the command line options of Squeezelite (not dependend of build-in audio active /not active):

    -o hw:CARD=IQaudIODAC -V Digital -Q

    I also added this to the description of the Rotary Encoder now (in Beta).

    Description of Parameters:
    – The Parameter „-Q“ starts the synchronisation with the Squeezebox Server
    – The Parameter „-V“ makes sure to use the correct alsamixer control
    – The Parameter „-o“ uses the dircet hardware as audio output (needed to use volume control on alsa level)

    Important: This will only work with the Squeezelite in Max2Play and not in other distributions!

    30. September 2016 at 11:39 #23266

    Hi Simon,

    the Wolfson card drivers and the driver selection within „Raspberry Pi Settings“ should work with the current Max2Play Image. We will test this again with the latest version. EDIT: ok – there seems to be a problem with the newer Kernel… we work on this.

    Cheers,
    Stefan

    • This reply was modified 7 years, 9 months ago by flysurfer.
    30. September 2016 at 10:56 #23263

    Hi,

    maybe the server was not available for a short period of time. I just tested the installation of the Plugin and it works fine.

    If you still encounter problems, maybe the internet connection is a problem – try rebooting Max2Play and check again.

    Regards,
    Stefan

    30. September 2016 at 10:49 #23262

    Hi,

    in the Settings / Reboot tab, could you remove the Autostart from „Autostart Desktop“ and try again? Jivelite starts the desktop automatically if this is not running yet. Maybe the RPi 1 is too slow and gets confused by 2 Desktops starting at the same time.

    Regards,
    Stefan

    23. September 2016 at 10:56 #23169

    Great job and thanks for sharing!!!

    Anyone who likes to add this functionality to a Max2Play Addon? Using the Pluginbuilder this might be not to difficult to achieve.

    Cheers,
    Stefan

Viewing 30 posts - 91 through 120 (of 266 total)