[SOLVED] Network of Access Points set up with M2P, players not found by the Squeezeserver

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Network of Access Points set up with M2P, players not found by the Squeezeserver

This topic contains 1 reply, has 2 voices, and was last updated by  flysurfer Moderator 10 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 23. November 2016 at 19:59 #24147

    Hello M2P team,

    I have been following you for a while now and using your products quite intensively.

    But I am now facing a problem with the latest developments of my setup:

    I have the following equipment on my network:

    1. Squeeserver on the very good 7″screen + RPi 2 + Hifibery DAC + M2P (squeezeplug + jivelight)
    2. Squeezebox
    3. RPi B + Hifibery AMP+ M2P (squeezeplug
    4. RPi B +2.8″ screen + M2P (squeezeplug + jivelight) (Portable radio)
    5. RPi 3 + M2P (Kodi Only)
    6. RPi B + M2P (Access Point only)
    7. RPi B + M2P (Access Point only)
    8. RPi B + M2P (Access Point only)
    9. Several other network equipment like IP cams, domoticz, but that’s not the topic.

    Everything is working fine as long as the equipments are on the wired network or on my old wifi network using the same range of IP adress (192.168.1.*).
    As you can see above, I sat up 3 old RPiB that I did not use anymore as Access points, using the access point plugin ( host names are Cauchard-AP*).
    The problem comes when I connect some of my players (items 3 and 4 for the moment) on wifi through my new access point. These are not found anymore by the squeezeserver and I can’t control them anymore.

    I was wondering few things:

    1. All the access points have the same IP adress on the wifi side (192.168.189.1), is it a problem ?
    2. The fact that the this IPs range (192.168.189.*) is different from my main network could be the problem
    2. I have changed the wifi chanel in set up in the /etc/hostapd/hostapd.conf and the DHCP range in /etc/dnsmasq.conf, to avoid conflict between the acces points, is it worthy ?
    3. Could it be possible to bring the IP range of the AP back inside my main network ? If yes, which files are tobe changed in addfition to those I already know.
    4. The main idea is to be able to move inside the house (old farm, big walls) and changing from one AP to the other with a tablet or a phone or anyother like in an hotel or a big office, the equipment just connecting to the stronger signal but with the same SSID and Password, specialy for RPi set up with batteries (portable radio) and make sure the WAF is ok.

    You help would greatly appreciated.

    Thanks in advance


    Cordialement Aurélien Cauchard

    13. December 2016 at 17:43 #24834

    Hi Aurélien,

    you are completely right with addressing the problem. It is mainly because of the different subnets. The idea behind the access point plugin was to give users access to the device itsself and maybe to an internet connection behind another router. If you also want to see the devices in your network you need to change the IP address to your existing subnet. In your case you need to:

    edit /etc/dhcpcd.conf and set the IP to some not yet existing IP
    static ip_address=192.168.1.150/24

    edit /etc/dnsmasq.conf to

    
    dhcp-range=192.168.1.151,192.168.1.160,255.255.255.0,12h
    address=/HOSTNAME/192.168.1.150
    

    edit /etc/hosts and change IP to 192.168.1.150

    I did not test this setup, but it should work. I’d rather recommend to use a good router and some wireless extenders to set up your wifi as this is better for performance and easy of use.

    All the Best,
    Stefan

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here