No sound after a few hours

Max2Play Home 2016 (en) Forums Max2Play Add-ons No sound after a few hours

Tagged: 

This topic contains 12 replies, has 3 voices, and was last updated by  LowTech premium 4 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 11. October 2016 at 21:09 #23375

    Hi,

    I have max2play running for ~3 weeks. Everything works fine as long as Music is playing.
    When the music is stopped and I try to play Music again a few hours later, there is no Sound or sometimes comes a muted stuttering noise. Then I have to kill Squeezelite, stopping is not possible. After killing, Music starts playing again.

    Max2play is running on a raspberry Pi 3 Model B. LMS is also installed and an old USB Sound-device “Creative Soundblaster MP3+”
    The Music is stored on a Western Digital USB-HDD.
    I would like to leave it always on, because of the absent power-switch.

    What I did:
    – Changed USB Sound-device to Terratec Aureon Dual USB
    – Tested internal 3,5mm Audio output
    – I tried a second Raspberry Pi 3 (disconnected HDD)
    – Changed Power Supply
    – WLAN changed to Ethernet cable connection

    there is always the same behavior.

    Does anyone have an Idea to fix the problem?

    • This topic was modified 1 month, 4 weeks ago by  LowTech. Reason: i forgot some details
    20. October 2016 at 12:32 #23468

    Hello LowTech,

    Thanks for your request.

    Please try to disable the inbuild audio. You will find it in the Raspberry Pi Settings menu. For this you will need a Max2Play premium license.

    Please check that there is not running a second audioplayer. (Take a look into the Kodi/XBMC menu and check that shairport is also disabled)

    Best Regards

    20. October 2016 at 21:35 #23489

    Hello Christoph,
    there is no other player running.
    Ok, thank you. I will buy a license. Hoping to fix the problem 🙂

    Best regards,
    LowTech

    25. October 2016 at 19:05 #23568

    Hallo Christoph,
    da mein Englisch nicht so gut ist, schreibe ich jetzt mal auf deutsch.
    Ich habe jetzt den internen Raspi-Sound deaktiviert. Blutooth ist jetzt auch abgeschaltet.
    Leider immer noch der gleiche Effekt. Immer wenn ich nach hause komme und Musik hören will, kommt kein Ton mehr. Wie lange es ganau bis zum Ausfall dauert, kann ich derzeit noch nicht sagen. Kurze Pausen (10 min oder so) sind kein Problem.
    Es scheint so, als wenn da irgendwas in den Power-Safe-Mode geht und nicht mehr aufwacht…

    26. October 2016 at 13:39 #23575

    Hallo Low-Tech,

    Danke für den Erwerb einer Premium Lizenz von Max2Play.

    Was steht bei dir im Audioplayer Menü bei Squeezelite –> Erweiterte Einstellungen –>Kommandozeilenparameter? Und hast du bereits den Haken bei Nutze USB Soundkarte gesetzt?

    Beste Grüße

    ————————————–

    What is in the audio player menu at Squeezelite -> Advanced settings -> Command line parameters ? And have you already set the tick for Use USB sound card ?

    26. October 2016 at 19:23 #23583

    Ich habe jetzt mit dem Terratec Aureon Dual USB-Stick folgenden Einstellungen:
    Raspberry Einstellungen: “USB Soundcards, Northstar…” ausgewählt. (Auswahl “none” hat keine Anderung bewirkt)
    Soundkarte: sysdefault-USB PnP Sounddevice
    Kommandozeilenparameter: leer
    ALSA Parameter: 80:4::

    In den Squeezelite Einstellungen hatte ich bisher kein Häkchen bei “Aktiviere “Nutze USB-Soundkarte” für gleichzeitigen Betrieb von Kodi/XBMC UND Squeezelite“. Ich werde das jetzt noch mal ausprobieren und sage morgen bescheid 🙂

    27. October 2016 at 21:33 #23586

    Hallo,
    Das Häkchen bei “Nutze USB-Soundkarte” hat auch nicht geholfen.
    Gruß,
    LowTech

    3. November 2016 at 18:17 #23657

    Hallo LowTech,

    Bitte füge folgendes bei Squeezelite – Erweiterte Einstellungen – Kommandozeilenparameter ein:

    -o hw:0 -V Digital

    In unserem Wiki findest du eine entsprechende Erklärung zu den Parametern:

    -o Specify output device, default “default”, – = output to stdout
    -V Use ALSA control for volume adjustment, otherwise use software volume adjustment
    ——————————————-

    Please add the following at Squeezelite – Advanced Settings – Command Line Parameters :

    -o hw:0 -V Digital

    In our Wiki you will find an explanation for the parameters:

    -o Specify output device, default “default”, – = output to stdout
    -V Use ALSA control for volume adjustment, otherwise use software volume adjustment
    Best Regards

    7. November 2016 at 23:32 #23758

    Hallo Christoph,
    das klappt leider auch nicht. Squeezelite läßt sich mit den Parametern nicht starten:

    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen
    [22:25:23.849896] test_open:384 playback open error: No such file or directory
    [22:25:23.850109] output_init_common:382 unable to open output device

    Status: Squeezelite läuft nicht

    8. November 2016 at 16:45 #23773

    Hallo LowTech,

    schreib bitte nur -o hw:0 in die Kommandozeilen Parameter. Entschuldige bitte den Fehler. Dann sollte es auch Funktionieren.

    Beste Grüße

    8. November 2016 at 21:04 #23778

    also mit diesen Parametern läßt sich Squeezelite auch nicht starten. Es kommt die gleiche Fehlermeldung wie oben.

    9. November 2016 at 17:00 #23840

    Hi LowTech,

    dein Grundproblem im Setup mit Squeezelite scheint zu sein, dass standardmäßig beim Abspielen auf die USB-Soundkarte “sysdefault-USB PnP Sounddevice” wohl nicht direkt auf Hardware abgespielt wird (Mixer Device hängt dazwischen).

    Wenn du direkt auf die Hardware abspielen willst, funktioniert das in der Regel über den genannten Parameter “-o hw:0”, der in den Kommandozeilenparametern von Squeezelite eingefügt wird. Wichtig ist dabei, dass kein anderer Audioplayer oder Kodi aktiv ist, der ggf. das Audiointerface schon exklusiv für sich beansprucht und keine sonstigen Parameter in diesem Feld stehen.
    Falls das nicht geht, gibt es eventuell eine Soundkartenoption, die etwas wie “hardware” oder “direct hardware output” im Namen enthält und gewählt werden kann.

    Weitere Möglichkeiten:
    – ein regelmäßger Reboot, um dem Audioproblem zuvor zu kommen (ggf. erstelle ich hierfür mal ein Plugin). Aktuell müsste der Reboot in die Crontab eingetragen werden (z.B. für 6 Uhr morgens)

    # Crontab Editieren über crontab -e
    0 6 * * * sudo /sbin/reboot
    

    – Nutzung von HifiBerry / IQAudIO / Justboom Karten, die alle fehlerfrei funktionieren statt der USB-Soundkarte (ggf. liegt es auch am USB selbst oder an der Stromzufuhr)
    – Umstellen der Audioausgabe auf Pulseaudio (Autostart Desktop aktivieren und Audioausgabe auf Soundkarte “Pulse”/”Pulseaudio” setzen)

    10. November 2016 at 19:16 #23867

    Hi flysurfer,

    “direct hardware output” war das richtige Stichwort. Ich habe nun “hw-USB pnp Sound device – direct hardware device without any conversions, Card=Device,DEV=0” ausgewählt und es funktioniert. Die Kommandozeilen Optionen sind leer.

    Vielen Dank für eure Hilfe.
    Max2Play gefällt mir sehr gut.
    Gruß, Lowtech

    English
    Solution for Terratec Aureon dual USB Sound:
    Select “hw-USB pnp Sound device – direct hardware device without any conversions, Card=Device,DEV=0”

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here