flysurfer

Forum Replies Created

Viewing 30 posts - 61 through 90 (of 266 total)
  • 10. Februar 2017 at 16:28 #26813

    Hi Lee,

    I also tested with a Z3 compact before it was ruined by a spider app… I had no problems with pairing – can you try scan for devices on your phone and if you see Max2Play, try to connect to it? Could you also try to disable Bluetooth on your Z3 and enable it again? This should also bring the phone into the Bluetooth discovery mode.

    1. Februar 2017 at 11:17 #26530

    Gary, have you updated to the BETA version of Max2Play to test it?

    The command I added, was just to show how it basically works. The Fix in the Max2Play Beta is little different. You have to edit the card number or use the cards name in the example command, if you want it to work in your setup. If you really want to use the command line, use „pacmd list-cards“ to see the index of your Echo, and use this instead of „2“.

    31. Januar 2017 at 17:35 #26526

    Hi Gary,

    what I found with Amazon Echo after some testing: sometimes it connects fine, but doesn’t start playing as mode of the bluetooth connection is „source“ and not „sink“. This is due to the fact, that the Echo can be sink and source for bluetooth (and Max2Play also allows Streaming from a smartphone). Maybe the Pi decides by throwing a coin during connection which mode is used and you were unlucky in all your attempts…

    Now how to resolve the issue: the bluetooth mode can be changed on the fly with an easy command for the Amazon Echo as user pi on console with
    pacmd set-card-profile 2 a2dp
    Where „2“ is the index of the card and „a2dp“ the prefered mode to send bluetooth to the Echo speaker.

    Easy fix for you: I added a patch to the current BETA of Max2Play, that always chooses the bluetooth speaker mode for Amazon Echo. You should try this. At least after 1 minute of playback it will change to play on the Echo.

    30. Januar 2017 at 15:46 #26414

    @DBP: somehow the Raspberry Pi Repository is not available from your Pi. This may be due to some downtime of the Servers. Trying the installer again after doing a reboot of Router / Max2Play should solve the problem.

    My experience with Bluetooth with Amazon Echo – Now I got an Echo for testing 🙂
    Saying: „Alexa koppeln“ (german for open bluetooth to start connection)
    In Max2Play Bluetooth Addon: Scanning for Devices -> click on Echo-ECW -> connected!
    Switch to Pulse audiooutput in Squeezelite and play somthing with Squeezebox Server -> running perfect!

    Next I am trying for some Smart Home with homematic and control Squeezebox Server with Alexa 🙂

    27. Januar 2017 at 12:15 #26360

    Hi,
    when you update to the latest Beta version of Max2Play (on settings/reboot page), you will have a box at the top of the bluetooth addon, that tells you if the Bluetooth dongle is recognized and loaded correctly.

    26. Januar 2017 at 19:53 #26350

    Hi,

    thanks for sharing this Bort!

    If anyone interested in IR-Support: we now have an easy installer for the Justboom Remote in our Justboom-Soundcard Plugin for Max2Play that supports Jivelite, Squeezlite (direct) and MPD. It comes with preconfigured IR-Codes for the Justboom Remote and has the button configuration ready for Jivelite, Squeezelite and MPD.
    You may also override existing settings with your own and replace IR-Codes or button configuration. There might come a even more powerful standalone IR-Addon for Max2Play in the future with more preconfigured remotes.

    All the Best,
    Stefan

    25. Januar 2017 at 18:07 #26313

    Hi heinzelrumpel,

    the setting is only to turn off the build in bluetooth in RPi3.

    I am sorry that you have problems with bluetooth. Trying to follow your problem description, one typical cause of errors is usually the power supply of the Pi. Different setups need different amounts of „power“ and when powering the Pi just via GPIO pins and running the Squeezebox Server and stream via bluetooth to Squeezelite instances the Pi might suffer from power lacks. It is not only an advertisement you are referencing – indeed we are testing all devices and setups that we send to our customers. The modularity of the plugin based project and the freedom to use Max2Play just makes it impossible to test every scenario. This is why we try to help the best we can in this forum 🙂

    All the Best
    Stefan

    25. Januar 2017 at 11:23 #26291

    @heinzelrumpel: when your streaming just stops, it seems that the bluetooth signal is lost. Do you have your Pi in a solid case? Do you have an external power supply for the Pi or only the power supply from the AMP that is also powering the PI. The reason for breaking bluetooth connection might be because of lack of power. Try to additionally connect a power supply directly to your Pi for testing OR if you can, use a powered USB-Hub and an external bluetooth dongle that works much better than the inbuild bluetooth on the RPi 3.


    @mnvelocitypilot
    & tonyw: great to hear it is working now!

    20. Januar 2017 at 15:20 #26162

    Hi,

    did you give the Display Addon “no mouse cursor” check-box a try? You need to reboot after checking this.

    20. Januar 2017 at 15:17 #26159

    Hi,
    the former Squeezeplug developed into Max2Play! Acutally i’d rather say it evolved into a more powerful piece of software. We do not have the older versions for download on our Server. If you really don’t like to use Raspberry Pi or other supported hardware, I am sorry to tell you, that we cannot help in that case…

    All the Best,
    Stefan

    20. Januar 2017 at 15:11 #26157

    kleiner Nachtrag: Falls du eine HifiBerry Dac-Pro Karte als Soundkarte benutzt, gibt es wohl einen Bug, der die Verwendung bestimmter WLAN-Kanäle beeinträchtigen kann.

    Details hier von einem anderen Max2Play Nutzer: https://www.max2play.com/en/forums/topic/getting-stable-wifi-with-hifiberry-dac-pro-on-pi3/

    20. Januar 2017 at 14:45 #26153

    @knorke007: stürzt der Squeezebox Server, der Bluetooth Stream oder der ganze Pi ab? Ggf. liegt es an unzureichender Stromversorgung, falls noch andere Verbraucher an deinem Pi angeschlossen sind. Bricht es auch ab, wenn du via Bluetooth nur zu einem (nicht mit anderen Playern synchronisierten) Player über den Squeezebox Server streamst?

    Es gibt ein neues Max2Play Update mit 2.40, das vielleicht dein Probleme löst.


    @std
    : ich hab ein Galaxy S7 und auch bei anderen getesteten Smartphones kommt diese Pin abfrage nicht. Hast du vielleicht irgendein File auf dem Pi bearbeitet? Eigentlich sollte bei dem Pairing auf dem Telefon nur die Bestätigung erscheinen, dass die Verbindung aufgebaut wird (nur OK drücken nötig). Kannst du vielleicht mit dem aktuellen Download-Image 2.40 mal testen?

    19. Januar 2017 at 13:09 #26114

    I also encountered the audioerror with squeezelite and shairport and Pulse setting when testing (plopping noise) – trying to figure out why this is happening: after around 1 min the stream recovers and plays nicely -> restarting squeezelite gives the same error again

    This comes from bad buffering values, that need some editing in pulseaudio configuration. Editing Squeezelite Alsa-parameters to use a period count of at least 4096 bytes also fixes this. I will add a fix to the current BETA of Max2Play (will be in next release 2.41), that adds 2 parameters to the pulseaudio configuration in /etc/pulse/daemon.conf :

    
    default-fragments = 5
    default-fragment-size-msec = 2
    

    Long story short: if you use your Audioplayers with soundcard „Pulse“ for Bluetooth Streaming to Bluetooth Speakers or direct streaming from Smartphone to Max2Play (without Squeezebox Server) while still having Squeezelite and Shairport available without conflicts, just update to the latest BETA of Max2Play and Reboot. Shairport and Squeezelite should play fine without the popping noise at start.

    18. Januar 2017 at 18:15 #26071

    @All: I released a new SD-Card Image (in download section) and Max2Play version 2.40 with some bugfixes also for Bluetooth. You should update and Reboot if you encounter any problems (might be solved with the update).


    @Christian
    : I think using the Pi for synchronized bluetooth streaming will be difficult (current focus is on streaming music). When streaming Youtube Audio via Smartphone to Max2Play I get 0.3 to 0.7 second delay (direct stream, not via Squeezebox Server as this delay is about 3 seconds). I don’t think there is an easy way to reduce this. Maybe you should try plain bluetooth speakers for watching videos.
    „Can i configure the available device classes of the Max2Play installation somewhere“ – this is currently not changeable by web interface, but you may try to set this via SSH-console.
    When using Shairport and Squeezelite and Bluetooth Steaming with one dedicated soundcard, it is important to know:
    – All audioplayers try to access the soundcard when set up to use harware soundcard -> if the soundcard is blocked by a player (e.g. Shairport is playing while trying to play Bluetooth) it will not work (might kill the player itsself). Shairport will release the soundcard short time after you stop streaming. Shairtunes for Squeezebox Server is a good way to work around this in a Squeezebox Setup or you wait a little time between start/stop streaming to different players.
    – Setting the audioplayers to use Pulse as audiooutput should give access to the soundcard for all players, even if they are playing at the same time. If you have a dedicated audiocard (hifiberry, Justboom, etc.), always disable the Build-In Audio on the Raspberry Pi! By this, Pulseaudio always uses the soundcard to play audio (and not the headphone jack of the Raspberry).
    I also encountered the audioerror with squeezelite and Pulse setting when testing (plopping noise) – trying to figure out why this is happening: after around 1 min the stream recovers and plays nicely -> restarting squeezelite gives the same error again

    I will add a highlighted Info-Box to the Bluetooth Plugin, that tells important things about the current Setup.


    @pschlaeppi
    :
    Synchronized Bluetooth streaming via Squeezebox Server does only work with Max2Play and Squeezebox Server on the same device, as it records the bluetooth stream on the device. You may try to setup FHEM with Max2Play for testing (have a look at our Plugin page).


    @bastler
    : das DEBUG-log schaut soweit gut aus. Hast du es mehrfach versucht die Verbindung aufzubauen (manchmal klappt es beim ersten Mal nicht)? Ggf. muss am Kopfhörer ebenfalls ein Pairing Knopf gedrückt werden? Ich habe einen Samsung Level One zum testen hier: damit klappt es auf anhieb nachdem man diesen in den Pairing-Modus versetzt hat (Kopfhörer darf nicht mit einem anderen Gerät verbunden sein).

    All the Best
    Stefan

    • This reply was modified 7 years, 5 months ago by flysurfer.
    • This reply was modified 7 years, 5 months ago by flysurfer. Reason: plopping noise with pulse and squeezelite
    13. Januar 2017 at 12:44 #25845

    Hi,

    nice 🙂

    When editing RaspDacDisplay.py, just make sure that you do not click „Reinstall“ in the web interface, as this will overwrite your local changes.

    The sound for the audiophonic should not (but might) have changed – when selecting the audiocard on the audiophonics addon, it sets Squeezelite and Shairport commandline values that are optimal for the card. You can have a look at these commandline parameters and compare theses to your earlier setup.

    All the Best
    Stefan

    11. Januar 2017 at 17:43 #25785

    Hi jcu-muc,

    I tested with the latest Betaversion from today and an external wifi-Stick with pretty much the same settings as you have and after running the Display installer on the audiophonics Addon page the end of the message output of the installer is this:

    
    Successfully installed python-mpd2
    Cleaning up...
    Set SERVER ADDRESS to 192.168.68.101
    Use Interface wlan0 with 7c:dd:90:9e:1a:b2
    Set MAC ADDRESS to 7c:dd:90:9e:1a:b2
    Activated Squeezebox Server in RaspDAC-Display
    Finished - Reboot needed: Click here to Restart Device
    

    It got the right MAC-Address and found the Squeezebox Server. Could you try a Beta-Update of Max2Play and click Reinstall and check the message output?

    Stefan

    11. Januar 2017 at 17:29 #25782

    @heinzelrumpel: yes, currently the device-id for streaming needs to be set for each device with the „install Bluetooth Streaming to Squeezebox Server“ button Castalla mentioned. If you want to stream with another device you must click this button after connecting the phone. This is quite complicated when using multiple bluetooth connections and I will have a look at possibilities to skip this in one of the next versions and just search for connected Bluetooth devices within the tool that starts the stream.

    8. Januar 2017 at 20:36 #25675

    @aschiller: do you have a Raspberry Pi 2 or 3? If you have an old Raspberry A/B/B+, it might just be too slow.


    @pschlaeppi
    :
    You are going for the full setup 🙂 some tips may help you:
    – deactivate the command line switch „Squeezelite Bluetooth Verbindungs Synchronisation“, this is for streaming to bluetooth Speakers. I think you want to stream to Max2Play.
    – you might better use the hardware soundcard output (e.g. automatically configure via hifiberry addon or choose soundcard manually in advanced options on audioplayer page) and do not use pulse, if your main goal is squeezebox and airplay. When shairport and squeezeplayer are paused, streaming with bluetooth should be possible. You always have to pause other players, otherwise you won’t get sound. But this should improve audioquality.
    – regarding „Connecting via Bluetooth works ok, but it will not stop the Squeezebox Player. I will get both Audio
    signals until I stop one or the other.“: The automatic switch for bluetooth only works when using the Squeezebox Server on Max2Play. In your setup you must stop all other audio signals manually.
    – when the switch between shairport and squeezelite is not working as expected, you might try to setup Squeezebox Server on Max2Play for testing. Please EXPAND the filesystem before you do that, as it does not seem to be expanded yet! Another option is to setup Shairtunes in Squeezebox Server. There is a one click installer on Squeezebox Server tab. This enables Airplay for all connected Squeezeboxes and you can disable Shairport on the audioplayer tab.

    Hope that helps.

    Stefan

    6. Januar 2017 at 23:40 #25648

    Hi,

    if anyone else is experiencing this „loading Logitech Media Server“ screen, it might be your Browser and/or Kasperski that is blocking the page from loading.

    try this solution from http://www.squeezebox-forum.de/viewtopic.php?t=3491 :

    
    * Open Kaspersky from the icon in the right bottom corner
    * In the Control Panel open 'Settings' (left bottom)
    * Click on 'Additional'
    * Click on 'Network'
    * Under Traffic processing deselect 'Inject script into web traffic to interact with web pages'
    
    4. Januar 2017 at 16:48 #25508

    @aschiller: The Autostart Bluetooth tool of Max2Play is directly connected to the Pulseaudio process that handles the bluetooth connection. When a stream is sent to Max2Play it should instantly start in the Squeezebox Server and the delay should only be because of recording, buffering and streaming to the choosen Squeezeplayer. Following your description, I think the reason might be the device you are streaming from. When it starts playing, do you miss the first 14 seconds or is it playing from the beginning? Do you stream some local content or from an internet source?
    Does it also take 14 seconds to stop in Squeezebox Server after you stop streaming?

    4. Januar 2017 at 16:24 #25504

    @Gary S: I think the problem is my Bluetooth Handling, as the Echo can Stream AND Receive Bluetooth audio. I don’t have an Echo for testing yet, but there is a part in a file of Max2Play, that sets Pulsaudio to stream via bluetooth (to Bluetooth speakers) if there is anything connected to stream to. This might cause the problem. For testing you could remove the part of the file via SSH Login and edit „nano /var/www/max2play/application/plugins/bluetooth/scripts/autostart.sh“

    search for

    
      # TODO: get current default sink and compare
      if [ ! "" = "$BLUETOOTHSINK" ]; then
    

    change to

    
      # TODO: get current default sink and compare
      BLUETOOTHSINK=""
      if [ ! "" = "$BLUETOOTHSINK" ]; then
    

    Maybe this helps 🙂


    @aschiller
    : 3 seconds should be normal – 30 seconds is way too much. I modified the WaveInput plugin to work with Pulseaudio and stream Bluetooth to the Squeezebox Server. Does this delay also occur after a fresh restart? Did you enable the „Autostart Bluetooth-Streaming in Squeezebox Server“? If you have a look on the Squeezebox Server webinterface – after you start streaming from your phone, how long does it take until the stream is indicated as playing in Squeezebox Server?

    3. Januar 2017 at 15:59 #25407

    Thanks a lot for posting this info! I will change the code to fix it!

    Already added this to the current Beta version of Max2Play.

    All the Best,
    Stefan

    • This reply was modified 7 years, 5 months ago by flysurfer.
    3. Januar 2017 at 13:41 #25384

    @TonyW: thanks for the detailled information! I just tested with your settings (enabled DTOverlay for hifiberry dac pro) and it is working for me (BT-adapter available). Just to make sure it is not because of insufficiant power: remove all other devices (usb-drives, display, etc.) from the Raspberry (maybe also remove the hifiberry card) and check if that solves the problem with bluetooth.

    @all: Bad BT-connection and playback errors (crackling sound, breaks) can be because of bad power supply and/or too many connected devices (usb-drives, display, etc.). You probably need a USB-Hub with an external power supply for USB-Drives and a strong power supply if a display is attached to your RPi. If you have your Pi in a solid metal case, this might also cause bad bluetooth signal and you may try an USB-Bluetooth dongle to improve the connection.

    2. Januar 2017 at 17:32 #25367

    @all: Happy new Year!!!


    @TonyW
    : as your Bluetooth Dongle (inbuild Bluetooth) seems not recognized: Have a look at the „Raspberry Pi Settings“ Page and see if Bluetooth is disabled. Is the Max2Play web interface header telling that you have a „Raspberry PI 3“? Maybe you are running on a RPi 2?


    @mnvelocitypilot
    : the long list in your Squeezebox Server playlist and the bluetooth app, that “reasserts” itself, is triggered by the autostart of the Bluetooth („Autostart Bluetooth-Streaming in Squeezebox Server“). Disable this setting at the bottom of the Bluetooth page (restart RPi), and manually start the Bluetooth Stream in your Squeezebox Server to see if this works better. During testing I had a similar problem with the inbuild bluetooth on RPi 3, when the BT-signal was not very good. The dropping of the BT-signal and reconnects confuse the script, that checks for connected audiostreams and starts/stops the streaming in Squeezebox Server. You may try to place your smartphone right beside your PI and the problem is gone – or use an external Bluetooth stick with better performance to improve the distance. I will also try to improve the autostart script with some delays to react little slower, when a stream is interrupted – this should solve it in the next version of Max2Play.

    27. Dezember 2016 at 10:38 #25258

    @TonyW: If your Bluetooth Debug log is almost empty, something went wrong during installation. Maybe your filesystem is full? Have a look at the Debug output on the settings/reboot page (bottom of page) to see if there is some space left on your SD-Card.

    @Amazon Echo: I will try to get my hands on one of these to test it. Watching at the Debug of Davey it seems that the Echo is recognized as „AudioSource, AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl“ and although he want’s to use it as Bluetooth speaker, it is connected as Bluetooth source (streaming TO Max2Play instead of being a target to stream to). Right now the Bluetooth Addon can be used to setup both: streaming to speakers and being a Bluetooth speaker itsself. There might be more configuration needed, to make sure the Echo is used as speaker and not as input source (or both together).
    If you want the Echo to be speaker, try to disable the Autostart from the „Autostart Bluetooth-Streaming in Squeezebox Server“.

    23. Dezember 2016 at 16:32 #25208

    @ihtruelsen: #1 your devices that are not visible on the Raspberry Pi can connect to other devices, but are not visible to other devices – right? I have to open the bluetooth devices overview on my phone to make it visible to other devices.

    #2 sometimes on a restart (depending on your setup) a second pulseaudio instance is running (this may cause the missing audio although everything seems to play). That is usually solved by a simple restart, if you see a 2 pulseaudio processes in the debug output of the bluetooth addon (at the buttom of the page).

    Another thing: when kodi is running and configured as webservice (remote control) it might block the port 9090 on which the command line interface of squeezebox server is running. If this happens, the bluetooth installer fails to add the favorites entry for the bluetooth device to the squeezebox server and the automatic bluetooth switch (enable streaming once smartphone is playing via bluetooth) won’t work either. I will build a fix for this later.

    22. Dezember 2016 at 18:08 #25174

    Hi guybrush,
    when your playback stops:
    – is it still indicated as playing in Squeezebox Server? If not, this may be because auf the „Autostart Script“ that pauses playing when the connection seems to drop in Pulseaudio. I only had this, when the bluetooth connection was really bad.
    – is it still indicated as playing on your phone?
    – is your smartphone still connected on the bluetooth page?

    22. Dezember 2016 at 12:33 #25144

    Hi Oliver,

    good to hear, that the Boom2 speaker is working now. This was indeed solved with the latest bugfix 🙂

    Sometimes you may have to click twice on the Reconnect Button for initial setup. Also make sure to open the bluetooth setup page on your smartphone before clicking the button. We addressed this in our video tutorial.
    In our tests with different iPhones and android phones (not with android 7.x) we encountered no problems so far.
    Instead of using chromecast you may also use the DLNA streaming via Squeezebox Server (stream to connected players) and smartphone apps like „AllConnect“ on android.
    Choppy sound might also come frome a bad bluetooth connection. I had no trouble or choppy sound with the RPi2 when testing.


    @ihtruelsen
    :
    #1 the other devices you tried to connect do not seem to be visible for the Pi. Maybe due to security settings?
    #2 do your stream to the Squeezebox Server or directly to the Soundcard of your Player? I had this problem only when the bluetooth connection dropped.


    @guybrush73
    :
    The bluetooth deivces in LMS favorites are less important when you activate „Autostart Bluetooth-Streaming in Squeezebox Server“. In this case you don’t need to do anything to start streaming from your smartphone (besides connecting and playing from the smartphone itsself).
    I do not have an Amazon Echo for testing, but maybe this is not recognized as input source (only as speaker)? You might see this in the Debug info on the Bluetooth page.


    @Christian
    – Feature Request:
    Multiple Bluetooth Speakers might be possible with multiple bluetooth adapters. Connecting more than one stream / source to one adapter doesn’t work. If you want to play audio from smartphone directly to some bluetooth speakers, I’d suggest to skip the device in the middle.

    All the Best,
    Stefan

    19. Dezember 2016 at 11:47 #24983

    Hi Wallie,

    sorry, but if you don’t have a Max2Play license the „Raspberry Pi Settings“ Page will not work. This is indicated with the message output above the content („License needed…“). You probably noticed that nothing gets saved when you try to change any values on the page. You may try the 3 month license of Max2Play to set up everything you need.

    All the Best,
    Stefan

    13. Dezember 2016 at 17:43 #24834

    Hi Aurélien,

    you are completely right with addressing the problem. It is mainly because of the different subnets. The idea behind the access point plugin was to give users access to the device itsself and maybe to an internet connection behind another router. If you also want to see the devices in your network you need to change the IP address to your existing subnet. In your case you need to:

    edit /etc/dhcpcd.conf and set the IP to some not yet existing IP
    static ip_address=192.168.1.150/24

    edit /etc/dnsmasq.conf to

    
    dhcp-range=192.168.1.151,192.168.1.160,255.255.255.0,12h
    address=/HOSTNAME/192.168.1.150
    

    edit /etc/hosts and change IP to 192.168.1.150

    I did not test this setup, but it should work. I’d rather recommend to use a good router and some wireless extenders to set up your wifi as this is better for performance and easy of use.

    All the Best,
    Stefan

Viewing 30 posts - 61 through 90 (of 266 total)