[UPDATE BUG FIX] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE BUG FIX] Bluetooth Addon BETA

This topic contains 464 replies, has 104 voices, and was last updated by  awalsh99 premium 4 months ago.

Viewing 30 posts - 151 through 180 (of 465 total)
  • 13. Dezember 2016 at 19:04 #24854

    First of all, thank you for the bluetooth plugin.
    But at the moment it does not work for me as expected.
    I want to use it, to stream music via BT to my M2P Squeezebox-Server running on a RPi3.
    I want to use my smartphone and my Amazon Echo dot to stream to the squeezebox server.

    I’m able to pair both devices with M2P, but with my smartphone streaming works only for a few seconds.
    Then music stops playing and won’t start again.
    With the amazon Echo it doesn’t work at all, device is connected, but no sound.

    Any advises?

    Thank you

    Edit: When I pair a device via BT for the first time, it get’s a name e.g. Bluetooth ECHO-VN2
    When I disconnect the ECHO and pair my smartphone the first time, it get’s the same name like the ECHO.
    And the I have two favourites with the same name in squeezebox server

    • This reply was modified 3 years, 10 months ago by  guybrush73.
    15. Dezember 2016 at 17:43 #24906

    Hi guys,
    I now did a supplementary Instructable for our Bluetooth plugin’s new feature to complement the video I did on it some weeks ago.

    Here is the Instructable:
    http://www.instructables.com/id/Bluetooth-Streaming-for-Raspberry-Pi-Multiroom-Aud/

    And here’s the video again in case you missed it:

    16. Dezember 2016 at 1:41 #24910

    First of all, thank you for the bluetooth addon. It is pretty much the main reason that I chose M2P. That said, I have a couple of problems that I am hoping you can help with:

    1. I set up my Galaxy S7, but I have not been able to connect another phone/tablet. I have tried removing the permanently removing the S7 and trying to scan for other devices, but it doesn’t see them. No errors are thrown, it just lets me know that the scan is complete, but not devices are listed. I can then rescan and reconnect to the S7. All of the other devices that I have tried are able to connect to other bluetooth devices.

    2. When the S7 is connected it is able to play, but after about 10 – 15 minutes or so, the sound cuts out. The phone is still playing, but no sound. If I disconnect from M2P and reconnect, the sound starts up again. Is anyone else seeing this?

    I am using the most up to date M2P on Jessie. Should I update to the M2P Beta to work around these issues?

    16. Dezember 2016 at 10:01 #24911

    Hi ihtruelsen,

    see my post above. I’m having the same issue.
    And additionally, if I pair two different devices, they all got the same name in the LMS favorites.
    And my Amazon Echo doesn’t play any sound through LMS. I’m only able to pair it with M2P.

    16. Dezember 2016 at 12:38 #24912

    I have a question or maybe a feature request:

    using squeeze server for raspberry, is it at all possible to pair and use more than one Bluetooth device at the same time? In the sense: is it possible to stream TO the squeezebox server (say from the mobile) and from it (to some loudspeakers)?
    Or to pair more than one pair of loudspeakers at once? I do this last thing under windows all the time just by creating a virtual sound card with virtual audio cable and by replicating the output signal across different Bluetooth devices.

    Thanks!

    22. Dezember 2016 at 1:07 #25135

    Hello Flysurfer,

    Upgrading to Beta-161219 did not solve my problem with streaming TO the LMS. But at least it helped streaming FROM the RPi to my UE Boom 2 speaker.

    I tried a Google Pixel (Android 7.1.1), an iPhone 5S (iOS 9.3.5), and an iPad Mini (iOS 6). Only the old iPad Mini showed a pairing dialog, when I clicked on the „Reconnect“ button in the max2play GUI.

    Playback on my Raspberry 2 B is choppy although the load average is below 3. Maybe the only solution would be to upgrade to a RPi 3 B?

    Maybe the WaveInput plugin plus an external USB soundcard is a better solution. So I could also connect a Chromecast Audio which might be more useful for streaming audio from Android.

    Thanks
    Oliver

    22. Dezember 2016 at 12:33 #25144

    Hi Oliver,

    good to hear, that the Boom2 speaker is working now. This was indeed solved with the latest bugfix 🙂

    Sometimes you may have to click twice on the Reconnect Button for initial setup. Also make sure to open the bluetooth setup page on your smartphone before clicking the button. We addressed this in our video tutorial.
    In our tests with different iPhones and android phones (not with android 7.x) we encountered no problems so far.
    Instead of using chromecast you may also use the DLNA streaming via Squeezebox Server (stream to connected players) and smartphone apps like „AllConnect“ on android.
    Choppy sound might also come frome a bad bluetooth connection. I had no trouble or choppy sound with the RPi2 when testing.

    @ihtruelsen:
    #1 the other devices you tried to connect do not seem to be visible for the Pi. Maybe due to security settings?
    #2 do your stream to the Squeezebox Server or directly to the Soundcard of your Player? I had this problem only when the bluetooth connection dropped.

    @guybrush73:
    The bluetooth deivces in LMS favorites are less important when you activate „Autostart Bluetooth-Streaming in Squeezebox Server“. In this case you don’t need to do anything to start streaming from your smartphone (besides connecting and playing from the smartphone itsself).
    I do not have an Amazon Echo for testing, but maybe this is not recognized as input source (only as speaker)? You might see this in the Debug info on the Bluetooth page.

    @christian – Feature Request:
    Multiple Bluetooth Speakers might be possible with multiple bluetooth adapters. Connecting more than one stream / source to one adapter doesn’t work. If you want to play audio from smartphone directly to some bluetooth speakers, I’d suggest to skip the device in the middle.

    All the Best,
    Stefan

    22. Dezember 2016 at 17:28 #25169

    Hi Stefan

    I’ll check, if the echo is recognised as speaker or as input device.
    Do you have any advise regarding the other issue I’m experiencing?

    When stream music from my android device to the LMS, the playback stops after a few seconds on the squeezeboxes.

    22. Dezember 2016 at 18:08 #25174

    Hi guybrush,
    when your playback stops:
    – is it still indicated as playing in Squeezebox Server? If not, this may be because auf the „Autostart Script“ that pauses playing when the connection seems to drop in Pulseaudio. I only had this, when the bluetooth connection was really bad.
    – is it still indicated as playing on your phone?
    – is your smartphone still connected on the bluetooth page?

    23. Dezember 2016 at 2:16 #25188

    @flysurfer
    #1 I am not sure what you mean by security settings. Do you mean on the device? I don’t know what settings that would be, but both of the devices that I can’t get the bluetooth addon to see are able to connect to my bluetooth headset and my bluetooth speakers. I also tried to connect them to my phone and they are able to connect to that.

    #2 I am streaming from my phone to the LMS server, using the link in favourites to stream. The connection does not drop and the phone continues to play, there is just no audio until I drop the connection and reconnect.

    23. Dezember 2016 at 16:32 #25208

    @ihtruelsen: #1 your devices that are not visible on the Raspberry Pi can connect to other devices, but are not visible to other devices – right? I have to open the bluetooth devices overview on my phone to make it visible to other devices.

    #2 sometimes on a restart (depending on your setup) a second pulseaudio instance is running (this may cause the missing audio although everything seems to play). That is usually solved by a simple restart, if you see a 2 pulseaudio processes in the debug output of the bluetooth addon (at the buttom of the page).

    Another thing: when kodi is running and configured as webservice (remote control) it might block the port 9090 on which the command line interface of squeezebox server is running. If this happens, the bluetooth installer fails to add the favorites entry for the bluetooth device to the squeezebox server and the automatic bluetooth switch (enable streaming once smartphone is playing via bluetooth) won’t work either. I will build a fix for this later.

    26. Dezember 2016 at 23:50 #25250

    I tried installing Bluetooth on RPI3, assumiong I could use built in Bluetooth, following steps in instructable and it all seemed to go ok until trying to connect (scan for bluetooth devices) – no devices are discovered at all – no area showing ‚known devices‘ as suggested in the video. I know at least 3 Bluetooth devices should be visible (2 TVs, speaker) as my phone can see them and also my phone should be a fourth visible device as it is on the Bluetooth settings page. The install all looked ok until that point. I tried uninstalling and reinstalling twice, including lots of reboots and still the same. Debug looks blank – does this mean Bluetooth is not working on the RPI3? Am I missing some other action I need to take to make it work. Debug below = no text at all other than the titles.

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####

    Other info: Max2Play Hifiberry V2.39, phone Oneplus 2, Hifiberry Dac+, Logitech Media Server Version: 7.9.0 – 1482423225 @ Mon Dec 26 04:38:40 UTC 2016, Squeezlite firmware v1.8

    27. Dezember 2016 at 4:33 #25255

    I’m experiencing the same issue as @guybrush73 with an Amazon Echo Dot. I think there is something strange going on with the Echo based on the following issue:

    – With Echo connected to Max2play (running LMS locally) the audio (Alexa’s voice) comes through with a massive delay (up to a couple of minutes, and sometimes not at all). Also LMS does not automatically start the bluetooth favourite – I have the select it manually.

    Alternatively, I can connect an iPad to max2play and BT streaming happens almost instantly and the LMS bluetooth favourite automatically starts playing and resumes the previous when the phone is stopped. I’ve tried two different RPI2’s (one with Wolfson card and one with IQAudio – same issue for both).

    I can connect the Echo to a commercial BT speaker and everything behaves without delays. There seems to be something unique about the Echo and Max2play connected together.

    How do I confirm if Max2play is seeing the Echo as a source or an output? I’ve included my debug but I am not sure what to look for.

    Does anyone else have any ideas on what the issue could be?

    DEBUG included below (I replaced some ID’s with XXXX):

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:1A:7D:DA:71:14 ACL MTU: 310:10 SCO MTU: 64:8
    UP RUNNING PSCAN
    RX bytes:97906905 acl:319725 sco:0 events:571 errors:0
    TX bytes:11907 acl:367 sco:0 commands:106 errors:0

    #### DEVICE iPad ####

    #### DEVICE XXXX ####
    [64:A3:CB:7C:7D:D8]
    Name: XXXX
    Alias: XXXX [rw]
    Address: 64:A3:CB:7C:7D:D8
    Icon: phone
    Class: 0x7a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [00000000-deca-fade-deca-deafdecacafe, ServiceDiscoveryServer, AudioSource, AVRemoteControlTarget, AVRemoteControl, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation]

    #### DEVICE Echo-JUQ ####
    [88:71:E5:24:08:5F]
    Name: Echo-JUQ
    Alias: Echo-JUQ [rw]
    Address: 88:71:E5:24:08:5F
    Icon: audio-card
    Class: 0x2c0414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [AudioSource, AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb]

    #### PACMD LIST | grep active ####
    active port: <speaker-input>
    active profile: <a2dp_source>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    module.description = „BlueZ 5 Bluetooth audio sink and source“
    argument: <source=“bluez_source.88_71_E5_24_08_5F“ source_dont_move=“true“ sink_input_properties=“media.role=music“>
    module.description = „Loopback from source to sink“
    1 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    1 sink input(s) available.
    sink: 0 <null>
    module-stream-restore.id = „sink-input-by-media-role:music“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    0 S 1000 1249 1 0 80 0 – 18635 – ? 00:00:00 pulsebluetooth
    1 S 1000 4723 1 0 80 0 – 25620 – ? 00:06:07 pulseaudio

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####

    27. Dezember 2016 at 10:38 #25258

    @tonyw: If your Bluetooth Debug log is almost empty, something went wrong during installation. Maybe your filesystem is full? Have a look at the Debug output on the settings/reboot page (bottom of page) to see if there is some space left on your SD-Card.

    @Amazon Echo: I will try to get my hands on one of these to test it. Watching at the Debug of Davey it seems that the Echo is recognized as „AudioSource, AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl“ and although he want’s to use it as Bluetooth speaker, it is connected as Bluetooth source (streaming TO Max2Play instead of being a target to stream to). Right now the Bluetooth Addon can be used to setup both: streaming to speakers and being a Bluetooth speaker itsself. There might be more configuration needed, to make sure the Echo is used as speaker and not as input source (or both together).
    If you want the Echo to be speaker, try to disable the Autostart from the „Autostart Bluetooth-Streaming in Squeezebox Server“.

    27. Dezember 2016 at 11:58 #25260

    From settings/rebbot, looks like plenty of space (as filesystem was expanded), but it appears I am using Wheezy not Jessie – not sure how that happened as I thought I had downloaded latest version using HifiBerry installer. Looks like I need to reinstall!!!!

    27. Dezember 2016 at 13:15 #25261

    My situation:
    I want to stream from tablet to m2p. BT worked until v2.38 with direct stream to soundcard via pulse.
    After update to v2.39 not anymore. The connection from tablet to m2p is ok and tablet plays, but I hear no sound.
    When I connect tablet to a BT speaker it works.
    AND:
    When I play via stream to SB server, it works (not using pulse, but sysdefault)!
    But I want to use direct stream, because SB server has a 3 second buffer delay.

    The problem seems to be that pulse does not work anymore -neither with BT nor directly with SB server. Any ideas?

    Regards,
    Mike

    *UPDATE*
    Ok, I just found the error:
    I watched the second tutorial and saw that these two settings were wrong in my installation:
    1. Shairplay was not set to pulse
    2. In BT options „Audio-Ausgang beim Trennen wechseln“ was not switched on.

    Now it works again… hope this helps some other people, too!

    27. Dezember 2016 at 17:39 #25262

    Issue report: Bluetooth pairing with Smartphone for Max2Play
    Hi Team! Happy Holidays!

    I have been really enjoying my Max2Play+Logitec Media Server image running on my Raspberry Pi 3. Recently I’ve been trying to get stability when using the new Bluetooth app released just this month. I see the following issues:

    – While the Bluetooth link between my iphone 6S and the RP3 appears stable, either Max2Play or LMS is intermittent. The playback randomly stops and eventually restarts. I see a long trail of my bluetooth device, „Dave’s Iphone“ shown in the playlist, and at each intermittent stop and restart, a new listing will appear in the playlist. If I leave it on long enough, I’ll get 100’s of them in the playlist.

    – This behavior is independent of whether I’m controlling LMS via my windows 10 chrome browser or my iPeng app running on my iphone.

    – Also noted – after attempting to run the bluetooth plugin, having it fail, and then going back to listen to either another plugin (i.e., pandora, etc.), or just listening to a networked audio file, the bluetooth app „reasserts“ itself… the selected audio file will start playing, stop, and the bluetooth plugin will reappear (and still not work). I have to stop the LMS and restart it to avoid having bluetooth reassert itself.

    While I’m really rocking on the abilities afforded by Max2Play + LMS, I really want the ability to drive the input from my smartphone via bluetooth (in order to play Sirius XM from the iPhone app, stream podcasts, etc.).

    Is this a user error, or a real issue?

    In any case – Thanks! And any/all help would be gratefully appreciated.

    28. Dezember 2016 at 5:52 #25283

    @flysurfer, Thanks for the info. Just to clarify, my intention is to use the Echo as a audio source to play to my Max2play, which is connected to ceiling speakers. That way I can be playing music but have the Echo interrupt with responses as necessary. It would be perfect for my home automation set up because I can add voice control but with the feeling that you are talking to your house.

    Thanks. I’ll continue to follow this thread and report back if I find any solution.

    28. Dezember 2016 at 15:58 #25311

    Following my earlier post I’ve reinstalled with current Jessie version (new card/fresh install) and done all updates etc. I’ve had more success with Bluetooth to a point in that packages seem to be installed, but still cannot connect to devices that are visible to other Bluetooth/eachother but not currently connected to anything (speaker and phone). No ‚known devices‘ section appears on the Bluetooth tab. Debug information below again showing nothing for dongle (but I am using RPI3 so no dongle attached, only built in Bluetooth – bought as RPI3 and detected as RPI3 by Max2Play). I also went in via terminal as user pi/sudo to check to see what was working in bluetooth – all packages seem to be installed and up to date and I have rebooted at least 3 times. I copied below bluetoothctl outputs which suggest no controller (list also blank)?? Any ideas? Google searches just suggest the packages etc which are already installed which I have checked with apt-get and they are definitely all installed.

    *** BluetoothCTL commands ***

    [bluetooth]# devices
    [bluetooth]# power on
    No default controller available
    [bluetooth]# list
    [bluetooth]#

    *** BLUETOOTH DEBUG INFO ***
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####

    #### PACMD LIST | grep active ####

    SSH is enabled and the default password for the ‚pi‘ user has not been changed.
    This is a security risk – please login as the ‚pi‘ user and type ‚passwd‘ to set a new password.

    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####

    SSH is enabled and the default password for the ‚pi‘ user has not been changed.
    This is a security risk – please login as the ‚pi‘ user and type ‚passwd‘ to set a new password.

    Default sink name: alsa_output.0.analog-stereo
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    module.description = „When a sink/source is removed, try to move its streams to the default sink/source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    1 sink(s) available.
    sinks:
    0 sink input(s) available.

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 1389 1 0 80 0 – 23636 – ? 00:00:00 pulseaudio
    1 S 1000 1453 1 0 80 0 – 478 – ? 00:00:00 start-pulseaudi

    *** SETTINGS/REBOOT DEBUG ALSO BELOW: – ***

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 7427824 2680568 4420892 38% /
    devtmpfs 437056 0 437056 0% /dev
    tmpfs 441388 68 441320 1% /dev/shm
    tmpfs 441388 6192 435196 2% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 441388 0 441388 0% /sys/fs/cgroup
    /dev/mmcblk0p1 61384 21576 39808 36% /boot
    tmpfs 88280 8 88272 1% /run/user/1000
    192.168.1.220:/volume1/Music 2879621632 1956036096 923483136 68% /mnt/MusicDS

    #### LOAD AVERAGE ####
    0.00 0.02 0.03 1/210 6824

    #### KERNEL ####
    Linux ServerLounge 4.4.20-v7+ #908 SMP Wed Sep 7 14:44:27 BST 2016 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 8.0 (jessie)
    Release: 8.0
    Codename: jessie

    30. Dezember 2016 at 11:57 #25323

    I would like to hear other people’s experience of using Amazon Echo Dots. I’ve just purchased one and I’m looking to use it as an ‚always on‘ speaker.

    I currently have one M2P setup as the LMS server plus using Multi-player (?) to run a HifiBerry DAC+ to a BOSE speaker, as well as the built in BT to connect to a second BOSE downstairs in the kitchen. The rest of the house is done using PiCorePlayer and BOSE devices.

    The problem with all of these is that the BOSE go to sleep when not used for a while. The means I cannot rely on them for house announcements.

    What I’m thinking of doing is replacing the PiCorePlayer in the lounge with a M2P again with two players. The existing HifiBerry will stay connected to the BOSE stack, while I want the BT to connect to the Dot and use it as a speaker.

    Has anyone got the Dot to work successfully as a speaker?
    Can anyone suggest ways to then get announcements to be played through it. Full text to speech would be nice, but pre-recorded MP3’s would do.

    1. Januar 2017 at 18:36 #25350

    So I’m curious – has anyone achieved stability in using this Bluetooth addon to source music from, say, a phone to LMS yet?

    I haven’t (after much effort). I still see:

    – While the Bluetooth link between my iphone 6S and the RP3 appears stable, either Max2Play or LMS is intermittent. The playback randomly stops and eventually restarts. I see a long trail of my bluetooth device, “Dave’s Iphone” shown in the playlist, and at each intermittent stop and restart, a new listing will appear in the playlist. If I leave it on long enough, I’ll get 100’s of them in the playlist.

    – This behavior is independent of whether I’m controlling LMS via my windows 10 chrome browser or my iPeng app running on my iphone.

    – Also noted – after attempting to run the bluetooth plugin, having it fail, and then going back to listen to either another plugin (i.e., pandora, etc.), or just listening to a networked audio file, the bluetooth app “reasserts” itself… the selected audio file will start playing, stop, and the bluetooth plugin will reappear (and still not work). I have to stop the LMS and restart it to avoid having bluetooth reassert itself.

    While I’m really rocking on the abilities afforded by Max2Play + LMS, I really want the ability to drive the input from my smartphone via bluetooth (in order to play Sirius XM from the iPhone app, stream podcasts, etc.).

    Is this a user error, or a real issue?

    In any case – Thanks! And any/all help would be gratefully appreciated.

    2. Januar 2017 at 17:32 #25367

    @all: Happy new Year!!!

    @tonyw: as your Bluetooth Dongle (inbuild Bluetooth) seems not recognized: Have a look at the „Raspberry Pi Settings“ Page and see if Bluetooth is disabled. Is the Max2Play web interface header telling that you have a „Raspberry PI 3“? Maybe you are running on a RPi 2?

    @mnvelocitypilot: the long list in your Squeezebox Server playlist and the bluetooth app, that “reasserts” itself, is triggered by the autostart of the Bluetooth („Autostart Bluetooth-Streaming in Squeezebox Server“). Disable this setting at the bottom of the Bluetooth page (restart RPi), and manually start the Bluetooth Stream in your Squeezebox Server to see if this works better. During testing I had a similar problem with the inbuild bluetooth on RPi 3, when the BT-signal was not very good. The dropping of the BT-signal and reconnects confuse the script, that checks for connected audiostreams and starts/stops the streaming in Squeezebox Server. You may try to place your smartphone right beside your PI and the problem is gone – or use an external Bluetooth stick with better performance to improve the distance. I will also try to improve the autostart script with some delays to react little slower, when a stream is interrupted – this should solve it in the next version of Max2Play.

    3. Januar 2017 at 0:45 #25373

    Hi

    I checked the rsapberry settings and bluetooth was not disabled. I tried disbale, reboot, then ‚enable‘ by unticking and reboot again, but still the same. I also checked the Pi model and confirmed it is a Pi3 both via both Max2Play header and also using: cat /proc/cpuinfo – see output at bottom of this post. I also looked at the overlays in the config.txt file as this seems to be where bluetooth can be disabled. It is not obviously disabled via an overlay such as pi3-disable-bt-overlay but there is a Hifiberry overlay and I also found on another forum that someone had issues when they connected devices to GPIO but no answers received. Could the hifiberry dac+ on GPIO and the hifiberry overlay somehow disable bluetooth? I am only guessing and do not know how to check!

    The below are the only uncommented items in config.txt: –

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem=128
    dtoverlay=hifiberry-dacplus

    Looking at hifiberry-dacplus, only documentation I can find is: –

    Name: hifiberry-dacplus
    Info: Configures the HifiBerry DAC+ audio card
    Load: dtoverlay=hifiberry-dacplus,<param>=<val>
    Params: 24db_digital_gain Allow gain to be applied via the PCM512x codec
    Digital volume control. Enable with
    „dtoverlay=hifiberry-dacplus,24db_digital_gain“
    (The default behaviour is that the Digital
    volume control is limited to a maximum of
    0dB. ie. it can attenuate but not provide
    gain. For most users, this will be desired
    as it will prevent clipping. By appending
    the 24dB_digital_gain parameter, the Digital
    volume control will allow up to 24dB of
    gain. If this parameter is enabled, it is the
    responsibility of the user to ensure that
    the Digital volume control is set to a value
    that does not result in clipping/distortion!)
    slave Force DAC+ Pro into slave mode, using Pi as
    master for bit clock and frame clock.

    ***Output of cat /proc/cpuinfo***

    processor : 0
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 1
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 2
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 3
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    Hardware : BCM2709
    Revision : a02082
    Serial : 000000002217f0a7

    3. Januar 2017 at 13:41 #25384

    @tonyw: thanks for the detailled information! I just tested with your settings (enabled DTOverlay for hifiberry dac pro) and it is working for me (BT-adapter available). Just to make sure it is not because of insufficiant power: remove all other devices (usb-drives, display, etc.) from the Raspberry (maybe also remove the hifiberry card) and check if that solves the problem with bluetooth.

    @all: Bad BT-connection and playback errors (crackling sound, breaks) can be because of bad power supply and/or too many connected devices (usb-drives, display, etc.). You probably need a USB-Hub with an external power supply for USB-Drives and a strong power supply if a display is attached to your RPi. If you have your Pi in a solid metal case, this might also cause bad bluetooth signal and you may try an USB-Bluetooth dongle to improve the connection.

    3. Januar 2017 at 23:45 #25442

    Amazon Echo Dot / Alexa as bluetooth speaker.

    As I stated previously I want to use my Dot as an always on BT speaker. Today I downloaded the latest M2P HifiBerry (my plan is to eventuallt use multiplayer and a HiFiBerry card to use one Pi to drive my BOSE stack, and my Dot

    I did all the usual stuff including expanding F/S installing Bluetooth plugin etc. I then managed to pair my Dot to the Pi.
    Lastly I made sure that the AudioPlayer was set to use Pulse as it’s output. A final reboot and everything was ready. Unfortunately, despite both the Pi and the Dot saying that they were paired, when I try to play music, nothing happens, and the track skips to the end.

    Does anyone have a suggestion as to what I can do next?

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: UART
    BD Address: B8:27:EB:62:B8:75 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:4345143 acl:8266 sco:0 events:81 errors:0
    TX bytes:2838 acl:30 sco:0 commands:54 errors:0

    #### DEVICE Echo-0NQ ####
    [88:71:E5:7F:B8:D1]
    Name: Echo-0NQ
    Alias: Echo-0NQ [rw]
    Address: 88:71:E5:7F:B8:D1
    Icon: audio-card
    Class: 0x2c0414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [AudioSource, AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active port: <speaker-input>
    active profile: <output:analog-stereo>
    active profile: <a2dp_source>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    module.description = „BlueZ 5 Bluetooth audio sink and source“
    argument: <source=“bluez_source.88_71_E5_7F_B8_D1″ source_dont_move=“true“ sink_input_properties=“media.role=music“>
    module.description = „Loopback from source to sink“
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    2 sink input(s) available.
    sink: 0 <alsa_output.0.analog-stereo>
    module-stream-restore.id = „sink-input-by-application-name:ALSA plug-in [squeezelite]“
    sink: 0 <alsa_output.0.analog-stereo>
    module-stream-restore.id = „sink-input-by-media-role:music“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 1082 1 3 80 0 – 77003 – ? 00:00:17 pulseaudio

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o pulse -a 80:4:: -B -n Alexa_Speaker
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d pulse
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S16_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 16384
    buffer_size: 16384

    #### OUTPUT SOUND DETAILS CARD 1 ####

    4. Januar 2017 at 13:19 #25469

    Hi everybody,

    first of all congratulations for the amazing work you are doing. This plugin is truly great. Today I followed your tutorial and everything worked out of the box!

    I have one question regarding the playback. At the moment there is a delay of 60 seconds when I use the „stream to squeezebox server“ option until the audio is played on my squeezebox radio. Is there any option or possibility to reduce this delay. I already studied the squeezebox server options but could not find an appropriate parameter. Is the waveinput plugin responsible for this delay?

    Thanks

    • This reply was modified 3 years, 9 months ago by  aschiller.
    4. Januar 2017 at 16:24 #25504

    @Gary S: I think the problem is my Bluetooth Handling, as the Echo can Stream AND Receive Bluetooth audio. I don’t have an Echo for testing yet, but there is a part in a file of Max2Play, that sets Pulsaudio to stream via bluetooth (to Bluetooth speakers) if there is anything connected to stream to. This might cause the problem. For testing you could remove the part of the file via SSH Login and edit „nano /var/www/max2play/application/plugins/bluetooth/scripts/autostart.sh“

    search for

    
      # TODO: get current default sink and compare
      if [ ! "" = "$BLUETOOTHSINK" ]; then
    

    change to

    
      # TODO: get current default sink and compare
      BLUETOOTHSINK=""
      if [ ! "" = "$BLUETOOTHSINK" ]; then
    

    Maybe this helps 🙂

    @aschiller: 3 seconds should be normal – 30 seconds is way too much. I modified the WaveInput plugin to work with Pulseaudio and stream Bluetooth to the Squeezebox Server. Does this delay also occur after a fresh restart? Did you enable the „Autostart Bluetooth-Streaming in Squeezebox Server“? If you have a look on the Squeezebox Server webinterface – after you start streaming from your phone, how long does it take until the stream is indicated as playing in Squeezebox Server?

    4. Januar 2017 at 16:39 #25507

    Thanks for your quick reply. Yes I enabled the „Autostart Bluetooth-Streaming“ option If I restart it sill needs 60 seconds until sound is played. This is also the time which passes by until the stream is inicated as playing in the Squeezebox webinterface. Do you have any idea what else could cause the delay?

    4. Januar 2017 at 16:48 #25508

    @aschiller: The Autostart Bluetooth tool of Max2Play is directly connected to the Pulseaudio process that handles the bluetooth connection. When a stream is sent to Max2Play it should instantly start in the Squeezebox Server and the delay should only be because of recording, buffering and streaming to the choosen Squeezeplayer. Following your description, I think the reason might be the device you are streaming from. When it starts playing, do you miss the first 14 seconds or is it playing from the beginning? Do you stream some local content or from an internet source?
    Does it also take 14 seconds to stop in Squeezebox Server after you stop streaming?

    5. Januar 2017 at 3:20 #25547

    Hi flysurfer – and thanks so much for helping out on my Bluetooth addon issues – much appreciated!

    So, per your instructions, I deselected „Autostart bluetooth streaming in squeezebox server“, rebooted the pi, restarted the squeezebox server, reset the bluetooth link from my phone to the pi, put the phone next to the pi, selected the bluetooth link from favorites inside the Logitech Media Server, and let ‚er rip. Sadly… nothing… nothing at all. Whereas with the autostart selected I would occasionally get snippets of music from my phone through squeezebox to the speakers, in this case I got nothing at all. Silence.

    In your response to me from 2 January you specifically say that I must „manually start the Bluetooth Stream in your Squeezebox Server“. Unless that is something different than selecting the bluetooth link from my favorites inside LMS, I think I’m testing the link as you intended.

    Is this (another) dumb user error? Or is there something else going on?

    For the record, here are the things I tried after this failure:
    – playing tunes directly from the library, or pandora, via LMS (works fine)
    – reselecting the Autostart feature – worked as before, with only short snippets of music (but at least it verified the other settings that could be causing a problem, like volume controls, etc.)

    Below I’ve copied the information from „debug information“ on the Bluetooth page. Can you see anything wrong? Again, I’m really happy with the way everything else is working, but really need the Bluetooth link to have a complete solution.

    Again, I really appreciate your help! Thank you!

    Dave

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: UART
    BD Address: B8:27:EB:EB:B5:5B ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:19429 acl:341 sco:0 events:335 errors:0
    TX bytes:15398 acl:319 sco:0 commands:102 errors:0

    #### DEVICE Daves iphone ####
    [70:81:EB:15:82:91]
    Name: Daves iphone
    Alias: Daves iphone [rw]
    Address: 70:81:EB:15:82:91
    Icon: phone
    Class: 0x7a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [00000000-deca-fade-deca-deafdecacafe, ServiceDiscoveryServer, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    0 sink input(s) available.

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 2686 1 0 80 0 – 25648 – ? 00:00:00 pulseaudio

Viewing 30 posts - 151 through 180 (of 465 total)

You must be logged in to reply to this topic.

Register here