[UPDATE BUG FIX] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE BUG FIX] Bluetooth Addon BETA

This topic contains 454 replies, has 102 voices, and was last updated by  yorickdowne premium 1 week, 3 days ago.

Viewing 30 posts - 61 through 90 (of 455 total)
  • 1. April 2016 at 11:33 #19557

    @schmello: vielleicht lässt sich das in Squeezelite integrieren. Sobald ich etwas zum Testen habe, schreibe ich das hier.

    @Gary: You may use the Multisqueeze Addon from our Addon-Page to set up a separate Squeezelite instance for your DAC and your BT-speakers. You may also try the latest Jessie Image that uses an other way to connect the BT-speakers.

    1. April 2016 at 12:04 #19558

    Thanks for this. After posting the above, I looked in plugins and found the MultiSqueeze add-on and installed it remotely (I’m currrently at work). I will try it out when I get home. Which sound device should I use for the HifiBerry device as it isn’t obvious?

    Is there an easy way to upgrade to the Jessie image, or is it a case of using a brand new image and re-configuring everything?

    • This reply was modified 3 years, 10 months ago by  Gary S.
    1. April 2016 at 13:13 #19561

    Alles klar.. freu ich mich 🙂

    1. April 2016 at 23:23 #19583

    Hi

    Auf meinen RaspBerry Pi 3 läuft das aktuelle max2play Beta-160330 incl. des Blutooth Plugin, mein Soundsystem Teufel Concept E 450 wird auch erkannt aber die Verbindung scheint nicht zu funktionieren. Ich hatte es bei einer fürheren installation schon einmal ans laufen bekommen aber dazu musste ich erst einige Tools nachinstallieren (fragt mich nur nicht welche;).
    Soweit ich es ereknnen kann müsste bei einer erfolgreichen Verbindung das Gerät unter „Known Devices“ grün hinterlegt sein, das schaffe ich einfach nicht. Sollte denn nicht auch ein Eintrag in der /etc/asound.conf erstellt werden? Und so ist dann auch unter Audioplayer > erweiterte Optionen das Bluetooth Gerät nicht wählbar. Ich hatte es auch über X11 versucht aber hier wird ein Pin für die Paarung verlangt und den gibt es bei dem Soundsystem von Teufel nicht.
    Hat jemand einen Tip ob und wie ich das ans laufen bekommen könnte?

    5. April 2016 at 11:11 #19620

    Stephan,
    I’ve just gone to download the Jessie image to see if this does fix the Bluetooth disconnect problem. (is there a reason I keep getting the HTTP authentication dialogue up when I go to the downloads page?)

    The only Jessie image I can see is for the Pi3. I’m only using a Pi2, so which image should?

    5. April 2016 at 13:54 #19636

    Hi Gary,

    thanks for the feedback to the authentication problem on the download page – there was a bug in our development server that is now solved.

    The new Image for the RPi 3 works also for the RPi 2 but not the other way around. To keep it short: new Users should pick the new Image that is based on Debian Jessie. Bluetooth should work well with this SD-Card-Image.

    5. April 2016 at 21:40 #19650

    Hello mine keeps on giving below message

    No valid Max2Play-License for additional plugins and features found. Please enter a valid eMail-address on the Settings-page to verify that you are a customer of Max2Play and to access all features.

    6. April 2016 at 11:34 #19656

    Good news: Squeezelite Power-Status can now be attached to Bluetooth Speakers connection status! An update to the latest Beta is required as this is not in the main release yet!

    I added an optional Squeezelite Update to the Bluetooth Addon (only available for new Debian Jessie based Max2Play with Pulse as audioutput). With this you can easily install a new Squeezelite version that reads the Bluetooth connection status and sets the „Power On“ / „Power Off“ for the Squeezelite Player.

    @castalla, @schmello: Any Feedback is welcome!

    @hansi9990: du musst da eigentlich nichts nachinstallieren (asound.conf ist nicht dafür zuständig). Den Audioplayer Output auf „Pulse“ stellen und nach der Installation von Bluetooth im Addon einmal „Scan“ und anschließend „Reconnect“ klicken (ggf. noch vorher bei deinen Boxen das pairing aktivieren). Falls dabei etwas schief geht den Vorgang einmal wiederholen und hier im Forum mal die Ausgabe (gelb hinterlegte Schrift) und das Debug (unten im Bluetooth Addon) posten.

    @chris piliouris: You need a premium license for Max2Play to setup the Bluetooth-Addon.

    6. April 2016 at 13:41 #19658

    @ flysurfer

    Habe es am Wochenende mal getestet, aber irgendwie will es nicht.
    Habe die Box vom Strom genommen, Beta Update durch geführt.
    Dann Box wieder mit Strom versorgt, Hat sich nicht verbunden, erst wieder nach Manuellen Reconnect.

    Jetzt ist mir aber eingefallen das ich meine Box über das BT Menu des May2Play nicht gefunden habe, musste mich mit Terminal anmelden und die Box Manuel hinzufügen, erst danach hatte Max2Play die Box in der Liste.
    Vielleicht hat es damit zu tun?

    Oder müsste ich mal mein System komplett neu Installieren um eventuelle Fehler zu beseitigen?

    Wie gesagt mir würde es auch schon genügen wenn ich mein Player einschalte, ich ein HTTP Request an mein PI3 senden kann, der den Reconnect für mich erledigt.

    Den würde ich in die Startszene von meinem LightManager setzen.

    7. April 2016 at 7:23 #19690

    Nach dem Update wird mein Speaker nicht mehr verbunden auch wenn er es nach einem Reboot nicht selbst getan hat, so konnte ich ihn wenigstens manuell verbinden. Und alles lief.
    Anbei die debug Info:

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:1A:7D:DA:71:0B ACL MTU: 310:10 SCO MTU: 64:8
    UP RUNNING PSCAN
    RX bytes:1700 acl:0 sco:0 events:84 errors:0
    TX bytes:2240 acl:0 sco:0 commands:72 errors:0

    #### DEVICE EDIFIER R1700BT ####
    [40:EF:4C:A9:25:B2]
    Name: EDIFIER R1700BT
    Alias: EDIFIER R1700BT [rw]
    Address: 40:EF:4C:A9:25:B2
    Icon: audio-card
    Class: 0x240428
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [AdvancedAudioDistribution, AudioSink, AVRemoteControl, VideoConferencing]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    name: <module-null-sink>
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    1 sink input(s) available.
    sink: 0 <alsa_output.0.analog-stereo>
    module-stream-restore.id = „sink-input-by-application-name:ALSA plug-in [squeezelite]“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 1045 1 3 80 0 – 41855 – ? 00:00:24 pulseaudio

    7. April 2016 at 17:39 #19700

    @matrixone: hast du nach dem Update mal neu gestartet und den Speaker aus und wieder angeschaltet?

    8. April 2016 at 9:12 #19704

    Hello,

    My speaker seems to be connected but i have no sound.

    My config : RPI 3, max2play 2.29

    Here are my logs :

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: UART
    BD Address: B8:27:EB:5B:52:4C ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:2970 acl:40 sco:0 events:163 errors:0
    TX bytes:144871 acl:202 sco:0 commands:54 errors:0

    #### DEVICE Audio M Plus ####
    [CC:90:93:05:A8:FB]
    Name: Audio M Plus
    Alias: Audio M Plus [rw]
    Address: CC:90:93:05:A8:FB
    Icon: audio-card
    Class: 0x240404
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl]

    #### DEVICE BeoPlay H8 ####
    [00:09:A7:07:C1:CB]
    Name: BeoPlay H8
    Alias: BeoPlay H8 [rw]
    Address: 00:09:A7:07:C1:CB
    Icon: audio-card
    Class: 0x240418
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [Headset, AudioSink, AVRemoteControlTarget, AVRemoteControl, Handsfree, PnPInformation]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    name: <module-null-sink>
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    0 sink input(s) available.

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 924 1 0 80 0 – 28090 – ? 00:00:00 pulseaudio
    1 S 1000 1132 1 0 80 0 – 25953 – ? 00:00:00 pulseaudio

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8.4-720, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o pulse -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    8. April 2016 at 9:36 #19705

    Hi pics,

    the problem is, that there are 2 pulseaudio processes (see your Bluetooth Debug Log) but it should be just one. Can you try to restart the Pi and if that doesn’t help update to the latest Beta version of Max2Play and try again.

    8. April 2016 at 9:46 #19706

    Thanks

    I restart many times 🙂

    I will try the beta.

    13. April 2016 at 9:39 #19757

    Heute komme ich endlich zum testen…

    Doch damit ich es direkt richtig mache… 🙂
    -Erst auf aktuelle Beta aktualisieren (reboot)
    -Dann Squeezelite aktualisieren (reboot)
    -Dann der zweiten Multisqueeze instanz Pulse Audio zuweisen und in den Parametern (-B) eintragen
    -Bluetooth Box Pairen und via reconnect einmal per Hand verbinden…

    Dann sollte bei der zweite Multisqueeze instanz auto Stop/Start funktionieren sobald die Bluetooth Box ein oder ausgeschaltet wird…
    Das ist so richtig? oder habe ich einen schritt vergessen?

    17. April 2016 at 6:52 #19796

    Hi,

    I still have the same problem : 2 pulseaudio process.

    It works when i „killall pulseaudsio“ and then reconnect the buetooth speaker.

    18. April 2016 at 8:58 #19805

    bei meinen Versuchen hat es kurz geklappt.. dann aber nicht mehr…
    Wenn ihr irgendwelche Daten/Logs braucht.. bescheid sagen.. werde ich dann hier Posten…

    21. April 2016 at 23:10 #19898

    Moin,
    ich habe mehrere Pi im Netz, einer davon ein Pi3. Auf diesem habe ich das Bluetooth-Plugin installiert, dass auch relativ gut funktioniert hat, wenn man davon absieht, dass die Wiedergabe nicht wirklich synchron mit den übrigen Geräten läuft. Hier haben die Einstellungen im LMS zwar eine Verbesserung gebracht, das Problem aber nicht ganz gelöst. Nun habe ich Multisqueeze hinzuinstalliert und einen Player mit Ausgabe auf Pulse und einen mit Ausgabe auf die USB-Soundkarte eingerichtet. Auch das funktiniert ganz gut, bis auf ein Problem: Wenn ich die Bluetoothausgabe mit einem anderen Player im Netzwerk synchronisiere, beschleunigt die Wiedergabe über Bluetooth manchmal plötzlich die Wiedergabegeschwindigkeit, die Songs werden schneller. Kann man das irgendwie in den Griff bekommen, z.B. über das Feintuning zur Synchronisierung in den Einstellungen des LMS?

    25. April 2016 at 15:41 #19954

    Hello,
    Something seems to be wrong for me.
    Install BT is ok
    BT dongle fonds the speaker.
    But not any pulse option anywhere.
    Should I install another plugin ?

    Here are the Debug log:
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 5C:F3:70:71:47:FB ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:1252 acl:0 sco:0 events:91 errors:0
    TX bytes:1815 acl:0 sco:0 commands:83 errors:0

    #### DEVICE MB5 ####
    [6A:6A:5A:A7:82:C0]
    Name: MB5
    Alias: MB5 [rw]
    Address: 6A:6A:5A:A7:82:C0
    Icon: audio-card
    Class: 0x240404
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [Handsfree, Headset, AudioSink, AdvancedAudioDistribution, AVRemoteControl]

    #### PACMD LIST | grep active ####

    #### PACMD LIST | grep sink ####

    #### X-SERVER RUNNING ####
    2

    #### PULSEAUDIO RUNNING ####

    1. Mai 2016 at 11:37 #20007

    flysurfer
    premium
    6. April 2016 at 11:34 #19656

    Good news: Squeezelite Power-Status can now be attached to Bluetooth Speakers connection status! An update to the latest Beta is required as this is not in the main release yet!

    I added an optional Squeezelite Update to the Bluetooth Addon (only available for new Debian Jessie based Max2Play with Pulse as audioutput). With this you can easily install a new Squeezelite version that reads the Bluetooth connection status and sets the “Power On” / “Power Off” for the Squeezelite Player.

    @hansi9990: du musst da eigentlich nichts nachinstallieren (asound.conf ist nicht dafür zuständig). Den Audioplayer Output auf “Pulse” stellen und nach der Installation von Bluetooth im Addon einmal “Scan” und anschließend “Reconnect” klicken (ggf. noch vorher bei deinen Boxen das pairing aktivieren). Falls dabei etwas schief geht den Vorgang einmal wiederholen und hier im Forum mal die Ausgabe (gelb hinterlegte Schrift) und das Debug (unten im Bluetooth Addon) posten.

    @flysurfer
    Die Antwort kommt zwar spät aber das Problem besteht ja noch 😉

    Ok, ich habe es so gemacht wie vorgeschlagen aber es gibt nicht direkt eine Möglichkeit beim Teufel Concept E das pairing zu aktvieren, ich kann nur den Eingang auf BT umschalten.
    Mir ist aber gerade aufgefallen das dieses Problem wohl am Teufel System liegt denn ich bekomme auch mit dem iPhone ode auch iPod Touch keine Verbindung her.

    2. Mai 2016 at 15:15 #20020

    @elembee: you seem to use a Max2Play based on Debian Wheezy that doesn’t need pulseaudio. You need to choose „Bluetoothspeaker“ as Audio Output. The new Max2Play (Debian Jessie) for Raspberry Pi 3 needs Pulseaudio to work.

    @hansi9990: kannst du es mal mit anderen BT-Speakern probieren?

    10. Mai 2016 at 21:28 #20083

    Hi flysurfer

    Danke für deine Unterstützung. 🙂
    Also ich konnte das Problem lokalisieren und die Lösung könnte auch für den einen oder anderen hier interessant sein.
    Die meisten Soundsysteme (z.B. mein Teufel Concept E Digital) lassen nur jeweils eine Verbindung von einem Gerät zu, in meinem Fall hat sich mein Windows PC die Verbindung vor dem Raspberry Pi gegriffen und somit war es nicht mehr möglich eine Verbindung aufzubauen.
    Das wirklich Teuflische 😉 daran ist, das es in Windows 10 nicht ganz so einfach herauszufinden ist ob eine BT Lautsprecher verbunden ist, denn entgegen der Anleitungen im Internet findet man gerade diese BT Klasse (zumindest war das bei mir so) nicht in den Win 10 Bluetooth Einstellungen, nicht unter „Angeschlossene Geräte“ und auch nicht unter „Geräte und Drucker“. Über die Klassische Systemsteuerung > Sound im Reiter Wiedergabe war bei mir das Soundsystem als Kopfhörer zu finden, mit einem Rechtsklick kann man im Popup Menü trennen oder verbinden.
    Nachdem ich es hier getrennt hatte und meine anderen Geräte wie z.B. Smartphone überprüft hatte konnte ich Problemlos über das BT Modul in Max2Play mit dem Soundsystem verbinden. 🙂

    18. Juni 2016 at 15:39 #20733

    Hi

    I can pair my BT Speakers. However, after I installed my Adafruit PiTFT, it wouldn’t work anymore. I can not see any bluetooth device at all.

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: alsa_output.0.analog-stereo
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    1 sink input(s) available.
    sink: 1 <alsa_output.0.analog-stereo>
    module-stream-restore.id = „sink-input-by-application-name:ALSA plug-in [squeezelite]“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 1133 1 2 80 0 – 42094 – ? 00:00:01 pulseaudio
    1 S 1000 1228 1 0 80 0 – 478 – ? 00:00:00 start-pulseaudi

    • This reply was modified 3 years, 8 months ago by  luke.
    19. Juni 2016 at 16:48 #20741

    Got a bit farther. Found out that I had Kernel 4.4.13-v7+ installed before installing the 3.5 PiTFT. During the installation it got downgraded to 4.1.14-v7+ which works for the screen but breaks the bluetooth. Any ideas?

    20. Juni 2016 at 12:05 #20746

    @hansi9990: danke für den Tipp! Ich vermute, dass wird bei einigen Nutzern das Problem sein. Wir werden das im Wiki aufnehmen.

    Hi Luke,

    I just tried your Setup with latest Max2Play Default Image: installed Max2Play Bluetooth Addon and configurated Squeezelite to use Pulse as sound output (important). After this I used the Max2Play Touchdisplay Addon to install the 3.5″ Adafruit Display. Did a reboot and reconnected speakers with Bluetooth – playing fine without problems.

    Maybe you did something in a different way – but it should basically just work out of the box.

    All the Best,
    Stefan

    20. Juni 2016 at 12:37 #20750

    Ok. I’m not sure what I’ve done. Got you latest Jessie Light image (Kernel 4.1.) Started it. Installed bluetooth. Paired my speakers. Set Audioplayer Squeezelight to Pulse. Played a song. Worked. Installed your RIP Plugin. Installed 3.5″ Adafruit. Reboot. Screen started. Bluetooth does not automatically connect. When I go into the bluetooth settings and scan for my BT speakers, I see nothing.
    I read that there are problems when using Adafruits firmware/kernel. https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=138757

    Maybe this shines some light on this matter? https://www.dropbox.com/s/mtncoejjwltm8y5/dmesg.rtf?dl=0

    Also saw that a failure gets displayed at startup:
    ~ $ systemctl status hciuart.service
    ● hciuart.service – Configure Bluetooth Modems connected by UART
    Loaded: loaded (/lib/systemd/system/hciuart.service; enabled)
    Active: failed (Result: exit-code) since Tue 2016-06-21 12:54:33 CEST; 3min 53s ago
    Process: 496 ExecStart=/usr/bin/hciattach /dev/serial1 bcm43xx 921600 noflow – (code=exited, status=1/FAILURE)

    • This reply was modified 3 years, 8 months ago by  luke.
    • This reply was modified 3 years, 8 months ago by  luke. Reason: hciuart failure detected
    8. August 2016 at 3:29 #22073

    Hi,
    I am unable to connect my JBL Charge 3. Got the actual release for my Pi2.
    It shows up in red ist Trusted but not paired or connected.
    Here is the Debug-Info from the Bluetooth page:
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:15:83:02:C3:98 ACL MTU: 310:10 SCO MTU: 64:8
    UP RUNNING PSCAN
    RX bytes:1707 acl:0 sco:0 events:100 errors:0
    TX bytes:849 acl:0 sco:0 commands:66 errors:2

    #### DEVICE JBL Charge 3 ####
    [B8:69:C2:42:DE:88]
    Name: JBL Charge 3
    Alias: JBL Charge 3 [rw]
    Address: B8:69:C2:42:DE:88
    Icon: audio-card
    Class: 0x240414
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: []

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    2 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    1 sink input(s) available.
    sink: 0 <null>
    module-stream-restore.id = „sink-input-by-application-name:ALSA plug-in [squeezelite]“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 986 1 3 80 0 – 42333 – ? 00:00:24 pulseaudio

    27. August 2016 at 19:58 #22674

    Hello!
    I have a Raspberry 2 (no Bluetooth onboard), so I use a dongle.
    With a clean image of Raspbian Jessie, I have no problem.
    With max2play, I installed Bluetooth plugin. Scan not found nothing.
    So, I check Debug output and…
    It doesn’t find any bluetooth dongle???

    #### Bluetooth Installation ####
     
    
    #### Bluetooth Dongle ####
     
    
    #### PACMD LIST | grep active ####
    	active port: <analog-output>
    	active profile: <output:analog-stereo>
     
    
    #### PACMD LIST | grep sink ####
    Default sink name: alsa_output.0.analog-stereo
    		module.description = "When a bluetooth sink or source is added, load module-loopback"
    		module.description = "Automatically restore the default sink and source"
    		module.description = "When a sink/source is removed, try to move its streams to the default sink/source"
    	name: <module-always-sink>
    		module.description = "Mantiene sempre almeno un sink caricato anche se è nullo"
    		module.description = "When a sink/source is idle for too long, suspend it"
    		module.description = "Load filter sinks automatically when needed"
    1 sink(s) available.
    	sinks:
    0 sink input(s) available.
     
    
    #### X-SERVER RUNNING ####
    1 
    
    #### PULSEAUDIO RUNNING ####
    1 S  1000  3005     1  1  80   0 - 23704 -      ?        00:00:00 pulseaudio
    1 S  1000  3026     1  0  80   0 -   475 -      ?        00:00:00 start-pulseaudi
     	

    ssh result:

    [email protected]:~# /etc/init.d/bluetooth status
    â bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
       Active: active (running) since sab 2016-08-27 21:49:11 CEST; 4min 36s ago
         Docs: man:bluetoothd(8)
     Main PID: 3622 (bluetoothd)
       Status: "Running"
       CGroup: /system.slice/bluetooth.service
               ââ3622 /usr/lib/bluetooth/bluetoothd
    
    ago 27 21:49:11 Orange bluetoothd[3622]: Bluetooth daemon 5.23
    ago 27 21:49:11 Orange bluetoothd[3622]: Starting SDP server
    ago 27 21:49:11 Orange systemd[1]: Started Bluetooth service.
    ago 27 21:49:11 Orange bluetoothd[3622]: Bluetooth management interface 1.10...d
    Hint: Some lines were ellipsized, use -l to show in full.
    [email protected]:~# hcitool scan
    Device is not available: No such device
    [email protected]:~#
    
    
    • This reply was modified 3 years, 5 months ago by  Arianna. Reason: add ssh result
    • This reply was modified 3 years, 5 months ago by  Arianna.
    6. September 2016 at 22:58 #22892

    Hi everybody!

    After installing bluetooth plugin, I have tried unsuccesfully to pair with my bluetooth speaker. After scanning and finding the speaker, I click connect button and after a while, nothing happens and devices list doesn’t appear, just the same that at the begging, what is happening? This is the info that appear:

    Connecting to: 00:1D:DF:50:67:D8
    Agent registered
    Device: PHILIPS AS851 (00:1D:DF:50:67:D8)
    Enter PIN code: Trusted: 0 -> 1
    [00:1D:DF:50:67:D8]
    Name: PHILIPS AS851
    Alias: PHILIPS AS851 [rw]
    Address: 00:1D:DF:50:67:D8
    Icon: audio-card
    Class: 0x240404
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: []

    YOU PROBABLY NEED TO RESTART your AUDIOPLAYER (e.g. Squeezelite) to get them to work with Bluetooth!

    Thanks!

Viewing 30 posts - 61 through 90 (of 455 total)

You must be logged in to reply to this topic.

Register here