[UPDATE BUG FIX] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE BUG FIX] Bluetooth Addon BETA

This topic contains 464 replies, has 104 voices, and was last updated by  awalsh99 premium 4 months, 2 weeks ago.

Viewing 30 posts - 91 through 120 (of 465 total)
  • 7. September 2016 at 14:45 #22910

    Hi JavM,

    it seems like your speakers need special identification with a Pin-Code – at least the Debug info says
    Enter PIN code: Trusted: 0 -> 1

    Did you push the „Connect“ button on your speakers when clicking connect in the Max2Play web interface?

    The messages also says Connected: 1, that indicates it was paired correct, but cannot be used until the code is entered and the device is „trusted“.

    As the Max2Play Bluetooth Plugin does not offer this method of pairing, I think it might be necessary to do the pairing one time from the command line. This has to be done only once:
    – Login with SSH (Putty) or use the Remote Control Plugin from Max2Play to login with SSH via Web interface as user „pi“ with password „raspberry“.
    – start /usr/bin/bluetoothctl
    – enter trust 00:1D:DF:50:67:D8 and enter the pin when asked

    7. September 2016 at 20:43 #22918

    Thank you so much for your prompt answer!
    This doesn’t work:

    /usr/bin/bluetoothctl 
    bluetoothctl: command not found

    So I tried:

    /etc/bluetooth $ sudo bluez-simple-agent hci0 00:1D:DF:50:67:D8
    RequestPinCode (/org/bluez/2220/hci0/dev_00_1D_DF_50_67_D8)
    Enter PIN Code: 0000
    Release
    New device (/org/bluez/2220/hci0/dev_00_1D_DF_50_67_D8)

    And it works!

    Thank very much, Max2Play is a really nice tool for noobs like me!

    • This reply was modified 4 years, 1 month ago by  JavM.
    19. Oktober 2016 at 10:13 #23445

    Hello,
    I use a Bluetooth Max2Play for Squeezbox, FHEM for home automation (ping Bluettoth on phone for presence) and Jivelite for connection to my 2.5 inch.
    This all works perfectly but if there is a power failure or the raspberry Rebbot I lose bluetooth controller despite the check box activated at boot.
    And if I run it bluetoothctl not find any controller so nothing works.
    What order do I run to finally find my bluetooth controller for the moment the only thing that works and completely reinstall Max2Play
    Thank you and congratulations for your work
    PS: Sorry for the translation but I’m French !-)

    26. Oktober 2016 at 13:56 #23577

    Hello Mar Letourneau,

    Are Bluetooth controllers still displayed when you are looking for them?

    Please try to deactivate the autostart of jivelite.

    Which plugins are running at the same time on your setup?

    Best Regards

    26. Oktober 2016 at 14:20 #23578

    I’m using a RPI3 with built in bluetooth, and an up-to-date M2P install.

    Connected to this I use a BOSE bluetooth speaker, and the sound is amazing. The problem I have is that the BOSE goes to sleep if it isn’t use for a while. When it goes to sleep, the player goes to ‚off‘ state. When I turn the BOSE back on, the player goes back to ‚on‘ state. However, I need to do it from the BOSE. Is there any way that I can turn it on over Bluetooth from my M2P server?

    26. Oktober 2016 at 16:31 #23581

    Hello,
    I redid a compléte installation and for a few days over bluetooth loss.
    By during installation, I have uninstalled and reinstalled FHEM for bluetooth normally.

    3. November 2016 at 13:37 #23768

    Dear Marc Letourneau,

    please make a BETA update. This should fix your problem

    ———————–

    Dear Gary S,

    Is this option already possible if you connect your smartphone with the Bose speaker? Or did you have to start it with the ON/OFF button on the BOSE speaker, too?

    5. November 2016 at 11:28 #23719

    Dear All,

    I have a problem that might as well be related to my USB BT dongle. I am using a PI2, under Max2Play version 2.37, and I have just bought the premium license (thanks for this amazing project, by the way!).
    I have installed the Bluetooth plugin and the procedure seemed to end correctly, only any scan for devices turns out empty. This is the debug window:

    
    #### Bluetooth Installation ####
     
    
    #### Bluetooth Dongle ####
    hci0:	Type: BR/EDR  Bus: USB
    	BD Address: 00:11:67:05:4A:C1  ACL MTU: 678:8  SCO MTU: 48:10
    	UP RUNNING 
    	RX bytes:760 acl:0 sco:0 events:31 errors:0
    	TX bytes:117 acl:0 sco:0 commands:31 errors:0
    
     
    
    #### PACMD LIST | grep active ####
     
    
    #### PACMD LIST | grep sink ####
    Default sink name: auto_null
    		module.description = "When a bluetooth sink or source is added, load module-loopback"
    		module.description = "Automatically restore the default sink and source"
    		module.description = "When a sink/source is removed, try to move its streams to the default sink/source"
    	name: <module-always-sink>
    		module.description = "Always keeps at least one sink loaded even if it's a null one"
    	name: <module-null-sink>
    	argument: <sink_name=auto_null sink_properties='device.description="Dummy Output"'>
    		module.description = "Clocked NULL sink"
    		module.description = "When a sink/source is idle for too long, suspend it"
    		module.description = "Load filter sinks automatically when needed"
    1 sink(s) available.
    	driver: <module-null-sink.c>
    	driver: <module-null-sink.c>
    0 sink input(s) available.
     
    
    #### X-SERVER RUNNING ####
    1 
    
    #### PULSEAUDIO RUNNING ####
    1 S  1000  1413     1  0  80   0 - 23265 -      ?        00:00:00 pulseaudio
    1 S  1000  1434     1  0  80   0 -   478 -      ?        00:00:00 start-pulseaudi
    

    A (little) bit of investigation from the console led me to:

    
     service bluetooth status
    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
       Active: active (running) since Sat 2016-11-05 09:41:28 CET; 24min ago
         Docs: man:bluetoothd(8)
     Main PID: 365 (bluetoothd)
    

    and to

    
    hcitool scan
    Scanning ...
            11:75:58:23:81:06       AS200
    

    and I can get the device information too.
    Only, if I try to connect:

    sudo hcitool cc  11:75:58:23:81:06
    Can't create connection: Input/output error

    Going into bluetoothctl, I have:

    
    [bluetooth]# list
    [bluetooth]# devices
    [bluetooth]#
    

    Any idea? Thanks!
    Christian

    8. November 2016 at 22:34 #23779

    Hi – not sure if i’m misunderstanding something….is there a way to pause the player when bluetooth is disconnected? And perhaps restart when reconnection happens??

    9. November 2016 at 15:56 #23832

    Dear Christian Valente,

    We can not ensure that all Bluetooth sticks work. Please check that the Bluetooth search mode is activated for the device you are looking for, and also let the Max2Play device search 2 or 3 times for the Bluetooth device.

    If it not work please try another Bluetooth dongle. Maybe this will fix your problem. Here you will find our recommended Bluetooth stick:

    Bluetooth Dongle

    Best Regards

    10. November 2016 at 11:39 #23853

    @southafricanrob: there is a setting for this to switch off / on squeezelite player by connection status of bluetooth speakers on the bluetooth page. See also the instruction on this page how to set up.

    11. November 2016 at 5:23 #23871

    I click the ‚Scan for Bluetooth Devices‘ button when my speaker is in Search mode but all I get back is

    Using BluetoothCTL Manager
    Scanning Complete

    Version 2.38
    Raspberry PI 3

    Any suggestions?

    • This reply was modified 3 years, 11 months ago by  TrickiDicki.
    14. November 2016 at 14:39 #23900

    Thanks – is there an option to do the reverse though? i.e turn off bluetooth when squeezelite is stopped/turned off?
    I have a set of bluetooth headphones I use with both my laptop and max2play – am having trouble connecting them to my laptop now as when i turn them on they are automatically connecting to max2play as its always on and trying to reconnect every minute…

    21. November 2016 at 14:23 #24048

    I have spent hours attempting to get the new server stream working … the latest failure is:

    Wheezy Image is not supported!

    Update Configfile – existing Entry changed
    bluetooth successfully removed from autostart
    Update Configfile – existing Entry changed
    bluetooth successfully added to autostart

    The install instructions are NOT clear enough.

    I installed bluetooth – then paired my smartphone – then attempted to create the stream

    Nothing – other than the above error message.

    21. November 2016 at 15:15 #24049

    Hi Castalla,

    the bluetooth streaming is only supported with the Debian Jessie version of Max2Play on Raspberry Pi (this is the base operating system). When it says „Wheezy Image is not supported“ this indicates, that you are using the older Debian Wheezy System. The jump from Wheezy to Jessie was around 6 month ago. Please flash a new SD-Card with the current download of Max2Play to use Bluetooth streaming to Squeezebox Server.

    Regards,
    Stefan

    21. November 2016 at 16:47 #24058

    I finally realised from all the disparate bits of information that I need the Jessie img.

    However, after installing, updating to the beta, adding the BT module and installing LMS, I am no further forward. The BT install appears to be successful (apart from some blurb about jivelite and pulseaudio ???). However the BT page never shows BT as installed – just repeatedly offers to install BT.

    I am now doing reinstall number 8 of the whole system.

    I only want the server stream feature – no speakers or direct audio.

    Grrrrrrrrrrrrrrrrrrrrr

    21. November 2016 at 17:07 #24064

    Hi Castalla,

    it should be really easy – maybe you missed the part where you couple your smartphone with Max2Play? This must be done just once after you installed the Bluetooth plugin and before clicking the „install Bluetooth Streaming to Squeezebox Server“ at the bottom of the Bluetooth Plugin (this really needs to know your smartphone as otherwise it will not start streaming).

    After this you should see the Bluetooth device in your LMS in favorites.

    Errors may occure when:
    – no space left on SD-Card when installing
    – no Bluetooth Connection to your Smartphone (indicated as green)

    Hope this helps – Stefan

    21. November 2016 at 17:17 #24066

    Thanks – but no help really. This last attempt just refused to install BT = claiming it was ‚finished‘ but no screen indication that it was installed.

    Does this require the beta img or is 2.38 enough?

    21. November 2016 at 17:23 #24067

    Hi – the 2.38 should work fine.

    If it cannot install Bluetooth, maybe you forgot to expand the filesystem and the SD-Card is full? After installing Squeezebox Server this might be the problem. You can check this in the DEBUG at the Settings Page.

    21. November 2016 at 17:30 #24068

    Nope! I always expand the FS on install.

    I’m now reinstalling LMS, then I’ll install BT again.

    To be clear – for the stream route, I don’t need to mess with any audioplayer setting?

    21. November 2016 at 17:35 #24069

    Yeah – right. No audioplayer settings need to be edited. The Bluetooth Streaming to Squeezebox Server works like a radio stream and is fully integrated into Squeezbox Server.

    The Bluetooth Plugin Page might be a little confusing at first, as it offers multiple options, depending on what you want to achieve.

    If the Bluetooth Plugin does not install, there must be something wrong with the system. Maybe the SD-Card had an error on installing.

    21. November 2016 at 18:19 #24070

    Okay.

    I’ll continue tomoorow. Thanks.

    21. November 2016 at 19:15 #24076

    Partial success!

    I now have bluetooth installed!

    Before the stream step – do I simply switch BT on the phone, then scan from max2play for the phone? Is that what you mean by connect the phone and max2play?

    22. November 2016 at 15:35 #24084

    Well – day 2 of frustration and head-scratching ….

    Turn BT on smartphone – enters discovery mode – scan from max2play. Phone appears in list in RED

    So what now? Any attempt to connect fails.

    ??????????????????????????????????????????

    22. November 2016 at 15:48 #24085

    We will make a video for this to clarify – but the text on the bluetooth page explains everything. There are just 4 buttons to click to install and setup…

    First click: install bluetooth

    Second click: scan for devices

    Third click (where you struggle): When your phone appears after the scan in red, you need to connect to it by clicking „reconnect“ button. Then your phone will ask you to open the connection. After you confirm this your phone will be indicated as connected and green on the bluetooth page.

    Fourth click: at the bottom of the bluetooth plugin page click „Install Bluetooth Streaming for Squeezebox Server“ and optionally enable „Autostart“ below it.

    Everything together takes about 2 minutes of time…

    22. November 2016 at 16:09 #24088

    Another fail ….

    Reconnect gives:

    Using BluetoothCTL Manager
    Make sure to set the soundcard of your audioplayers to PULSE (advanced settings Squeezelite) to get them to work with Bluetooth!
    bluetooth
    Controller 00:1B:10:00:05:94 max2play default

    Device 3C:DF:BD:12:C4:xx HUAWEI Y3000100
    scan on
    quit
    …….. etc

    • This reply was modified 3 years, 11 months ago by  castalla.
    22. November 2016 at 16:23 #24089

    castalla,

    I must admit that I’ve been sat here wondering what your problem is, because from memory, when I set my bluetooth it was a doddle.

    Then, yesterday I had to reset it. I thought that there was a problem with the BT setup on my m2p server so I removed it so that I could reset it. (It turned out that the real problem was that my phone had paired with my speaker preventing it from linking to anything else)

    I then spent ages trying to get the server and speaker to pair.

    To cut a long story short, I finally remembered that I’d had this problem initially and had to pair them via the command line. The problem being that to pair the devices, a PIN needed to be entered. I did the following:

    hcitool scan
    bluez-simple-agent hci0 A0:E9:DB:40:12:D1

    The first found the BT device address which I then used in the second command. I can’t remember exactly what I did inside
    bluez-simple-agent but the doc’s were very simple.

    22. November 2016 at 16:37 #24092

    I set up speakers earlier this year – worked okay.

    I’ve been down the command-line BT route before – if it works, fine. When it doesn’t, then it’s easy to reduce everything to a complete mess!

    Max2play claim this is simple – not my experience! The onpage instructions are confusing as there is no clear distinction between what’s necessary for speakers versus the stream methods.

    The two routes should be clearly set apart.

    22. November 2016 at 16:51 #24093

    Here’s the last lines of the BT log:

    —————————————–
    3C:DF:BD:12:C4:A0
    Name: HUAWEI Y3000100
    Alias: HUAWEI Y3000100 rw
    Address: 3C:DF:BD:12:C4:XX
    Icon: phone
    Class: 0x58020c
    Paired: 0
    Trusted: 1 rw
    Blocked: 0 rw
    Connected: 0
    UUIDs: 0000180000001000800000805f9b34fb 0000180100001000800000805f9b34fb AudioSource AVRemoteControlTarget HeadsetAudioGateway OBEXObjectPush HandsfreeAudioGateway PhoneBookAccess

    —————————————–
    No pairing and no connection

    22. November 2016 at 17:29 #24095

    Hi castalla,

    once more: After you click „reconnect“ in the web interface, does your smartphone show a window with „Do you want to connect to Max2Play?“ AND did you confirm this message with „OK“?

    After the first initial setup you just need to choose „Max2Play“ from your smartphone (Bluetooth Settings) to connect.

    • This reply was modified 3 years, 11 months ago by  flysurfer.
Viewing 30 posts - 91 through 120 (of 465 total)

You must be logged in to reply to this topic.

Register here