[UPDATE] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE] Bluetooth Addon BETA

This topic contains 413 replies, has 92 voices, and was last updated by  Heiner Moderator 2 weeks, 4 days ago.

Viewing 24 posts - 391 through 414 (of 414 total)
  • 16. November 2018 at 17:09 #42091

    Ja, Problem besteht trotz neuem Image.

    17. November 2018 at 6:52 #42103

    Info:
    Nachdem ich ein

    Upgrade zum letzten Kernel (deaktiviert Wolfson Soundkarten!):
    Update alle Pakete (apt-get update; apt-get upgrade):

    durchgeführt habe, haben Sich die Lautsprecher verbunden. So wie es bis jetzt aussieht funktioniert soweit auch alles.

    Ich werde weiter testen und hier berichten.

    19. November 2018 at 17:27 #42127

    Danke für die Info. Das sollte eigentlich nicht nötig sein mit einem frisch gebrannten Image (2.45). Wir versuchen das nochmal nachzustellen hier.

    3. Dezember 2018 at 12:31 #42482

    Hallo,

    seit dem letzten Update funktioniert mein Bluetooth leider nicht mehr, sobald ich meinen Raspberry Pi nach dem Update neu starte.

    Was habe ich bisher versucht?

    Bluetooth deinstallieren, Bluetooth device resetten, Update auf die aktuelle Beta, apt-get update, apt-get upgrade.

    Gerät: Raspberry Pi 3 Model B
    Aktuell installierte max2play Version: 2.47

    Ich hoffe Ihr könnt mir mit meinem Problem weiterhelfen.

    VG

    DEBUG Info:

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:FA:D2:14 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN ISCAN
    RX bytes:745 acl:0 sco:0 events:46 errors:0
    TX bytes:1283 acl:0 sco:0 commands:46 errors:0

    #### DEVICE Logitech BT Adapter ####
    [88:C6:26:A9:0D:4A]
    Name: Logitech BT Adapter
    Alias: Logitech BT Adapter [rw]
    Address: 88:C6:26:A9:0D:4A
    Icon: audio-card
    Class: 0x240414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [AudioSink, AdvancedAudioDistribution]

    #### DEVICE MD 43621 ####
    [00:6A:8E:17:26:B3]
    Name: MD 43621
    Alias: MD 43621 [rw]
    Address: 00:6A:8E:17:26:B3
    Icon: audio-card
    Class: 0x240404
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [Headset, AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, Handsfree]

    #### DEVICE Philips AEA2700 ####
    [0C:A6:94:99:20:DE]
    Name: Philips AEA2700
    Alias: Philips AEA2700 [rw]
    Address: 0C:A6:94:99:20:DE
    Icon: audio-card
    Class: 0x240414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [AudioSink, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl]

    #### BLUEALSA ERROR ####
    ● bluealsa.service – Start Bluealsa for Bluetooth on Alsa (not compatible with Pulseaudio)
    Loaded: loaded (/etc/systemd/system/bluealsa.service; enabled; vendor preset: enabled)
    Active: activating (auto-restart) (Result: exit-code) since Mon 2018-12-03 11:15:32 CET; 940ms ago
    Process: 1336 ExecStart=/usr/bin/bluealsa -p a2dp-sink -p a2dp-source (code=exited, status=1/FAILURE)
    Process: 1305 ExecStartPre=/bin/sleep 2 (code=exited, status=0/SUCCESS)
    Main PID: 1336 (code=exited, status=1/FAILURE)

    Dec 03 11:15:32 max2play systemd[1]: bluealsa.service: Failed with result ‚exit-code‘.

    #### BLUEALSA RUNNING ####
    0

    4. Dezember 2018 at 16:44 #42548

    Hallo Elfe,

    Deine Installation sieht in Ordnung aus.

    Es kann sein, dass aktuell zu viele Geräte versuchen auf deinen Pi zuzugreifen, da anscheinend 3 Geräte gekoppelt aber nicht verbunden sind. Versuch ggf einmal, alle Geräte aus deiner Auswahl zu löschen und nur eins aktiv und an zu haben zu Koppeln um dies als Fehlerquelle auszuschließen. Der eingebaute Bluetooth-Chip vom Pi teilt sich die Ressourcen mit dem WLAN-Chip. Hast du WLAN oder Ethernet als Netzverbindung? Ggf. noch versuchen mit Ethernet falls noch nicht getan.

    5. Dezember 2018 at 13:08 #42569

    Hallo Heiner,

    Danke für deine Rückmeldung. Ich nutze immer Ethernet als Netzverbindung.

    Das Löschen der Geräte in max2play hat leider nicht geklappt, weil diese trotz Neustart beim Scannen immer wieder unter bekannte Geräte aufgetaucht sind.

    Beim Verbinden ist mir u.a. die folgende Fehlermeldung aufgefallen: failed to pair org.bluez.error.alreadyexists

    Die Anleitung unten hat letztendlich zum Erfolg geführt (über SSH mit Putty):

    
    1. sudo apt-get install pulseaudio-module-bluetooth
    2. sudo killall pulseaudio (möglicherweise Fehlermeldung --> ignorieren)
    3. pulseaudio --start
    4. bluetoothctl
    5. connect xx:xx:xx:xx:xx:xx (xx:xx:xx:xx:xx:xx --> MAC Adresse vom AEA2700)
    

    Quelle: https://bit.ly/2zLO2CP (raspberrypi stackexchange)

    VG

    elfe414

    6. Dezember 2018 at 17:28 #42578

    Hallo,
    ich habe folgendes Problem. Die Bluetooth Verbindung zu meinem Sony AV Receiver funktioniert nur wenn ich über die Einstellungsseite das Gerät manuell verbinde. Soweit ich verstanden habe sollten sich doch bekannte Bluetooth Geräte automatisch verbinden wenn ich zuerst Max2Play starte und dann das Bluetooth Gerät oder?
    Der Receiver taucht auch in der Übersicht in rot auf.
    Gibt es da einen speziellen Trick?

    VG

    J.Eckey

    7. Dezember 2018 at 12:40 #42598

    @elfe: Danke für die Rückmeldung, freut mich dass es jetzt wieder bei dir läuft.

    @courgan: Das kommt leider immer sehr auf die jeweilige BT-Implementation deiner Hardware an. Manche haben eine Auto-Verbindungsoption. Um einen möglichen Fehler in der Max2Play-Installation ausschließen zu können, kannst du noch versuchen das BT-Plugin neu zu installieren.

    7. Dezember 2018 at 17:33 #42611

    Hallo Heiner,

    danke erstmal für die Antwort.
    Aber ich verstehe noch nicht ganz wann und wie der Connect Befehl von Max2Play abgesetzt wird. Wenn ich meinen Receiver auf BT-Standby lasse, also er sich automatisch anschalten soll sobald sich ein Bluetooth Gerät verbinden will und ich manuell über die Weboberfläche den Connect anstoße, schaltet der Receiver sich ein und alles funktioniert.
    Wäre es nicht möglich den Connect Befehl irgendwie beim starten von Max2Play schon automatisch abzusetzen? Evtl. über einen Cronjob oder Start Skript?

    Gruß Jörg

    10. Dezember 2018 at 12:45 #42632

    Hallo Jörg,

    Das wäre sicherlich umsetzbar. Gegebenenfalls wäre der einfachste Weg sogar eine Umsetzung mit unserer HTTP-Befehlstruktur.

    12. Januar 2019 at 20:59 #43557

    (German description below)

    Hi,

    just doing the first steps with our Raspi 3B+/HifiBerry device. Squeeze controller work well (SqueezePlay for PC, Squeezer for Android phone). Tried to connect smartphone via Bluetooth, but failed.

    Pariing works. Tried to connect smartphone directly to squeezebox server. No stream under „Favorites“ implemented, no sound output. Is this, because LMS is running not on the RPI but on our Synology nas? Should we try something else?

    – installed Bluetooth streaming to squeezebox server
    – checked AutoStart-streaming-on-server option
    – added Debug mode in a second step
    – no player MAC address specified

    Thanks for all support!

    – – –

    Hallo,
    wir haben glücklich mit dem neuen Raspi 3B+/HifiBerry gestartet. Die Squeeze-Controller auf dem PC und Smartphone steuern den Raspi sehr schön, auch Synchronisieren mehrerer Player im Netz haben wir schon probiert mit InternetRadio und AudioDateien vom NAS. Der nächste Schritt wäre Bluetooth-Sound vom Smartphone gewesen – aber das klappt nicht.

    Aktivieren von Bluetooth auf dem Raspi klappt, Pairing des Smartphone mit Max2Play auch – als „Media Audio“ (so im Smartphone). Aber es entsteht kein Streaming Channel in LMS unter „Favoriten“. Also auch keine Audioausgabe. Liegt das daran, dass die entsprechende Option der Max2Play-Settings voraussetzt, dass LMS auf dem Raspi läuft? Bei uns läuft sie auf dem NAS. Was sollen wir tun?

    Vielen Dank für jeden Hinweis.

    FZinForen

    • This reply was modified 1 month ago by  FZinforen.
    12. Januar 2019 at 21:23 #43559

    Direct Bluetooth Audio output on the Raspberry/Hifiberry didn’t work either – and the steps to go while following the instructing video mention a „Pulse“ Audio output which I can’t find on my M2P 2.47 installation browser admin page.

    • This reply was modified 1 month ago by  FZinforen.
    13. Januar 2019 at 22:27 #43564

    OK, found the point. Didn’t pay attention to that sentence: (Install stream to squeezebox server) „Dies funktioniert nur, wenn der Squeezebox Server auf diesem Gerät läuft!“ (‚only works if Squeezebox server ist running on this device‘) Doesn’t in my setting.

    So then no wonder it doesn’t work.

    But I still don’t understand why there is no streaming to the Raspi audio card.

    The smartphone is paired:

     If you connected Bluetooth Speakers, make sure to set the soundcard of your audioplayers to bluetooth as audio output! You need to restart your Audioplayer if the Bluetooth Device changed.
    If you connected a Smartphone to stream to Squeezebox Server, NO further setting to your soundcard is needed (do NOT set your soundcard to bluealsa)!
    Device C4:86:E9:05:E9:B6 HUAWEI P9 lite
    trust C4:86:E9:05:E9:B6
    Changing C4:86:E9:05:E9:B6 trust succeeded
    pair C4:86:E9:05:E9:B6
    Attempting to pair with C4:86:E9:05:E9:B6
    Failed to pair: org.bluez.Error.AlreadyExists
    connect C4:86:E9:05:E9:B6
    Attempting to connect to C4:86:E9:05:E9:B6
    Device C4:86:E9:05:E9:B6 Connected: yes
    Connection successful
    quit
    Name: HUAWEI P9 lite
    Address: C4:86:E9:05:E9:B6
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Connected: 1 

    Streaming to Raspi audio card is activated with:

    Status: Bluetooth-Speaker läuft aktuell unter der ProzessID 16168
    Autostart Bluetooth Speaker: Yes
    Sound Device: ALSA - hw:0:0 - Mixer

    The other two sound devices don’t work either.

    FZinFOren

    13. Januar 2019 at 23:17 #43566

    If you have other audioplayers (squeezelite / shairport / MPD / Kodi) running, make sure the audiocard is not blocked!

    I didn’t pay attention to this, first – but it doesn’t work either, if I stop and de-autostart Squeezelite.

    What do I all have to pay attention to?

    FZinForen

    14. Januar 2019 at 16:12 #43608

    Hi FZ,

    With direct streaming to audio card, the output needs to be Bluetooth on both players.

    Max2Play Bluetooth switched to bluealsa instead of pulse for better performance. However, the procedure is the same and the help materials still all apply.

    14. Januar 2019 at 20:58 #43633

    Hi,

    I’ve gone through all the instructions and completed all the steps to use the Bluetooth addon. It works with the onboard Bluetooth in my Pi, but then stops. After doing some reading, I see the problem is that the onboard Bluetooth isn’t stable for streaming. The solution seems to be that I should use a USB Bluetooth dongle, so I ordered one that works on the Raspberry Pi and have installed it. Now for the stupid question of the day. How do I tell M2P to use the external/dongle Bluetooth vs the internal/onboard Bluetooth? Should I disable the internal one? Is there some way to select the external one in settings? I’m using the Stream to Squeezebox Server option.

    I’ve found many post about adding USB Bluetooth to a Pi, but they are mostly for Jesse and I’m now using Stretch, which as a different implementation of Bluetooth. In the end, I couldn’t find anything specific on how to select which Bluetooth I want to use.

    Thanks for any help!

    14. Januar 2019 at 21:00 #43634

    Thank you, Heiner,
    for your answer. You encouraged me to try it again, but I still don’t quite get it.

    I want to stream audio from an android device via Bluetooth to the Raspi audio card (HifiBerry) and get it to the rca jacks/amplifier, not connect a bluetooth speaker.
    1. I install Bluetooth (successful).
    2. I connect my device via bluetooth – android phone says: connected to Max2Play as „Media-Audio“.
    3. I run „Bluetooth Speaker“ from the Bluetooth page (auto run) because it seems to be necessary.
    4. I run music with my „Play Music“ app on the phone and set output to bluetooth (if I uncheck, I hear the music playing on my phone)
    5. There are different places in M2P where you can set audio devices. I don’t change „ALSA – hw:0:0 – Mixer“ on the Bluetooth page, I don’t change „Standard (use HDMI if plugged)“ (or the like) for the RPI audio output on the Players page, but I change „default – snd_rpi_hifiberry…“ into „bluetooth – Your Bluetooth device…“ (with the MAC address of my smartphone following in the name) in Squeezelite > Extended Options on the Players page. This option sounds strange to me, because I don’t want to send sound to that device, but get it from there. BTW there is no „-B“ parameter set in the extended Squeezelite options (it’s „-C 5“), but only older material says it would be necessary (and you haven’t set it in the video neither).
    6. No sound. I even stop Squeezelite Player so that the sound card is not blocked (as the warning says), but nothing changes. In my opinion, it can’t either, because there must be some player to play the streamed audio.

    You say, I’ve got to change the output for both players – if you mean Shairport as the second, I haven’t changed it because it isn’t running. I was running only one, and that one is now stopped…

    Btw, Squeezelite player doesn’t want to be started manually as long as the Squeezelite option „Bluetooth“ soundcard is set.

    Unfortunately, I’m someone who can be very complicated if he doesn’t understand what he’s doing.

    I’m glad, Squeezelite still works fine after all those trials.

    I would really appreciate another hint, as I’m quite confused by all that different sorts of help channels (and even don’t remember where I found a howto some days ago).

    FZinForen

    15. Januar 2019 at 13:57 #43657

    Hi FZ,

    Below in the BT plugin, you have two options for streaming with instructions. Follow either one to get streaming from your phone to either a channel in your Squeezebox Server or directly to your sound card.

    Since you want the latter, make sure the player is running and you have your output device selected. Once this is case, the other players only to open the channel for BT output to go to your hardware. This is achieved with Squeezelite by the option „-C 5“ which automatically disconnects the player form the hardware after 5 seconds of inactivity. Select „sndrpihifiberry…“ for your sound card’s audio output in the Bluetooth player (called bluetooth speaker, this is indeed confusing but the name of the playersoftware). Afterwards, make sure Shairport and MPD are not running and you should be able to stream BT to your sound card (even with Squeezelite running but inactive).

    16. Januar 2019 at 21:22 #43762

    Hallo Zusammen,

    auch ich bekomme mein BT-Streaming vom Handy auf den Pu und dann auf den Sequeezebox Server nicht zufriedenstellend hin.

    Meine Konfiguration:
    What Raspberry Pi do you use and what Max2Play SD-Card-Image did you install?
    –> Raspi 3B+ mit Raspberry Pi Shield – HiFiBerry DAC+ RCA
    –> Dieses Raspi ist auch mein Squeezebox Server und LSM läuft logischerweise darauf. Momentan habe ich noch ein weiteren Client verbunden.
    –> SD Carf image: m2p_stretch_rpi_v247.img
    What Max2Play-Version do you use?
    –> 2.47
    Do you use a Bluetooth dongle? If yes, which one?
    –> No, internal Raspi BT module
    What is the output of the „DEBUG“ window at the bottom of the bluetooth addon?
    –>
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:3E:31:9B ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:34756725 acl:62045 sco:0 events:1263 errors:0
    TX bytes:37917 acl:1482 sco:0 commands:164 errors:0

    #### DEVICE blacksurfer ####
    [**MAC ID**]
    Name: blacksurfer
    Alias: blacksurfer [rw]
    Address: **MAC ID**
    Icon: phone
    Class: 0x7a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [00000000-deca-fade-deca-deafdecacafe, ServiceDiscoveryServer, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 02030302-1d19-415f-86f2-22a2106a0a77]

    #### BLUEALSA RUNNING ####
    1

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    NEW Bluetooth state: 0 | OLD Bluetooth state: 1
    Off – Stop Stream on Squeezebox Server (Restore Stream before Bluetooth)
    Socket created
    Sending : playlist deleteitem wavin:bluetooth
    Socket created
    Sending : playlist index -1
    Socket created
    Sending : playlist play

    What exaclty is not working? Pairing, Connecting, Playing Audio, Reconnecting on Reboot,…
    1. Bluetooth Plug-IN ist erfolgreich installiert und gestartet
    2. Handy iPhone mit iOS12 verbindet sich erfolgreich mit dem Raspi
    3. iOS zeigt die Verbindung an
    4. im m2p BT Plug-In wird mir auch die Verbindung durch grüne Markierung der Handybezeichnung angezeigt
    5. Ich starte „Stream zum Squeezebox Server“ im BT Menü. Die Installation des „Bluetooth Streaming zum Squeezebox Server“ ist abgeschlossen. (Bluetooth wird ebenfalls in den Favouriten des LMS angezeigt)
    6. „Autostart Bluetooth-Streaming im Squeezebox Serve“ ist aktiviert.

    Was ich nun mache, ist sicherstellen, dass sich mein Handy mit dem BT des Pi verbunden hat: check
    Dann starte ich Musik über die iTunes App oder über amazon music oder ähnliches auf dem Handy.
    Ich lasse mir via airplay im Handy zeigen, dass die Verbindung zum Pi nach wie vor steht. iPhone Symbol: Lautsprechetzeichen vor dem Bluetooth-„Runen“

    In iPeng oder/und im LMS kann ich Bluetooth aus Quelle wählen. Ich bekomme jedoch keinen Sound auf die Boxen.
    Als „Liedtitel“ wird ‚wavin: bluetooth – Bluetooth‘ angezeigt. Aber wie gesagt, keine Musik.

    Check your Power Supply! Most problems result from unsufficient power – remove all usb-devices, drives and displays to see if this solves the problem.
    –> 5V 2100 mA @ mini USB vom Raspi

    Alle anderen Funktionen udn Features und Plug-Ins funktionieren problemlos. Aber die möglichkeit per BT auf den Squeszebox-Server zu streamen ist eben schon seeeeehr sehr nützlich!

    Danke für die Hilfe!

    Viele Grüße,

    Philip

    17. Januar 2019 at 17:28 #43845

    Hallo Philip,

    Danke für die ausführliche Beschreibung deines Setups.

    Zwei mögliche Fehlerquellen sind die folgenden:

    Der 3B+ braucht mindestens 2.5 Ampere auf dem Netzteil, 3 Ampere wenn es noch USB-Geräte gibt.

    Falls du WLAN nutzt, wechsel einmal zu LAN um sicherzugehen dass dies nicht das Problem ist. Der 3B+ nutzt nur ein Modul für WLAN und Bluetooth und priorisiert WLAN vor Bluetooth Signalen.

    17. Januar 2019 at 22:16 #43863

    Hallo Heiner,

    Danke für Deine schnelle Antwort!

    Ich habe mal versucht, einiges zu reproduzieren und habe meine Feststellungen notiert.
    Netzteil: Ich habe ein 5,1V 2,5A Netzteil an meinem Raspi. Entgegen der Spec noch zu klein, meine Angabe oben war falsch.
    Ich habe getestet mit meinem Labornetzteil auf 5,1V und begrenzt auf 4A. Keine Änderung im Verhalten, zumal wurden maximal 0,8 A gezogen, da kamen maximal 3,5 Watt raus, uns das grade mal beim rebooten 😉
    Den Strombedarf des Hifiberrey DAV habe ich nirgends gefunden.

    WLAN habe ich in den Raspi Einstellungen „Disable Default WiFi Interface WLAN0 on RPI3“ –> Haken gesetzt deaktivert
    –> keine Änderung
    Allgemein ist das BT relativ langsam: Wenn ich am Handy den Titel ändere oder die Lautstärke ändere, dauert es immer so 1 bis 2 Sekunden, bis was passiert.

    Der Handy BT-Stream funktioniert tadellos.
    Es ist etwas schade, dass sich das Handy und Raspi nicht automatisch miteinander verbinden wenn ich heim komme.

    **** Dies gilt nur MIT Logitech Media Server bzw. Squeezebox Server – START****
    BT Stream funktioniert, unter folgenden Vorraussetzungen:
    – BT Stream darf nur in der Wiedergabeliste eines Players vorhanden sein. Ist der Stream bei zwei Playern in der Wiedergabeliste –> Problem
    – Syncen geht: Ich hab gelernt, man muss grundsätzlich den Slave (der Player der gesynct werden soll) an den Master (der Player, der spielt) hängen. Umgekehr hilft in dem Fall nichts.
    – Beim Syncen kann dann zwischen MP3, Radio, Soundcloud, Youtube und wieder zurück zum BT-Stream gegangen werden.
    – Beim De-Syncen muss man wiederum aufpassen, dass der BT-Stram nur bei einem Player läuft.

    Vermutung: es waren in den Wiedergabelisten beider Player jeweils der BT-Stream vorhanden –> das funktioniert nicht.
    Der identische Radiosender in beiden Wiedergabelisten beider Player –> funktioniert.
    BT muss explizit aus der Wiedergabeliste des „falschen“ Players entfernt werden!
    Werden die Player gesynct, ist in der Wiedergabeliste beider Player der BT Stream.
    Wird de-synct, bleiben beide BT STreams in der Wiedergabeliste stehen.
    –> dies kan zu Verwirrung führen
    **** Dies gilt nur MIT Logitech Media Server bzw. Squeezebox Server – ENDE****

    Jetzt kommt iPeng. Sobald ich dann aufs iPhone gehe oder auf das iPad und iPeng starte,

    Mit IPeng zwischendrin mache ich „alles kaputt“:
    Der BT-Stream bricht beim Öffnen der App ab. Keine Chance ihn wieder zu starten.
    Weiterhin muss man danach immer alles in LMS „reparieren –> BT-Stram aus der Wiedergabeliste entfernen und wieder
    neu rein hängen…

    Vermutung: iPeng ist/hat ein Problem mit dem BT-Stream. Und genau das wäre cool wenn funktionieren würde. BT-Stream mit iPeng… Aber ich dneke, das ist auch nicht die Baustelle von iPeng.
    Gibt es da vlt trotzdem eine Rat von Eurer Seite?

    Danke udn viele Grüße,

    Philip

    29. Januar 2019 at 14:51 #44226

    Hallo Heiner,

    hatte vor 14 Tagen Probleme, die einfache BT-Verbindung hinzubekommen (Musik streamen von Smartphon auf RPI/HifiBerry DAC+: https://www.max2play.com/en/forums/topic/bluetooth-addon-beta/page/14/#post-43657). Klappt jetzt zumindest mit _einem_ Smartphone – nachdem ich die Soundkarte umgestellt habe: Und zwar nicht im Audioplayer-, nicht im Raspbery-Einstellungen-, sondern direkt im Bluetooth-Modul des Web-Interface: sndpihifiberry… Musste dafür aber im Modul „Raspberry Einstellungen“ „Disable built-in audio“ aktivieren. Etwas verwirrend, v.a. durch die verschiedenen Hilfe-Kanäle, die alle auch einem leicht anderen Stand sind. Blöd dann, wenn man ausgerechnet das Hilfsangebot auf dem Web-Plug-In selbst missachtet. Mein Eindruck: Euer System ist relativ robust, und mit etwas kühlem Kopf kriegt man die Dinge dann schon noch gedeichselt. Eins kriege ich noch immer nicht hin: Im Vergleich zu den anderen Hifi-Geräten (Yamaha) ist der RPI/Hifiberry an der Anlage sehr laut – und „Analogue Boost“ von 100% auf 85% reduzieren funktioniert nicht, weil das Interface immer nur 0% oder 100% speichert. Oder muss ich die allg. Lautstärke anderswo einstellen?

    Problem with Bluetooth audio streaming (smartphone > RPI/Hifiberry DAC+) solved! One phone now gets connected and disconnected with audio stream running smoothly. Soundcard had to be set to „sndpihifiberry…“ on the Bluetooth tab of your web interface – no changes needed for the soundcard settings on the other tabs. Just to get that „soundcard“ into the selection, I had to enable „Disable built-in soundcard“ on the „Raspberry settings“ page. That did the trick! Besides, most things work fine. One last point: Loudness of the RPI/Hifiberry is quite high on the HiFi rack – I tried to reduce „Analogue Boost“ on the Hifiberry tab down to 85%, but that setting isn’t stored: It switches either to 0% or to 100%!

    29. Januar 2019 at 15:42 #44227

    Hallo FZ,

    Wenn dein „hw:0“ Parameter gesetzt ist, sollte sich die Lautstärke dynamisch mit dem Regler im Squeezebox Server anpassen.

Viewing 24 posts - 391 through 414 (of 414 total)

You must be logged in to reply to this topic.

Register here