[UPDATE] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE] Bluetooth Addon BETA

This topic contains 381 replies, has 87 voices, and was last updated by  Ti-ejtsch premium 5 hours, 17 minutes ago.

Viewing 22 posts - 361 through 382 (of 382 total)
  • 17. Juli 2018 at 16:05 #36646

    Does the first device still work if you disconnect the second and repair with the first? If not, please reinstall the Bluetooth plugin from the web interface.

    22. Juli 2018 at 21:30 #36727

    @heiner I have removed the second and re paired the first. If I put the Bluetooth favorite to the playlist manually it plays the sound. But the favorite is not put to the list automatically.

    I have removed the first mobile and uninstalled the plugin. rebooted. installed the plugin. rebooted. And paired the second mobile. The favorite is automatically put to the playlist again. But it plays for only 3 to 4 seconds and without sound, when the mobile is connected or when it plays sound.
    I removed the second mobile, and paired the first mobile. The plugin works now as it should. It puts the favorite automatically to the list and plays the sound.
    On a second connect it still started the favorite automatically, but stopped after 3 to 4 seconds. When I klicked the play button in LMS it played the sound.

    I have noticed a difference in the two devices connection settings. The first gives the option to connect with high audio quality (AAC).

    19. August 2018 at 20:54 #36999

    Hi All – I’ve been playing around with Max2Play for a few days after getting the premium license. It took a few tweaks to get it set up how I want, but I’m still having an issue with bluetooth. I looked in this thread, and couldn’t find anything like this issue so excuse me if has already been answered before. As background, Here’s my set up:

    RPi 2 B+ with HiFiBerry DAC+
    installed and updated Max2Play

    I want to use the RPi for playing music from a bluetooth device, spotify connect and Airplay (a bonus to have). I set up SBS and squeezelite and am using that for bluetooth and spotify connect. Everything works great with spotify connect via the spotty plugin. I’m using the Shairpoint audio player and have the IP set for automatic switch, this works great.

    The only way I can get bluetooth to work is if I manually hit the Play button in SBS. My device is connected, and works great once I hit play, but I’d like to be able to listen once the device starts streaming and be able to switch between spotify and bluetooth without needing to hit play in SBS.

    I think this has something to do with the MAC address option, I initially had it set to the MAC address shown as the one for this machine. It’s b8:27:eb:db:a9:fb, still had to hit play in SBS. Then I looked up the RPi MAC address using the command prop and it’s: 86-16-f9-db-a9-fb

    I tried that too, same result.

    Any ideas on how to get this set up so I can be „hands off“?

    Why does one address have colons and the other dashes? The addresses are similar but not the same. I’m not an IT guy, but can follow directions if pointed in the right direction.

    Thanks and Enjoy the music!

    21. August 2018 at 11:25 #37051

    Hi discgo,

    The MAC address is optional, the syntax should be with colons. Please try reinstalling the Bluetooth plugin. Also, make sure the „-B“ value is set in Squeezelite.

    21. August 2018 at 19:41 #37075

    Thank you very much, Heiner…do I need to uninstall bluetooth or just do the install over again? Could you explain what you mean by „Also, make sure the „-B“ value is set in Squeezelite“

    Excuse my technical ignorance, it’s been about 10 years since I played with Squeezebox at all.

    Enjoy the music!

    • This reply was modified 2 months, 3 weeks ago by  discgo1013.
    22. August 2018 at 11:20 #37100

    Sorry about the confusion. -B must be in the command line options in Squeezelite’s advanced settings.

    By reinstalling in mean clicking the uninstall button, rebooting, installing Bluetooth again and rebooting once more.

    11. September 2018 at 9:09 #37770

    IMPORTANT:

    There was a bug fix we added to our version 2.47 of Max2Play.

    It fixes a problem with Bluetooth packages that can occur if you updated Max2Play recently.

    Everyone updating their Max2Play now is not affected by this issue.

    Anybody experiencing issues with their Bluetooth plugin:

    – Install the plugin again in Settings/Reboot (Link) or make a beta update and then a normal update. This will fix the issue.

    – If you install the plugin again and you were affected by the bug, you should get the following message when accessing the plugin after the new install:
    Fixed Service File for Bluealsa compatibility for previous installs.

    15. September 2018 at 13:32 #37851

    Servus,

    seit gestern laufen meine zwei RPi nicht mehr mit den BT Lautsprechern.
    Ich kann die Speaker zwar sehen aber nicht verbinden, Squeezelite lässt sich nicht starten.

    Bisher lief das immer völlig Problemlos, Speaker einschalten und über den Squeezebox Server den Player und die Titel auswählen, fertig.

    Gestern habe ich über die Max2Play Oberfläche die Updates gemacht und nun geht nichts mehr.

    Anbei die Logs:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o plug:bluetooth -a 80:4:: -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    BLUEALSA_PLAY_AUDIOCARD=hw:0,0
    BLUEALSA_PLAY_MIXER=PCM

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    bluetooth – Your Bluetooth device FC:58:FA:C8:7C:C3
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    no setup

    #### OUTPUT SOUND DETAILS CARD 1 ####

    15. September 2018 at 15:32 #37852

    So, nochmal ich,

    habe Bluealsa zum laufen gebracht mit Neuinstallation und dachte ich kann einfach die Geräte verbinden.

    Leider nicht, es kommt die Fehlermeldung:

    If you connected Bluetooth Speakers, make sure to set the soundcard of your audioplayers to bluetooth as audio output! You need to restart your Audioplayer if the Bluetooth Device changed.
    If you connected a Smartphone to stream to Squeezebox Server, NO further setting to your soundcard is needed (do NOT set your soundcard to bluealsa)!

    Weiters kann ich Squeezelite nicht starten, de es Device Yourbluetooth nicht akzeptiert als Soundkarte, da ja der Speaker nicht dran hängt.

    Hat wer Ideen?

    LG

    17. September 2018 at 12:11 #37872

    Hi rhusz,

    Hast du bereits 2.47 Update vor dem Installieren von Bluetooth gemacht oder danach?

    17. September 2018 at 14:51 #37875

    Hi everyone,

    IMPORTANT UPDATE:
    If you are still experiencing issues, please make another beta update. This will change some rights for the bluetooth plugin that might be affected if you recently installed Bluetooth for the first time.

    17. September 2018 at 16:22 #37876

    Hi,

    alles neu gemacht und vor der BT Installation das Update auf die Beta gemacht, nun läuft es.
    Die Frage bleibt warum es nach normalem Update nicht mehr ging.
    Auch funktioniert der Ausschalt-Button beim 7″ Touch Display nicht mehr.

    LG Ric

    17. September 2018 at 16:46 #37877

    Hi Ric,

    Bitte versuch auch dort nochmal ein installieren im Jivelite-Menü.

    17. September 2018 at 18:38 #37880

    Installed mine on a Intel Corporation STK1AW32SC/Cherry Trail stick. It works good. But I did have to do a apt install squeezelite and make a link to it.

    Have Beta-180917 and with the plug-in http://shop.max2play.com/media/downloadable/beta/bluetooth.tar

    It does see my Blue tooth speaker but I can’t get it to connect.

    It will say this:

    Connecting to: 6C:5A:B5:4F:CA:38
    Trusted: 1 -> 1
    [6C:5A:B5:4F:CA:38]
    Name: iHome iBT372
    Alias: iHome iBT372 [rw]
    Address: 6C:5A:B5:4F:CA:38
    Icon: audio-card
    Class: 0x240414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [Headset, AudioSink, AVRemoteControlTarget, AVRemoteControl, Handsfree]

    YOU PROBABLY NEED TO RESTART your AUDIOPLAYER (e.g. Squeezelite) to get it to work with Bluetooth!

    The Degug information his this:

    #### Bluetooth Installation ####
     
    
    #### Bluetooth Dongle ####
    hci0:	Type: Primary  Bus: USB
    	BD Address: 00:21:5C:C6:B0:1E  ACL MTU: 1021:5  SCO MTU: 96:6
    	UP RUNNING PSCAN 
    	RX bytes:1295 acl:0 sco:0 events:82 errors:0
    	TX bytes:2837 acl:0 sco:0 commands:82 errors:0
    
     
    
    #### DEVICE Crasher Mini ####
    [00:50:00:00:19:D7]
      Name: Crasher Mini
      Alias: Crasher Mini [rw]
      Address: 00:50:00:00:19:D7
      Icon: audio-card
      Class: 0x240404
      Paired: 1
      Trusted: 1 [rw]
      Blocked: 0 [rw]
      Connected: 0
      UUIDs: [SerialPort, Headset, AudioSink, AVRemoteControlTarget, AVRemoteControl, Handsfree]
     
    
    #### DEVICE iHome iBT372 ####
    [6C:5A:B5:4F:CA:38]
      Name: iHome iBT372
      Alias: iHome iBT372 [rw]
      Address: 6C:5A:B5:4F:CA:38
      Icon: audio-card
      Class: 0x240414
      Paired: 1
      Trusted: 1 [rw]
      Blocked: 0 [rw]
      Connected: 0
      UUIDs: [Headset, AudioSink, AVRemoteControlTarget, AVRemoteControl, Handsfree]

    I rebooted and still same.

    It my be that Max2play don’t know how to restart my Squeezelite. It I click Stop or Kill it can’t do it. May need to link it some other way.

    I know you don’t support this Intel stick but seems like it all most works with the Blue tooth built in this stick.

    18. September 2018 at 9:23 #37883

    Hi Raymond,

    The Bluetooth solution only works on Raspberry Pis and our images based on Raspbian.

    @Ric: Did the reinstall also solve the Jivelite button issue or does it still persist? If so, we’ll test it and see if it’s another bug.

    18. September 2018 at 13:07 #37888

    I know that. Like I said „I know you don’t support this Intel stick but seems like it all most works with the Blue tooth built in this stick.“ It be nice if it could. I will look into it more see if I can fix it.

    18. September 2018 at 13:37 #37889

    Hi Raymond,

    Sorry I missed that part. Our Bluetooth plugin is based on blueALSA, so if the stick can support that you might be one step further.

    28. September 2018 at 22:06 #38232

    Hi, I recently installed M2P and bluetooth plugin on a Zero W. I cannot start the bluetooth soundcard in Squeezelite:

    Trying to launch … NOT successful Click here to show detailed information
    ../../../src/asound/../shared/ctl-client.c:105: Connecting to socket: /var/run/bluealsa/hci0
    [22:01:39.438294] test_open:384 playback open error: No such file or directory
    [22:01:39.438797] output_init_common:382 unable to open output device

    And I cannot connect to my bluetooth speaker:

    Device 40:EF:4C:31:82:94 sonoroRADIO
    trust 40:EF:4C:31:82:94
    Changing 40:EF:4C:31:82:94 trust succeeded
    pair 40:EF:4C:31:82:94
    Attempting to pair with 40:EF:4C:31:82:94
    Failed to pair: org.bluez.Error.AlreadyExists
    connect 40:EF:4C:31:82:94
    Attempting to connect to 40:EF:4C:31:82:94
    Failed to connect: org.bluez.Error.Failed
    quit
    Name: sonoroRADIO
    Address: 40:EF:4C:31:82:94
    Icon: audio-card
    Class: 0x240414
    Paired: 1
    Connected: 0

    Also updated to beta, but still no success…

    1. Oktober 2018 at 10:17 #38258

    Hi bkonijn,

    It seems your device is not properly connected. Please make sure does fall into a sleep mode too fast, preventing reconnection.

    12. November 2018 at 6:40 #41927

    Habe hier selben Fehler wie bkonijn

    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen
    ../../../src/asound/../shared/ctl-client.c:105: Connecting to socket: /var/run/bluealsa/hci0
    [05:37:27.554111] test_open:310 playback open error: No such file or directory
    [05:37:27.554583] output_init_common:382 unable to open output device

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:C2:1D:D2 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:9530 acl:55 sco:0 events:342 errors:0
    TX bytes:4635 acl:55 sco:0 commands:194 errors:0

    #### DEVICE SoundCore Boost ####
    [00:22:37:53:D5:38]
    Name: SoundCore Boost
    Alias: SoundCore Boost [rw]
    Address: 00:22:37:53:D5:38
    Icon: audio-card
    Class: 0x240414
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [AudioSink, AVRemoteControlTarget, AVRemoteControl, Handsfree, PnPInformation]

    #### BLUEALSA ERROR ####
    ● bluealsa.service – Start Bluealsa for Bluetooth on Alsa (not compatible with Pulseaudio)
    Loaded: loaded (/etc/systemd/system/bluealsa.service; enabled; vendor preset: enabled)
    Active: activating (auto-restart) (Result: signal) since Mon 2018-11-12 05:16:43 CET; 1s ago
    Process: 7475 ExecStart=/usr/bin/bluealsa -p a2dp-sink -p a2dp-source (code=killed, signal=ILL)
    Process: 7468 ExecStartPre=/bin/sleep 2 (code=exited, status=0/SUCCESS)
    Main PID: 7475 (code=killed, signal=ILL)

    Nov 12 05:16:43 M2P-Terrasse systemd[1]: bluealsa.service: Failed with result ’signal‘.

    #### BLUEALSA RUNNING ####
    0

    12. November 2018 at 16:07 #41969

    Hier noch weitere Infos:

    Auf dem Pi Zero W läuft aktuell die Version Beta-181022
    Update alle Pakete (apt-get update; apt-get upgrade) wurde durchgeführt

    • This reply was modified 2 days, 5 hours ago by  Ti-ejtsch.
    14. November 2018 at 16:45 #42032

    Mit dem integrierten Bluetooth Modul habe ich keine Verbindung zustande bekommen.
    Nun Habe ich mir einen externen Dongle Logilink geholt. Muss hier etwas installiert oder beachtet werden?

    Gruß

Viewing 22 posts - 361 through 382 (of 382 total)

You must be logged in to reply to this topic.

Register here