No support for Audiophonics I-Sabre DAC ES9023 TCXO ? :(

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No support for Audiophonics I-Sabre DAC ES9023 TCXO ? :(

This topic contains 21 replies, has 8 voices, and was last updated by  flysurfer Moderator 5 months, 2 weeks ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • 6. September 2015 at 10:59 #15630

    Hello

    I got this (beautifull) DAC with my raspberry PI 2.

    Audiophonics I-Sabre DAC ES9023 TCXO Raspberry Pi A+ B+ 2.0 / I2S
    http://www.audiophonics.fr/fr/kits-modules-diy-dac/audiophonics-i-sabre-dac-es9023-tcxo-raspberry-pi-a-b-20-i2s-p-9978.html

    It perfectly works with picore player using “I2S audio generic”
    I tried several options with the licensed version of max2play in Raspberry pi settings but i do not see the i2S audio output in “Set Audio Output on Raspberry Pi” (and got no output sound).

    Could you explain me how to solve the issue ?

    I use Max2play 2.20

    7. September 2015 at 13:40 #15633

    Hi Mrpink,
    Please try using the option “HiFiBerry DAC+” in Raspberry Settings. Since your sound card uses the same drivers as HiFiBerry, that could do the trick.

    27. November 2016 at 10:53 #24279

    Hello Heiner,

    I just changed from piCoreplayer to M2P and using the licensed version 2.34
    I have a similar issue.
    I am using Wyred4Sound dac2 with Sabre and i2s over GPIO.
    It works perfectly with piCoreplayer using “I2S Audio generic” and Squeezelite settings
    – hw:CARD=sndrpihifiberry
    – ALSA setting: 80 : 4

    I tried to use the HiFiBerry DAC+ without success, the option hw:CARD=sndrpihifiberry does not apear

    Any chance to implement a generic i2s?
    Otherwise need to go back to pCP :-(((

    29. November 2016 at 11:42 #24296

    Hello,

    I have an Audiophonics I-Sabre DAC in one of my RPi setups (it’s a RaspDAC streamer box). Please follow the instructions below, might also work for you:

    1. Install Max2Play HiFiBerry Image

    2. On the HifiBerry Tab:

    Select:
    Hifi Berry DAC (PI A/B)

    3. On the Audioplayer Tab:

    Squeezelite –> Edit advanced options

    Soundcard:
    sysdefault - snd_rpi_hifiberry_dac, - Default Audio Device, CARD=sndrpihifiberry

    ALSA Parameter:
    80:4::

    Command Line Options:
    -o hw:0 -V Digital

    This command line option noticeably improved the sound quality, at least to my ears. Please see the following Wiki post for more details:
    https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/

    @ Max2Play team – questions about M2P support of I-Sabre DACs are becoming more frequent. Is there any chance you could add proper support for the following DAC in the next release, i.e. so it can just be chosen in the dropdown list? There may also be additional parameters which might further improve sound quality. Please see

    AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO Raspberry Pi 3 / Pi 2 A+ B+ / I2S

    Best regards,
    JCU

    • This reply was modified 7 months ago by  jcu-muc.
    29. November 2016 at 23:24 #24361

    Hi JCU,

    Thanks a lot for the tip!! It works perfectly!! ;-D

    I could not set the command line option because I have no idea how to determine the card’s slot or the sound card’s mixer device as per the instructions in the link. Any idea how to know that?

    I agree with your request to the @ Max2Play team to include support for Sabre

    30. November 2016 at 0:24 #24362

    Hi Popper,

    Very happy that you were able to get things working, I appreciate it and understand, as I struggled for a while as well. I honestly believe that Max2Play is the best platform out there, at least for me, as it offers Logitech Media Server as a basis. Volumio, RuneAudio have better out of the box support for Sabre DACs, but I need the superior library management etc. that LMS offers.

    Regarding the command line option, SSH into your RPi and enter “amixer” and see what it outputs. That is the official procedure. That being said, that didn’t work for me since evidently the Audiophonics Sabre has no hardware volume control. I just went ahead and entered -o hw:0 -V Digital on good faith and was pleased with the results. If you encounter problems, you can always go back and delete the command line options and carry on. Again, the command line options worked well for me and the sound was instantly much deeper, warmer, richer – essentially what I had been expecting from the DAC to begin with. 😉

    If you are a Linux newbie such as myself, you can SSH via Windows with PuTTY, available here: http://www.putty.org/ To determine the IP address you need to SSH into, go to http://max2play/ and go to the tab WiFi/LAN – there you will see the IP address. Username: pi Password: raspberry

    Edit: just for the hell of it, if you need admin privileges for anything else, you can su with pw: max2play

    Best regards,
    Jason

    1. December 2016 at 15:48 #24464

    Hi guys,
    Some good news are on the way. We have been working with the guys from Audiophonics and will soon start offering solutions combined with Max2Play. More details are on the way and next week we will have new products in our shop. The Sabre DAC V3 will take center stage and we will also start offering a complete solution with a great case. Stay tuned!
    The Sabre is already available as a selection in the Raspberry Settings in our current beta update.

    1. December 2016 at 15:51 #24465

    Great !!!!

    1. December 2016 at 15:57 #24466

    That is FANTASTIC news!!!

    Best regards,
    Jason

    1. December 2016 at 20:58 #24475

    Hi JCU,

    Thanks for all your useful hints. I have also tried several platforms and HW configurations. From MPD to PiCore.

    I am really happy that M2P will offer support for Audiophonics !!!
    As for my experience with M2P … hummm how to start?

    Well let’s put it this way, I was seduced by the capabilities that seem superior to piCore, especially the integration of Kodi as I also use it.

    Unfortunately despite your help I need to go back to piCore, before explaining why, Let me describe my set up.

    I use a Wyred4Sound DAC2 equipped with 9018 ESS Sabre DAC a 9018 ESS Sabre DAC

    https://wyred4sound.com/products/dacs/dac-2-series

    with input of I2S over GPIO using a HDMI connector and cable. I use a HDMI output module bought at Audiophonics

    http://www.audiophonics.fr/en/interfaces/audio-gd-diy-kit-i2s-to-hdmi-output-module-p-9347.html

    The set ups is similar to:

    http://www.psaudio.com/forum/directstream-all-about-it/directstream-i2s-input/

    So ….

    With piCore the play is smooth using Generic I2S and hw:CARD=sndrpihifiberry
    Hi resolution files play perfect and the whole thing is stable. I use piCore 2.6 since the 3.02 version produces a horrible crackling when switching from 44.1 KHz to 96KHz.

    With your help I managed to get the sound out but could not manage to transfer volume control to the DAC wih -o hw:0 –V Digital

    It took me a while to figure out the output of a mixer which was:

    Simple mixer control ‘PCM’,0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 – 400
    Mono: Playback 100 [97%] [1.00dB] [on]

    Then I realized that I had to replace Digital for PCM and tried -o hw:0 –V PCM … but did not work

    I tried the option on LMS -> Settings -> player -> Audio -> Volume Control -> Output level is fixed at 100%
    … and it worked !! (I wonder what the difference is with the transfer with –o hw:0 –V Digital

    Then I tried to play Hi-Res files and …. After a few seconds and horrible crackling, the play back simply stops >:-(((

    No way to get it back. The output of a mixer was

    Simple mixer control ‘PCM’,0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 – 400
    Mono: Playback -25 [96%] [-0.25dB] [on]

    The difference is the Mono: line where I figured that 96% is the volume level but still do not know that the other mean

    I then reinstalled from scratch but the problem is still there, no Hi-Res play

    Bottom line …. I am back to piCore 2.6 with a license M2P I do not use

    The output or piCore amixer is

    Simple mixer control ‘PCM’,0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 – 400
    Mono: Playback -2000 [77%] [-20.00dB] [on]

    Where the Mono Line is completely different

    @M2P team: It would be great if there would be a I2S generic support and help to figure out the best parameters

    8. December 2016 at 16:23 #24691

    Hello Popper72,

    Normally you only need to choose the Sabre DAC under the Raspberry Settings.
    Then you go into the audioplayer menu. Here you can find the advanced settings of squeezelite. There, like you already did, you choose the “sysdefault snd_hifiberry_dac”.

    Now the necessary settings are automatically accepted. If you want to enter a specific output device with “-o hw:0” please note that normally “hw:0” is the onboard chip of the Raspberry Pi. The onboard chip can also be disabling in the Raspberry settings. After disable the onboard sound please reboot your device. Now the Sabre DAC can be addressed with “-o hw: 0”.

    However, the function “-V ” is not possible here.
    The ALSA control for volume adjustment is not working with this setup.

    8. December 2016 at 17:58 #24702

    Hi Christoph,

    I see that M2P 2.39 is out as of today and now natively supports the Audiophonics I-Sabre-V3 via the Raspberry Settings tab – thank you!

    Just to confirm:

    I have selected Audiophonics I-Sabre-V3 and in the Audioplayer tab / Squeezelite Advanced Options added -o hw:0 to the Command Line Options. On the HifiBerry tab, it now reads under Your installed HiFiBerry Card: none

    I guess that is all the way it is supposed to be then?

    Many thanks!
    JCU

    9. December 2016 at 11:26 #24711

    Hello jcu-muc,

    Yes that’s right. On the HifiBerry page no card is selected. Only on the Raspberry settings page, there is selected the Audiophonics I-Sabre-V3. And in the Audioplayer menu, you select in the advanced settings of Squeezelite – “sysdefault snd_hifiberry_dac”.

    12. December 2016 at 16:44 #24780

    hi guys, one quick question: is there any difference between “default: CARD…” and “front:CARD…” when selecting the sound card? Is front recommended for 2.0 systems?

    • This reply was modified 6 months, 2 weeks ago by  lynoo.
    • This reply was modified 6 months, 2 weeks ago by  lynoo.
    4. January 2017 at 10:44 #25457

    Hi Christoph!
    I love m2play and
    I love AUDIOPHONICS Products like
    AUDIOPHONICS RaspDAC LTE V2 HIFI Streamer Raspberry Pi 3 & DAC I-Sabre V3
    (especially if powered by 6V (or more) linear power supply)
    http://www.audiophonics.fr/en/network-audio-players/audiophonics-raspdac-lte-v2-hifi-streamer-raspberry-pi-3-dac-i-sabre-v3-p-11594.html

    the are coming in a lovely alu case with an ‘intelligent’ power button – very clever
    with grateful help of dhrone https://github.com/dhrone/Raspdac-Display and some time i was able to make this Button-thingy working in max2play.

    if one of the admins could contact me i am willed to send my documentation (.pdf) – maybe some others can make use of it

    kind regards
    thomas

    my setup
    AUDIOPHONICS RaspDAC HE Network player Raspberry Pi 3 & DAC Sabre V3
    AUDIOPHONICS RaspDAC LTE V2 HIFI Streamer Raspberry Pi 3 & DAC I-Sabre V3
    linear power supply 6V
    and some more hifiberry dacs and some iqaudio dacs ….
    u could call it everyroom instead of multiroom 🙂
    logitech media server on Synology NAS

    4. January 2017 at 12:09 #25468

    Hello and Happy new year to all of you.

    Dear Heiner and JCU,

    Sorry for this very late reply, but was out for business early December, then holidays ….
    Here is where I stand (I hope this helps someone else).
    I followed Heiner advice and chose the Sabre DAC under the Raspberry Settings but chose the “hw:CARD=sndrpihifiberry” instead of “sysdefault snd_hifiberry_dac” which according to my ears has a better sound.
    Crackling when switching from normal def files to hi-def files is still there, but not horrible. Any advice to completely eliminate it would be appreciated
    Then I had an issue with ALAC files which I figured was the native squeezebox server decoder from this forum and some others and use the parameter

    -e alsa

    This I think transcodes to flac
    The issue is that the player does not seem to recognize the end of the file and keeps playing at the end with no sound, or the sound would stop after few seconds

    Is it really that the ALAC decoder from squeezebox server is that bad?

    Btw, it only happens with files I generated by ripping my CD collection to ALAC using dbPowerAmp and not with the files bought in apple store
    I do not feel like transcoding my whole collection to flac (30 000+ files) so any help on using properly the native decoder is appreciated too.

    SO I AM HAPPY that I have an acceptable and stable Max2Play set up !! Thanks

    My next step is to see if I can transfer the Volume control to my Wyred4Sound DAC2 using the USB connection as opposed as the I2S over GPIO.
    Any thoughts on this?

    Thanks

    9. January 2017 at 17:50 #25715

    Hi guys,
    Happy new year! With it comes a new update on our Audiophonics development:
    We have been working on an image and a specific plugin for Audiophonics. This plugin is already available in a beta release under http://shop.max2play.com/media/downloadable/beta/audiophonics.tar and it offers one-click installation for the Sabre V3 sound card, the Audiophonics power button and the Winstar OLED Display individually. This allows a simple and quick configuration of the whole RaspDAC setup. We will also officially inform the community with a blog article and more information soon. Stay tuned

    10. January 2017 at 17:38 #25756

    Hi Heiner!

    2017 ist starting with very good news!
    thanks for listening to your customers

    i will try the beta and leave a reply

    Kind regards to the whole Team!

    11. January 2017 at 16:12 #25773

    Hello Heiner!

    Thanks very much for this and apologies for the slow response.

    I gave the plugin a try yesterday but must admit I’ve encountered some problems.

    — The power button works

    — The display turns on and initializes (displays “Ready” etc. after booting)

    — However, the display does not show any music info when playing music – it just remains stuck at “Ready”

    I searched for and found the Raspdac-Display configuration files at

    /opt/Raspdac-Display/

    I checked RaspDacDisplay.py to see if the plugin had properly set the MAC address of my LMS player, which it had not.

    For anyone new to this topic, it is important to understand that the following files in /Raspdac-Display/ determine the behavior of the display:

    — RaspDacDisplay.py: General settings, time zone, MAC-address of LMS player
    — pages.py: Configure what the display shows and set scrolling behavior

    For detailed instructions on what and how to edit these files see https://github.com/dhrone/Raspdac-Display

    After manually editing RaspDacDisplay.py and setting my MAC-address as listed in Logitech Media Server, still no luck.

    I did notice that the plugin tries to determine the proper MAC address and write it to RaspDacDisplay.py by determining if ethernet is on, or WLAN0. On my RaspDAC, I have no ethernet and use an external Wifi stick for better reception. In Raspberry Settings I have the following activated: “Disable Default WiFi Interface WLAN0 on RPI3”. I unchecked this and went back to the default setting, rebooted, and still no luck…

    Any idea? Does anyone else have different results?

    Best regards,
    JCU

    11. January 2017 at 17:43 #25785

    Hi jcu-muc,

    I tested with the latest Betaversion from today and an external wifi-Stick with pretty much the same settings as you have and after running the Display installer on the audiophonics Addon page the end of the message output of the installer is this:

    
    Successfully installed python-mpd2
    Cleaning up...
    Set SERVER ADDRESS to 192.168.68.101
    Use Interface wlan0 with 7c:dd:90:9e:1a:b2
    Set MAC ADDRESS to 7c:dd:90:9e:1a:b2
    Activated Squeezebox Server in RaspDAC-Display
    Finished - Reboot needed: Click here to Restart Device
    

    It got the right MAC-Address and found the Squeezebox Server. Could you try a Beta-Update of Max2Play and click Reinstall and check the message output?

    Stefan

    11. January 2017 at 22:35 #25801

    Hello Stefan,

    Thanks for this… 😉

    — Updated M2P to latest Beta — OK
    — Audiophonics Plugin Tab — Display — RE-Install Display Software — OK

    Cleaning up...
    Set SERVER ADDRESS to 192.168.178.69
    Use Interface wlan0 with b8:27:eb:bd:f5:a9
    Set MAC ADDRESS to b8:27:eb:bd:f5:a9
    Activated Squeezebox Server in RaspDAC-Display
    Finished - Reboot needed: Click here to Restart Device

    — Display now shows track info as intended.

    Q: Is it safe for me to edit RaspDacDisplay.py and pages.py in /opt/Raspdac-Display so I can customize the display output? I have customized versions of these files that I would ideally just like to overwrite the current default versions.

    Excellent work guys, thank you very much.

    Best regards,
    JCU

    Edit: By the way, is it my imagination, or does the I-Sabre-V3 music output sound better now?? Did you tweak some new parameters when selecting the card in the configuration?

    13. January 2017 at 12:44 #25845

    Hi,

    nice 🙂

    When editing RaspDacDisplay.py, just make sure that you do not click “Reinstall” in the web interface, as this will overwrite your local changes.

    The sound for the audiophonic should not (but might) have changed – when selecting the audiocard on the audiophonics addon, it sets Squeezelite and Shairport commandline values that are optimal for the card. You can have a look at these commandline parameters and compare theses to your earlier setup.

    All the Best
    Stefan

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Register here