[SOLVED] Volume Settings

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Volume Settings

This topic contains 36 replies, has 8 voices, and was last updated by  RHCP-NG 2 months ago.

Viewing 30 posts - 1 through 30 (of 37 total)
  • 26. May 2016 at 10:53 #20301

    Hi,

    I’m using a PI2 B with a Dac+. I installed the latest HifiBerry release. Now I noticed that I have 3 audio Volume options on the webinterface:

    Settings for Digital Volume (Optimum 100%)
    Settings for Analogue Playback Boost (Optimum Off)
    Settings for Analogue Boost (Optimum 100%)

    So I set all to optimum as recommended and also set fixed output in my Ipeng Control (I heard that this should be the best setting. Unfortunatelly now the level is much too high. It seems any of these setting adds additional voulme (I assume more than +10db) to the system. I just wat +0db. No influence from the software but only to set the volume on my amplifier.

    What would you recommend? Thanks

    26. May 2016 at 17:56 #20329

    Hi alex,

    according to this: https://www.hifiberry.com/guides/mixer-settings/ you should keep the playback boost off and reduce the Digital Volume slightly to about 96%.

    Anyway I would recommend to directly connect the squeezelite volume control to the hardware control of your DAC. With the standard setting you have a software volume control and a fixed hardware volume on your DAC – but this doesn’t improve audioquality.
    You can connect the volume control for squeezelite to your DAC by adding
    -o hw:0 -V Digital
    to the command line options of Squeezelite in the advanced settings of the audioplay tab.

    15. June 2016 at 9:46 #20676

    Hi,

    thanks a lot for this information and your support. I did

    1) Set the Digital Volume to 96%
    2) Turned off the “Analogue Playback Boost” and
    3) Left the “Analogue Boost” as is (100). See screenshot 1 attached

    Secondly I now start squeezelite with this options: “-o hw:0 -V Digital” (Screenshot 2)

    I am not 100% sure what happened now because I still can control the loudness with my mobile device (if I do not set to fixed output) and it’s still very loud. Can you please have a look at the screenshots if there’s anything wrong or is that the behaviour I should expect?

    Thanks a lot

    Alex

    Screenshot 1
    Screenshot 2

    • This reply was modified 1 year ago by  alex.ba.
    • This reply was modified 1 year ago by  alex.ba.
    15. June 2016 at 16:04 #20696

    Hi alex,
    All your configurations are correct. If you find the default output volume to be too loud with your setup, you can of course lower the default configuration to your liking. However, we would recommend to adjust the volume on your Audioplayer and leave the recommended volume of HiFiBerry to receive the full output without clipping.

    20. June 2016 at 9:01 #20742

    Hi,

    I installed a RPi2 with a HifiBerry DAC+ Pro (and a 7″ touchscreen).

    According to the Max2Play support I configured the HifiBerry:
    – Set the Digital Volume to 96%
    – Turn off the “Analogue Playback Boost” and
    – Leave the “Analogue Boost” as is (100).

    So far everything is fine, audio output is OK.

    If I configure squeezelite with the options: “-o hw:0 -V Digital” (according to your proposal) I get no longer any audio output. Erasing the options leads to normal audio output again.
    What am I doing wrong after having added the options “-o hw:0 -V Digital”?

    Rainer

    20. June 2016 at 11:12 #20743

    Hi Rainer,

    are there any errors when starting squeezelite? If squeezelite is shown as running in the Max2Play web interface and the audio stream seems to play fine you might try “-o hw:1 -V Digital” as your HifiBerry Card might be the second audiocard, depending on the status of the InBuild-Audiocard of the RPi. If you deactivate the InBuild-Audiocard on Raspberry Pi Settings in Max2Play web interface, the “-o hw:0 -V Digital” command will work.

    All the Best,
    Stefan

    20. June 2016 at 11:47 #20745

    Hi Stefan,

    thanks for your support, “-o hw:1 -V Digital” did the job.
    By the way: how do I deactivate the inbuild audiocard on the RPi?

    Rainer

    20. June 2016 at 12:06 #20747

    Hi Rainer,

    If you deactivate the InBuild-Audiocard on Raspberry Pi Settings in Max2Play web interface…

    -> can be enabled / disabled in the first block of settings on “Raspberry Pi Settings” tab.

    20. June 2016 at 20:01 #20772

    Hi Stefan,

    not sure which setting you mean under “Raspberry Pi Settings”/”Raspberry Einstellungen”.

    Rainer

    21. June 2016 at 12:09 #20791

    Hi Rainer,
    It’s in the “Overclocking and GPU-Memory” box of options, between “Disable Bluetooth” and “Disable IPv6”.

    28. September 2016 at 7:10 #23234

    Hi

    Is it possible to use both the rotary encoder in IQaudio dac+ and volumen control on my phone at the same time?

    If I do as described (options: “-o hw:0 -V Digital”) it’s only the rotary encoder that works.
    If i don’t use the option, volume on my phone works from 0-100% volume, but rotary encoder only works from 0 to x% where X = the volume settings on my phone!

    With option ON, it would be nice if the volume control on the phone would work on HW volume too:)

    Thanks in advance

    Bjarne

    • This reply was modified 8 months, 4 weeks ago by  bjarne.
    • This reply was modified 8 months, 4 weeks ago by  bjarne.
    8. October 2016 at 22:50 #23321

    stange??? It didn´t work last week….now it´s working:)

    Sorry for disturbing.

    Bjarne

    9. October 2016 at 17:40 #23324

    Hi again

    When I switch between using rotary encoder and volume slider i LMS I find that the synchronization is missing.
    If I set LSM volume to 50% and then turn the encoder the volume will be set to what it was the last time the encoder was used ±1 step.

    How can I change that?

    Thanks in advance.
    Bjarne

    9. October 2016 at 17:40 #23325

    Hi again

    When I switch between using rotary encoder and volume slider i LMS I find that the synchronization is missing.
    If I set LSM volume to 50% and then turn the encoder the volume will be set to what it was the last time the encoder was used ±1 step.
    LMS volume setting also override encoder setting in that way that if you go to next number or jump in the same number or pause the number and start it again, the volume will change to the LMS setting.
    How can I change that?

    Thanks in advance.
    Bjarne

    • This reply was modified 8 months, 2 weeks ago by  bjarne.
    10. October 2016 at 11:45 #23333

    Hi,

    to get the Rotary Encoder on IQAudio-Cards working with Synchronisation of volume with Squeezebox Server (control with App / webinterface / rotary encoder) you need to add following to the command line options of Squeezelite (not dependend of build-in audio active /not active):

    -o hw:CARD=IQaudIODAC -V Digital -Q

    I also added this to the description of the Rotary Encoder now (in Beta).

    Description of Parameters:
    – The Parameter “-Q” starts the synchronisation with the Squeezebox Server
    – The Parameter “-V” makes sure to use the correct alsamixer control
    – The Parameter “-o” uses the dircet hardware as audio output (needed to use volume control on alsa level)

    Important: This will only work with the Squeezelite in Max2Play and not in other distributions!

    11. October 2016 at 7:07 #23365

    Thanks, it works:)

    Another question. Is it possible to reduce the volume change/step on the encoder?
    The standard step change is too much, I think!

    thanks in advance
    Bjarne

    11. October 2016 at 17:31 #23374

    Hi Bjardne,

    very good so far 🙂

    If you really like to change the volume steps, this is a little more difficult, as we just use the file from IQAudIO. If you know how to compile a file and log in with SSH on the Pi, you can do it this way:

    1. get the file from https://github.com/iqaudio/tools/blob/master/IQ_rot.c and edit lines
    currentVolume = currentVolume + 10;
    and
    currentVolume = currentVolume - 10;
    to the step you like – e.g. “5” or “2” to use smaller steps.

    2. complile the file with
    gcc IQ_rot.c -oIQ_rot -lwiringPi -lasound

    3. change the existing file in /opt/IQ_rot with the one you just compiled

    4. set file permissions with chmod 777 /opt/IQ_rot

    This should do the trick…

    All the Best,
    Stefan

    16. October 2016 at 1:27 #23425

    Hi,
    I am new to this forum and Max2Play.
    I put this image on my RP2 <<m2p_rpi3_default_234_wps>> and added a HiFiBerry DAC+ Light.
    Followed set-up instructions for Starter on the HiFiBerry page.
    On the Music Player (MPD) Setup page, I selected YMPD and chose some random radio stations. Plugged in my speakers. Can hear the music very faintly, and the volume control on YMPD says “problems setting volume”.
    What should I do?
    thanks in advance,
    Hilary

    17. October 2016 at 16:28 #23432

    Hi Hilary,
    Could check your Music Player Sound Card Settings in the MPD menu and tell us what the parameters are?

    17. October 2016 at 19:58 #23435

    Hi Heiner,
    Here they are
    sound card Settings:
    Sound device default snd_rpi_hifiberry_dac, -Default Audio Device, CARD=sndrpihifiberry
    Audioformat 192000:24:2
    Mixer device hw:1
    Mixer control Digital

    Hilary

    18. October 2016 at 13:30 #23436

    Those parameters are all correct. The DAC+ light does not have a volume control mixer. Once the selection of the DAC+ light has been set, it is automatically activated to a 100 %. You might want to try a different end device and turn up the volume there.

    18. October 2016 at 20:15 #23441

    Heiner,
    I think you are saying I need a preamplifier, is that correct? Any particular recommendation.
    thanks
    Hilary

    19. October 2016 at 13:18 #23449

    You do not necessarily need one, usually a HiFi system (stereo) on its own is enough to amplify the signal of a DAC. What end device are you currently connecting your DAC to?

    20. October 2016 at 7:06 #23461

    I’m not using a HiFi system (it stopped working). I think I should replace the DAC+ Light with the Amp+ — do you agree? (my speakers are 6-8 ohms).
    thanks
    Hilary

    20. October 2016 at 15:28 #23479

    If you do not have an amplifying unit, the Amp+ would make a lot of sense since it does not require any additional amplification. You can just connect your passive speakers directly. According to HiFiBerry, the Amp+ works best with speakers of 4-8 ohms, so perfect for yours.

    16. February 2017 at 10:40 #26950

    Hi,

    I tried the -Q option, but then I get the error the it is not a parameter. Can you help me?

    My problem is that after setting the hardware volume parameter I can’t adjust the volume within LMS anymore.

    23. February 2017 at 10:00 #27163

    Hi,

    it seems i have similar problems like Bjarne regarding the syncronization of volume between slider and encoder, but i`m using the Justboom Amp Hat.

    When turning the rotary at first the volume steps (i think to volume form settings) and then in- or decreases. But i want the it in- or decreases the actual Volume.

    16. March 2017 at 18:08 #27768

    Hi,

    I tried the -Q option, but then I get the error the it is not a parameter. Can you help me?

    My problem is that after setting the hardware volume parameter I can’t adjust the volume within LMS anymore.

    Can somebody help me out with this? It is really bugging me.

    16. March 2017 at 18:26 #27769

    @rens: the encoder is changing the Volume on Alsa level. To connect the Alsa volume control to Squeezelite just use the Max2Play settings on the Justboom Plugin page: first set up the Amp Hat as soundcard and then follow the description on the same page for the rotary encoder installer. The Squeezelite audioplayer must have the commandline options set to use “hardware volume control” and “alsasync”. Both are explained on the page.

    @RHCP-NG: The Option “-Q” (synchronize Alsa-volume changes e.g. from rotary encoder with Squeezebox Server) might not be available if you have an older version of Squeezelite. You should try to update Squeezelite on the Audioplayer-Page (advanced settings Squeezelite) to get the latest version. If it still does not work, please post the “command line parameter” field of Squeezelite Advanced Options and more details on your setup.
    The “-Q” option does only work for soundcards that offer volume control and you need to specify this volume control element! In case of Justboom cards the complete command line parameter for Squeezelite looks like “-o hw:CARD=sndrpijustboomd -V Digital -Q”.

    16. March 2017 at 19:35 #27770

    @flysurfer
    I tried the update, but with no luck. The value in command line field is: -o hw:0 -V Digital

    I have a raspberry pi 2 with a hifi berry amp on top.

Viewing 30 posts - 1 through 30 (of 37 total)

You must be logged in to reply to this topic.

Register here