[SOLVED] Volume Settings

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Volume Settings

This topic contains 36 replies, has 8 voices, and was last updated by  RHCP-NG 4 years, 5 months ago.

Viewing 7 posts - 31 through 37 (of 37 total)
  • 17. März 2017 at 15:55 #27783

    Hi,

    The Build options for Squeezelite (in the Squeezelite Advanced Options) should contain: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC. At least after an update of Squeezelite theses should be available. Do you use the Download Image from our website?

    Did you disable the build-in audio of the Raspberry Pi (important when using „-o hw:0“)? If not, your should use „-o hw:1 -V Digital -Q“.

    Hope this helps,
    Stefan

    17. März 2017 at 18:20 #27784

    Thanks for your answer. It seems that squeezelite won’t update. I overlooked the following error: Makefile.m2p:20: recipe for target ‚ir.o‘ failed

    Any idea what to do about it? I haven’t got a clue.

    Thanks!

    17. März 2017 at 18:24 #27785

    Easiest way: download the latest Max2Play Image from our download page and use this -> everything will work.

    I really don’t know why you get the compiler error – sorry.

    18. März 2017 at 11:47 #27787

    Thanks, flysurfer! I will loose all my settings when I setup a new image, so that’s not ideal, but will probably be the way to go then.

    15. April 2017 at 11:19 #28261

    Hi guys,

    I’m back unfortunately with still the same problem. I’ve used an up-to-date image to start over with my RPI 2 with a HiFiBerry Amp. I’ve tried the configuration again to synchronize hardware volume with Squeezelite, but it still doesnt’t work. The configuration is accepted and I have sound, but I can only set the volume via master volume on the hifiberry page. When I try to change the volume in LMS it doesn’t do anything.

    Anyone has any ideas left?

    My command line options for squeezelite are:

    -o hw:CARD=sndrpihifiberry -V Digital -Q

    Amixer command outputs the following:

    Simple mixer control ‚PCM‘,0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 – 400
    Mono: Playback 100 [97%] [1.00dB] [on]

    Thanks!

    18. April 2017 at 16:47 #28326

    Hi,

    for the HifiBerry AMP you need to use „-o hw:CARD=sndrpihifiberry -V Master -Q“ for Squeezelite. We did not set this to Default, because it does not work with Shairport. Use „Master“ instead of „Digital“ and it will work.

    This is because the Volume Control in the Alsa-Mixer that it should connect to has the name „Master“.

    Stefan

    19. April 2017 at 17:03 #28356

    Hi flysurfer,

    It worked. Many thanks!

    Niels

Viewing 7 posts - 31 through 37 (of 37 total)

You must be logged in to reply to this topic.

Register here