How to replace internal WIFI function with aditional WIFI stick?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI How to replace internal WIFI function with aditional WIFI stick?

This topic contains 6 replies, has 3 voices, and was last updated by  jnile1 premium 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 27. October 2016 at 22:09 #23588

    I bought this “IQaudIO Pi-DAC+ Bundle with Raspberry Pi3 and Max2Play. Everything is working fine except WIFI reception which is very low but working. Therefore I would like to replace internal WIFI with a more powerful WIFI stick Edimax EW-7612UAN V2. This stick is known to be compatible with Pi3. Configuration over web interface recognizes two time the same network ID. But whatever I’m trying it gets renamed as “rename4” and not as WLAN0/1

    Does anybody know what I need to configure so that internal WIFI function gets switched off and external WIFI stick is working?

    Thanks for your help!

    Greets
    Marc

    3. November 2016 at 15:48 #23649

    Hi,

    you have to edit a file and add a rule for your Wifi Stick to make sure it gets named wlan0:

    Login per SSH as user pi and do
    sudo nano /etc/udev/rules.d/70-persistent-net.rules

    now add a new line and edit the old line that it looks like this:

    
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="[MAC-ADDRESS-OF-YOUR-DEVICE]", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"
    

    Change the part [MAC-ADDRESS-OF-YOUR-DEVICE] with your Mac-address of your wifi stick and change the name of the existing entry to wlan1.

    This should do the trick.

    All the Best,
    Stefan

    • This reply was modified 1 month ago by  flysurfer.
    3. November 2016 at 18:33 #23658

    Update: I just added a switch to the “Raspberry Pi Settings” Page, to change the default Wifi from wlan0 to wlan1. You may just use this setting and your wifi-stick should work. You need to do a Beta-Update on the “Reboot/Settings” Page to get this feature, as it is not released yet.

    Stefan

    3. November 2016 at 23:16 #23660

    I am experiencing the same issue, tried the first method and also a fresh install, switch to beta, updating kernel and rpi update, wifi stick hasn’t lit up yet once…, tried every combination I can think of, when I run ifconfig, the mac address of wlan0 is something other than what I inputted into sudo nano /etc/udev/rules.d/70-persistent-net.rules, so maybe It isn’t saving the change? not sure, been at this for five hours now… still cant boot without Ethernet cable waving the white flag:(

    3. November 2016 at 23:21 #23661

    Worth mentioning that I am using a raspberry pi 3 and hifiberry digi+ pro instead of the iqaudio dac…

    4. November 2016 at 12:06 #23662

    Hi jnile1, hi Marc,

    sorry, but the new feature in the Max2Play-Beta to change the build-in wifi interface in Raspberry Pi Settings had a minor bug. Just load the latest Max2Play-Beta and uncheck the Checkbox “Disable Default WiFi Interface WLAN0 on RPI3” -> click save -> check it again and save.

    After a Restart the build in Wifi will be at position wlan1 and the other stick will have wlan0 and be default.

    4. November 2016 at 23:05 #23716

    That seems to have done the trick, one thing of note, I couldn’t access the max2play hifiberry UI by typing http//max2play/ in my browser, I had to use ifconfig in putty to get the ip address of the wifi stick. then I was able to access the page in my browser. This was with edimax nano wifi adapter, Microsoft edge on windows 10. but all seems well with the connection, now on to setting up Spotify ­čÖé Thanks!

    Jared

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here