Rpi2 + Amp+ +M2P – no sound

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Rpi2 + Amp+ +M2P – no sound

This topic contains 29 replies, has 3 voices, and was last updated by  hnaylor premium 5 months, 1 week ago.

Viewing 30 posts - 1 through 30 (of 30 total)
  • 12. November 2016 at 7:28 #23888

    I have the Amp+ installed on my Rpi2, and have configured the HiFiBerry setting appropriately. I have connected my speaker wires to the the four speaker binding posts per this diagram:
    https://www.hifiberry.com/wp-content/uploads/2014/12/connection_diagram.jpg
    I opened YMPD and chose a radio station at random. The blue bar progresses but no sound. I plugged in a USB stick with some music files on it. Stick mounted ok, appeared in “Browse DB” in YMPD, but when selected, appears to play, but again no sound.
    Tested speakers with low-power 1v battery and they are working ok.
    What am I missing?

    thanks
    Hilary

    14. November 2016 at 15:04 #23903

    Hi Hilary,
    I just tested the MPD player myself to make sure there are no new errors in our newest version of Max2Play. However, I could, unfortunately, not replicate your issue.
    What parameters are displayed in the “Soundcard Settings”? There should be a selection in the “Sound Device” line indicating the hifiberry amp.
    What power supply are you using? The Amp’s need a separate power supply since they power passive speakers, the Amp itself and the Pi (no normal Pi power supply should be connected).

    14. November 2016 at 21:49 #23908

    Hi Heiner,
    The power supply is the same as the one recommended:
    60 W Watt, Single Output, 18 [email protected] A External Power Supply Desktop AC-DC Power Supply
    Under Raspberry Pi Settings, Soundcard Setting is Hifi Berry Amp/Amp+
    However, under MPD Music Player Soundcard Settings, sysdefault was bcm-something, so I changed it to
    sysdefault – snd_rpi_hifiberry_amp
    and now it’s playing!
    Wow, I thought I’d done all that, but maybe I didn’t save it.
    Now the problem is too much sound!
    Next question: I have no control over the volume and it’s blasting the neighbors! The volume setting in YMPD doesn’t change the volume at all. What do I do to adjust volume?
    Next question: How do I add my local radio stations to the choices for Radio?

    thanks
    Hilary

    15. November 2016 at 16:20 #23912

    Hi Hilary,
    For volume control, please add the parameter “hw:0” in the option “mixer device”. If this does not work, please change it to “hw:1”. This connect your volume control of YMPD to the Amp’s.
    You can add radio stations by adding the file linking the station to the MPD folder. However, if you are looking for a simpler interface that has most radio stations preloaded and the ability to add stations in its own web interface, try out Squeezelite in combination with the Squeezebox Server. Just install the Server with one click (select 7.9 nightly) and activate Squeezelite with the sysdefault hifiberry amp option selected (make sure MPD is not running anymore). Then, you can control the playback, volume, etc. via the Squeezebox Server web interface or with one of the great Apps for Android (Squeezer) or iOS (iPeng).

    15. November 2016 at 17:44 #23914

    Hi Hilary,

    please choose “Master” as mpd mixer control in the MPD settings.

    Regards,
    Stefan

    15. November 2016 at 22:46 #23919

    Hi Heiner,
    It was set to hw:0 so I changed it to hw:1. Even with a “Save” it didn’t work until I rebooted. I think it should be made clear somewhere that rebooting is necessary after making changes on the MPD page.

    Re: “adding the file linking the station to the MPD folder” — can you give me more of a step-by-step for that? Firstly what file? where do I get it? Secondly what MPD folder, and how do I access it? (Is this in the GUI or by Putty?)
    Perhaps an example would help: I want to add this radio station — https://kpfa.org/

    Hi Stefan,
    Thanks for the additional info.

    cheers
    Hilary

    17. November 2016 at 15:05 #23936

    Hi Hilary,
    You can add a file in the format of .pls or .m3u including your desired radio stations. You can do this by adding a share for the MPD player, the path is named in the MPD’s advanced options as well as information on how to add the music or in this case the radio stations playlist file and you can find out how to mount a samba share with our help section on the right in the GUI of the Filesystem Mount plugin.

    19. November 2016 at 17:53 #24024

    Hi Heiner,
    I added the share following these instructions:

    The radio station’s playlist file is this:
    http://www.kpfa.org/streams/kpfa_64k.m3u
    So I created a text file with these 5 lines:
    [playlist]
    NumberOfEntries=1
    File1=http://www.kpfa.org/streams
    Title1=KPFA
    Length1=-1

    And put it in the RADIO folder.
    It appears in the database but doesn’t play. Please advise.

    thanks
    Hilary

    21. November 2016 at 8:02 #24038

    Hi Heiner,
    OK, I think I got the radio station thing working now. I didn’t realize I could download that m3u file.

    Now I have another issue. I want to add a Network Path to the Music folder on my Windows desktop. I found the folder using “Show Network Devices”.
    I added this:
    //HILARY7/Music /mnt/share cifs user=Hilary,password=***,sec=ntlm,iocharset=utf8
    It mounted successfully.
    However, I don’t see it in the YMPD database.
    What next?

    thanks
    Hilary

    23. November 2016 at 16:41 #24130

    Hi Hilary,
    Please have a look at the basic settings of the MPD in our web interface. There you will find info on the music folder and its mount options:
    To access your music on a network share, you have to setup the share with the mountpoint folder /mnt/mpd.

    24. November 2016 at 6:31 #24157

    Hi Heiner,
    So you mean this:
    //HILARY7/Music /mnt/share cifs user=Hilary,password=***,sec=ntlm,iocharset=utf8
    should be this:
    //HILARY7/Music /mnt/mpd cifs user=Hilary,password=***,sec=ntlm,iocharset=utf8

    Now I see the shared folder under “MOUNT” — thanks!
    I think the instructions could be clearer, with examples.

    thanks
    Hilary

    24. November 2016 at 15:13 #24162

    Thank you for the feedback, we will look into making the documentation more transparent and understandable. Good to hear it all worked out!

    1. December 2016 at 7:32 #24427

    Hi Heiner,
    It worked out only temporarily unfortunately. The contents of the /mnt/mpd folder disappeared quite soon after they appeared. And they stayed disappeared for several days, even with rebooting the Pi and desktop and router. Then yesterday they appeared again and I was able to play some of the tracks. But now gone again. The radio playing was also on/off — sometimes just stopping for no apparent reason after playing for an hour or more.

    So I decided to try your suggestion of the Squeezebox Server:
    “Just install the Server with one click (select 7.9 nightly) and activate Squeezelite with the sysdefault hifiberry amp option selected (make sure MPD is not running anymore). Then, you can control the playback, volume, etc. via the Squeezebox Server web interface or with one of the great Apps for Android (Squeezer) or iOS (iPeng).”
    You didn’t say how to activate Squeezelite, but I found it in the Audioplayer. I have turned off the MPD player and ympd. Now one of my radio stations appears to be playing — I see it in the Logitech Media Player, and in the Squeeze App on my phone. But no sound once more! Is there another setting somewhere that I have missed?

    thanks
    Hilary

    1. December 2016 at 12:12 #24429

    Please check whether your sound card selection is correct (should include hifiberry amp in the name) and whether the MPD still has autostart activated, if so, deactivate.

    1. December 2016 at 21:41 #24476

    The soundcard selection in Squeezelite is sysdefault – snd_rpi_hifiberry_amp
    MPD does not have autostart activated. The only autostart is Squeezelite.
    What should I do next?
    thanks
    Hilary

    2. December 2016 at 5:07 #24478

    Still no sounds, so I decided to go back to MPD. I unchecked autostart on Squeezelite, rebooted, and tried to start MPD Player and got this error message:

    Trying to launch … NOT successful Click here to show detailed information
    /etc/init.d/mpd: 57: /etc/init.d/mpd: log_daemon_msg: not found
    Check for running Kodi
    Dec 02 04:03 : socket: Failed to bind to ‘[::]:6600’: Address already in use
    /etc/init.d/mpd: 87: /etc/init.d/mpd: log_end_msg: not found

    (Click here doesn’t open a page or any additional information)
    I am not running Kodi.
    Do I have to remove Squeezebox Server?

    thanks
    Hilary

    13. December 2016 at 4:01 #24814

    Hello,
    Still no sound using Squeezebox Server. I did get MPD Player running again (plays radio stations, but my music in the /mnt/mpd folder does not appear).
    Now when I stop MPD and un-check the “run at startup”, and
    start Squeezebox server (Status: Squeezebox Server is running with processID 1274) and
    start Squeezelite (Status: Squeezelite is running with processID 1600) and
    open the Squeezebox Wed Administration, and
    choose a radio station,
    it appears to play (time increments on play bar) but no sound.

    Please advise.

    Hilary

    13. December 2016 at 18:08 #24837

    Hi Hilary,
    Sorry about the late response. In the upper left corner of the Squeezebox Server’s web interface, do you see a player by the name of “Max2Play” or your chosen name for the RPi2 you are running Squeezelite on? This needs to be selected in order for the playback to work.

    15. December 2016 at 1:26 #24898

    I do see the max2play player, except it is in the upper right corner of the web interface (the Logitech Media Server). Is there some way I can send you a screeshot, if that would help?

    thanks
    Hilary

    15. December 2016 at 13:06 #24900

    Sorry, the upper right corner was what I meant. Can you select the max2play player in this section and if so, does it activate your playback?

    15. December 2016 at 16:40 #24903

    Yes, it is selected. And has been throughout this conversation. Still no playback.

    15. December 2016 at 17:08 #24904

    Then issue has to be either with the Squeezelite player if you can really still produce sound output via MPD. Again, please make sure that MPD is not still running, if you remove it from your menu without shutting it down first, it might still be running in the background.

    Also, here are some wiki articles that might help you:
    https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/
    https://www.max2play.com/en/wiki/power-supply-as-a-source-of-error/
    https://www.max2play.com/en/wiki/audioplayer-squeezelites-shairport/
    https://www.max2play.com/en/wiki/starter-guide/

    15. December 2016 at 20:24 #24907

    I found this under Raspberry Settings:

    Enable High-Resolution Audio on HDMI
    (set to default)
    Activate 192Khz sample rate and 32Bit encoding for soundoutput through HDMI. Important: Set Alsa-Parameter for Squeezelite on page Audioplayer to “::16:0” (fix bitrate to 16 and disable MMAP) if you get no sound at all or crackling sound!

    Could this be applicable even if it is set to default?

    Yes, MPD Player is playing. At least it was yesterday. Today I get this error:

    Trying to launch … NOT successful Click here to show detailed information
    /etc/init.d/mpd: 57: /etc/init.d/mpd: log_daemon_msg: not found
    Check for running Kodi
    Dec 15 19:22 : socket: Failed to bind to ‘[::]:6600’: Address already in use
    /etc/init.d/mpd: 87: /etc/init.d/mpd: log_end_msg: not found

    This is after I stopped Squeezebox and Squeezelite and updated Max2Play.
    Maybe I need to start again from scratch?! Is there a new version of Max2Play to download and re-image the SDcard?

    thanks
    Hilary

    17. December 2016 at 4:33 #24953

    Also, I found that after the above error, I cannot get back to the Settings/Reboot page without manually restarting the Pi (ie, pulling the plug!)

    21. December 2016 at 6:39 #25096

    Some progress: Everything froze up, so I re-imaged the SDcard. Previously, on the Start page I had chosen “Basic”. This time I really wanted to use the Squeezebox Server because the mobile app is much better. So I chose “Advanced”. This got it working properly (for a time!). I think you should have told me to go back to the Start page and change to Advanced, as it doesn’t work properly to install Squeezebox after choosing Basic.

    I still have a problem accessing /mnt/mpd. All the folders and music was listed for a couple of days, but now LMS says the folder is Empty.

    And radio stations are random, some work, and some don’t. Previously, with MPD Player/YMPD I was able to play my local stations KQED, KPFA, KALW. Now with LMS, none of those will play. However, other local stations such as KCSM and KDFC do play. What is the difference, and how do I fix it?

    I see there is an update for LMS available — should it be installed? If so, how and by whom?

    thanks
    Hilary

    28. December 2016 at 4:45 #25282

    Hi,
    A new question, in addition to the above: I’ve been looking at the wikipage on “power as a source of error”. It says the requirement for
    Raspberry Pi 2 / 3 and HiFiBerry AMP+ is 6A / 12V
    I have the MEANWELL GS60A18-P1J that is sold by HiFiBerry for the AMP+ but its specs are 3.33 A / 18 V (60W max). Is this a possible problem? Too few amps? I know that the R-Pi on its own requires 5 V / 2.5 A and if one uses one with less amps, there are problems.

    thanks
    Hilary

    5. January 2017 at 14:28 #25555

    Hi Hilary,

    Regarding your radio issues: In the LMS you can also directly load the URL of your preferred radio station. Have you tested this yet?

    Regarding your power supply: As you mentioned, HiFiBerry recommends this power supply. Thus, you should not experience any problems, it just cannot deliver as much power as the supplies we recommend. This can be a problem with larger passive speakers and high volume but should not be an issue otherwise.

    5. January 2017 at 21:58 #25581

    Hi Heimer,
    You mean that in LMS, under “Radio”, I should paste the URL of my radio station, <http://tunein.com/radio/KPFA-941-s34653/&gt; ?
    Yes, I have tried that several times and the station appears in the right-side panel but no sound and the timeline (is that what it is called?) bar increments for a few seconds and then resets to 0:00.
    Please keep in mind that when I first install Max2Play a few weeks ago, I chose the “Basic” set-up and the MPD Player. With that player, all radio stations played just fine (using YMPD).

    regards,
    Hilary

    13. January 2017 at 17:33 #25892

    Hi Hilary,
    Sorry about the late response. I tested your URL and got it to work on our test device. Please try entering just:

    http://tunein.com/radio/KPFA-941-s34653/

    In your LMS’ web interface in the internet radio segment.

    15. January 2017 at 4:30 #25918

    Hi Heiner,
    Thank you for getting back. Good to know it works on your test device. However, it does not work on my device. Here is a screenshot
    https://dl.dropboxusercontent.com/u/9466307/2017-01-13_LMS_KPFA.png
    Sometimes the seconds start incrementing, 1-2-3, and then back to zero, but never any sound.

    Hilary

Viewing 30 posts - 1 through 30 (of 30 total)

You must be logged in to reply to this topic.

Register here