tomsat50

Forum Replies Created

Viewing 29 posts - 1 through 29 (of 29 total)
  • Posted in:
  • 21. Mai 2021 at 16:47 #51285

    Ich habe die Buster Version 2.53 (Raspberry Pi 2b – HifiBerry DAC + – 7 inch Waveshare display), und auf 2 Systemen installiert haben (wobei auf einem System der Logitech Media Server installiert ist).

    • This reply was modified 1 year, 2 months ago by  tomsat50.
    • This reply was modified 1 year, 2 months ago by  tomsat50.
    21. Mai 2021 at 16:38 #51283

    Folgendes sehe ich oben auf der Justboom-Seite, nachdem ich die Konfiguration gespeichert habe:

    Max2Play – JustBoom Edition
    Saved SmartRemote Configuration
    Mapping saved

    Ich kann auch sehen, dass die Änderungen in der zuvor genannten Tabelle (für die SmartRemote) gespeichert werden, die ich vorgenommen habe..
    Das Ergebnis ist, dass die Fernbedienung gar nicht auf die Änderungen in der Tabelle reagiert, die ich vorgenommen (und gespeichert) habe.

    21. Mai 2021 at 16:26 #51282

    Das habe ich getan und es zeigt mir die Tabelle, die ich ändern kann:

    evdev:input:b0003v2252p0120*
    KEYBOARD_KEY_c00ea=minus
    KEYBOARD_KEY_c00e9=equal
    KEYBOARD_KEY_c00e2=u
    KEYBOARD_KEY_c0224=j
    KEYBOARD_KEY_c0223=h
    KEYBOARD_KEY_c0030=q
    KEYBOARD_KEY_c0040=semicolon
    KEYBOARD_KEY_c0041=enter

    Dies ist die Standardkonfiguration, sodass ich ändern kann, was ich möchte, aber nichts ändert sich.
    Auch nicht nach einen Reboot…

    21. Mai 2021 at 16:12 #51278

    Hallo Mario,

    Was ist die Standardkonfiguration, die ich in den ersten Zeilen des Justboom-Plug-Ins auswählen sollte (Your installed JustBoom Card:)?
    Ich habe keine Justboom-Karte ausgewählt (also „none“) …
    Nur um sicherzugehen, dass ich es richtig verstehe …

    19. Mai 2021 at 14:30 #51268

    Hallo Mario,

    Danke für Ihr Antwort.
    Die Fernbedienung macht nichts anderes, wenn ich Änderungen an der Justboom-Konfiguration vornehme.
    Es funktioniert sogar OHNE die Installation des Justboom-Plug-In. Ich habe den Eindruck, dass das Justboom-Plug-In mit meiner Fernbedienung überhaupt nichts Anderes macht.
    Ich habe keine Justboom-Hardware, sondern verwende stattdessen einen HifiBerry DAC +.
    Aus diesem Grund kann ich in den ersten Zeilen der Justboom-Seite keine Justboom-Kartenkonfiguration auswählen („none“).

    Möglicherweise muss ich einige geringfügige Konfigurationsänderungen am Justboom-Plug-In vornehmen. Im Moment habe ich mich nur für die Option „Smart Remote“ entschieden, die für einen ordnungsgemäßen Betrieb des Plug-Ins möglicherweise nicht ausreicht (mit meiner HifiBerry DAC + Hardware).
    Ich habe nur die Option „Zusätzliche Einstellungen für Justboom-Karten“ -> Smart Remote ausgewählt, das ist alles.
    Sollte ich weitere Änderungen an der Plug-In-Konfiguration vornehmen, damit die Fernbedienung richtig funktioniert?
    Es ist wirklich schade, dass die Lautstärketasten nicht funktionieren …

    • This reply was modified 1 year, 2 months ago by  tomsat50.
    11. Mai 2021 at 14:57 #51232

    Hallo MarioM,

    Geht leider nicht.
    Ich habe gerade herausgefunden, dass KEINE Kombination der Werte in der Tabelle des Justboom-Plug-Ins überhaupt einen Effekt hat!
    Ich habe dies überprüft, indem ich zufällige Zeichen und Hex-Codes in das Justboom-Konfigurationsfenster eingegeben habe …. keine Auswirkung …

    Ich habe nicht die Original-Justboom-Fernbedienung (nicht mehr verfügbar), sondern die HifiBerry-Funkfernbedienung (https://www.hifiberry.com/shop/accessories/wireless-remote-control/).
    Diese Fernbedienung funktioniert mit wireless statt mit Infrarot.
    Was ich gerade getan habe: Ich habe das Justboom-Plug-In deaktiviert und die Fernbedienung funktioniert immer noch (natürlich keine Lautstärkeregelung), sodass alle Änderungen, die ich an der Justboom-Konfiguration vorgenommen habe, anscheinend keine Auswirkungen haben.

    Schade, dass diese Fernbedienung nicht vollständig mit Jivelite funktioniert …. Ich habe sie mit HifiBerryOS getestet und in diesem Fall ist die Fernbedienung voll funktionsfähig …

    Es ist also wahrscheinlich nicht das richtige Plugin (Justboom), das ich für diesen Zweck benötige ….
    Entschuldigung für die ganze Verwirrung.

    11. Mai 2021 at 13:18 #51229

    Hallo MarioM,

    Ich habe die Fernbedienung durch eine drahtlose Tastatur (logitech K400R) ersetzt und festgestellt, dass die Taste „/“ (Slash) die Lautstärke verringert und die „Shift /“ (Fragezeichen) die Lautstärke erhöht!
    Es handelt sich also um eine Nichtübereinstimmung zwischen diesen Tasten auf der Fernbedienung.
    Was schlagen Sie vor? Wie kann ich die Tastaturcodes in die Hexadezimalwerte für meine in Jivelite verwendete Fernbedienung „übersetzen“?

    • This reply was modified 1 year, 2 months ago by  tomsat50.
    8. Mai 2021 at 14:36 #51212

    UPDATE: Ich habe die Fernbedienung mit dem HifiberryOS-Audiosystem getestet und die Lautstärketasten funktionieren!
    Dieses Audiosystem verwendet diese spezielle Fernbedienung sofort.
    Es ist also nur eine Frage der richtigen Codes für Minus und Equal, die mir unbekannt sind, um es mit max2play zu verwenden.
    Vielleicht kann mir jemand mit den richtigen Hex-Codes für diese Fernbedienung helfen oder hat eine Idee, wie man diese Codes von der Fernbedienung „lernt“.

    • This reply was modified 1 year, 3 months ago by  tomsat50.
    7. Mai 2021 at 14:30 #51209

    Ich suche nach einer Lösung, um die Lautstärkeregler für meine HiFiBerry-Fernbedienung, die ich kürzlich gekauft habe, zum Laufen zu bringen (https://www.hifiberry.com/shop/accessories/wireless-remote-control/).
    Meine Konfiguration: Raspberry Pi 2b – HiFiBerry DAC plus, 7-Zoll-Waveshare-Touchscreen mit max2play version 2.53.
    (Diese Angelegenheit wurde in einem anderen Thread (HifiBerry Fernbedienung) initiiert, sorry für das …).
    Die meisten Tasten funktionieren einwandfrei: up, down, left, right, Home, flymouse, back key, power (was zu einem Herunterfahren führte).
    Die wichtigsten Tasten (Lautstärke erhöhen und verringern) funktionieren jedoch überhaupt nicht.
    Meine Frage ist also, was ich in der Hardware-Steuerungskonfiguration (Justboom) ändern sollte:

    evdev: input: b0003v2252p0120 *
    KEYBOARD_KEY_c00ea = minus
    KEYBOARD_KEY_c00e9 = equal
    KEYBOARD_KEY_c00e2 = u
    KEYBOARD_KEY_c0224 = j
    KEYBOARD_KEY_c0223 = h
    KEYBOARD_KEY_c0030 = q
    KEYBOARD_KEY_c0040 = semicolon
    KEYBOARD_KEY_c0041 = enter

    Die Minus- und Equal lines sollten geändert werden, und ich habe keine Ahnung, wie ich das anordnen soll.
    Also noch einmal meine Frage: Was soll ich ändern, um die Lautstärketasten zu aktivieren?
    Vielen Dank im Voraus und entschuldigen Sie die doppelte Veröffentlichung (ich gehe davon aus, dass dies der richtige Thread für die Probleme mit der Fernbedienung ist).

    6. Mai 2021 at 17:29 #51203

    Hallo MarioM, danke für die schnelle Antwort.
    Ich kann die Konfiguration jetzt nach dem Zurücksetzen auf die Standardeinstellungen sehen!
    Ich weiß jedoch nicht, was ich in den Zeilen ändern oder hinzufügen soll:

    KEYBOARD_KEY_c00ea = minus
    KEYBOARD_KEY_c00e9 = gleich

    Ich habe die tcz-lirc-Webseite überprüft und sehe eine Tabelle, in der ich die Lautstärke nach oben (=) und nach unten (-) finden kann.
    Was soll ich also in den oben genannten Zeilen ändern?
    Ich hoffe, dass Sie mir (wieder) helfen können …

    • This reply was modified 1 year, 3 months ago by  tomsat50. Reason: Language
    6. Mai 2021 at 16:58 #51199

    Hallo MarioM,

    Ich habe die HiFiBerry-Fernbedienung gekauft (https://www.hifiberry.com/shop/accessories/wireless-remote-control/).
    Nach dem Einstecken des USB-Dongles und dem Neustart kann ich die Fernbedienung teilweise mit Jivelite verwenden.
    Die Lautstärketasten funktionieren aber nicht ….
    Außerdem möchte ich die Funktion des Netzschalters ändern. Die Raspberry wird heruntergefahren, und ich möchte sie in den Standby-Modus versetzen.
    Ich habe gemäß Ihrem Rat das Hardware Control-Plugin installiert und kann jetzt die Tab „Justboom“ öffnen.
    Ich gehe davon aus, dass ich einige Informationen in das Fenster „“ Zusätzliche Einstellungen für Justboom-Karten – Smart Remote „“ eingeben muss (das jetzt leer ist).
    Leider weiß ich nicht, was ich in dieses Fenster eingeben soll, um die Lautstärkefunktion hinzuzufügen und den Netzschalter zu ändern.
    Ich hoffe, dass Sie mir helfen können, insbesondere das Fehlen der Funktion der Lautstärketasten ist ein Problem.

    6. Mai 2021 at 16:25 #51197

    Double posting, sorry!!

    • This reply was modified 1 year, 3 months ago by  MarioM.
    • This reply was modified 1 year, 3 months ago by  tomsat50.
    23. April 2021 at 16:03 #51154

    Das Problem wurde gelöst! Ich habe alle Jivelite-Einstellungen zurückgesetzt (‚Reset Jivelite settings‘ im Jivelite-Menü) und die Raspberry neu gestartet.
    Jetzt kann ich sowohl das Spektrum-Display als auch die VU-Meter richtig verwenden (obwohl der Hintergrund des VU-Meters grau ist, kein Problem).
    Ich musste immer noch den Zusatz in der Datei boot / config.txt verwenden, wie ich zuvor beschrieben habe, um der Anzeigegröße von 800 x 480 zu entsprechen.
    Also funktioniert es jetzt gut!

    20. April 2021 at 16:21 #51147

    Die HiFiBerry Fernbedienung kann eine Lösung sein, wenn der Raspberry Player nicht direkt sichtbar ist.
    Es ist mit einem USB-Dongle ausgestattet, daher sollte es keine Hardwareprobleme geben (einfach einstecken und * vielleicht * betrieben).
    Es scheint mit HiFiBerryOS und LibreElec zu funktionieren (Ich bin nicht mit beiden Distributionen vertraut).
    Die Preise ist auch nicht zu hoch (ca. 13 Euro).
    Es wäre großartig, wenn diese Fernbedienung mit meiner Max2Play-Konfiguration funktionieren sollte, von der das 7 inch Anzeigemodul (mit JiveLite) das einzige sichtbare Element in meinem Raum ist.
    Meine Frage ist also: Hat jemand diese Fernbedienung gekauft und ausprobiert? Es wäre meiner Meinung eine großartige Ergänzung zum Max2Play-System!

    • This reply was modified 1 year, 3 months ago by  tomsat50.
    17. April 2021 at 13:49 #51137

    Ich habe ähnliche Probleme mit der Skalierung des Jivelite-Bildschirms: Ich hatte ein zu breites Display (auf der rechten Seite des Jivelite-Displays).
    Anfangs musste ich einige Einträge in der Datei config.txt (Boot-Ordner) ändern / hinzufügen:

    max_usb_current = 1
    hdmi_force_hotplug = 1
    config_hdmi_boost = 10
    hdmi_group = 2
    hdmi_mode = 87
    hdmi_cvt 800 480 60 6 0 0 0

    Dies behebt das Off-Scale-Problem des Bildes in Jivelite (Overscan auf der rechten Seite des Bildschirms).
    Der Grund für diese Änderung in der Konfiguration ist, dass mein 7-Zoll-Display ((Waveshare 7-Zoll-HDMI-LCD (H)) eine nicht standardmäßige Auflösung (1024 x 600 Pixel) hat.
    In Jivelite muss ich die Anzeige auf 800 x 480 skalieren (wie in der Datei config.txt hinzugefügt).

    Außerdem scheint die Visualisierung des VU-Messgeräts immer noch falsch zu sein (ähnlich der Anzeige des Initiators dieses Threads).
    Ich gehe davon aus, dass ich die Anzeigeeinstellungen im entsprechenden Ordner zurücksetzen muss:

    / opt / jivelite / jivelite / share / jive / applets / JogglerSkin / images / UNOFFICIAL / VUMeter

    In diesem Ordner befinden sich mehrere Dateien. Die am besten passende Datei sollte diese sein: vu_analog_25seq_m2p_b_800.png
    Daher habe ich diese Datei in ‚vu_analog_25seq_w.png‘ konvertiert und festgestellt, dass sich die Abmessungen des Bildschirms des VU-Messgeräts geändert haben, aber immer noch die Anzeige ‚instabil‘ angezeigt werden.
    Ist es möglich, eine Datei zu erstellen, die der für meinen Bildschirm erforderlichen Jivelite-Größe (800 x 480) entspricht?

    Danke im Voraus,

    Tom

    15. April 2021 at 17:33 #51134

    Problem has been resolved!
    I had to add some lines in the config.txt file:

    max_usb_current=1
    hdmi_force_hotplug=1
    config_hdmi_boost=10
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0

    That’s all, now I have the proper Jivelite display, all sized well.

    Cheers,

    Tom

    12. Mai 2020 at 15:42 #48766

    Hello MarioM,

    Thanks for your reply.
    Btw, I did NOT carry out the ‚update kernel‘ (which is a separate cmd from the Raspberry Settings page).
    I only selected the ‚update packages‘ which stands for apt-get update and upgrade which should be ’safe‘ in most cases…

    In addition, I have carried out the „apt –fix-broken install“ as you suggested.
    This has, finally, completed the update and upgrade action, I was able to re-run that commmand after the fix, and now all is OK!
    Thanks for your help!

    25. Mai 2019 at 17:34 #45488

    Hello Heiner,

    Maybe it has been asked before, but is it possible to make the microSDcard ‚read-only‘, so that the card does not get corrupted when the power is accidentally removed.
    For the rest I am very satisfied with the Max2Play solution. I am using a Raspberry 2B with a HiFiBerry hat, together with a Squeezebox Touch and 2 Squeezebox Radios, all remotely controlled with the Android app Squeeze Ctrl from angryGoat.

    18. Januar 2018 at 14:47 #33523

    Vous pouvez également utiliser la nouvelle version bêta de max2play (Raspbian Stretch), qui fonctionne bien ici. Ce matin j’ai aussi eu des problèmes avec ma version Jessie, les LED’s LAN du Raspberry étaient sorties et je ne pouvais plus contacter max2play avec mon ordinateur … Seul un redémarrage pourrait garantir que tout a fonctionné à nouveau.
    Bonne chance, vous allez réussir!

    17. Januar 2018 at 22:35 #33506

    Avez-vous une option pour afficher les adresses IP dans votre réseau (comme FING – Android)? Après avoir redémarré le Raspberry, l’adresse IP doit être visible, et je suppose que vous avez configuré DHCP dans votre routeur ….

    17. Januar 2018 at 22:35 #33507

    Avez-vous une option pour afficher les adresses IP dans votre réseau (comme FING – Android)? Après avoir redémarré le Raspberry, l’adresse IP doit être visible, et je suppose que vous avez configuré DHCP dans votre routeur ….

    15. Januar 2018 at 17:02 #33451

    Je ne comprends pas ça. La procédure consiste à graver l’image sur une carte SD (avec par exemple Win32Diskimager), metter le carte SD dans le Raspberry, et démarrer. Après un certain temps, tapez l’adresse IP dans un navigateur sur un PC, et voilà ….
    Pas de moniteur requis, tout passe par l’interface web, aussi le redémarrage et l’arrêt (jamais couper le 5 V sans ’shutdown‘ par l’interface web pour éviter corruption du carte SD) …
    Ce n’est pas possible d’installer max2play séparément, il est intégré dans l’image (avec Jessie ou la version Beta Scratch). J’ai 2 RPI’s en cours d’utilisation, tout les deux équipé avec un HifiBerry, un avec Jessie et un avec Scratch. Ils fonctionnent parfaitement avec Logitech Media Server et le plug-in Spotty (pour Spotify).

    15. Januar 2018 at 14:20 #33441

    Je pense qu’il est préférable de faire une nouvelle image (parce qu’il n’y a pas aucun image au moniteur pendant le redémarrage). Avez-vous un carte sd rapide (classe 10), et au moins un Raspberry B +?

    14. Januar 2018 at 22:13 #33414

    Vous pouvez connecter un moniteur et un clavier au Raspberry, et demander l’adresse IP avec un session terminal en utilisant la commande „ifconfig“. Je suppose que le Raspberry est connectée via LAN.

    14. Januar 2018 at 17:30 #33405

    L’adresse IP peut avoir changé pendant le redémarrage. Cela peut être retrouvé avec, par exemple, FING (application Android).

    13. Januar 2018 at 14:59 #33393

    Hello Heiner,

    Has the fixed-LAN setup been fixed in the new image? I still have problems that I cannot always get back the current IP address after a shutdown.
    In addition, will it be possible (maybe in the near future) to add the ‚read-only‘ option for the SD card when using the Logitech server?
    That would be very useful to avoid corruption of the SD card when the power to the Raspberry is accidently cut prior to a proper shutdown command.
    Anyway, I will download and install the Stretch version, and I will notify you when ’new‘ problems are detected.
    Best regards from The Netherlands,

    Tom

    28. Oktober 2017 at 14:02 #32167

    This sounds familiar, and it has already been recognized as a bug: https://www.max2play.com/en/forums/topic/fixed-ip-dhcp-still-working-and-i-get-two-ip-addresses/

    So this problem will hopefully be resolved when an update of max2play will be launched.
    For the time being I will stay with DHCP activated: the IP address seems to be ‚fixed‘ even after a reboot / restart.
    You may get into problems as soon as you disable DHCP… it is quite confusing anyway…

    25. Oktober 2017 at 15:20 #32104

    Hello Heiner,

    I have just put a brand new class 10 SD card into the Raspberry with the most recent version of the max2play image.
    For now it runs fine after having carried out all updates and configurations.
    The red LED on the Raspberry is always lit, the green LED is flashing shortly from time to time (approx. 6 times in a minute).
    The CPU load is 0.14 at this moment, the SD card usage is 15 % (16 GB size), CPU temp. will not exceed 50 deg. (playing for 1/2 hr. from boot).
    I will check this from time to time, and I will keep you updated!

    10. Oktober 2017 at 15:17 #31850

    I have added the above mentioned text to the /etc/dhcpcd.conf file, but it still does not work properly.
    The ‚fixed‘ IP address as set in the file and in the LAN configuration of max2play changes after a while into another address, and all services are stopped.
    So I cannot get access to the ’system‘ after that, and I have to disconnect the power supply (which I hate to do because of the risk of a corrupted SD card)…
    This happens all the time, so for now I will leave the DHCP service active. I cannot use a fixed IP address, strange behaviour…

    I hope that someone can resolve this issue..
    For the rest max2play works great on my Squeezebox devices with the Logitech Media Server and Spotty (for Spotify).

    • This reply was modified 4 years, 10 months ago by  tomsat50.
    • This reply was modified 4 years, 10 months ago by  tomsat50.
Viewing 29 posts - 1 through 29 (of 29 total)