Bluetooth on Max2Play client blocks connection to my Max2Play LMS server

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Bluetooth on Max2Play client blocks connection to my Max2Play LMS server

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 3 weeks, 3 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 30. Dezember 2022 at 23:47 #52558

    I have 2 Max2Play clients that are connected to another Max2Play „server“ which is equipped with LMS:

    Clients: 1 x Raspberry 3B and 1 x Raspberry 3B+, both with HifiBerry DAC+ and a 7 inch Waveshare touchscreen display.
    Server: 1 x Raspberry 3B+, with LMS installed (including Spotty for Spotify) and several internet radio stations.

    This set-up works fine for several years now.
    The problem came up recently when I tried to connect 1 of my clients with my JBL tuners (JBL tuner 2 and tuner XL) with bluetooth.
    I have installed the bluetooth plugin onto the client, and made the changes in the Audioplayer (advanced settings) to redirect the audio stream to bluetooth (Soundcard: Bluetooth, and Command line options: -v -B).
    I could make the connection with the JBL tuner without any problems, but I could not connect to the Max2Play server after a reboot.
    It worked suddenly after some time, and from that moment I did not have any problems with the set-up.
    The Max2Play client returned to a standby status when I turn of the JBL tuner, and it connected properly after I restart the JBL tuner.
    However, it takes a lot of time for getting the connection to the server after I shut down and/or reboot the Max2play client.
    This did not happen without the bluetooth feature, I always got the connection to the server within a minute.
    Has anyone an idea how to fix this issue?? Should I add some extra information in the Max2Play client software??

    EDIT: seems to be normal behaviour… some time (approx. 2 minutes) is required (after the bluetooth connection is made) for the finalization of the connection with the Max2Play server…….

    • This topic was modified 3 weeks, 5 days ago by  tomsat50.
    3. Januar 2023 at 15:45 #52569

    Hi tomsat50,

    As you have already recognised, some time seems to be necessary to establish a connection. You could add -s <server>[:<port>] to the advanced options of Squeezelite to automatically connect the player to the server. But apart from that there is not much more you can do.

    4. Januar 2023 at 17:55 #52571

    Hello MarioM,
    Thanks for your reply.
    How can I, in detail, add this entry in the advanced settings of Squeezelite?
    I assume: -v -B -s 192.168.1.5:port…
    Is this the correct format, and… which port do I have to use?
    The ports (as displayed with FING on my smartphone) that I can find are 22 (ssh), 80 (http), 139 (netbios-ssn) and 445 (microsoft-ds).

    5. Januar 2023 at 15:37 #52572

    You do not necessarily need to specify the port. The IP address should be sufficient. Just add -s <IP address> in the command line options of Squeezelite.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here