Jivelite screen is too wide on a Waveshare 7 inch display – update

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Jivelite screen is too wide on a Waveshare 7 inch display – update

This topic contains 2 replies, has 2 voices, and was last updated by  MarioM Moderator 2 weeks, 3 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 14. April 2021 at 17:02 #51128

    UPDATE:

    Hello support team,

    I have connected a Waveshare 7 inch touchscreen display to my Raspberry Pi 2B/HiFiBerry DAC + audio player.
    The version of Max2Play is 2.53, and this Max2Play system is running fine for several months until I started to connect this display.
    The Waveshare display is a 7 inch HDMI LCD (H) which is connected between the HDMI ports of the display and the raspberry.
    The size of the display is 1024 x 600.

    I have installed the Jivelite add-on, and I started with the configuration:
    I had to install the „port for 2.8 “ 320×240 Adafruit LCD (QVGA TouchSkin by bogdandimitru)“ which seems to be the only valid choice.
    The „patch joggler skin for 1024×600 Waveshare 7 inch screen (by Martin)“ which seems to be more relevant could NOT be installed.
    In addition I have chosen for the Joggler Skin for the display in 7 inch in the Jivelite Settings (as mentioned in the Jivelite configuration screen).

    This works (almost) fine (including the touch function). However, the Jivelite display is too wide (at the right side) so not all text is displayed at the right side…
    This only occurs with Jivelite…. the initial Max2Play window which pops up during the start of the software is correctly sized: it fits very well in the linux window.
    I have tried to decrease the overscan in the config.txt file, but this does not help….

    So it is almost OK….. is there a way in which I can decrease the horizontal span at the right side in Jivelite???

    Best regards, Tom
    Almere
    The Netherlands

    • This topic was modified 3 weeks, 1 day ago by  tomsat50.
    • This topic was modified 3 weeks, 1 day ago by  tomsat50.
    15. April 2021 at 17:33 #51134

    Problem has been resolved!
    I had to add some lines in the config.txt file:

    max_usb_current=1
    hdmi_force_hotplug=1
    config_hdmi_boost=10
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0

    That’s all, now I have the proper Jivelite display, all sized well.

    Cheers,

    Tom

    20. April 2021 at 13:56 #51139

    Hi Tom,

    I am glad that you found a solution to your problem. Thank you for the info!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here