[LIRC Infrared Fix Update] Max2Play Hardware Control Plugin – We Need Your Feedback!

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) [LIRC Infrared Fix Update] Max2Play Hardware Control Plugin – We Need Your Feedback!

This topic contains 89 replies, has 26 voices, and was last updated by  tomsat50 5 months, 1 week ago.

Viewing 30 posts - 61 through 90 (of 90 total)
  • 4. Juni 2020 at 16:26 #48943

    Hallo Jochen,

    eigentlich haben wir in unseren letzten Updates nichts verändert, was die Nutzung der Smart Remote beeinflusst haben könnte. Trat das Problem auf, nachdem du ein Software Update durchgeführt hast? Falls ja, von welcher Max2Play Version aus hast du geupdatet und welche Version läuft jetzt auf deinen Pis? Hast du sonst noch Änderungen an deinem System vorgenommen bevor das Problem auftrat?

    7. Juni 2020 at 21:16 #48952

    Hi,

    die Pis laufen auf 2.52.

    Die Codes für die SmartRemote entsprechen dem Standard:
    evdev:input:b0003v2252p0120*
    KEYBOARD_KEY_c00ea=minus
    KEYBOARD_KEY_c00e9=equal
    KEYBOARD_KEY_c00e2=u
    KEYBOARD_KEY_c0224=j
    KEYBOARD_KEY_c0223=h
    KEYBOARD_KEY_c0030=q
    KEYBOARD_KEY_c0040=semicolon
    KEYBOARD_KEY_c0041=enter

    Ansonsten kann ich mich an keine Änderung erinnern…

    Gruß und Vielen Dank fürs Mitdenken

    Jochen

    9. Juni 2020 at 13:42 #48963

    Hallo Jochen,

    ich bin morgen wieder im Büro. Falls ich die Zeit dazu finde, werde ich das Ganze selbst noch einmal testen und dir dann Bescheid geben.

    17. Juni 2020 at 13:09 #49043

    Hallo Jochen,

    ich bin nun endlich dazu gekommen die Smart Remote zu testen. Mit meinem Testgerät hat die Lautstärkeänderung in Jivelite unter v2.52 direkt funktioniert. Kannst du hier eventuell nochmal deine Squeezelite Einstellungen (Debug Info unten auf der Audioplayer Seite) posten? Funktioniert bei dir die Lautstärkeänderung wenn du den Pi als Audioausgabe in Squeezelite einstellst und dann z.B. Kopfhörer an den Pi anschließt? Ansonsten kann ich dir nur empfehlen zunächst für eines der Geräte ein neues Images zu brennen und es damit noch einmal zu probieren.

    17. Juni 2020 at 22:26 #49051

    Vielen Dank für Deine Mühen, auch wenn es meinen Horizont übersteigt.
    Die Debuginfos lauten:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o plug:equal -a 80:4:: -o hw:1 -V Digital -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:equal -t hardware -m hw:1 -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    23. Juni 2020 at 12:39 #49069

    Hallo Jochen,

    in deiner Squeezelite Debug kann ich nichts ungewöhnliches erkennen, dass zu dem Fehler führen könnte. Ich leite das Problem mal an unseren Chef-Entwickler weiter. Vielleicht weiß er eine Lösung.

    4. Juli 2020 at 19:36 #49184

    Das gibt es nicht – ich habe ein komplett neues Image gebrannt und den gleichen Fehler – da fällt mir nix mehr ein…..
    Gruß
    Jochen

    8. Juli 2020 at 12:35 #49238

    Hallo Jochen,

    zum Vergleich hier nochmal mein Vorgehen:

    1. Stretch Image auf SD-Karte gebrannt
    2. Gerät hochgefahren, Lizenz aktiviert, Justboom Plugin installiert
    3. Max2Play Update auf 2.52 durchgeführt
    4. Smart Remote USB Dongle angeschlossen
    5. Smart Remote im Justboom Plugin installiert: 1. Reset with Defaults 2. Save
    6. Jivelite Autostart aktiviert, Reboot
    7. Wiedergabe über Squeezebox Server gestartet, Smart Remote Lautstärkeregelung getestet –> funktioniert über Pi Audioausgang

    8. Shutdown, Amp2 aufgesteckt
    9. Hochfahren, Amp2 in Raspberry Einstellungen auswählen, Reboot
    10. Wiedergabe über Squeezebox Server gestartet, Smart Remote Lautstärkeregelung getestet –> funktioniert über Amp2 Audioausgang

    7. Januar 2021 at 20:50 #50563

    I will use the plugin to control jivelite via IR.

    Problem:
    „irxevent“ does not start out of the box.

    HW:
    Pi 4B / 4GB RAM,
    7″ Touch Display „official“,
    TSOP4838,
    PRC-30 Remote (Sky),
    BH1750

    SW (Version Beta-201125):
    Linux 5.4.51-v7l+ #1333 SMP Mon Aug 10 16:51:40 BST 2020 armv7l GNU/Linux
    Logitech Media Server (v8.0.1, 1608617100, Tue Dec 22 07:18:04 CET 2020)
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999
    JiveLite 0.1.0
    Plugin Bluetooth
    Plugin Hardwarecontrol

    Solution:
    in /opt/max2play/custom_autostart.sh replace:
    – `if [ „$(ps -Al | grep irxevent | wc -l)“ -lt „1“ ]; then export DISPLAY=:0;sudo su -l pi -c „irxevent -d /var/www/max2play/\
    application/plugins/hardwarecontrol/scripts/ir/my_lircjivelite“;fi`
    with
    + `if [ „$(ps -Al | grep irxevent | wc -l)“ -lt „1“ ]; then export DISPLAY=‘:0′;sudo -u pi -H /usr/bin/irxevent -d /var/www/max\
    2play/application/plugins/hardwarecontrol/scripts/ir/my_lircjivelite; fi`

    (same sudo-pattern used for starting up jivelite from start_audioplayer.sh)

    Happy new year from HH, Germany.

    12. Januar 2021 at 14:10 #50583

    Hi HHit,

    Thank you for the bug fix. I will pass this on to our developer, he will implement the fix in our image if necessary.

    27. Januar 2021 at 16:06 #50666

    Hallo HHit,

    würde gerne meinen Raspi 4/4GB, 7″ Touch Display „official“, TSOP4838, auch per Fernbedienung(Justboom) steuern, leider habe ich die gleiche Fehlermeldung(„irxevent“ does not start out of the box.9 wie du.
    Da ich in Linux nicht bewandert bin kann ich Deiner Lösung leider nicht folgen.
    Die Datei /opt/max2play/custom_autostart.sh habe ich gefunden, nur wie kann ich diese öffnen und umschreiben?
    Ich würde mich sehr über Hilfe freuen.
    Beste Grüße
    Thomas

    8. März 2021 at 19:13 #50892

    Hallo M2P Team,
    Kann ich mit dem Hardware-Control-Plugin und einem Rotary encoder auch das Menü in JIVELITE (7″ Touch-Bildschirm) steuern oder funktioniert nur Lautstärke, Play und Pause?
    Falls nicht, gibt es eine andere Möglichkeit das Menü in Jivelite mit einer Hardware zu steuern?
    Danke und VG,
    Michael

    9. März 2021 at 16:22 #50901

    Hallo Michael,

    der Rotary Encoder kann nur für Play, Pause und Lautstärke verwendet werden. Zur Steuerung des Jivelite-Menüs empfehle ich dir eine IR- oder Smart Remote zu benutzen. Leider sind unsere Fernbedienungen von JustBoom aktuell nicht mehr auf Lager. Aber theoretisch kannst du auch andere Fernbedienungen mit dem Pi verbinden und zur Steuerung von Jivelite verwenden.

    9. März 2021 at 18:23 #50905

    Hallo Mario, danke für die schnelle Antwort.
    Schade, aber eine Fernbedienung hilft mir hierbei nicht weiter. Ich suche eine Möglichkeit um Jivelite direkt am Gerät (… und nicht über Touch) zu bedienen.

    10. März 2021 at 14:25 #50909

    Hallo Michael,

    Eventuell könntest du Taster an die GPIO-Leiste des Pi anschließen und darüber Befehle senden. Am besten du schaust mal im Netz nach ähnlichen Projekten. Die Keycodes für Jivelite findest du hier: https://github.com/ralph-irving/tcz-lirc/blob/master/jivekeys.csv

    7. Mai 2021 at 14:30 #51209

    Ich suche nach einer Lösung, um die Lautstärkeregler für meine HiFiBerry-Fernbedienung, die ich kürzlich gekauft habe, zum Laufen zu bringen (https://www.hifiberry.com/shop/accessories/wireless-remote-control/).
    Meine Konfiguration: Raspberry Pi 2b – HiFiBerry DAC plus, 7-Zoll-Waveshare-Touchscreen mit max2play version 2.53.
    (Diese Angelegenheit wurde in einem anderen Thread (HifiBerry Fernbedienung) initiiert, sorry für das …).
    Die meisten Tasten funktionieren einwandfrei: up, down, left, right, Home, flymouse, back key, power (was zu einem Herunterfahren führte).
    Die wichtigsten Tasten (Lautstärke erhöhen und verringern) funktionieren jedoch überhaupt nicht.
    Meine Frage ist also, was ich in der Hardware-Steuerungskonfiguration (Justboom) ändern sollte:

    evdev: input: b0003v2252p0120 *
    KEYBOARD_KEY_c00ea = minus
    KEYBOARD_KEY_c00e9 = equal
    KEYBOARD_KEY_c00e2 = u
    KEYBOARD_KEY_c0224 = j
    KEYBOARD_KEY_c0223 = h
    KEYBOARD_KEY_c0030 = q
    KEYBOARD_KEY_c0040 = semicolon
    KEYBOARD_KEY_c0041 = enter

    Die Minus- und Equal lines sollten geändert werden, und ich habe keine Ahnung, wie ich das anordnen soll.
    Also noch einmal meine Frage: Was soll ich ändern, um die Lautstärketasten zu aktivieren?
    Vielen Dank im Voraus und entschuldigen Sie die doppelte Veröffentlichung (ich gehe davon aus, dass dies der richtige Thread für die Probleme mit der Fernbedienung ist).

    8. Mai 2021 at 14:36 #51212

    UPDATE: Ich habe die Fernbedienung mit dem HifiberryOS-Audiosystem getestet und die Lautstärketasten funktionieren!
    Dieses Audiosystem verwendet diese spezielle Fernbedienung sofort.
    Es ist also nur eine Frage der richtigen Codes für Minus und Equal, die mir unbekannt sind, um es mit max2play zu verwenden.
    Vielleicht kann mir jemand mit den richtigen Hex-Codes für diese Fernbedienung helfen oder hat eine Idee, wie man diese Codes von der Fernbedienung „lernt“.

    • This reply was modified 5 months, 3 weeks ago by  tomsat50.
    11. Mai 2021 at 12:44 #51226

    Hallo Tom,

    Bitte öffne auf deinem Pi mal ein Terminal oder ein anderes Eingabefeld und drücke die Tasten für Lauter und Leiser auf deiner Fernbedienung. Da die Eingabe der Fernbedienung einer Tastatur entspricht, müssten dann Symbole wie „+“ oder „-“ erscheinen. Welche sind das bei dir?

    In der Regel sollten das nämlich „+“ und „-“ sein. Bitte überprüfe auch, ob die Lautstärkeänderung über eine angeschlossene Tastatur in Jivelite funktioniert. Klappt denn auch die Lautstärkeänderung über das Display? Teste das bitte mal, damit wir ausschließen können, dass Jivelite in dem Moment gar keine Lautstärkeänderung zulässt.

    11. Mai 2021 at 13:18 #51229

    Hallo MarioM,

    Ich habe die Fernbedienung durch eine drahtlose Tastatur (logitech K400R) ersetzt und festgestellt, dass die Taste „/“ (Slash) die Lautstärke verringert und die „Shift /“ (Fragezeichen) die Lautstärke erhöht!
    Es handelt sich also um eine Nichtübereinstimmung zwischen diesen Tasten auf der Fernbedienung.
    Was schlagen Sie vor? Wie kann ich die Tastaturcodes in die Hexadezimalwerte für meine in Jivelite verwendete Fernbedienung „übersetzen“?

    • This reply was modified 5 months, 2 weeks ago by  tomsat50.
    11. Mai 2021 at 14:08 #51231

    Hi Tom,

    Bitte probiere mal in der Config:

    KEYBOARD_KEY_c00ea = –
    KEYBOARD_KEY_c00e9 = =

    und falls das nicht hilft:

    KEYBOARD_KEY_c00ea = /
    KEYBOARD_KEY_c00e9 = ?

    11. Mai 2021 at 14:57 #51232

    Hallo MarioM,

    Geht leider nicht.
    Ich habe gerade herausgefunden, dass KEINE Kombination der Werte in der Tabelle des Justboom-Plug-Ins überhaupt einen Effekt hat!
    Ich habe dies überprüft, indem ich zufällige Zeichen und Hex-Codes in das Justboom-Konfigurationsfenster eingegeben habe …. keine Auswirkung …

    Ich habe nicht die Original-Justboom-Fernbedienung (nicht mehr verfügbar), sondern die HifiBerry-Funkfernbedienung (https://www.hifiberry.com/shop/accessories/wireless-remote-control/).
    Diese Fernbedienung funktioniert mit wireless statt mit Infrarot.
    Was ich gerade getan habe: Ich habe das Justboom-Plug-In deaktiviert und die Fernbedienung funktioniert immer noch (natürlich keine Lautstärkeregelung), sodass alle Änderungen, die ich an der Justboom-Konfiguration vorgenommen habe, anscheinend keine Auswirkungen haben.

    Schade, dass diese Fernbedienung nicht vollständig mit Jivelite funktioniert …. Ich habe sie mit HifiBerryOS getestet und in diesem Fall ist die Fernbedienung voll funktionsfähig …

    Es ist also wahrscheinlich nicht das richtige Plugin (Justboom), das ich für diesen Zweck benötige ….
    Entschuldigung für die ganze Verwirrung.

    18. Mai 2021 at 14:00 #51262

    Hallo Tom,

    bitte entschuldige die späte Antwort. Die Fernbedienung sollte nichtsdestotrotz funktionieren. Bitte gehe nochmal sicher, dass du im JustBoom Plugin die Smart Remote und nicht die Infrarot Steuerung installiert hast. Der Tab „Smart Remote“ ist genau für solche USB Fernbedienungen gedacht.

    19. Mai 2021 at 14:30 #51268

    Hallo Mario,

    Danke für Ihr Antwort.
    Die Fernbedienung macht nichts anderes, wenn ich Änderungen an der Justboom-Konfiguration vornehme.
    Es funktioniert sogar OHNE die Installation des Justboom-Plug-In. Ich habe den Eindruck, dass das Justboom-Plug-In mit meiner Fernbedienung überhaupt nichts Anderes macht.
    Ich habe keine Justboom-Hardware, sondern verwende stattdessen einen HifiBerry DAC +.
    Aus diesem Grund kann ich in den ersten Zeilen der Justboom-Seite keine Justboom-Kartenkonfiguration auswählen („none“).

    Möglicherweise muss ich einige geringfügige Konfigurationsänderungen am Justboom-Plug-In vornehmen. Im Moment habe ich mich nur für die Option „Smart Remote“ entschieden, die für einen ordnungsgemäßen Betrieb des Plug-Ins möglicherweise nicht ausreicht (mit meiner HifiBerry DAC + Hardware).
    Ich habe nur die Option „Zusätzliche Einstellungen für Justboom-Karten“ -> Smart Remote ausgewählt, das ist alles.
    Sollte ich weitere Änderungen an der Plug-In-Konfiguration vornehmen, damit die Fernbedienung richtig funktioniert?
    Es ist wirklich schade, dass die Lautstärketasten nicht funktionieren …

    • This reply was modified 5 months, 1 week ago by  tomsat50.
    21. Mai 2021 at 15:49 #51274

    Hallo Tom,

    Wenn du die Smart Remote im JustBoom Plugin installiert hast, solltest du anschließend die Standardkonfiguration laden. Dann erscheinen in dem Textfeld die Keymapping Befehle. Falls die Lautstärketasten dann immer noch nicht funktionieren, ändere im Textfeld bitte die Befehle wie oben beschrieben. Starte das Gerät zur Sicherheit zwischendurch neu, damit wir sichergehen, dass die Änderungen auch wirksam sind. Ansonsten brauchst du nichts an der Pluginkonfiguration zu verändern. Die Smart Remote Einstellungen sollten auch für nicht JustBoom Fernbedienungen funktionieren, da sie alle wie eine Tastatur arbeiten.

    21. Mai 2021 at 16:12 #51278

    Hallo Mario,

    Was ist die Standardkonfiguration, die ich in den ersten Zeilen des Justboom-Plug-Ins auswählen sollte (Your installed JustBoom Card:)?
    Ich habe keine Justboom-Karte ausgewählt (also „none“) …
    Nur um sicherzugehen, dass ich es richtig verstehe …

    21. Mai 2021 at 16:20 #51280

    Hallo Tom,

    bitte entschuldige die Verwirrung. Weiter unten im JustBoom Plugin gibt es unter der Überschrift „Erweiterte Einstellungen für JustBoom Karten“ drei Reiter: Drehregler, Infrarot-Steuerung und Smart Remote. Klicke dort auf Smart Remote. Dort kannst du dann auf „Neustarten mit Standardeinstellungen“ auswählen. Anschließend kannst du die Standardwerte anpassen.

    Edit: Oben brauchst du keine JustBoom Soundkarte auswählen, wenn du eine HiFiBerry Karte nutzt, „none“ ist dort also richtig.

    • This reply was modified 5 months, 1 week ago by  MarioM.
    21. Mai 2021 at 16:26 #51282

    Das habe ich getan und es zeigt mir die Tabelle, die ich ändern kann:

    evdev:input:b0003v2252p0120*
    KEYBOARD_KEY_c00ea=minus
    KEYBOARD_KEY_c00e9=equal
    KEYBOARD_KEY_c00e2=u
    KEYBOARD_KEY_c0224=j
    KEYBOARD_KEY_c0223=h
    KEYBOARD_KEY_c0030=q
    KEYBOARD_KEY_c0040=semicolon
    KEYBOARD_KEY_c0041=enter

    Dies ist die Standardkonfiguration, sodass ich ändern kann, was ich möchte, aber nichts ändert sich.
    Auch nicht nach einen Reboot…

    21. Mai 2021 at 16:38 #51283

    Folgendes sehe ich oben auf der Justboom-Seite, nachdem ich die Konfiguration gespeichert habe:

    Max2Play – JustBoom Edition
    Saved SmartRemote Configuration
    Mapping saved

    Ich kann auch sehen, dass die Änderungen in der zuvor genannten Tabelle (für die SmartRemote) gespeichert werden, die ich vorgenommen habe..
    Das Ergebnis ist, dass die Fernbedienung gar nicht auf die Änderungen in der Tabelle reagiert, die ich vorgenommen (und gespeichert) habe.

    21. Mai 2021 at 16:41 #51284

    Ok, das ist gut zu wissen. Dann werde ich das mal an unseren Entwickler weitergeben. Normalerweise sollte man dort Werte verändern können und diese sollten auch angewendet werden. Das werden wir nochmal überprüfen. Könntest du mir noch einmal sagen, welches Max2Play Image du verwendet hast (Stretch oder Buster)?

    21. Mai 2021 at 16:47 #51285

    Ich habe die Buster Version 2.53 (Raspberry Pi 2b – HifiBerry DAC + – 7 inch Waveshare display), und auf 2 Systemen installiert haben (wobei auf einem System der Logitech Media Server installiert ist).

    • This reply was modified 5 months, 1 week ago by  tomsat50.
    • This reply was modified 5 months, 1 week ago by  tomsat50.
Viewing 30 posts - 61 through 90 (of 90 total)

You must be logged in to reply to this topic.

Register here