[SOLVED] Visualisations in Jivelite?

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Visualisations in Jivelite?

This topic contains 21 replies, has 11 voices, and was last updated by  tomsat50 5 months ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • 30. November 2015 at 23:26 #17072

    Hi,

    A couple of weeks ago I ordered a set of components here at Max2play and this made me a very happy and satisfied (and proud!!) owner of a RPi2 + DAC + 7“ touchscreen in a sleek case. Man, I love that puppy!!

    I have one question: in the web pages there is the note about de -v command line option to enable VU meter / spectrum analyzer in Jivelite. I have enabled the -v option to squeezelite but I cannot find the VU meters anywhere in Jivelite. Where to look for them?

    1. Dezember 2015 at 10:49 #17076

    Where to look for them?

    Just tab anywhere on the now playing screen and it should cycle through different visualizations/artwork etc. You can activate those screens in the screen settings of jivelite if nothing happens

    1. Dezember 2015 at 11:45 #17077

    Thank you fblu, at least I know wehere to look now.

    But: in the settings screen I only have three options: artwork, text and artwork + text. No visuals.

    Any clue?

    17. Februar 2016 at 15:05 #18537

    Hi Pastinakel,
    When you added the „-v“ parameter, you should be able to switch between visualisation by just tapping anywhere on the screen during normal playback.

    28. Juni 2016 at 18:16 #20905

    Hi,

    if Jivelite doesn’t show any visualisation after adding the „-v“ parameter to the startup of Squeezelite, it might be neccessary to „Reset Jivelite Settings“ on Jivelite Tab of Max2Play web interface. After this you must restart Jivelite and choose your skin (Joggler Skin for 7″ touchdisplay) and your language again. VU-Meter and Spectrum should now show up when playing music.

    9. August 2019 at 9:15 #46712

    my problem is that i see the vu and spectrum but it did not make any reaction. what can i do? my specs are RPi3 + DAC + 7“ raspi touchscreen

    9. August 2019 at 10:44 #46714

    Hi Dragon,

    Have you reset your Jivelite settings via our web interface yet?

    9. August 2019 at 15:15 #46734

    Okay, after another reset it works! Thank you!

    28. November 2019 at 14:23 #47627

    Hello,
    I had a similar experience. In my case I coul not manage to make the VU meter and Analyzer work properly. The VU meter is kind of flickering-tossing-wandering and the Analyzer is kind of hidding bellow the bottom and displaying only top/max values of spectrum. My stup is Pi 3B, HiFi berry dac+, 7” rpi official touch, joggler skin for 7”. Any ideas how to fix this?

    4. Dezember 2019 at 13:17 #47672

    Hi Palme,

    Have you tried resetting the Jivelite to Max2Play presets in our web interface?

    25. September 2020 at 10:04 #49753

    I have the same problem as Palme30. The VU meter is flickering, and the Analyzer is hiding below the bottom of the screen. I have Pi 3B, IQ-Audio Pi DAC+, 7″ rpi touch, joggler skin for 7″. I have reset the Jivelite two times with no success.

    Display with VU meter

    Also a link to a very short video showing the display: VU meter video

    30. September 2020 at 13:59 #49773

    Hi trondkj,

    Which Max2Play version do you use and which image (stretch/buster)? What settings have you made in Squeezelite?

    1. Oktober 2020 at 9:27 #49781

    I’m running M2P v 2.5.2 on stretch, Jivelite set to use the Joggler skin on 7″ touch screen.

    2. Oktober 2020 at 14:32 #49784

    Hi trondkj,

    I tested the VU meter with a Pi 3 and a DAC and couldn’t reproduce the problem. Can you please send me your debug info from the audio player tab?

    15. Februar 2021 at 10:34 #50798

    Hallo Max2play-Team,
    ich habe exakt das gleiche Problem wie in #49753 beschrieben.
    Bin auf der neusten Version (2.53) und habe (vorerst) keine HAT angeschlossen.
    Habe das 7″ Raspberry Display an einem Raspberry 3B und das Joggler Skin angewählt.
    Die VU-Anzeige „verschwimmt“, wie oben im Bild zu erkennen ist, sobald Musik abgespielt wird. Wird die Musik gestoppt, steht die Anzeige („verschwimmt“ nicht mehr), ist allerdings in der Darstellung etwas zu breit für den Bildschirm.
    Ich habe mal zum testen ein anderes Skin (Grid Skin (1024×600) gewählt. Da scheint die VU-Anzeige zu funktionieren, allerdings passt diese Format nicht zum 7″ Touch.
    Könnt ihr mir da bitte weiterhelfen?

    Danke und VG Michael

    15. Februar 2021 at 10:36 #50799

    … als zusätzliche Info, nachfolgend die Debug-Info von meinem Player …

    ——————–

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=ALSA -a 80::: -v
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S16_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 884
    buffer_size: 3536

    #### OUTPUT SOUND DETAILS CARD 1 ####

    15. Februar 2021 at 16:07 #50800

    … ich glaube das Problem ist gelöst!
    Nachdem einem Update von Jivelite auf die neuste Version funktioniert es jetzt.
    Allerdings sine die VU-Meter jetzt weiß und nicht mehr schwarz. Kann man das irgendwo einstellen bzw. auswählen?

    16. Februar 2021 at 14:56 #50803

    Hallo dicker007,

    Schön, dass das VU-Meter jetzt bei dir funktioniert. Leider ist die Hintergrundfarbe nicht ohne weiteres veränderbar. Am besten, du schaust dich mal im Slimdevices Forum um. Dort kannst du mit den Entwicklern von Jivelite und den Applets in Kontakt treten. Die Directory, in der du das VU-Meter auf dem Gerät finden solltest, ist diese: /opt/jivelite/jivelite/share/jive/applets/

    17. Februar 2021 at 22:36 #50814

    @dicker007

    Du findest die .png Dateien der VU-Meter in folgendem Pfad /opt/jivelite/jivelite/share/jive/applets/JogglerSkin/images/UNOFFICAL/VUMeter

    Beachte die Bildgrösse der .png!
    Das Original für JogglerSkin (vu_analog_25seq_w.png) hat die Bildgrösse 10’000×453.
    Eine andere Vorlage im Ordner kann (im Bildbearbeitungstool deines Vertrauen) auf die korrekte Grösse skaliert und nach belieben visuell angepasst werden. Dann benennst du es nach dem Original (vu_analog_25seq_w.png) um und ersetzt das Original. Um nichts zu verlieren benennst du auch das Original
    – zb. „vu_analog_25seq_w_ORIGINAL.png“ – um. Am besten gleich den ganzen Ordner „VUMeter“ mit Cyberduck oä.
    auf den Rechner ziehen, einmal Kopieren, das Original behalten und in der Kopie arbeiten und nach Wunsch anpassen.

    Ansonsten, hier die Originale zum Downloaden, Bearbeiten und auf deinen Pi laden:
    https://github.com/ralph-irving/jivelite/tree/master/share/jive/applets/JogglerSkin/images/UNOFFICIAL/VUMeter

    17. April 2021 at 13:49 #51137

    Ich habe ähnliche Probleme mit der Skalierung des Jivelite-Bildschirms: Ich hatte ein zu breites Display (auf der rechten Seite des Jivelite-Displays).
    Anfangs musste ich einige Einträge in der Datei config.txt (Boot-Ordner) ändern / hinzufügen:

    max_usb_current = 1
    hdmi_force_hotplug = 1
    config_hdmi_boost = 10
    hdmi_group = 2
    hdmi_mode = 87
    hdmi_cvt 800 480 60 6 0 0 0

    Dies behebt das Off-Scale-Problem des Bildes in Jivelite (Overscan auf der rechten Seite des Bildschirms).
    Der Grund für diese Änderung in der Konfiguration ist, dass mein 7-Zoll-Display ((Waveshare 7-Zoll-HDMI-LCD (H)) eine nicht standardmäßige Auflösung (1024 x 600 Pixel) hat.
    In Jivelite muss ich die Anzeige auf 800 x 480 skalieren (wie in der Datei config.txt hinzugefügt).

    Außerdem scheint die Visualisierung des VU-Messgeräts immer noch falsch zu sein (ähnlich der Anzeige des Initiators dieses Threads).
    Ich gehe davon aus, dass ich die Anzeigeeinstellungen im entsprechenden Ordner zurücksetzen muss:

    / opt / jivelite / jivelite / share / jive / applets / JogglerSkin / images / UNOFFICIAL / VUMeter

    In diesem Ordner befinden sich mehrere Dateien. Die am besten passende Datei sollte diese sein: vu_analog_25seq_m2p_b_800.png
    Daher habe ich diese Datei in ‚vu_analog_25seq_w.png‘ konvertiert und festgestellt, dass sich die Abmessungen des Bildschirms des VU-Messgeräts geändert haben, aber immer noch die Anzeige ‚instabil‘ angezeigt werden.
    Ist es möglich, eine Datei zu erstellen, die der für meinen Bildschirm erforderlichen Jivelite-Größe (800 x 480) entspricht?

    Danke im Voraus,

    Tom

    20. April 2021 at 14:18 #51142

    Hallo Tom,

    das sollte wie zuvor von PAUSE beschrieben funktionieren. Die Auflösung des Bildes kannst du mit einem Bildbearbeitungsprogramm deiner Wahl anpassen. Anschließend ersetzt du das angepasste Bild durch das Original mit dem selben Dateinamen. Vorher solltest du am besten eine Kopie der Datei oder des ganzen Ordners sichern.

    23. April 2021 at 16:03 #51154

    Das Problem wurde gelöst! Ich habe alle Jivelite-Einstellungen zurückgesetzt (‚Reset Jivelite settings‘ im Jivelite-Menü) und die Raspberry neu gestartet.
    Jetzt kann ich sowohl das Spektrum-Display als auch die VU-Meter richtig verwenden (obwohl der Hintergrund des VU-Meters grau ist, kein Problem).
    Ich musste immer noch den Zusatz in der Datei boot / config.txt verwenden, wie ich zuvor beschrieben habe, um der Anzeigegröße von 800 x 480 zu entsprechen.
    Also funktioniert es jetzt gut!

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Register here