Update Packages fails on new image

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Update Packages fails on new image

This topic contains 2 replies, has 2 voices, and was last updated by  tomsat50 5 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 7. Mai 2020 at 14:02 #48731

    I have created a new image of Max2Play (Stretch version) for my Raspberry Pi 2B / HiFiBerry DAC+.
    The configuration has been completed includeing the prompted Max2Play update, and afterwards the installation of LMS (nightly update version).
    All worked fine, and at that moment I decided to run the Raspberry update/upgrade in order to be up-to-date with the OS.
    This causes problems: the upgrade is NOT completed: the web page on which the update can be followed (yellow block) stops, and the page does not refresh any more. The web page was unreachable…
    I was able to shutdown the system properly by using SSH (putty) and the cmd ’sudo shutdown -h now‘.
    I rebooted the Raspberry, and all looked fine, so I tried to run the update/upgrade again.
    The text of the progress (yellow block) was displaying a message that the update progress was not carried out properly (did not make a screen dump of the exact message….). Then, again, I tried to run the update/upgrade and now it was started…. and stopped with some errors:

    Update / Upgrade to latest Version started
    Installation started – This Messages refreshes every 3 seconds to show current installation status. When finished this message disappears.

    Setting up libidn11:armhf (1.33-1+deb9u1) …
    Setting up libdbus-1-3:armhf (1.10.28-0+deb9u1) …
    Setting up libdbus-1-dev:armhf (1.10.28-0+deb9u1) …
    dpkg: error processing package apache2 (–configure):
    package is in a very bad inconsistent state; you should
    reinstall it before attempting configuration
    Setting up systemd (232-25+deb9u12) …
    addgroup: The group `systemd-journal‘ already exists as a system group. Exiting.
    Setting up dbus (1.10.28-0+deb9u1) …
    A reboot is required to replace the running dbus-daemon.
    Please reboot the system when convenient.
    Setting up systemd-sysv (232-25+deb9u12) …
    Setting up dbus-x11 (1.10.28-0+deb9u1) …
    Setting up libpam-systemd:armhf (232-25+deb9u12) …
    Setting up dbus-user-session (1.10.28-0+deb9u1) …
    Processing triggers for initramfs-tools (0.130) …
    Processing triggers for libc-bin (2.24-11+deb9u4) …
    Errors were encountered while processing:
    apache2
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:3 http://pipplware.pplware.pt/pipplware/dists/stretch/main/binary InRelease
    Reading package lists…
    Reading package lists…
    Building dependency tree…
    Reading state information…
    You might want to run ‚apt –fix-broken install‘ to correct these.
    The following packages have unmet dependencies:
    E: Unmet dependencies. Try ‚apt –fix-broken install‘ with no packages (or specify a solution).
    Finished – Reboot needed! Click here to Reboot Now

    UPDATE ENDED – CHECK ABOVE LOG FOR ERRORS

    I wonder why the update/upgrade is not carried out properly.
    I have created a brand new image, and started all over….. no improvement…
    The Max2Play device runs fine, but I do not feel very comfortable with probably an unstable system.
    So I hope that this can be fixed with some help.

    12. Mai 2020 at 14:42 #48758

    Hi tomsat,

    Kernel updates are always difficult and can lead to problems. You should only update if a backup of the SD card has been made beforehand or if you have no problem burning a fresh image to the SD card afterwards. As long as you don’t miss any explicit functions on your system, I don’t recommend doing a kernel update. To solve your problem you could try executing the command „apt –fix-broken install“ with our remote control plugin.

    12. Mai 2020 at 15:42 #48766

    Hello MarioM,

    Thanks for your reply.
    Btw, I did NOT carry out the ‚update kernel‘ (which is a separate cmd from the Raspberry Settings page).
    I only selected the ‚update packages‘ which stands for apt-get update and upgrade which should be ’safe‘ in most cases…

    In addition, I have carried out the „apt –fix-broken install“ as you suggested.
    This has, finally, completed the update and upgrade action, I was able to re-run that commmand after the fix, and now all is OK!
    Thanks for your help!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here