grimmt

Forum Replies Created

Viewing 14 posts - 1 through 14 (of 14 total)
  • 21. Juli 2021 at 22:00 #51489

    Ah, so the „normal“ permission is 666.
    Good to know for me.

    However, not helpful for you 🙁 .

    21. Juli 2021 at 17:25 #51485

    I had a similar issue a month ago. I could not add nor delete mount points.
    I’m guessing the problem might be with a kernel upgrade.

    It looks like a permissions issue somewhere.
    I changed the permissions on /etc/fstab (owned by root) from 644 to 666 and was then successful updating the mount points. I’ll see if I can isolate where the edit is performed to see how max2play modifies the file.

    Maybe the modification is not elevating privileges properly?

    Edit: The change I mentioned above is not a proper fix due to security concerns.
    Edit2: I checked and this page runs under user www-data and does not appear to request a privilege elevation.

    • This reply was modified 2 years, 10 months ago by grimmt.
    • This reply was modified 2 years, 10 months ago by grimmt.
    6. Mai 2021 at 21:18 #51208

    I think I found a solution.
    I added the following parameter to /boot/config.txt

    hdmi_ignore_edid=0x5000080

    The XServer now starts up in 1920×1080 resolution.
    Since the XServer appears to be overriding the „forced resolution“ selection due to EDID, perhaps your Dev Team should consider adding this as an option in the HDMI Settings for Display Resolution area.
    i.e.
    Disable EDID (checkbox) Disable Extended Display Identification Data (use this in the event a forced resolution is not working)

    6. Mai 2021 at 20:12 #51206

    I just updated my version to Beta-210428 and notice that this has not yet been fixed in the code.

    27. November 2020 at 2:21 #50363

    I noticed this today as well. All the top menus looked good but when I selected a play list they all had a count of 0.
    I logged into Spotify using my phone and it looked fine there.

    In the end I re-installed the most up to date version of squeezebox server in max2play (I’m using version 8.0) and it’s working properly now.

    21. Juli 2020 at 19:43 #49370

    I found a few minutes between meetings 🙂

    I loaded the latest Beta (200717) and verified that I no longer get „This function is for Raspberry PI ONLY“ on the Raspberry Settings page.
    [Side note: I peeked at the Services.php file and did notice your text for revision d03114 shows Raspberry PI 4B 4GB and it should be Raspberry PI 4B 8GB 🙂 ]

    21. Juli 2020 at 19:30 #49369

    Thanks for the confirmation MarioM!
    I’ll update max2play to the latest beta to verify later today or tomorrow morning.

    13. Juli 2020 at 7:35 #49289

    Correct, this should only impact the Spotty plugin, if you just disabled Ogg Vorbis in the Spotty File Type.

    12. Juli 2020 at 22:57 #49285

    MarioM,

    This weekend I noticed that max2play Beta-200708 still does not have this fixed.

    Can you check that a fix (if not my suggestion) is in the queue?

    11. Juli 2020 at 19:54 #49281

    I had a similar problem with spotty. Sometimes it would only play one song, other times it would play a few seconds of a song and skip to the next song.
    Squeezebox Server Spotty seems to have issues using the Ogg Vorbis codec which is Spotify’s codec.

    I fixed my issue by going to the Squeezebox Server WebAdmin settings/File Types section. Then look for the Spotty File Format entry and disable the Ogg Voris decoder. Remember to hit Save Settings. This will force the Squeezebox Server to convert the stream to flac.

    I am using max2play 2.52 and Squeezebox Server 8.

    23. Juni 2020 at 3:37 #49065

    You may be in a catch 22 condition.
    My max2play Kodi installation had services->control->Allow remote control via HTTP turned off by default.
    You will need to turn it on to use a Kodi remote controller app
    If it is off, how can you turn it on with a remote controller app?

    #use ssh to connect and login as pi
    cd /home/pi/.kodi/userdata
    # create a back up of your guisettings.xml file
    # i.e. „cp guisettings.xml guisettings.xml_orig“

    # edit the guisettings.xml file to turn on the webserver
    # do not change anything else!
    nano guisettings.xml
    change the line:
    <setting id=“services.webserver“ default=“true“>false</setting>
    to:
    <setting id=“services.webserver“>true</setting>

    you will need to restart Kodi to turn it on.

    • This reply was modified 3 years, 11 months ago by grimmt.
    • This reply was modified 3 years, 11 months ago by grimmt. Reason: changed "may" to "will"
    9. Mai 2020 at 5:58 #48739

    Unfortunately, I don’t have a solution for you Gonçalo.

    Off the top of my head it looks like you have some other issues in play.
    1. 504 Gateway Timeouts – looks like network or Spotify system server issues – this is not generated by you; but you may be doing something that causes the server to produce a time out.
    2. Access Rate limit exceeded – you are sending/receiving too much from Spotify.

    What else are you doing?
    Are you using anything to convert playlists to Spotify? You may be trying to do too much all at once.
    This is just from googling, I’m not familiar with these things as I don’t use playlist much on Spotify.

    Apparently, there may be a way to ask Spotify to increase your rate limit for a period of time.
    Otherwise, you can try to reduce your quality (lower than extreme 320kps) for a short duration to see if that clears up some of your issues. This would give you a data point to work with Spotify, if necessary.

    Tony

    • This reply was modified 4 years ago by grimmt. Reason: elaborate on 504 Gateway cause
    7. Mai 2020 at 20:47 #48736

    That’s odd – my longest runs are around 2-3 hours and have never had an issue
    Longest listening sessions are maybe 60-70 or so songs with jump to next song (scanner_fwd) used occasionally

    I’m hoping your system stabilizes with your reboot.
    If you hadn’t rebooted after changing the Spotty Ogg Vorbis setting, perhaps something was left in an unstable state on your system.

    My environment:
    . Max2play 2.52
    . raspberry pi 4 (buster)
    . LMS 8.0 on same raspberry pi 4
    . Spotty 4.0.6 Audio set to extreme (320kps) and File Type Ogg Vorbis disabled
    . Justboom Digi+ Hat
    . Bluetooth used for Harmony Remote support
    . Kodi 18.3 installed

    From DEBUG Info:
    #### KERNEL ####
    Linux Rasp4 4.19.50-v7l+ #895 SMP Thu Jun 20 16:03:42 BST 2019 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 10 (buster)
    Release: 10
    Codename: buster

    6. Mai 2020 at 20:20 #48721

    I was having the same issue with Spotify (Spotty plugin):
    . plays 3 or 4 seconds and skips to next song randomly (sometimes plays song properly)
    . stops playing
    . wouldn’t reliably skip to next/previous song when directed

    I used LMS->Settings->Advance/File Types and disabled Ogg Vorbis for Spotty.
    It now transforms the stream to FLAC and works reliably.

    Tony

Viewing 14 posts - 1 through 14 (of 14 total)