HDMI-Mode Not Saving Correctly (hdmi-drive) – Fix

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI HDMI-Mode Not Saving Correctly (hdmi-drive) – Fix

This topic contains 1 reply, has 2 voices, and was last updated by  MarioM Moderator 5 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 7. Juni 2020 at 18:41 #48950

    On the Raspberry Settings page, I noticed when setting the HDMI-Mode to either value „DVI/VGA“ or value „HDMI“ and saving, the page always displays „DVI/VGA“ and /boot/config.txt also shows hdmi-drive set to 1 for DVI/VGA, rather than 2 for HDMI.

    I found the value configured in /var/www/max2play/application/plugins/raspberrysettings/view/setup.php sets both DVI/VGA and HDMI to value 1.

    In version 2.52
    on line 229:
    <option <?php if($rs->view->hdmi_drive == „2“) echo ’selected‘; ?> value=’1′>HDMI</option>

    needs to be changed to:
    <option <?php if($rs->view->hdmi_drive == „2“) echo ’selected‘; ?> value=’2′>HDMI</option>

    12. Juni 2020 at 14:55 #48999

    Hi grimmt,

    Thank you for this fix. I’ll pass that on to our chief developer.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here