Spotify stops after playing one song

Max2Play Home 2016 (en) Forums Max2Play Add-ons Spotify stops after playing one song

This topic contains 4 replies, has 2 voices, and was last updated by  djvj premium 3 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 9. Juli 2020 at 1:28 #49271

    Hi,

    I’m having an issue where I play a spotify playlist from my phone, but every time, it stops after one song finishes. If I hit play again, it will play the next song on my phone. So each song I have to reconnect to my squeezebox room. This happens on both my raspberry pis running max2play. One has LMS and the other doesn’t.

    Also if I try to fast forward or rewind during a song, it disconnects from spotty and starts playing on my phone. I noticed the progress bar is not in sync with the actual place of the song. The time keeps ticking past the time the song was supposed to end. So it’s also out of sync.

    Here is the log from today, you can see the last lines show invalid data…I’m running latest spotty plugin.
    https://pastebin.com/rQsrRVWh

    I saw this thread, but the fix was to turn off squeezelite, which I don’t see anything like that running anywhere.

    [SOLVED] Spotify Connect Stops Playing on Track Change

    • This topic was modified 3 months, 2 weeks ago by  djvj.
    11. Juli 2020 at 19:54 #49281

    I had a similar problem with spotty. Sometimes it would only play one song, other times it would play a few seconds of a song and skip to the next song.
    Squeezebox Server Spotty seems to have issues using the Ogg Vorbis codec which is Spotify’s codec.

    I fixed my issue by going to the Squeezebox Server WebAdmin settings/File Types section. Then look for the Spotty File Format entry and disable the Ogg Voris decoder. Remember to hit Save Settings. This will force the Squeezebox Server to convert the stream to flac.

    I am using max2play 2.52 and Squeezebox Server 8.

    13. Juli 2020 at 1:14 #49287

    Thank you!!! That was indeed the issue!

    Songs now play one after another and I can skip around the track w/o issue.

    This needs to be in the spotty plugin, no reason we should have to disable this for the entire server.

    13. Juli 2020 at 7:35 #49289

    Correct, this should only impact the Spotty plugin, if you just disabled Ogg Vorbis in the Spotty File Type.

    14. Juli 2020 at 5:05 #49290

    Oh, I didn’t notice there was a Spotty only section. Ok that’s even better then. Weird to have that option there if it causes issues. But I guess that makes it more transparent to the end user.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here