Cannot delete network share

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot delete network share

This topic contains 20 replies, has 3 voices, and was last updated by  MarioM Moderator 3 days, 13 hours ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • 26. Juni 2021 at 20:45 #51367

    When I click on ‚delete‘ nothing happens, tried many times, restarted, upgraded – no progress

    cannot-delete-share-bug
    bugshares

    • This topic was modified 1 month ago by  polrus.
    30. Juni 2021 at 17:37 #51377

    Hi polrus,

    Which of our images do you use? Please check the debug info at the bottom of the Settings/Reboot page to see if you are using our Stretch or Buster image. If you are using an older image (e.g. Jessie or Wheezy), please download a fresh Stretch image and burn it to the SD card. Deleting the mount points should work there.

    30. Juni 2021 at 20:25 #51380

    Hi,
    I’m using Buster and M2P version is
    Version 2.53

    2. Juli 2021 at 16:37 #51403

    Hi polrus,

    Could you please try to update to the current beta? Does the deletion work this way?

    2. Juli 2021 at 17:58 #51406

    How do I do it?
    Is there a way to go back to stable ?

    6. Juli 2021 at 11:43 #51416

    Hi polrus,

    With an activated Premium licence, you can perform a beta update in the „Settings/Reboot“ tab. You can perform a „normal“ update at any time to return to the current version of Max2Play.

    6. Juli 2021 at 12:04 #51420

    It does not work in Beta either

    what I saw in Firefox is that you call
    http://192.168.0.121/plugins/max2play_settings/controller/Filesystem.php?action=delete_0&mountpoint=&path=&type=&options=
    or
    http://192.168.0.121/plugins/max2play_settings/controller/Filesystem.php?action=delete_1&mountpoint=&path=&type=&options=

    when I press on first or second button. Maybe mountpoint and path are also needed? Just guessing

    6. Juli 2021 at 15:27 #51423

    Hi polrus,

    I suspect that it is the Buster Image in combination with the Raspberry Pi 2. If I find the time tomorrow, I will test it on a Pi 2. I’ll get back to you when I’ve found a solution. Our developer might have to take a look at it again too.

    6. Juli 2021 at 21:26 #51426

    ok – if you want me to shoot some commands in terminal for troubleshooting I’m fine with it

    7. Juli 2021 at 16:17 #51430

    Hi polrus,

    I tested the Buster image with a Pi 2 and was able to successfully create and delete mountpoints. Have you made any other adjustments to your system? Were the mountpoints added successfully or was there an error message when adding them? You may need to burn a fresh Buster image to the SD card again if your system is corrupted.

    9. Juli 2021 at 9:05 #51440

    I checked the sdcard – it is not currupted.

    Of course burning new image would be an option but as I dedicated lots of time to set it up I would like to avoid doing this again.

    for troubleshooting steps you might consider:

    1. I deleted the mountpoints in /etc/fstab
    2 I added one of them with m2p gui – success
    3. I checked /etc/fstab modification date after adding -08:51
    4. I pressed delete on the newly added mountpoint in m2p gui at 08:53, for several seconds icon of turning gear apears – then it refreshed – feedbacj no message if removing was succesfull or not – just a refresh where the mountpoint is still present
    5. INTERESETING – there were no changes in /etc/fstab but modification time of /etc/fstab changed to 08:53 so the time when I pressed „delete“ in gui

    So to me there is no corruption but a bug in the file parsing /etc/fstab

    • This reply was modified 3 weeks ago by  polrus.
    13. Juli 2021 at 15:53 #51453

    Hi polrus,

    Many thanks for the troubleshooting. Could you please send us the debug info at the bottom of the filesystem/mount page?

    14. Juli 2021 at 2:41 #51462

    #### blkid ####
    /dev/mmcblk0p1: LABEL_FATBOOT=“boot“ LABEL=“boot“ UUID=“B6BB-0F0E“ TYPE=“vfat“ PARTUUID=“0634f60c-01″
    /dev/mmcblk0p2: LABEL=“rootfs“ UUID=“638417fb-7220-47b1-883c-e6fee02f51ac“ TYPE=“ext4″ PARTUUID=“0634f60c-02″
    /dev/mmcblk0: PTUUID=“0634f60c“ PTTYPE=“dos“
    /dev/mmcblk0p3: PARTUUID=“0634f60c-03″

    #### mounted ####

    20. Juli 2021 at 16:25 #51479

    It looks like there is no mounpoint defined. Otherwise there should be something under ####mounted####. Yet you see the entries above and can’t remove them?

    20. Juli 2021 at 18:26 #51483

    yes exactly, i can see them but cannot remove them.

    as I mentioned for troubleshooting I added the entries with the m2p gui also after removing them from console

    21. Juli 2021 at 17:25 #51485

    I had a similar issue a month ago. I could not add nor delete mount points.
    I’m guessing the problem might be with a kernel upgrade.

    It looks like a permissions issue somewhere.
    I changed the permissions on /etc/fstab (owned by root) from 644 to 666 and was then successful updating the mount points. I’ll see if I can isolate where the edit is performed to see how max2play modifies the file.

    Maybe the modification is not elevating privileges properly?

    Edit: The change I mentioned above is not a proper fix due to security concerns.
    Edit2: I checked and this page runs under user www-data and does not appear to request a privilege elevation.

    • This reply was modified 1 week, 2 days ago by  grimmt.
    • This reply was modified 1 week, 2 days ago by  grimmt.
    21. Juli 2021 at 21:43 #51488

    anyway in my case
    sudo ls -la /etc/fstab
    -rw-rw-rw- 1 root root 409 Jul 14 09:35 /etc/fstab

    21. Juli 2021 at 22:00 #51489

    Ah, so the „normal“ permission is 666.
    Good to know for me.

    However, not helpful for you 🙁 .

    26. Juli 2021 at 12:27 #51506

    Hi polrus,

    I have spoken to our developer again. He says that our plugin uses fstab as a direct source for the entries in the web interface. So if the entries in fstab are deleted, another problem ensures that they are still displayed in the GUI. We can therefore only recommend that you burn the image again if nothing else helps.

    27. Juli 2021 at 8:35 #51514

    HI
    as I wrote during the troubleshooting steps I could see that /etc/fstab gets updated by m2p (modification timestamp) but the content of fstab is not changed – so the mountpoint remains.

    So if the mountpoint is in fstab of course it is displayed.

    So again I’m saying that the script responsible for fstab modification is faulty.

    27. Juli 2021 at 11:48 #51524

    Since creating and deleting mountpoints worked without problems on my test device, I assume that something went wrong with yours. As I said, I can only recommend you to burn a new image, then everything should work properly again.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

Register here