Is there a way to force 1920×1080 for the X-Server?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Is there a way to force 1920×1080 for the X-Server?

This topic contains 2 replies, has 2 voices, and was last updated by  MarioM Moderator 1 month, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 6. Mai 2021 at 20:26 #51207

    I have a 4K LG TV and I have my Max2Play system connected via HDMI – I’m having difficulty forcing 1080p resolution consistently.

    I have tried forcing Max2Play HDMI screen configuration to 1920×1080 using the Raspberry plugin settings:
    o HDMI-Resolution: HDMI-Resolution: 1920×1080 @ 60Hz
    o HDMI-Mode: HDMI
    o HDMI Force Hotplug: enabled
    And discovered, this only works properly if I reboot my Max2Play system with my TV turned off or detached.

    If I reboot my system while the TV is turned on, the XServer and subsequent Jivelite app always starts in 4K resolution. This causes jivelite to fill only a top 1/4 rectangle of the screen.

    I’m guessing the XServer is using EDID to sense the available HDMI display resolution rather than forcing the selected resolution.
    Is there a way around this that I am missing?

    [I’ll also keep looking for a solution, and I’ll post back if I find anything.]

    • This topic was modified 1 month, 1 week ago by  grimmt. Reason: clarify what 1/4 of screen is filled
    6. Mai 2021 at 21:18 #51208

    I think I found a solution.
    I added the following parameter to /boot/config.txt

    hdmi_ignore_edid=0x5000080

    The XServer now starts up in 1920×1080 resolution.
    Since the XServer appears to be overriding the „forced resolution“ selection due to EDID, perhaps your Dev Team should consider adding this as an option in the HDMI Settings for Display Resolution area.
    i.e.
    Disable EDID (checkbox) Disable Extended Display Identification Data (use this in the event a forced resolution is not working)

    11. Mai 2021 at 11:57 #51224

    Hi grimmt,

    Thank you for pointing this out. Actually, the HDMI Force Hotplug should ensure that the resolution remains the same. As always, I will report this to our developer.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here