Cannot connect to Kodi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot connect to Kodi

This topic contains 1 reply, has 2 voices, and was last updated by  grimmt premium 5 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 21. Juni 2020 at 14:53 #49059

    Hi guys,
    I have started with a fresh image of max2play with default settings but am still getting the same error as I was before.
    Kodi is running and visible on the TV but I cannot access it via any method. Yatse or Kore app cannot see it, I cannot access it via the web interface at port 8080 and the CEC is not working so I cannot change any settings (presumably I would need to in order for Yatse etc to work?)

    Any suggestions please?

    FYI I am running Squeezebox server on a raspberry pi with a HiFiberry setup.

    23. Juni 2020 at 3:37 #49065

    You may be in a catch 22 condition.
    My max2play Kodi installation had services->control->Allow remote control via HTTP turned off by default.
    You will need to turn it on to use a Kodi remote controller app
    If it is off, how can you turn it on with a remote controller app?

    #use ssh to connect and login as pi
    cd /home/pi/.kodi/userdata
    # create a back up of your guisettings.xml file
    # i.e. „cp guisettings.xml guisettings.xml_orig“

    # edit the guisettings.xml file to turn on the webserver
    # do not change anything else!
    nano guisettings.xml
    change the line:
    <setting id=“services.webserver“ default=“true“>false</setting>
    to:
    <setting id=“services.webserver“>true</setting>

    you will need to restart Kodi to turn it on.

    • This reply was modified 5 months, 2 weeks ago by  grimmt.
    • This reply was modified 5 months, 2 weeks ago by  grimmt. Reason: changed "may" to "will"
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here