Accesspoint issues

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint issues

This topic contains 305 replies, has 11 voices, and was last updated by  Heiner Moderator 4 years, 2 months ago.

Viewing 30 posts - 91 through 120 (of 306 total)
  • 10. Januar 2016 at 0:18 #17660

    OK the start command does generate a lot of output.
    now the command
    ifconfig wlan0
    should confirm the static IP address 192.168.189.1 something like

    wlan0     Link encap:Ethernet  HWaddr 00:0f:60:xx:xx:xx
              inet addr:192.168.189.1  Bcast:192.168.189.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:20305 errors:0 dropped:9758 overruns:0 frame:0
              TX packets:20859 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:3953760 (3.7 MiB)  TX bytes:5779163 (5.5 MiB)
    

    If so can you then see the network SSID from your IOS device?

    10. Januar 2016 at 0:41 #17661

    Hi noop
    Yes it looks nearly exactly the same as yours, all but the addresses
    And sadly still can’t see it on my iPad nor iPhone

    It’s so weird and more frustrating than weird, because even the m2p says it’s installed ok too

    I was debating about putting in another dongle, but I’ve done that…

    And considering how many times I have burnt new images and how I’ve installed the plugin’s I Honestly just don’t get it and I’m just very very grateful you’ve helped as much as you have. Please don’t feel pressured to carry on noop

    Do you think it’s worth buying another dongle, I had a look for one like yours but now they come with external aerials
    A

    10. Januar 2016 at 0:50 #17662

    And I have been hardwired into my router.
    And like the other night, I have just tried it with ipeng it works where I can see the M2P as a player

    10. Januar 2016 at 1:02 #17663

    your IP addresses should be the same…what do you see?

    Assuming they were the same, I’d be interested in knowing the contents of your file:
    /etc/hostapd/hostapd.conf, it’s not too long.

    cat /etc/hostapd/hostapd.conf

    • This reply was modified 5 years, 11 months ago by  noop.
    10. Januar 2016 at 1:36 #17665

    Ok noop

    Interface used by access point
    Interface=wlan0

    Firmware driver
    Driver=n180211

    Access point SSID
    SSID=max2play

    Operation mode (a = IEEE 802.11a, b = IEEE 802.11g
    Hw_mode=g
    Accsesspoint channel
    Channel=6
    Maccddr_acl=0
    Auth_algs=1
    Ignore broadcast_ssid=0

    Key management algorithm
    Wpa_key_mgmt=WPA-PSK
    wpa_passphrase=max2play
    Wpa=2

    Set ciphers
    Wpa-pairwise=TKIP
    rsn_pairwise=CCMP

    NOOP, do you mean the max2play, on my lan ( as its connected that way) scanner it’s Showing 192.168.1.11
    But I can’t see it on ipeng.

    However, since I mentioned this, I got up to answer the phone and caught my chair on the power lead to the m2p so I just plugged it back in again.

    I really hope I’ve not screwed things up, sorry noop

    10. Januar 2016 at 1:46 #17666

    in your response to the what the command ifconfig wlan0 you said

    Yes it looks nearly exactly the same as yours, all but the addresses

    was the inet addr 192.168.189.1 ?

    10. Januar 2016 at 1:54 #17667

    Hi noop,
    Yes exactly that

    10. Januar 2016 at 2:06 #17668

    So everything looks good with info you sent. Do you have another wireless device to check for the accesspoint with? say a laptop?
    It should be working.

    ALSO:
    command:
    iwconfig

    look for „Mode:Master“ in wlan0

    mon.wlan0  IEEE 802.11bgn  Mode:Monitor  Tx-Power=20 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    
    wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    • This reply was modified 5 years, 11 months ago by  noop.
    10. Januar 2016 at 3:18 #17670

    Hi NOOP

    It should be working, wow as for checking it, I do have a laptop but it’s at work but what I will do is go and pick it up in the morning

    Also

    In wlan0 2nd line I have
    Mode:Managed Frequency 2.437. ACCESPOINT 00:50:7F:A9:E9:AB

    Not mode:master ?

    Also I have retry off, while yours is short limit 7, is this relevant ?

    I have just rebooted it and just remembered I have a touch, so just went to see if the touch could see it, sorry again it can’t

    • This reply was modified 5 years, 11 months ago by  alex.
    10. Januar 2016 at 3:24 #17672

    Sorry noop
    It’s lost some of my words

    I will pop to work in the morning and get the laptop and let you know the results. But I hope you will not be offended if I say goodnight, or good morning more like

    10. Januar 2016 at 3:26 #17673

    It’s happened again, I wrote that it’s 1:20 here in the UK and I have been up since 5:45 and my eyes

    10. Januar 2016 at 3:27 #17674

    Won’t stay open

    10. Januar 2016 at 3:29 #17675

    So I need a few hours sleep. But I have to say, thanks so much for your help, it’s actually

    10. Januar 2016 at 3:30 #17676

    Been really interesting , God you must know your stuff noop
    I’m impressed, really.

    Ok watch this space and sorry I have to go as my eyes just won’t stay open, hahah
    Goodnight

    10. Januar 2016 at 4:18 #17677

    No problemo get some sleep! I’m 5 hours behind you.

    OK there’s a problem…mode „Managed“ is client not „Master“.

    i’m guessing that hostapd is not able to set mode master for some reason.
    stop hostapd and run manually…

    sudo /etc/init.d/hostapd stop
    sudo /usr/sbin/hostapd /etc/hostapd/hostapd.conf -d | less

    this will display one page of the output at a time, you can use the <return> key to advance one
    more line at a time, <space> key one page at time. These lines in my output show the interface
    being set to mode „AP“ (access point)

    Configuration file: /etc/hostapd/hostapd.conf
    nl80211: interface wlan0 in phy phy0
    rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
    nl80211: Using driver-based off-channel TX
    nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
    nl80211: Register frame match - hexdump(len=2): 04 0a
    nl80211: Failed to register Action frame processing - ignore for now
    nl80211: Add own interface ifindex 3
    nl80211: Set mode ifindex 3 iftype 3 (AP)        <----- HERE
    nl80211: Create interface iftype 6 (MONITOR)
    .
    .
    .
    Using interface wlan0 with hwaddr 00:0f:60:05:50:82 and ssid 'max2play'
    Deriving WPA PSK based on passphrase

    What does your output look like? Look at the output for problems/errors.
    BTW: to exit the program type: q followed by ctrl-c

    • This reply was modified 5 years, 11 months ago by  noop.
    • This reply was modified 5 years, 11 months ago by  noop.
    10. Januar 2016 at 11:46 #17680

    Morning noop, well I needed that.

    I fetched the laptop, and tried the touch again, just to make sure, still no joy on that

    So I’ve run the command you sent and to be honest the ONLY thing which is the same or close to yours is your last two lines of yours, they are identical

    I have a block of
    RATE [0] rate=10
    All the way to rate [11]

    I have taken a photo just in case I need to ref

    10. Januar 2016 at 11:54 #17681

    Sorry, I sent this as I didn’t want to loose txt again

    There is also a block of

    rt1871x_set_key_ops

    But nothing close to your n180211n Noop

    This is bitter sweet I hope ( bet you do to)
    1. That it’s not identical to yours and two because it’s not you may have nailed it !
    I guess ( hahahah and it’s only a guess) you’re checking the wireless here, if so, I’m obviously learning something from you

    Ok, I have just come out and switched off as there’s not anything more I can do.
    But I just can’t thank you enough for your help noop

    A

    10. Januar 2016 at 16:32 #17682

    Hi Alex:

    for your dongle rt1871x may be correct and expected to be different.
    Look through the output for errors and warnings.

    I would expect that the command

    lsusb

    confirms that your dongle has a realtech „rt“ chip

    You should try (if you are not already using it) the edimax dongle as it is supported by MAX2PLAY according the the change logs.

    On a separate note:
    What release of max2play are you starting with? Have your tried downloading the latest?

    • This reply was modified 5 years, 11 months ago by  noop.
    10. Januar 2016 at 18:29 #17684

    Hi noop,
    A couple of things going on

    I ran the two lines you asked me to and it worked. When I came back to it the second line is not running the results (script)
    It’s just saying
    ioctl[RTL_IOCTL_HOSTAPD]: invalid argument
    Even if I try to exit the programme the way you told me it won’t let me it’s just hanging, so I just rebooted ( powered down) several times

    The other thing is, sorry for sounding dumb, but what do you mean when you mean look at the the output for problems . The worry is due to the limited knowledge I have on this on the best I can do it tell you any obvious errors and those that don’t match your script or when it tells me.

    Hope this makes sense noop, in the meantime, I’m going to input those two lines again, and I did try and use the q ctrl code but as its hanging it’s not letting me
    A

    10. Januar 2016 at 18:35 #17685

    Yep just hung again, maybe I have put something in there that’s wrong and it’s buggered it up

    I can burn a new image and start again if you like noop, won’t take long ?

    10. Januar 2016 at 18:35 #17686

    NOW THAT KNE THING I AM GETTING AN EXPERT IN DOING HAHAHAH

    10. Januar 2016 at 19:51 #17687

    Alex:

    Are you starting with the latest max2play image download? 2.22 (I think?).
    If not, do that.

    10. Januar 2016 at 20:17 #17688

    Hi noop,

    It’s yes, its 2.26

    10. Januar 2016 at 21:26 #17689

    there’s a command „iw“ which might be helpful.

    apt-get install iw    <--install the iw software if not already installed
    iw list           <-- returns lots of info on the dongle capabilities

    If it returns an error that’s a clue

    iw wlan0 info

    Interface wlan0
            ifindex 3
            type AP
            wiphy 0

    type AP is what you want.

    10. Januar 2016 at 21:39 #17690

    Hi Noop

    Oh dear

    Just entered the first line and it returned

    E:Could not open lock file /var/lib/dpkg/lock – open (13: Permission denied)
    E: unable to lock the administration directory ( var/lib/dpkg/), are you root

    I continued to input the second line and got this

    -bash: iw command not found

    A

    10. Januar 2016 at 21:53 #17691

    my mistake

    you need to execute as root

    sudo apt-get install iw

    10. Januar 2016 at 22:03 #17692

    Hi noop

    That’s better, thanks

    Ok it came back to say the following packages will be installed
    Crda iw wireless regdb and warned me it would take 276kb of disk space, did I want to proceed , I said yes

    So it ran an onscreen script, I then out the other command in and it came back with
    nl80211 not found

    Was this the error you were hoping for

    10. Januar 2016 at 22:05 #17693

    The three packages I think has been installed are
    Wireless-regdb

    Crda

    And

    iw

    10. Januar 2016 at 22:17 #17694

    dmesg | grep rtl

    what does that return? I’m reading this web page BTW:
    http://jacobsalmela.com/raspberry-pi-and-routing-turning-a-pi-into-a-router/

    10. Januar 2016 at 22:27 #17695

    The demseg
    It gives 3 group listings

    First group is options
    C = clear
    c = read clear

    Etc etc

    The second group

    Supported log facilities
    Kern- kernel messages
    Etc

    The third is

    Supported log levels

    Emerg – system is unusable

    Etc

    There’s about 10 lines in each group

Viewing 30 posts - 91 through 120 (of 306 total)

You must be logged in to reply to this topic.

Register here