Accesspoint issues

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint issues

This topic contains 305 replies, has 11 voices, and was last updated by  Heiner Moderator 4 years, 2 months ago.

Viewing 30 posts - 241 through 270 (of 306 total)
  • 16. Januar 2016 at 17:29 #17937

    Alex:

    Does the maz2play accesspoint page debug info say something like this?
    Just making sure that with this new dongle these remain running.

    #### DNSMASQ Running ####
    5 S   110  2444     1  0  80   0 -  1612 poll_s ?        00:00:00 dnsmasq
     
    
    #### HOSTAPD Running ####
    5 S     0  2519     1  0  80   0 -  1294 poll_s ?        00:00:00 hostapd

    out of interest please run: lsusb to see what info is returned for the new dongle.

    16. Januar 2016 at 17:41 #17938

    Hi Noop

    yes I think it’s ok

    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    2

    #### DNSMASQ Running ####
    5 S 109 2491 1 0 80 0 – 1612 poll_s ? 00:00:00 dnsmasq

    #### HOSTAPD Running ####
    5 S 0 2544 1 0 80 0 – 1294 poll_s ? 00:00:00 hostapd

    16. Januar 2016 at 17:49 #17939

    OK please log:

    sudo /etc/init.d/hostapd restart

    also what does lsusb return?

    16. Januar 2016 at 17:54 #17940

    Hi Noop

    This is the first one
    sudo /etc/init.d/hostapd restart
    [ ok ] Stopping advanced IEEE 802.11 management: hostapd.
    [….] Starting advanced IEEE 802.11 management: hostapdrandom: Trying to read entropy from /dev/random
    Configuration file: /etc/hostapd/hostapd.conf
    nl80211: interface wlan0 in phy phy0
    rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
    nl80211: Using driver-based off-channel TX
    nl80211: Add own interface ifindex 3
    nl80211: Set mode ifindex 3 iftype 3 (AP)
    nl80211: Create interface iftype 6 (MONITOR)
    nl80211: New interface mon.wlan0 created: ifindex=5
    nl80211: Add own interface ifindex 5
    BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
    nl80211: Regulatory information – country=00
    nl80211: 2402-2472 @ 40 MHz
    nl80211: 2457-2482 @ 40 MHz
    nl80211: 2474-2494 @ 20 MHz
    nl80211: 5170-5250 @ 160 MHz
    nl80211: 5250-5330 @ 160 MHz
    nl80211: 5490-5730 @ 160 MHz
    nl80211: Added 802.11b mode based on 802.11g information
    Completing interface initialization
    Mode: IEEE 802.11g Channel: 6 Frequency: 2437 MHz
    nl80211: Set freq 2437 (ht_enabled=0 sec_channel_offset=0)
    Failed to update rate sets in kernel module
    RATE[0] rate=10 flags=0x1
    RATE[1] rate=20 flags=0x1
    RATE[2] rate=55 flags=0x1
    RATE[3] rate=110 flags=0x1
    RATE[4] rate=60 flags=0x0
    RATE[5] rate=90 flags=0x0
    RATE[6] rate=120 flags=0x0
    RATE[7] rate=180 flags=0x0
    RATE[8] rate=240 flags=0x0
    RATE[9] rate=360 flags=0x0
    RATE[10] rate=480 flags=0x0
    RATE[11] rate=540 flags=0x0
    Flushing old station entries
    Deauthenticate all stations
    wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
    Using interface wlan0 with hwaddr 00:13:ef:b7:06:47 and ssid ‚max2play‘
    Deriving WPA PSK based on passphrase
    SSID – hexdump_ascii(len=8):
    6d 61 78 32 70 6c 61 79 max2play
    PSK (ASCII passphrase) – hexdump_ascii(len=9): [REMOVED]
    PSK (from passphrase) – hexdump(len=32): [REMOVED]
    random: Got 20/20 bytes from /dev/random
    GMK – hexdump(len=32): [REMOVED]
    Key Counter – hexdump(len=32): [REMOVED]
    WPA: Delay group state machine start until Beacon frames have been configured
    VLAN: vlan_set_name_type(name_type=2)
    nl80211: Set beacon (beacon_set=0)
    WPA: Start group state machine to set initial keys
    WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
    GTK – hexdump(len=16): [REMOVED]
    WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
    wpa_driver_nl80211_set_key: ifindex=3 alg=3 addr=0x88fd4 key_idx=1 set_tx=1 seq_len=0 key_len=16
    broadcast key
    wpa_driver_nl80211_set_operstate: operstate 0->1 (UP)
    netlink: Operstate: linkmode=-1, operstate=6
    wlan0: Setup of interface done.
    . ok
    Additional Configure Parameters to WiFi
    RTNETLINK answers: File exists
    [email protected] ~ $

    And this is the second one

    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
    Bus 001 Device 005: ID 0bc2:ab21 Seagate RSS LLC
    Bus 001 Device 006: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

    16. Januar 2016 at 18:03 #17941

    ah same as mine…

    lets check wpa_supplicant
    sudo cat /opt/max2play/wpa_supplicant.conf

    16. Januar 2016 at 18:08 #17943

    that was probably a waste time….as you are connecting to your router wirelessly without a problem.

    so same dongle … lets compare hostapd programs please run:

    sudo md5sum /usr/sbin/hostapd

    16. Januar 2016 at 18:09 #17944

    Hi noop
    the ssid was correct, psk and wpa, but I have **** it out just because I’m not sure who could be reading this

    sudo cat /opt/max2play/wpa_supplicant.conf
    ctrl_interface=/var/run/wpa_supplicant
    update_config=1

    network={
    ssid=“********“
    psk=“*********“
    key_mgmt=******,

    16. Januar 2016 at 18:26 #17945

    did you miss my previous post?

    16. Januar 2016 at 18:33 #17946

    Sorry noop, i have to keep refreshing my screen, missed the lasy one, opps

    This is what I have got after running

    sudo md5sum /usr/sbin/hostapd

    6105c07ee031c5fc2e519d5e560cff8a /usr/sbin/hostapd

    16. Januar 2016 at 18:42 #17947

    good same as mine….going to lunch be back later

    16. Januar 2016 at 18:44 #17948

    fine, thanks noop, and its dinner for me
    catch you later

    16. Januar 2016 at 23:52 #17949

    Hi Alex:

    I think I found the answer, please try the following:

       cd /tmp
       wget https://www.dropbox.com/s/we0d928vfddovia/interfaces.192.168.1.0
       sudo cp /etc/network/interfaces /etc/network/interfaces.orig
       sudo cp interfaces.192.168.1.0 /etc/network/interfaces
       sudo chown root:root /etc/network/interfaces
       sudo chmod 666  /etc/network/interfaces

    Then reboot. If it works I’ll follow with an explanation.

    17. Januar 2016 at 0:28 #17950

    Noop, god, , oh my god god.

    If you could only see me now. It’s done it, you have cracked it noop, what a , well fantastic bloke !

    TOP MAN !!!!

    I’m shocked, overjoyed and just in awe of what you’ve done noop
    Thanks so very very very much,

    It’s there on my ipeng and although my drive is connected to it, I guess it’s got to rescan the drive before I can really test it, but my, I’m BLOWN away with this.

    So what was the problem noop

    Was it a series of issues, was it just one thing which cascaded into lots of other „issues“. I’m dying to know

    But at the moment, Im like a kid a christmas, I rekon the whole street heard me just now..
    hahahah
    Thanks Noop, what a star

    17. Januar 2016 at 0:32 #17951

    opps
    one slight problem, well maybe

    in settings/wifi

    It picked up m2p, then while I was writing the last message it dropped out and it picked up my router ?

    But it’s certainly better than before, its fantastic

    17. Januar 2016 at 0:36 #17952

    What its did noop was to come up with the password box, i entered the password and it connected.

    Then it comes up with the m2p gui, and says log in, but there’s nowhere to log in, so maybe logging in is a two tier thing…So because I don’t log in again, maybe i’m getting timed out.

    17. Januar 2016 at 0:48 #17953

    you will never guess what
    Ive been trying several times using my phone, and this time I had an option to connect „without“ internet connection, I said yes

    So I mangaged to see my music, I got a track playing and then noticed the m2p icon on ipeng had gone.

    So I checked the setting in wifi, it had dropped connection and hooed up to my wifi. So I guess when this track has finished, I’ll not have a connection, damm

    17. Januar 2016 at 1:01 #17954

    I think I have sorted it, said I gingerly !

    I set m2p in wifi setting to auto join and auto log in…
    So far its holding !!!

    🙂

    17. Januar 2016 at 1:05 #17955

    a cup of tea later, still holding
    I’m dying to turn it off to see if it holds but I’m scared stiff !!!!

    17. Januar 2016 at 1:06 #17956

    damm, after about 10mins its gone back to my router and dropped m2p Agghhh

    17. Januar 2016 at 1:08 #17957

    funny, that when it drops out it, I click back on to m2p in my wifi settings, it then goes to the gui m2p page and says log in albeit, its connected.

    Maybe there is something I should do but not sure what because I have connected AND played tracks ?
    it just keeps dropping out for some strange reason

    17. Januar 2016 at 1:17 #17958

    The issue or at least the latest issue turned out to be that the DHCP Daemon (DHCPD) was not starting.The DHCPD provides IP addresses to clients when they connect to the access point.
    The latest init.d script to start DHCPD, scans the /etc/network/interfaces file and exits if it finds an interface set to DHCP.
    The default file from M2P has such an entry so DHCPD never starts, causing the connect problem. In the file I had you download with „wget“
    I replaced the dhcp entry with a static entry for eth0, and removed the dhcp setting for wlan0 as well.
    BTW you will find M2P through the ethernet/wired interface at: 192.168.1.250 with the current setting.

    17. Januar 2016 at 1:32 #17959

    Noop

    What can I say, thanks is just not enough and if you round the corner at least I could buy you a drink.
    You’ve worked hours on this and had to put up with me at the same time and stupid questions.

    I can’t beleive I was as lucky as this to have you help me, I’m just so chuffed.

    So, why do you think it’s doing this noop?
    Why did’nt yours, software bug ?
    And I do have my other Pi with the same issues, so if I run your last script, do you think that will work too.

    And any ideas why its droping out. Maybe if I shut my main router down my iphone won’t go scanning for it. I’ll try that later, well tomorrow as its 23:30 .

    But talk about just on cloud nine…Well happy, Thanks noop, great top bloke, and I can’t mean that enough
    A

    17. Januar 2016 at 1:34 #17960

    am i ok to turn this off/on, noop, talk about nervous

    17. Januar 2016 at 1:35 #17961

    yep my iphone certianly likes my router more than m2p !

    17. Januar 2016 at 1:55 #17962

    just killed the server and i think it’s holding as there is nothing for it to hook onto.
    So how I’m going to use it, thats just perfect, it’s snowing at the moment, and heavy. But this is going in the car in the morning, no matter what !

    hahahahah, I can’t tell you how chuffed I am noop, just fantastic

    Sorry I’m on one !!!

    I’ll try running the last script with my other pi and I bet that sorts that out too.

    So going back to my other set of questions.

    Is this something the guys at M2P ought to be able to fix for future upgrades ?

    Is it a bug in m2p ?

    17. Januar 2016 at 2:18 #17963

    It is a flaw in M2P, and something they should address in the next update.

    I did not see the problem because my base release is older started with 2.16?
    It didn’t have the dhcpd check that the newer versions have.

    I found the problem by loading the new release and trying to get my dongle to work.

    You’re very very welcome, my reward is your reaction when it worked ROFL

    It’s been a long haul but it ended in success.

    17. Januar 2016 at 12:39 #17965

    Hi Noop

    Well its now sundy and its working, this is just great I’m really pleased, and appreciate your time, over two weeks you have been helping with this.

    What a decent chap, thanks noop very very much.

    All I have to do now is dig my way to the car and install it, hahahah, after what we have been through, this really is the easy bit.

    Alex

    19. Januar 2016 at 20:07 #18005

    Alex/Noop, just wanted to quickly comment on my progress.

    I have been experiencing exactly the same issues as Alex, nothing was working, Wifi or Accesspoint.

    Turns out it was the Wifi dongle, recommended to me by the same place I ordered my Pi equipment from.

    In truth, it is probably the default drivers Max2play includes in their boot-up that do not work nice with my Wifi Dongle.

    Anyways, I ordered the same Dongle as you have Noop (Cankit), and it arrived late last week.

    Plopped it in and BOOM everything is working from the get go, no problems at all.

    However, just like you experienced Alex, Access Point would NOT let my in, no matter WHAT password I set it to or entered. Very frustrating!

    Noop, DHCP has not been setup correctly in the build, is that correct and should be resolved in a new build soon?

    Equally I can execute the code you mentioned above to confirm?

    Anyways, just want to say thanx again for figuring this all out. It was nice to see someone have the same frustration as myself.

    All for now, Fred in Canada

    20. Januar 2016 at 1:38 #18007

    HI Fred:

    I do not know when m2p will be updated to fix this…but yes following the instructions above to change the „interfaces“ file and you should be up.

    PS I’m Canadian too 🙂

    20. Januar 2016 at 11:20 #18009

    Hi both,

    Glad to hear you got your’s up and running Fred, its a good feeling don’t you think, but all down to noop.

    I just hope when the guys at M2P update things, they don’t undo all the hard work and the long hours noop has put into this.

    Next stage for me with this is project is fitting a decent D/A in it, I have a usb D/A at the moment which cost about $8 and works, but it’s $8 quality too

    I was considering a hifiberry or a Wolfson. Would be good to know if you have one fitted and if so, which one. And what you think of it.

    Alex

Viewing 30 posts - 241 through 270 (of 306 total)

You must be logged in to reply to this topic.

Register here