Accesspoint issues

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint issues

This topic contains 305 replies, has 11 voices, and was last updated by  Heiner Moderator 4 years, 2 months ago.

Viewing 30 posts - 271 through 300 (of 306 total)
  • 20. Januar 2016 at 17:49 #18020

    Alex:

    I used one of those cheap USB sound dongles too. I found it much better than the raw audio output on the PI.
    Not super but good enough for my purposes so far. I have zero experience with the hifiberry or wolfson cards.
    I have also been using KODI and playing music through the HDMI to my amplifier, the sound is great.

    20. Januar 2016 at 18:16 #18022

    Hi Noop

    Thats good to know because my amp does have a HDMI in but, I’m away this weekend but I’ll give that option a go in the next few weeks for my second one that I’m making

    This one is in the car and I just think I can get better audio by replacing the USB DAC I have at the moment.

    BW
    Alex

    20. Januar 2016 at 19:13 #18028

    Here’s my setup

    I have 2 Pi’s, one uses the HifiBerry DAC which is PRETTY good, considering the price.

    The other has the Hifiberry Digi+ which connects via coax, to my Schiit Bifrost.

    This is in my „Main Rig“ and it sound FANTASTIC!

    I also have the Schiit Fulla at hand, which I purchased for my Son’s PS4, but have not connected it to the Raspberry Pi, but intend to just for giggles.

    http://schiit.com/products/fulla

    I also have the Schiit Modi, which is also very good.

    Alex, I think the Fulla may be something to consider, as it is very portable and has very good sound for the money.

    And ya Noop, I figure you were a Canuck when I saw you had the Cankit Dongle. 🙂

    21. Januar 2016 at 9:43 #18039

    Hi Fred
    Sounds like a decent set up you have there, and just read the reviews about the Schitt Fulla (what a name!!) and did’nt realise it was that good, especially for the costs involved.

    Now you’ve made things really difficult…

    Looks like maybe a bit more reading needs doing, but have to say, the now working M2P, just gets better and better and better.

    Good luck with your Pi and thanks again all

    Alex

    15. Februar 2016 at 5:13 #18490

    Hi Alex, Noop and Fredly,

    I am having the same Access Point problem. I can see max2play as a network on my devices, but cannot login using ‚mypasscode‘. Noop, I will try your script, but as I am a complete novice with the Pi and programming it may take me a little time to work it all out. Hope the Max2play people can fix this in a future release for amateurs like me. I am on 2.27.

    Alex. Glad you got it working. Fredly, did you have any success?

    Alex. I have the new Cirrus Wolfson card, and have to say I am very impressed with the quality of all outputs. Well worth the money.

    Regards,
    Simon

    15. Februar 2016 at 9:48 #18491

    Hi Simon

    I put this together for a friend just after I got mine working (and to remind me how we did it), I hope you can follow it, but it’s Noop who deserves full credit for this, I was just following his instructions.

    Here goes and good luck hope it works for you

    How I installed Max2play.

    Installation Preparation (read this first before installation, and the **** below to get a feel of whats needed before you start, it just helps to understand the procedure)

    Please note, this was to resolve my accesspoint issues which I had MAJOR problems with.

    Problems were, not all dongles work as an access point, and when I did get one that should have worked it was faulty, so you just have to be aware and lastly Noop also found there was a bug in M2P accesspoint plugin module too.

    But Not everyone had problems with that particular dongle, very odd, I did !
    YOU might have no issues at all, hopefully not

    Anyhow a great little programme to use is Putty. Install this before you start, it’s very useful as it allows you to run the commands later on in this set up on your Pi.
    With putty, you can also cut and past between windows, This means you don’t have to type any of the commands into the command prompt, just cut and paste using Ctrl V each time for cutting and pasting

    You can find Putty here http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    When you are ready to start your installation Load and run Putty.exe.

    Once loaded ensure your Pi (M2P) is hard-wired (at this point) into your Lan, switched on and running.

    When Putty is loaded, you will be presented with a DOS type screen, this is what I call the command prompt, at this point, put in your IP address of your SWITCHED ON Pi 192.168.1.XX
    Then when asked, enter your user and passwords (Pi then Raspberry) to get into your Pi. Once in, leave this screen open as this is where all commands will be entered and run (just shrink the screen for now).

    It may also be a good idea at this point to register your M2P account before you start your installation, you need to register for a premier account, this gives you access to your accesspoint plug in and other plug-in modules

    Its also worth noting if all works, the least you need to do are actions 1 – 8 to get is working in its basic form. Actions 9 -11 just offer a way to check your connection/set up so far.

    If all is good at this point and all is working, jump to No 13, 14, 15. If not, then run No 12 and then 13, 14, 15

    Remember you need to know your ip address of your Pi so you can get to M2P via your browser once switched on

    Please note:

    After each module is installed, you will be asked to reboot, make sure you do otherwise the plugin’s may not be installed properly, EVEN if you are not prompted to do this DO IT !!

    The Plugin’s will/should be sat across the top of the GUI page on switch on except for the Raspberry and Access point plug-in’s

    Installation (at this point only your lan and power supply should be connected)

    1. Burn a new image (min 8gb SD card), plug it into your Pi and switch on and navigate to your PI’s IP address using your browser, this will present you with the main Max2play Gui page, from here you will do all setting up
    2. Expand your new image in (Settings/Reboot plug-in )
    3. Update M2P in (Settings/Reboot plug-in)
    4. Increase the USB current via the Raspberry Settings plug in. To do this you can either install the pi plug in by going to the
    squeezebox server module where you can enter your registered email account, (after this the Raspberry Pi module should be in view at the top of the page you opened). Another way is go to the Pi command prompt and enter
    at the prompt, max_usb_current=1 (remember if you want to do this via the command prompt, just open Putty and enter it there (Cut & Paste), then shrink Putty again)
    I opened a M2P account previously and did this part via the Raspberry Plug.

    Once done continue with the installation

    5. Plug in the wifi dongle**.
    6. install wifi.
    7. install access-point*.(then reboot)
    8. remove power and then apply power.
    9. On your IOS device***, set-up -> wifi (after a few minutes) should show an available network with SSID “max2play” (or whatever you set it to)
    10. Try to connect to this network, if you get an error, “forget” the network, and re-try (you will prompted for password in this case).
    11. If connected, on the IOS device use safari or chrome and browse the PI at: http://192.168.189.1/ , you should see the max2play page, so it should be working at this point
    ONLY if there is a problem with the wifi, do the following

    12. login to the PI command by opening Putty and execute these commands: (remember you can cut and paste)

    cd /tmp
    wget https://www.dropbox.com/s/we0d928vfddovia/interfaces.192.168.1.0
    sudo cp /etc/network/interfaces /etc/network/interfaces.orig
    sudo cp interfaces.192.168.1.0 /etc/network/interfaces
    sudo chown root:root /etc/network/interfaces
    sudo chmod 666 /etc/network/interfaces

    After installing this, check the following as you did previously as below 12a – 12c

    12a. On your IOS device, set-up -> wifi should show an available network with SSID “max2play” (or whatever you set it to)
    12b. Try to connect to this network, if you get an error, “forget” the network, and re-try (you will prompted for password in this case).
    12c. If connected, on the IOS device use safari or chrome and browse the PI at: http://192.168.189.1/ , you should see the max2play page.

    If successful carry on installing the rest of the plug-in’s in this order

    13. Install Squeezebox Server (click on show available versions, click 7.9 nightly, click install)
    14. Install Audio Player (and plug in the USB DAC or other before installing the audio player)
    15. Plug in your ext hard drive and scan contents via Squeezebox Server plug-in (go to webadministration tab)

    It takes time for your m2p to scan your data, so leave it running for as long as it takes, mine took overnight.

    Now it should all be working correctly

    If you have photos/films/music on your M2P HD, and need to access them via kodi on your tablet, run the M2P kodi plug-in and follow these instructions

    http://www.instructables.com/id/Raspberry-Pi-Mobile-Media-Center-with-Smartphone-C/?ALLSTEPS
    (please note, I have not done this at the time of writing this, it was from memory before Christmas, but I’m sure it’s the right procedure) I just wanted to put this down while I remembered

    If you try and connect via LMS, you may need to enter the password for max2play

    The user is user and passwords is root (I think, lower case)

    NB
    **My wifi dongle was and RT5370. You need one that works in access mode, this does. £4.89 from Ebay
    http://www.ebay.co.uk/itm/RT5370-150Mbps-USB2-0-Wireless-Network-Card-WiFi-LAN-Adapter-Antenna-Warranty-/400801704684?hash=item5d51a4aaec:g:ttYAAOSwzOxUWyVY

    ***When have set up your your wifi in settings, and you connect, it may prompt you with the home screen of Max2Play. It may ask for a password but will not offer anywhere to put it. If so, Press cancel, top right. It should come up with another screen, use internet connection Yes or NO, pick NO. I don’t have a clue what would happen if you say yes. Maybe it will hook into the local wifi and you access it that way..

    * to install accesspoint, go to the bottom of the settings/reboot page (a demo can be seen here)

    http://demo.max2play.com:81/plugins/max2play_settings/controller/Basic.php

    click on the „list of Max2Play extensions“ and find accesspoint plugin and follow the instructions and install it

    16. Februar 2016 at 12:25 #18505

    Hi Alex,

    Thanks for your brilliant instructions. Unfortunately, I am stuck at step 12.

    I have been able to log into the Pi with Putty using your instructions, but I am unable to paste into the DOS type window at the ‚prompt‘. I thought that I may have to start the desktop from the ‚prompt'(startx), but that just causes a fatal error. Should I type in the 6 lines of code that you list for step 12? I am not really sure how to do this while creating separate lines of code (as you show), or doesn’t it matter that it is typed in as just one line?

    To be honest, I am not sure I need to do step 12, as ‚everything‘ up to step 11 seems to work!? I have two USB wifi dongles, although one appears to be more suitable than the other. At step 11 both allow me to connect wirelessly to the Max2play Gui either by going to http://max2ply on my Windows devices or through 192.168.1.XX on my Apple and Android devices.

    If I install Access Point at this stage one of the dongles brings up SSID ‚max2play‘ as a visible network on all devices, but does not allow me to login using ‚mypasscode‘ on any of the devices. The other dongle, an Edimax EW-7811Un, does not appear to allow the creation of an SSID for the Pi.

    From your wording in step 11, „ONLY if there is a problem with the wifi, do the following“ it appears that step 12 is to help if you have no wifi, and cannot see the ‚max2play‘ Gui, which I can.

    From the short experience I have had, it appears that this Access Point problem could be USB wifi dongle dependent? Do you think that maybe only a few dongles may be totally Access Point compatible with Max2play and the Pi? Ahhh… I just don’t understand why I cannot login to the successfully created SSID.

    Thanks again for your time, help and any suggestions.

    Regards,
    Simon

    16. Februar 2016 at 13:32 #18508

    Hi Simon

    Sorry I’m not going to be much of a help because I like you I’m very novice in this area.
    But as for pasting from this text to the putty „dos prompt“, I just did a copy/paste from this page to my dos prompt and it work. It really should work for you too.

    What you are getting Simon, are you unable to see the password (in accesspoint) because that is what I was getting, amongst other things..

    Then Noop, sent me the script above and it just worked, prior to that I also had issues with my dongles too. Even the edimax, the recomended one did’nt work „as an access point“..

    If you can’t copy paste the script, yes you have to enter line by line. Try that. If that fails I just wish I could help more but I feel I may do more harm than good.

    You will get there, keep trying. I know this is’nt what you want to hear, mine in now in my car and its pretty impressive, try and hang on in there, you’ll feel its worth it.

    That said I do have a problem with my audio, it „pops“ most but not every time when its switched on, I’ve not had time to check this out yet but [email protected] hoping its the DAC, which was less than a uk £1, but did’nt want to invest money until I knew it was working.

    I hope you get sorted
    Alex

    16. Februar 2016 at 14:18 #18510

    Hi Alex

    Thanks for your reply. Glad yours is still up and running/driving.

    Basically, I am thrilled with the Pi and Cirrus Wolfson setup. I just think that being able to run it without my home network would be the „icing on the cake“. I can’t say I’ve ever had any issue with pops or clicks, except when trying out Airplay. That was a stuttering disaster, and obviously needs more investigating by me. Even the built in Wolfson 2.4 Watt power-amp sounds fantastic. I have run it powering small DIY speakers using single 3″ ‚fullrange‘ drivers of about 86dB efficiency , and for the price the sound is amazing, if not a little under powered with speakers of that efficiency. All the other outputs DAC, SPDIF, Analogue and Headphone sound far better than my expectations. I use a 5v @ 4 Amp power pack.

    My Putty window looks like this, not exactly of course. Should it?

    https://learn.adafruit.com/assets/9030

    Should I just be able to paste the code into it at the ‚Green Prompt‘ ?

    When I try to login to the ‚max2play‘ network, it asks me for the password, but doesn’t ever connect. When I setup Access Point, and because I cannot login to SSID ‚max2play‘ I get locked out of the max2play Gui until I reconnect with LAN, then I can remove Access Point and wireless returns. Before I remove Access Point all the settings and Passcode ‚mypasscode‘ look correct.

    Strangely, there was an occasion earlier today when a laptop I have running Windows 10 found the max2play Gui while Access Point was running. It found it all by itself at http:/go.microsoft.com/plugins/max2play.settings/controller/wlan.php

    No idea how! Cannot seem to reproduce it again.

    Cheers,
    Simon – Australia

    16. Februar 2016 at 14:19 #18511

    Removed double post.

    • This reply was modified 5 years, 9 months ago by  gapmedia. Reason: Double post
    16. Februar 2016 at 15:34 #18519

    Hi Simon

    I have to shoot off to a meeting and not properly read your message , but when I first tried it, I get to my car and I switched on my iphone to connect to my M2P,it did’nt connect at first because my iphone was hooked into my home network, so just note that for one point

    The second point is on my iphone when I connect it comes up with the M2P main web page, top right it says cancel, if you cancel and god knows why, but if I don’t get the timing right, ie hit the cancel too soon or too late, nothing happens, if I get it right, another pop up appears with two opitions, do I want to connect without the internet or with. You pick without..

    AND, just to confuse you even more, if I leave mine (as long as I have already connected once) after its‘ booted and settled, it allows me in and I can just play my music…I wonder if yours is working, its just getting the hang of driving it, if this makes sense

    By the way I’m using the LMS (Logitech Media Server app) which seems to work ok, but for the one in the house I use ipeng, just so you know.
    There’s other media players you can get too if the user and password is a problem, well if I have got this right, that you could use where you don’t need any passwords, I think kodi is one such player

    As for the command (dos) prompt, I can’t honestly remember even looking at my instructions again here. But I’m sure was open the putty and copy and paste those commands, and it worked, well once I figured out what it was doing as above.

    But remember to Log in first using the conventional way via the M2P way, then do the dos commands

    As for your DAC, I have read a lot of very good reviews about them and, if I get once it will be one of those so thanks for the confidence boost and gald you’ve at least got it working in one form and I agree for what it is, it’s an amazing piece of kit..

    Ok its my meeting time better go

    Good luck Simon
    A

    • This reply was modified 5 years, 9 months ago by  alex.
    16. Februar 2016 at 15:50 #18522

    Hi Alex,

    Just saw your post above after I posted the bit below. I am off to bed now, hope you have a successful meeting. As you will see, I have had some success thanks to you, just have to work out the ’switching‘ between wifi and accesspoint operation.

    I worked out the Putty bit. Didn’t realise when I paste the script it will just run.

    Hooray!!! The script worked. I was able to log onto ‚max2play‘ network, and find the max2play Gui on my devices. Then, as I had not installed the Squeezebox Server, I decided to remove the Accesspoint so I could setup the Server from the Net. Unfortunately, this seemed to remove USB wifi dongle support and the wifi did not load on reboot. It is not responding to WPS at startup either. I will reconnect to the LAN in the morning to see if I can set up the wifi again, and if this is a reoccurring issue when switching between Accesspoint and wifi. I would like to be able to switch between wifi access and Accesspoint at times if possible, without having to connect to LAN. Have you tried ’switching‘ between wifi and Accesspoint? Did it work for you?

    Anyway, thank you and Noob for your help and instructions. At least I have seen Accesspoint work now. Just hope I can figure out the last little bit.

    Regards,
    Simon

    • This reply was modified 5 years, 9 months ago by  gapmedia.
    17. Februar 2016 at 9:59 #18531

    Hi Simon

    Well thats a good start and sorry I did’nt make it clear in my instructions about the script, glad you sorted it.
    The wifi and access point, good question.

    As I mentioned a above when I first tried it, my iphone was hooked into my home network so although I was trying it would’nt hook into it until I realised what was happening.

    So after going into my settings and told my iphone to foregt my home network (because I think the iphone will try to hook up to its last known wireless network) it did connect to the M2P which was in my car on the drive. Problem there it was in earshot of my home network so it just kept hooked into it.

    So because I did’nt want the trouble of doing all this, I now have a spare iphone I have and just leave that in the car (hidden) and I either wait for the Pi to boot up after its been powered up, then pick up my iphone and go from there. As I said if I leave my phone long enough it will boot up with LMS already active, I just have to press play (note no logging on issuse at all). The LMS boots up and „sits“ waiting for you just to hit play, and it does.

    However, I do have a problem with this. If I have an album playing, for some strange reason, when I leave my car and turn off the supply to the pi, when I return, yes it does, if I leave it long enough to boot up and „settle“ load the LMS, but if you press play its starts at track 1 every time, which is a bit frustrating, it does not continue from where you have stopped it, but I can deal with that for what I have in return if you get my drift.

    In addition, it’s not really a good thing to just kill the power on any PC, you can mess up files etc and find strange things happening. So I got myself a ups specially for the pi that shuts it down properly when power it switched off to it. But I have not needed it and I used this every day for nearly two months and its been rock steady, so I’m not going to put this in yet, well I will if I get issues, just tought you ought to know about this if you don’t already.

    Hope this helped, even just a bit..But I can see big things for me and M2P, a cracking but of kit, good luck
    A

    17. Februar 2016 at 13:16 #18534

    Hi Alex,

    I have a similar issue. I own a Logitech Touch, which was my inspiration for trying the Pi with Max2play. I have to say that I think the Pi and Cirrus/Wolfson surpasses the Touch. Stupidly, I often forget that I have LMS running on my PC, and it takes ‚control‘ of the Pi before I remember what’s going on, and I have to switch the Pi from one LMS to the other. No big problem really.

    I think Noob has solved the Accesspoint problem, but unfortunately Max2play doesn’t ‚know‘ about the new ‚files‘ it has to remove to go back to wifi. I hope Noob and Maximilian can get together and combine their codes to fix the Accesspoint issue.

    With Noobs 6 lines of code ‚installed‘ in Max2play all works brilliantly with Accesspoint and both of the USB wifi dongles I own , in my case anyway. Without Noobs code installed in Max2play, one dongle shows me a ‚max2play‘ network but does not allow me to login, and the other (Edimax) dongle creates no SSID for ‚max2play‘ at all.

    The only problem is that after Noobs code is installed in Max2play I cannot go back to wifi, even after connecting with LAN and removing Accesspoint. On bootup the dongles show activity , but then stop flashing and never create a wifi connection. The only way back to wifi access is a fresh install of Max2play.

    Regards,
    Smon

    22. Februar 2016 at 17:42 #18629

    Hi all,

    we have checked the accesspoint feature of Max2Play at least two times since Alex has run into problems with it and now again in reaction to gapmedia. If we set up accesspoint on a Raspberry Pi, the smartphone finds the Pi’s WiFi network and can successfully connect to it, both in „Standalone“-mode (without internet) and out „Standalone“ (with internet through the Pi’s LAN connection).
    We use dnsmasq to provide IP addresses to each device trying to hook into the Pi’s own WiFi network. On our test devices, this service starts automatically as expected without adding the code of noop.

    Due to the amount of information in this thread, it is very hard for us to reveal the reasons causing Accesspoint to fail on your devices. Cool thing that noops lines of code help you out for the moment.

    Maximilian from Max2Play

    22. Februar 2016 at 23:49 #18636

    Hi Maximilian,

    Can I ask which wifi dongle you are using? The two different brand dongles I have both support accesspoint, but they don’t appear to be fully compatible with the Max2play Accesspoint. Also, one dongle appears to be ’slightly more‘ compatible than the other. Maybe if I can try the same wifi dongle as you Accesspoint will work as expected.

    As you have noted, Noop’s code allows me to create an Accesspoint using either dongle, and then successfully login with smartphone or PC. The only problem for me is that once Noob’s code is installed I cannot go back to wifi mode, even after uninstalling Accesspoint. Obviously, and as expected Noob’s code is still installed. The only way for me to reconnect the Pi to other wifi networks from then on is via LAN, or a fresh Max2play install. I could I suppose swap between installs on different SD cards. Not my preferred option.

    Thanks for Max2play, and your ongoing support.

    Regards,
    Simon

    23. Februar 2016 at 11:13 #18643

    Hi Simon,

    we use the Logilink WiFi dongle we offer in our shop as well. Unfortunately, we cannot guarantee every WiFi dongle is fully compatible with our Accesspoint solution because of the high number of different models that we would have to buy and test.

    Maximilian from Max2Play

    23. Februar 2016 at 19:27 #18678

    Hi Maximilian:

    To summarize and help you see, what I think the problem is. Look at the file:
    /etc/init.d/dhcpcd
    and specifically the lines:

    if grep -q "^[[:space:]]*iface[[:space:]]*.*[[:space:]]*inet[[:space:]]*dhcp" \
        $INTERFACES; then
            log_failure_msg "Not running $NAME because $INTERFACES"
            log_failure_msg "defines some interfaces that will use a" \
            "DHCP client"
             exit 6
     fi

    If I read this correctly, it scans the /etc/network/interfaces file and aborts the script if it finds any interface that is set to request dhcp setup. I know that this is not max2play code, but it seems wrong to me, because I see no reason why a server with multiple interfaces cannot be both a DHCP server and a DHCP client. Perhaps the best fix is to comment out this test.
    The fix I had implemented was NOT this, I simply modified the interfaces file to satisfy the test by assigning static IP addresses. That fix is not undone by „access point removal“ causing the issue that gapmedia refers to. So an alternate fix of commenting out the check is better, I think.

    I read that your tests with an alternate dongle works. Does the /etc/init.d/dhcpcd file on the test system contain the code above? If it does then, I have no idea why it works, as DHCPD should fail to start, with the max2play standard interfaces file.

    19. März 2016 at 4:10 #19364

    I have now tried setting up Accesspoint under Max2play 2.28. It shows Accesspoint as setup/installed under the web interface. but it appears that a ‚max2play‘ network is not created using the 2 different wifi dongles I have. Under 2.27 a ‚max2play‘ network was created using Accesspoint and one of the wifi dongles, but I couldn’t login to it.

    I was wondering if anyone using the Raspberry Pi 3 with onboard wifi has had success with Accesspoint under 2.28?

    Simon

    22. November 2016 at 21:42 #24109

    Hi there,

    pleas help me with another access point issue. Not sure if this was already discussed here, my apologies if yes:

    I set up a stand alone access point with max2play on a raspberry Pi 3 with the onboard wifi hardware. I used the default SSID and passcode at first, i checked the stand alone box.
    When i try to connect the network with my iPod touch, the configuration side of max2play comes up. When i cancel this side, the connection is lost. There is no chance to keep the connection.

    What did i wrong?

    Thanks for helping me with this issue.

    Kind regards
    Chrischi

    • This reply was modified 5 years ago by  Chrischi.
    • This reply was modified 5 years ago by  Chrischi.
    • This reply was modified 5 years ago by  Chrischi.
    28. November 2016 at 13:12 #24286

    Hi Chrischi,

    I seem to have the same problem.

    After access point is setup I can see max2play as a network, but only for a very short time immediately after re-booting. Sometimes I can login, but the connection only lasts briefly, and after that max2play will no longer shows up as an available network. On one occasion, and I have tried many, many times, my mobile-phone was able to stay connected to the max2play access point, login via the web interface, and control LMS via Squeezebox control for Android, so access point will work with my hardware (RPi3 and Wolfson/Cirrus card) but only ever that once.

    The same problem occurs with the Apple devices we have at home. I have tried turning of our home network to see if it interferes with the max2play access point, but it makes no difference. Does anyone have any suggestions I could try?

    Simon

    28. November 2016 at 19:43 #24294

    Hi Simon,

    i just found out that the problem is my old IOS 6 device as this doesn’t allow WIFI-networks without internet access.

    I use an older Android device and this works fine now.

    I hope that helps you.

    Kind regards
    Christoph

    29. November 2016 at 12:41 #24300

    Hi Christoph,

    Thanks for the suggestions.

    I have no data to backup my thoughts, but I am beginning to wonder if there is a difference between Raspberry Pi’s throughout the world. My Pi’s (Australia) are all made in China, I assume most Pi’s sold in Europe are made in UK (Wales?). Could this be a reason why WIFI (Access Point) and Bluetooth seem to perform better for some than others? Different chips? I would think that a RPi3 with on board WIFI and Bluetooth running Max2play should perform the same anywhere in the world, but I can’t seem to get somethings working as they should? Just a (stupid) thought.

    Simon

    3. Dezember 2016 at 19:15 #24526

    Hello …

    I´ve got a problem while the installation of the accesspoint.
    I have a max2play premium account and M2P running on a RaspberryPi 2 (1024MB RAM).

    When I copy the following download link
    „http://shop.max2play.com/media/downloadable/currentversion/accesspoint.tar“
    into the form i get an error message like this
    „Get Plugin from http://shop.max2play.com/media/downloadable/currentversion/accesspoint.tar
    Wrong file type for Plugin! Must be one of these: .zip/.tar.gz/.tar/.rar“.

    Also the download of the tar-File and an upload from the local file doesn´t work.

    The software Version is: Version 2.38 | Raspberry PI 2
    If I try the same on the following device: Version 2.37 | ODROID-U2/U3
    … it just works fine! 🙂

    Can someone explain why this doesnt work? Bug in the new version 2.38???

    7. Dezember 2016 at 15:28 #24632

    Hi formicula,
    I just tested the installation of the access point plugin with a RPi3 M2P 2.38 successfully. However, our servers had some issues in the last days, so you might want to try it again. Also, just in case, please try leaving out the „quotation marks“ if you had them in your copy pasted text.

    27. Dezember 2016 at 3:50 #25253

    Hi guys,

    Fortunately, I did not have as much problem as Alex to set up an access point :). I’m using the onboard wifi from a Raspberry Pi 3, which is in a homemade waterproof case in my garden, and should able me to send music to Bose outdoor speakers.

    The Pi is cable-connected to my house, and I need to use the access point to connect my phone to the Pi (my home wifi is too far). I have set it up with the same SSID/password as the network inside my house, so that it connects automatically when I go outside.

    With the default installation, I could connect to internet, but I was not able to see my local network because I was set on a different subnet. So I modified /etc/network/interfaces accordingly to what I found in this thread, and now, I have internet access, and I can browse my local network (192.168.1.x) even if I’m on a different subnet (192.168.189.x).

    But I use Bubbleupnp on android to play my music inside my house, and I can’t get it to see Max2play nor my LMS Server (which is on a Synology NAS inside the house) when I am connected through the access point. I’ve tried with some other Squeeze players, like Squeezer and Squeeze Commander, and they don’t see the LMS server automatically. But if I connect manually to the server, they both works. I understand that the server may not advertise itself on other subnets.

    But in Bubbleupnp, I can’t set servers and players manually. In order to get it working, my first thought was to deactivate the DHCP server on the access point, so that it use the existing DHCP from my network (which is on a Cisco router). But I didn’t manage to deactivate it and still connect to the access point.

    Maybe one of you can help on that, or suggest some configuration on the access point or on my router so that the 2 subnets can successfully see each other.

    I’m not good enough at networking even to know where to start looking.

    Thanks in advance for your help.

    3. August 2017 at 20:40 #30403

    Sorry, had issue but can’t get it to repeat ;-/ edited post to remove possibly wrong information – feel free to just delete post
    Thanks
    Mutt

    • This reply was modified 4 years, 4 months ago by  MarkMutt. Reason: says in post
    7. August 2017 at 9:37 #30459

    No problem, if it shows up again, just make a new post 😉

    14. August 2017 at 18:32 #30621

    Heiner,
    Thanks for your understanding.
    As I said in the post I just removed above, I have just downloaded the latest image of M2P (2.44) and I think most issues people will have with this is that it’s a bit different than previous versions. Overall a LOT better integrated and smoother ride. Qudos to the team.
    My problem (now sorted) was getting my head round the create max2play AP if no network connection established within 2 mins. This is just a diagnostic tool allowing you access from phone/tablet in an emergency, to change something (like the SSID and passphrase of new location, see later 😉 ).
    From reading the 10 pages of issues people have had my issues may just seem like ’nitpicking‘ but I think if I can get a couple of little things resolved then a GREAT product will be pretty much PERFECT !
    I have a Pi that I take on holiday with me with two memory cards :-
    1. is for Video as I use OpenELEC and Kodi (not that I have anything against your implementation I just customise it a bit)
    2. is for Music and it loads a M2P LMS server and squeezelite player (why when you select USB sound card (Audioplayer – Squeezelite – Advanced Settings and selecting the USB DAC) does it require you to go to „Raspberry Settings“ and disable the onboard sound ??? (For English this SHOULD also read :- „Disable Built-In-Audio“) why is this not done for you ?
    Anyway, both use the WiFi dongle on my RPi2 and work seemlessly with a custom SSID and passphrase.

    Apart from the niggle above (USB SC) my suggestion for development (for other squeezelite players) would be :-
    1. (nowhere to put this under „WiFi/LAN“ so put it here under Accesspoint) I used to ‚hand roll‘ my WiFi connection (i.e. editing /etc/wpa_supplicant/wpa_supplicant.conf or /opt/max2play/wpa_supplicant.conf to add in a second WiFi connection). This would allow people to set up a system for two or even three locations, so that when you take a unit between them you could list out the SSID’s you have entries for (possibly withholding passphrases) and add/delete them. I’ve only just got my systems up and running again and not had time to experiment with this build, so not sure if this would just work with the current set up (again manually) but if it could be rolled into the M2P interface then BRILLIANT.
    2. The „Accesspoint Setup“ with the OpenELEC/Kodi setup I just enable/disable the Accesspoint, but for M2P I have to install and uninstall :-(((. What I’d prefer is to be able to write installation locally and install from there as an option (this would allow me to switch the Accesspoint on and off without an internet connection and then it would be like turning other elements of M2P on and off (e.g. Squeezelite, LMS, File Mounts etc.
    Anyway, hope you can consider these for future and/or point me at how to do it manually
    Cheers
    Mutt

    15. August 2017 at 12:10 #30635

    Hi all,

    After being double hit last month (Spotify triod plugin blocked and LMS blocked by the QNAP NAS s/w update) I could successfully switch to a Spotty plugin + MAX2PLAY 2.44 + Raspberry PI 3B solution. Considering my little expertise in Linux, the system works very well and was rather easy to setup. Recommended!

    I have one residual issue related to the Accesspoint access (on-board WiFi RSPI3, no external dongle). All the wireless devices I have tried can see the max2play accesspoint, and the DEBUG info is clean on the M2P AP initialization is clean.

    However I only managed to connect to the max2play AP using a Windows7 laptop. For all other devices (iPhone7, wireless HP printer, Samsung Android) that I have tried, the connection is rejected (with different generic error messages „connection could not be established“, „connection timed out“, „wrong password“ …).

    The issue looks similar to the one of gapmedia/Simon, but the setup and the s/w versions were very different. This thread is pretty long, and it is hard to understand for me what is actually applicable to my problem.

    Anyway, thanks for your work, as it saved a big multi-room Squeezebox investment.

    Gianluigi

Viewing 30 posts - 271 through 300 (of 306 total)

You must be logged in to reply to this topic.

Register here