Accesspoint issues

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint issues

This topic contains 305 replies, has 11 voices, and was last updated by  Heiner Moderator 3 years, 7 months ago.

Viewing 30 posts - 31 through 60 (of 306 total)
  • 3. Januar 2016 at 19:23 #17550

    Hi noop
    Sorry can you see how many times I have tried to reply

    3. Januar 2016 at 19:24 #17551

    So just to say I’ll wait till the site is working

    3. Januar 2016 at 19:25 #17552

    My iPhone and touch, can see the SSID

    3. Januar 2016 at 19:26 #17553

    When it’s wireless but can’t access the library

    3. Januar 2016 at 19:26 #17554

    When it’s wireless but can’t access the library“

    3. Januar 2016 at 19:27 #17555

    When it’s wired my touch works my iPhone with ipeng dont

    3. Januar 2016 at 19:29 #17556

    But I have ordered an edimax, maybe we should wait until it gets here

    3. Januar 2016 at 19:29 #17557

    Then I can try that, maybe it’s just a dongle conflict

    3. Januar 2016 at 19:30 #17558

    Unless there could be anything else I can do

    3. Januar 2016 at 19:31 #17559

    Sorry for this noop but the forum won’t accept all of my message

    3. Januar 2016 at 19:33 #17560

    Thanks for sticking with me, seems like 3 months on the curse of M2P hasn’t been vanished

    3. Januar 2016 at 19:34 #17561

    YET !!!!!!!!!!!!!!!! Alex

    3. Januar 2016 at 19:56 #17562

    With the iPod connected to the PI’s SSID, IPeng on the iPod, should see the squeezebox server if it is also running on the PI (check that).

    Assuming your music library is local to the PI, everything should be working at this point.

    3. Januar 2016 at 21:14 #17563

    Hi Noop

    Just checked, The server is running , and obviously I can only check this with my pc via the gui when wired

    When I disconnect it the router from it ( unwired) it just hangs.it being my iPhone

    Although I can see the url through ipeng, which was or is just how you said it was with the correct url details

    But It all seems to work fine when it’s wired, well for the touch, not for the iPhone

    Then not wired, nothing works. AlSo the LMS on the server I guess has to be working ( because it works wired) which leads me to feel maybe there’s part of the accesspoint that’s not quite right as it seems to be that side of things that’s failing

    I really also appreciate you’re working blind, and you’ve helped lots so far and have taken this up a notch so thanks.
    Maybe for now this is as far as we can go, but it’s all good and I’m hopeful with another dongle things will change for the better.

    Alex

    • This reply was modified 5 years, 3 months ago by  alex.
    • This reply was modified 5 years, 3 months ago by  alex.
    3. Januar 2016 at 22:06 #17566

    Hi Alex:

    I have to admit that I am confused, as to what you are trying to accomplish at this point and specifically what is not working.

    With the PI disconnected from the wired interface, you should see it’s wireless SSID and be able to connected to it with, either the iPod or iPhone or other wireless device. While connected you should be able to point your browser to http://192.168.189.1 and see the M2P interface. Is this not the case? If so, you should be able to check the status of any pluggins. With the hardwired interface disconnected you will not have internet access from the PI, so things like internet radio will not function. You should however have access to your music library assuming it is local to the PI, say on an external hard-disk, or even on the SDCARD.

    3. Januar 2016 at 23:14 #17567

    Hi noop

    Sorry for putting you through this

    What I wanted to do was use M2P in my car, connected to a 2tb ext hard drive, controlled via an access point with ipeng or the LMS app

    So the server deals with the music files, the wifi, does the connection between my iPhone and server, the player plays the music to the USB then to a d-a USB to the aux of my radio

    I have the following modules installed
    Server
    Wifi
    Access point
    Raspberry pi
    Audio player
    Xbmc
    Start
    And I hope all working
    Ok so that’s the aim and set up I have

    Unwired ipeng does see the wifi at the address where you said, 192.168.189.1.9000 and the ssid which is the default max2play
    But that’s it
    If I put this in my browsers, it times out and does not connect

    It only works when it’s hard wired for some unknown reason
    Hence why I think there is potentially still a wifi issue, but that’s a guess from someone is not very savvy in this area

    I just hope after all this is not an issue with the driver, ie me 🙂

    Alex

    • This reply was modified 5 years, 3 months ago by  alex.
    3. Januar 2016 at 23:45 #17569

    hrmm… I cannot see what might be causing the issue, of apparently not being able to load the web interface when connect wireless to the PI running as an access-point.

    I’m assuming that you are entering the URL ->

    http://192.168.189.1/

    Be sure that your iPod or iPhone is not dropping the max2play network and reconnecting to your home hub.

    4. Januar 2016 at 0:00 #17570

    Hi noop

    Yep good point about the local network, I did switch it off several times , but not so today and it didn’t make any difference sadly

    That said, if I go to settings/wifi on my iPhone that doesn’t see the connection either, but ipeng does
    Well it’s showing the ssid and url, is that odd too?

    Well this has been epic, sorry I keep saying that,but I can’t help thinking it will get sorted and when it does it will be worth it and all I can say is thanks to people like you putting in the effort

    What a pain
    Alex

    4. Januar 2016 at 0:33 #17571

    Hi noop, , do you think this could be another indication of the wifi dongle

    I have just taken your advice

    I have restored my touch to factory settings and turned off my main router

    I turned on my m2p, then my touch

    The touch found the ssid (max2play) and for the first time asked for a password
    I entered the correct password, but it couldn’t connect and said it was the wrong password OR network issues

    So I repeated the above, same thing happened

    So my gut feeling is, is this connecting, it must be because it’s ssid can be seen, so is it dropping out at some point?
    Is this possible, what do you think noop

    4. Januar 2016 at 1:02 #17572

    I suppose that it could be a defective dongle, things do seem weird.

    Running the command dmesg on the PI might yield something useful.

    4. Januar 2016 at 20:25 #17576

    Hi Noop

    Just to let you know that I ran the dmesg command and there was a lot of scrolling which I couldn’t stop nor raise the cursor up the list to look what it all read

    That said, even if I could look at the whole script, I wouldn’t have a clue what I was looking at..

    But fingers crossed, the other dongle should be here tomorrow or Wednesday

    But if there is anything to learn from this, would be interesting to know what I should be looking at, oh and how to control the scrolling 🙂

    Cheers Alex

    5. Januar 2016 at 17:42 #17585

    dmesg prints a time based log of system messages. The most recent messages are at the bottom of the file. You could for any errors/warning/info regarding hostapd or wireless authentication, etc, that might be useful. The stuff that flies by at the beginning are older messages.
    An alternate command to try is: tail /var/log/messages which should print similar info. „tail“ prints the end of the the file.
    tail -50 filename prints the last 50 lines etc… tail -f filename monitors the file and dynamcially prints the end of the file as it grows.
    Cntl-C to terminate. /var/log/messages is the file where system messages are logged.

    • This reply was modified 5 years, 3 months ago by  noop.
    5. Januar 2016 at 23:41 #17587

    Hi noop

    My edimax arrived today and I plugged it in and to my horror it did excatly the same as before I put it in, which is not worked

    So here we go again, I reformatted the SD card,**** and rebuilt M2P, still didn’t work….

    So 3.5 months later, and well over 300 hours, 4 raspberry Pi, several new images, 4 dongles, God knows how many times I have reformatted my SD, a huge amount of stress and sheer frustration, considering I can now get all the plug’ins installed in less than 30 mins, I’ve had it I think

    I have to thank you and the other guys on the forum who have tried to help, but I just don’t know what to do next, I think I have still got the will to carry on, I just don’t know how

    Well I’m going to do one more last thing, I am going to write out Exactly , from start to Finnish step by step
    What I’m doing , then I will send that to Max at M2P with a hope he can see something that Im doing wrong

    I just has to be the driver, thats me!!!

    I have to be missing a step, a stage, not activating something , I must be

    Ah well. Thanks for your time nook, if I ever get this sorted I’ll put this on the forum, even if it’s my driving as I wouldn’t want anyone to go through as much hassle as I have trying to get this m2p working as a stand alone accesspoint & server

    Thanks again Nook, but if anyone or you nook has any further suggestions I really really would appreciate if you could let me know as I’m sure I’ll find the will to give it a try

    6. Januar 2016 at 4:49 #17588

    Alex:

    As a long shot…have you tried your setup without the hard drive? Marginal power can cause strange problems.

    6. Januar 2016 at 9:45 #17589

    Hi nook

    I did try that, I even took it to the car and plugged it in there as an alternative PSU, but to still no avail.

    Weird that it will work as a slave to my squeezeplug server but not as a standalone access point. It will also work perfectly with the M2P connected directly to the router/lan.

    Even more weird, it’s exactly the same for all the 4 Pi’s, dongles etc etc I have used, I guess this is why you mentioned the PSU as that as far as you were aware was the only none variable in all of this.

    Maybe it’s what sequence I install the plugin’s. But I have done so many variations on this and its still not working. It just won’nt work as an standalone access point, the server, player, wifi, all fine (you’ve helped me prove that) just no access point.

    The other thing is, the forum is still young, so I guess if this had been active as and long as the Pi sites there would have been others that would have experianced the same as this, and this would have been sotred a long time ago. I just hope I do get this working, for the sake of people like you who have been kind enough to help, for me and others who might come after this with the same issues.

    But I am so desperate to find out why I can’t do it. I have an old (very old) vortexbox, that was set up, no problem, then upgraded to the squezeplug, again no problem, but my lord, M2P, wow I can’t say its been a pain, but as you once said, it’s a learning curve, and this has been a great leaning curve.

    Tell you what I do miss about the vortexbox, Vortexbox had a ripper (to flac) where you could feed in your personal Cd’s onto it, would be great to get a facilty like this onto M2P, unless there is an „easy“ or simple way to transfer your CD’s to flac, which is what I use.

    Anyhow, big thanks again for sticking with me noop, I hope I do crack this and when I do I will for sure post the answer here on the forum because after all thats exactly what its for.

    Thanks Noop

    Alex

    7. Januar 2016 at 4:54 #17596

    Alex:

    I found this recipe for setting up access point. I have not tried this myself. You could try if you wish.

    Use the RT8188CUS dongle. I would recommend installing the minimum addons (not accesspoint of course), then running this.

    Then test if the accesspoint is working.

    1 you see the ssid
    2 you can connect to the ssid
    3 you can get access to the m2p webpage on the PI

    wget "http://raspberry-at-home.com/files/ap_setup.sh"
    chmod +x ap_setup.sh
    sudo ./ap_setup.sh

    The reference web site is: http://raspberry-at-home.com/hotspot-wifi-access-point/`

    • This reply was modified 5 years, 3 months ago by  noop.
    7. Januar 2016 at 9:51 #17598

    Hi Noop

    I have to say thanks again, thats really very decent of you to spend even more of your time on this.

    I’m at work now, but as soon as I get home, before dinner, I’ll try this.

    But I’m convinced it has to be something I’m doing wrong as I can’t think why I’m having such an issue with it.

    Agggaaahhhh !!!

    But all the same, thanks Noop, will let you know what happens, wish it was my day off so I could give it a go now!!!

    Alex

    7. Januar 2016 at 21:35 #17607

    Hi noop,
    Ok I have just added the code you sent me after reformatting the M2p sd card

    It bricked the Pi the first time so I redid again ( formatted the card) and although it didn’t brick it, all I got was the same as before, I could see the M2P address through ipeng but that’s it.

    So I tried to swop dongles but that didn’t work either. But once again when I plug into the lan it works perfectly.

    As another last chance siuation, I’ve not got my oldold Pi out and im having a go at that. But boy is this fun !

    Thanks for your help again noop , in the meantime I will try and work out what’s happening , not sure I’ll get anywhere fast!!

    Alex

    • This reply was modified 5 years, 3 months ago by  alex.
    7. Januar 2016 at 21:39 #17608

    Alex, Fred here in Canada.

    PLEASE get this feature working, I have been banging my head against the wall trying to get it working, but like yourself, no luck.

    I’m assuming its my WiFi Dongle, which may NOT support Access Point BUT….am waiting for you to get it working BEFORE I order another dongle.

    Hope you had a great Holiday and Happy New Year!

    Fred

    7. Januar 2016 at 21:53 #17610

    Hey
    Hi Fred and a happy new year to you too, hope you had a great time

    I have to laugh otherwise I’d cry, it’s been one hell of a fantastic learning curve I can tell you

Viewing 30 posts - 31 through 60 (of 306 total)

You must be logged in to reply to this topic.

Register here