Accesspoint issues

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint issues

This topic contains 294 replies, has 8 voices, and was last updated by  Heiner premium 3 days, 10 hours ago.

Viewing 30 posts - 1 through 30 (of 295 total)
  • 28. December 2015 at 23:50 #17495

    Hi all

    After struggling on not knowing there’s a java issus when setting up M2P via the Pi and not having enough current to drive my ext USB HD, I’ve now hit another brick wall and quickly loosing the will to live.

    After many many hours of trying to get these problems sorted, with the help of the people on the forum I got my M2P to work as a server and player.

    But my aim was to get it to work as an accesspoint

    So it works as a wireless server/player and works very very well. Unfortunately it won’t even let me load up the accesspoint module now, it has let me load it but when I do/can when it just kills the wifi. I can’t do a thing with it until I plug a cable into it which goes to my router and it starts to work again. But doing that seems to mess up the wifi and I have to reinstall the wifi part again.

    And does anyone know if the LAN should be connected ALL the time until its all set up, or can I just use wireless, ie if I installed wireless first (not sure why, but presume), would it still be possible to set up the audioplayer/server/ and access
    Any suggestions would be very much appreciated

    Thanks Alex

    • This topic was modified 11 months, 2 weeks ago by  alex.
    • This topic was modified 11 months, 2 weeks ago by  alex.
    29. December 2015 at 1:17 #17498

    Alex:

    When you do get it to install, say with the hardwire lan connected (not necessary but might help debug), what do you see on the max2play access point setup page, under debug information?

    29. December 2015 at 2:20 #17499

    Hi Noop

    Thanks for the quick reply, I really appreciate it as it’s been a real headache, been on and off with this for weeks and weeks, so I appreciated your help

    Before I start I get this with the lan attached. The A/P is loading up as I speak speak, well type….Loading up I mean the page where you put your password/user name

    It can just crash and normally does at this point so fingers crossed as soon as its done, should’nt be too long, I’ll be back..If not I may have to format the SD and re do it so might be morning when I can do that as I have been on this last problem now since 16:00 today its now 00:19 none stop, not even had my dinner yet ­čÖé hahah

    #### DNSMASQ Installed ####

    #### HOSTAPD Installed ####
    Status: deinstall ok config-files

    #### WiFi Interface Installed ####
    0

    #### DNSMASQ Running ####

    #### HOSTAPD Running ####

    29. December 2015 at 2:25 #17500

    Hi Noop
    Its just loaded and come up with this.

    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    2

    #### DNSMASQ Running ####
    5 S 111 7402 1 0 80 0 – 1612 poll_s ? 00:00:00 dnsmasq

    #### HOSTAPD Running ####

    29. December 2015 at 2:26 #17501

    Hi Noop
    I also ticked the standalone box !

    A

    29. December 2015 at 2:28 #17502

    In addition I get this in the yellow info box that appears when tasks have been done, hope this makes sense
    A

    Update Configfile – existing Entry changed
    Reloading advanced IEEE 802.11 management: hostapdNo /usr/sbin/hostapd found running; none killed.
    failed!

    Restarting DNS forwarder and DHCP server: dnsmasq.
    Stopping advanced IEEE 802.11 management: hostapd.
    Starting advanced IEEE 802.11 management: hostapd failed!
    Additional Configure Parameters to WiFi

    29. December 2015 at 2:35 #17503

    Noop,
    I have just run the LMS app on my iphone and it works while the lan is attached
    I have just disconnected it and again it fails to find the LMS.

    And using a LAN sniffer, the wifi dongle is off, which is what it’s been doing all the time when the accesspoint boots up, it just kills the wifi
    So it’s no suprise its not working.
    Alex

    • This reply was modified 11 months, 2 weeks ago by  alex.
    29. December 2015 at 11:43 #17505

    Hi Noop

    I have also tried ipeng and this works the same as LMS. When the LAN is connected to the Pi I can control the music, when it’s not then after a few seconds after I disconnect the LAN, the wireless drops out and thats it.

    So is it the access point or the wireless dongle ( I have tried two wireless dongles, both are working identically) I’m struggling again with this and have now run out of ideas..

    29. December 2015 at 17:19 #17508

    Starting advanced IEEE 802.11 management: hostapd failed!

    This is key, it appears that “hostapd” (host-access-point-daemon) is failing to start.
    if that is not running you will not see a network.

    There are many reasons why it might not start. Some wireless dongles do NOT support access point, and some do.
    It depends on the chips used in the dongle. What model is dongle?

    29. December 2015 at 20:05 #17509

    Hi noop

    Thanks for the reply

    Well well well, that would explain a lot!!!!

    It was bought from the pi-hut and Hasn’t got any markings on it

    I did try another and another Pi and same thing happened, again this has no markings.

    I actually do need another for my other pi so I think I’ll get one from the M2P shop anyhow.
    But thanks for the lead on this noop as I didn’t realise , if it is you’ve saved me a shed load of work.
    I had a quick look on here and didn’t see anything about this and I’m amazed as it’s an easy mistake I guess, but thanks noop for getting back to me and understanding the line above
    Alex

    29. December 2015 at 20:31 #17510

    from a command line shell prompt, you can type:

    lsusb

    with the dongle plugged in, it should list some infomation.

    i.e.:

    
    [email protected] ~ $ lsusb
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 005: ID 1058:1010 Western Digital Technologies, Inc. Elements External HDD
    Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
    
    29. December 2015 at 20:47 #17511

    Hi noop
    Sorry I will have to type this in by hand not knowing how to do a screen dump

    I’ll just put the words in starting with the first line to the 6th and if you need more info I can give that

    Standard Microsystems corp
    Linux foundation 2.0 root hub
    Standard Microsystems corp
    Realtek semiconductor corp. RLT8188CUS.802.11n WLAN Adapter
    Logitech inc
    Seagate RSS LLC

    That’s it noop

    30. December 2015 at 4:43 #17513

    The RLT8188CUS chip does apparently support access point according to what I read.
    .
    Perhaps the coders here can comment.

    • This reply was modified 11 months, 2 weeks ago by  noop.
    30. December 2015 at 10:06 #17517

    Hi noop
    Thanks for your help with this and if anyone can help it would be very much appreciated
    even if it’s to recommend another wifi stick.
    But it has to be small, (without an external aerial) as I’m going to fit this in the car and only have very limited space

    But thanks again
    Alex

    30. December 2015 at 17:57 #17518

    Alex:

    I don’t know how adventurous you are but there is a pre-compiled hostapd binary available that supports the RTL8188CUS chipset.
    It’s up to you if you want to try it out.

    Here is how to try it out… it looks complicated but what it essentially does is: download a new hostapd file, move the current one aside, and creates a link to the new hostapd program.

    After going through the Max2Play Access point setup, then replace the hostapd binary…

    cd /tmp
    wget http://www.daveconroy.com/wp3/wp-content/uploads/2013/07/hostapd.zip
    unzip hostapd.zip 
    sudo mv /usr/sbin/hostapd /usr/sbin/hostapd.bak
    sudo mv hostapd /usr/sbin/hostapd.edimax 
    sudo ln -sf /usr/sbin/hostapd.edimax /usr/sbin/hostapd 
    sudo chown root.root /usr/sbin/hostapd 
    sudo chmod 755 /usr/sbin/hostapd

    Then reboot, and see if this version of hostapd runs for your dongle.

    30. December 2015 at 20:11 #17519

    Hi noop,

    Thanks again for your help
    Programming isn’t my forte but I will give it a go IF I can understand what you mean, it’s me that’s the problem being unable to understand this level of programming which I guess to you is quite low

    Ok can I clarify what I think you mean

    I’m going to wipe my SD just to make sure, now this is what I’m getting really good at!!!

    When I’ve done that I will load the all the plugin’s I need the last one will be the access point
    Now this is what I think you mean, I load up the access point plug in and save it

    Then do I enter the above at the point where I have logged into the Pi, which I think Is the command line shell prompt, Is this right or am I talking rubbish….

    Or do I enter this the boot/config.txt…

    Sorry noop but my knowledge even having worked on this for must be over 300 hours now, is still limited

    very very very frustrating and very very soul distroying but I am always thankful for ANY help anyone can give
    Thanks
    A

    30. December 2015 at 20:22 #17520

    Noops
    When I access the GUI page when the Pi is hard wired into the lan it has a different IP address than it has when I access it via the wifi.

    I know this happens as a fact, but if I say load the access point plugin while wired, then disconnect it from lan and access this via the wifi, I am right in thinking they are different ip’s but looking at exactly the same thing ?

    I’m 100% sure I’m right but it’s been such a pain this that I’m starting to question my sanity with this project, this being one example
    Thanks Alex

    31. December 2015 at 5:57 #17521

    Hi Alex:

    You would install the access point plugin to get to the point where the supplied hostapd is failing.
    Then you would issue the commands provided at a shell prompt. Then reboot.

    Yes the wired and wireless network connections would have different IP addresses. Accessing the same data/computer.

    Don’t be discouraged, as long as you learn something the time is not wasted. Keep your chin up.

    31. December 2015 at 12:50 #17522

    Thanks for the encouragement noop,

    I’ve never done a job like this before so minor but has taken so long
    But I really do appreciate your help

    It’s New Year’s Eve and sadly I have to go to relatives and just leaving now and will be away for a couple of days so I’ll not be able to try this now, but I will, can’t wait actually

    So thanks again noop really appreciate it

    Happy new year to you

    Alex

    1. January 2016 at 20:21 #17525

    Hi Noop

    now back (early) and I did try what you said and sadly it’s still not working

    I will tell you what I did.

    I reformatted the SD card, then installed all the plug-in’s until I got to the access point (AP) plug in.

    I went to the AP set up page and hit the install button. This eventually brought up the SSID, Passphrase and standalone options

    I then dropped out of that to the Pi command prompt and put in the above. I did have a couple of goes at this as it was’nt liking it. But it did all go smoothly

    My only worry was I hope this was the right point in the proceedings to do this ?

    But Should I have filled in the sssid etc saved it THEN put this (above in) ?

    Anyhow, once this was inputted at the command prompt I then went back to M2P GUI page and rebooted it, and just to make double sure, I then disconnected the power and did a major reboot

    But sadly, still no accesspoint working.

    I have since ran the ifconf and lsusb commands and it all seems to be functioning. Well I looked on the web to see if I was getting what I’m suppose to get and it seems like I am.

    so I’m still hoping for a miracle..

    hope this makes sense
    Alex

    1. January 2016 at 20:43 #17526

    Noop
    its new years day so please whatever you do, this has been going on for months, there’s no rush, I’m just thankful for any help you can give me

    Thanks again
    Alex

    2. January 2016 at 4:05 #17527

    Happy New year Alex:

    You should have completed and submitted the form to complete the access point installation, then run the commands to replace the “hostapd” program. You should not need to start over again, just run the commands again now.

    • This reply was modified 11 months, 1 week ago by  noop.
    2. January 2016 at 11:02 #17529

    Hi noop

    I have just reloaded the accesspoint plugin
    It’s asking me to reboot so I did

    At this point I dropped out to the command prompt and started entering the above commands as they are above
    All looked like it went well with no errors

    Then I rebooted again went to my iPhone opened up the settings wifi to see if I could see this new network, unfortunately I could’nt.

    I tried with ipeng and LMS and I knew they were not going to work and they didn’t .

    What I did notice in the M2P shop, they recommend a edimax dongle.
    So as I think this script has been installed ok, and as it mentions edimax, if I order an edimax 7811, do you think that will work as I would be happy to pay the £10 to end this 3 months of stress,

    Noop, did you have any problems setting your accesspoint , well if you have one?

    But after saying this it’s possible I have totally misunderstood your instructions and I have loaded the new script at the wrong time / point

    I can uninstall it and try again if that’s so.

    Just another point, I did’t alter or add to the boxes in the accesspoint set up at any point until after the 2nd reboot so after entering the SSID, PASSPHRASE AND TICKING the standalone box , rebooted again by disconnecting the power) and again it failed to work sadly

    30 mins on I have just stopped writing to uninstall the accesspoint plug in and reinstall and to no avail

    Maybe I’ve just loaded the script at the wrong point, here’s hoping

    But thanks for all your help, if you think a new dongle would be the best path to go down no problem

    Alex

    3. January 2016 at 5:00 #17537

    Yes I have access point running…if i click “Debug Informations” near the bottom of the “ACCESS POINT” setup screen, I see:

    #### DNSMASQ Installed ####
    Status: install ok installed
     
    
    #### HOSTAPD Installed ####
    Status: install ok installed
     
    
    #### WiFi Interface Installed ####
    2
     
    
    #### DNSMASQ Running ####
    5 S   110  4525     1  0  80   0 -  1612 poll_s ?        00:00:00 dnsmasq
     
    
    #### HOSTAPD Running ####
    5 S     0  4508     1  0  80   0 -  1294 poll_s ?        00:00:00 hostapd
     

    Notice that hostapd is running… what do you see now?
    I would expect that a recommended dongle from M2P should work out of the box, and they are inexpensive so you can certainly go that way.

    3. January 2016 at 13:04 #17538

    Hi noop

    Guess what !!!!

    Great news, you’ve done it

    Its the same as yours ????????????????????????

    BUT…………………….

    Only when I hard wire it to my router as I can’t get into the setting (GUI) unless its hard wired, well it won’t let me in if I try doing it wirelessly

    So I fired up ipeng and tried to see what was happening there.
    ipeng saw my URL, but it was not coming up with a Mac address (using wireless).
    Then I checked in my settings/wifi on my iphone and still could’nt see it there.

    So I connected the M2P back up to my router and sure enough the Mac address appeared, which kinda is like was I was saying before, but now at least you have proved, and got the wifi dongle working. Another step closer, which feels good to be honest after several months of working on this. I just don’t know why I keep hitting brick walls

    Anyhow, I thought every Pi/PC etc had a mac address, so why should it not be there when its wireless but it is when hardwired. Odd

    And I did compare the mac address issue with my squeezplug I’m running, that has both the URL and Mac, which you’d expect ( when hard wired)

    Maybe its something in M2P I’ve not ticked, or need to install another plugin ?

    And noop, I’m aware this is eating into your time, so if you like, maybe I just get the other dongle then see what happens.
    But you have been a really great help, and thanks for your help.

    But if you do have any ideas I honestly would be very thankful if you could let me know

    Thanks Noop
    Alex

    • This reply was modified 11 months, 1 week ago by  alex.
    • This reply was modified 11 months, 1 week ago by  alex.
    • This reply was modified 11 months, 1 week ago by  alex.
    3. January 2016 at 17:23 #17542

    Hi Alex:

    That is good news…sounds like you are there. With hostapd running on the PI, another wireless device you should now see the new wireless network with the SSID you setup in the form. You should then be able to connect to that new network, providing the password you had setup (default mypasscode).
    For his new network the PI will provide IP addresses in the 192.168.189.X range, with the PI acting as a router at address 192.168.189.1 (by default). This network will be independent of your other networks unless you clear the “Standalone” box and connect the hardwire ethernet. In that case the PI will route packets to your the other connected network. You WILL NOT see devices connected to the new wireless network, show up on your home router as clients, because they are on a subnetwork managed by the PI. Only the PI’s hardwire interface will be client on your home router’s network (which is what you see, I think). I hope this make sense.

    You will find max2play at: http://192.168.189.1

    • This reply was modified 11 months, 1 week ago by  noop.
    • This reply was modified 11 months, 1 week ago by  noop.
    • This reply was modified 11 months, 1 week ago by  noop.
    3. January 2016 at 19:04 #17546

    Hi Noop

    Thanks for sounding upbeat

    3. January 2016 at 19:05 #17547

    Hi Noop

    Thanks for sounding upbeat

    3. January 2016 at 19:05 #17548

    Hi Noop

    Thanks for sounding upbeat

    3. January 2016 at 19:22 #17549

    Hi noop
    Just lost my last message to you so here we go again

    Thanks for sounding upbeat

Viewing 30 posts - 1 through 30 (of 295 total)

You must be logged in to reply to this topic.

Register here