[Announce] New Max2Play Image for Raspberry Pi 4

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [Announce] New Max2Play Image for Raspberry Pi 4

This topic contains 134 replies, has 28 voices, and was last updated by  MarioM Moderator 2 weeks, 3 days ago.

Viewing 30 posts - 31 through 60 (of 135 total)
  • 26. August 2019 at 13:14 #46838

    When will the Pi 4 image be out of beta status? I’d like to avoid setting it up two times…

    28. August 2019 at 11:16 #46892

    Hi cramcram,

    Thanks for asking, we will soon release the official image for the Pi4. However, the current beta will also be updatable to the official release, so you can already set it up now and update to the proper version just by clicking the normal update Max2Play button.

    28. August 2019 at 12:15 #46897

    Thx for your reply, great to know it will be updatable!

    24. September 2019 at 12:17 #47139

    Just to let you know that I’m running max2play on a Pi 4 now. And it works beautifully, no issues.

    26. September 2019 at 21:15 #47167

    Found one issue. I don’t manage to install Shairtunes2. When I try to open the plugin settings page I get:

    404 Not Found: plugins/Extensions/settings/plugins/ShairTunes2W/settings/basic.html

    So the plugin doesn’t seem to install properly. Installing the SSL fix on the Squeezebox Server page in max2play doesn’t help.

    27. September 2019 at 10:20 #47172

    Hi cramcram,

    Thanks for the feedback, is the version „shairtunes2 (fork)“ and is no other version of shairtunes active?

    27. September 2019 at 10:26 #47173

    Yes and yes. Also tried the dev version. Happens on 2.50 and the latest Beta. Does the SSL fix need to be upgraded to Buster? In the max2play frontend (Squeezebox Server tab) I can only install the SSL fix for Stretch.

    30. September 2019 at 23:19 #47205

    Over at the slim devices forum somebody fixed it with

    sudo apt install libcrypt-openssl-rsa-perl

    https://forums.slimdevices.com/showthread.php?106289-announce-ShairTunes2W-Airtunes-on-LMS-(forked-version-with-Windows-support)/page73

    2. Oktober 2019 at 9:28 #47216

    Hi max2play team

    Could you reproduce the issue? Are you working on it? Shairtunes is important in my setup.

    Thank you 🙂

    2. Oktober 2019 at 10:48 #47217

    Hi cramcram,

    We were and we’ve added a beta update that adds an automatic installer for the missing package under buster in the lms.

    You can try it out by making a beta update and installing the LMS afterwards.

    2. Oktober 2019 at 13:24 #47221

    It works. You’re amazing. Thx for your wonderful software.

    11. Oktober 2019 at 15:05 #47269

    Thanks for letting us know it worked with your system 🙂

    18. Oktober 2019 at 15:46 #47382

    Now that Buster is in stable are we going to get a patch or should we just manually move to the stable release?
    „E: Repository ‚http://raspbian.raspberrypi.org/raspbian buster InRelease‘ changed its ‚Suite‘ value from ‚testing‘ to ’stable'“

    13. November 2019 at 14:00 #47525

    Hi Staudie,

    We will add all major updates and changes in our own updates.

    Anonymous
    22. Dezember 2019 at 10:38 #47826

    I have max2play installed on RPI4. I use only LMS on this System, but LMS is missing lame encoder. So all players are only playing with low quality. What can i do?

    27. Dezember 2019 at 15:19 #47836

    I have installed the Buster image on a Pi4. After updating Max2Play to the latest versions I tried updating Raspbian with
    sudo apt-get update
    sudo apt-get dist-upgrade
    After the upgrade the Pi no longer boots. I have tried this a few times and another user on the slimdevices forum has confirmed that he also found the same issue after performing the upgrade.
    Any ideas?

    Anonymous
    27. Dezember 2019 at 17:27 #47837

    The Audiophonics switch is not working. The process ID is displayed on the Webpage but shutdown is not working. The LED on the button is always blinking. The Audiophonics switch works on Raspberry 3B+.

    27. Dezember 2019 at 18:15 #47838

    So you can’t even get to the command line?

    If you can just install Max2Play like I show here.

    Or you can just see if installing the PI OS and then do them commands.

    -Raymond Day

    30. Dezember 2019 at 18:47 #47859

    The Spotify Connect plug-in won’t automatically start on boot-up with this Pi4 build. Can manually start in and works fine then, but can’t get it to automatically start.

    Erik

    26. Januar 2020 at 13:29 #47969

    Have you planned to make LMS 8 available via the Squeezebox Server tab in max2play (http://max2play/plugins/max2play_settings/controller/Squeezeserver.php)?

    2. Februar 2020 at 11:00 #47977

    Will the new buster 64 bit kernel with latest beta run
    1. On pi 2 ?,
    2. On pi 3 ?
    3. Will there be speed increase, eg. in Kodi YouTube searches or in Logitech media server database updates when building up huge music collection on big hd ?

    Is there now a stable max2play buster, incl. 64 bit?

    Wird der buster 64 bit kernel mit der neusten Beta auch 1. Auf pi 2 , 2. Auf dem pi 3 laufen?
    3. Wird es den beschriebenen geschwindigkeitszuwachs geben?
    Oder gibts nun eine max2play stable mit buster und 64 Bit?

    17. Februar 2020 at 22:34 #48035

    Hi

    I’m coming back to Max2Play after a break and would like to download version 2.51 for my Pi4. Your download page only seems to have version 2.50, am I being stupid as I can’t seem to find the new version.

    Many thanks
    Ashley

    18. Februar 2020 at 16:37 #48038

    I worked it out for myself….Install v2.50 and then update within Max2Play to V2.51.

    But why isn’t there a v2.51 download?

    Many thanks
    Ashley

    18. Februar 2020 at 16:49 #48039

    If you do this then don’t try to update using
    Apt-get dist-upgrade
    If you do your Pi will no longer boot. So you are likely to be stuck with the old kernel with the associated temperature issues.
    This would not be an issue if a Max2Play version based on the latest Raspbian Buster with updated kernel was available for download.

    18. Februar 2020 at 18:37 #48040

    It’s funny you should say that because that’s exactly what I did and yes, The Pi4 wouldn’t boot. I simply started again but didn’t do the Apt-get dist-upgrade the second time.

    I was only experimenting to see how easy it is to get Max2Play and Pi-hole operating on the same Pi which I was able to do once I’d changed the port number of Pi-hole.

    I tried to get Max2Play to use the 64bit kernel using the switch in v2.51 but nothing happened which I assume is because I’m not a paid up user?

    22. Februar 2020 at 17:31 #48058

    Hi everyone,

    I have a HiFiBerry DAC+ ADC running on a Raspberry Pi 4.

    I am using Max2Play latest beta for the Pi4 and I am using the default LMS server and squeeze player.

    Playing music from my NAS works perfectly, but I cannot play anything from the aux/line-in source on the DAC.
    I have setup by following these instructions: https://www.hifiberry.com/docs/software/integrate-analoge-audio-devices-into-your-multi-room-system/?utm_campaign=website&utm_source=sendgrid&utm_medium=mail

    I have set the URL for the wavein plugin to wavin:default and I have also tried wavin:sysdefault because I found some information on this forum and saw that my default soundcard in M2P is named “sysdefault”. https://www.max2play.com/en/forums/topic/using-the-input-function-of-hifiberry-dac-adc-pro/

    Nothings works – does anyone have any suggestions? Is anyone else able to get this working with a DAC+ ADC and a Pi V4?

    Many thanks

    • This reply was modified 8 months, 1 week ago by  andy2111.
    25. Februar 2020 at 18:08 #48079

    I am running the Hifiberry DAC+ADC on a Pi 4 with the WaveInput plugin.

    In difference to your case, I do not use the analog output. Only the analog input and HDMI for digital audio output isin use.

    To get WaveInput running, you need to know the correct soundcard and channel of the audio input of the ADC.

    On my installation I entered wavin:plughw:1,0 as favorite and it runs correctly.

    26. Februar 2020 at 23:38 #48090

    Thanks for your reply.

    I’ve tried various things with no luck and looking at the format of the soundcard name you used I still can’t figure out mine.

    I have the following set as my default in the audio player settings:

    plughw – snd_rpi_hifiberry_dacplus, -Hardware device with all software conversions, CARD=sndrpihifiberry,DEV=0

    Any idea from the above what I would put after „wavin:“ ?

    And it looks like I have a couple of other options I can set as the soundcard – I’ve tried unsuccessfully here too..

    hw – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions, CARD=sndrpihifiberry,DEV=0
    sysdefault – snd_rpi_hifiberry_dacplus, – Default Audio Device, CARD=sndrpihifiberry,DEV=0

    Any help is very gratefully received!

    27. Februar 2020 at 11:37 #48092

    For me its easier to check the right soundcard on the command line. So I logged into the RPi by SSH (Logon: pi, Password: max2play) and become root („sudo bash“).

    With the command arecord -L you get a list of the available audio input interfaces.

    To your information: It is not possible to use the Audio-In Port in parallel with the Audio-Out Port, using SqueezeLite/WaveInput: Squeezelite normally uses the highest bit rate possible, WaveInput uses 16 Bit. The Hifiberry sound chip is not capable using different bit depth/sampling frequencies for simultainiously input and output.

    27. Februar 2020 at 12:40 #48093

    Ahhhh…. that’s the whole reason I bought the hifiberry and setup M2P – I wanted to switch between the line-in port and streaming music from my NAS. 🙁

    I know Volumio supports the line-in port, but only on their top paid plan.

    I might switch to plan B and use an external amplifier and use a hardware switch to select the input feed to the amp

    Many thanks for all your help – at least I know not to try any more – I could have wasted even more hours getting frustrated!!

Viewing 30 posts - 31 through 60 (of 135 total)

You must be logged in to reply to this topic.

Register here