[Announce] New Max2Play Image for Raspberry Pi 4

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [Announce] New Max2Play Image for Raspberry Pi 4

This topic contains 123 replies, has 25 voices, and was last updated by  MarioM Moderator 1 day, 9 hours ago.

Viewing 30 posts - 61 through 90 (of 124 total)
  • 27. Februar 2020 at 14:06 #48094

    to be more precise: „It is not possible to use the (Hifiberry DAC+ADC) ANALOG-In Port in parallel with the (Hifiberry DAC+ADC) ANALOG-Out Port, using SqueezeLite/WaveInput“

    I use HDMI as Audio-Out, so everythings works.

    When I remember it right, you can change the squeezelite parameters, so that it will match the same bit depth/sampling frequency WaveInput needs. Then it might be possible zu use it in parallel.

    • This reply was modified 5 months, 2 weeks ago by  flyingscot.
    • This reply was modified 5 months, 2 weeks ago by  flyingscot.
    28. Februar 2020 at 15:49 #48102

    Moin

    Ich habe heute versucht die Beta zu installieren. Der Rechner hat keine Netzwerk-Verbindung.
    Ich komme dementsprechend nicht zur Konfiguration.
    Funktioniert bei dem Raspi 4 mot 1gb noch ein anderes Image?

    Gruß

    17. März 2020 at 12:37 #48153

    Hi guys,i have bought raspberry pi 4 4gb and i downloaded the beta image for max2play. Installation is ok,i installed allo boss dac too,it works..but i have a serious problem with temperature. When it s not active it arrives to 76°. I have bought the raspberry kit with dissipators too.. but i m not understanding why the temperature is so high.
    tnx for the help

    17. März 2020 at 14:00 #48154

    It is getting too hot because the downloaded image comes with an old kernel and it is impossible to update it . If you try updating via the command line then the Pi will no longer boot.

    17. März 2020 at 14:28 #48155

    There are things you can do to get the Pi to run cooler . First use Putty to SCP in to the Pi . After running as pi then password max2play you should be given a command line .

    Type in sudo apt update

    Then press return .

    When it stops reading the updates it should tell you how many files it can update .

    Then again on the command line type sudo apt upgrade . It will then read and compile the update and ask if you want to go ahead Y/N pres yes and this should start the update process . Once this finishes and the screen has reurned to command line type

    sudo reboot

    Once the Pi has renooted this should have updated the kernal and all files and it will run not as hot as before. I would also suggest that you buy something like the flirc case for the Pi 4 as this is very effective at getting the Pi 4 to run cooler .

    17. März 2020 at 14:58 #48156

    Updating Max2Play using „apt-get upgrade“ just leaves you with a Pi that doesn’t boot.

    17. März 2020 at 15:12 #48157

    So why am I listening to Lizz Wright singing Another Angel using a Max2play driven Raspberry Pi 4 4Gb as server and a Max2play driven Raspberry Pi 2gb with HiFiBerry Digi Hat which is working perfectly and has done for over seven months.

    Just to test out your claim I have just run sudo apt update , then sudo apt upgrade on both players again works without any fault at all .
    I do not know how to achieve what you are saying happens .

    I would consider either re-formatting your current sd card or replacing it and trying a new download and install . The only issues that the Beta Max2play has ahd were in the very early days and I have four different players arounf the house including JustBoom , Allo and HiFiBerry all of which work .

    17. März 2020 at 15:22 #48158

    I think it is probably because you updated your kernel many months ago. Anyone starting from a fresh image now finds the issue that the Pi won’t boot afterwards. When I mentioned this in the Squeezebox forum a member there tried updating a new image and found exactly the same thing. Of course the original poster is welcome to try it and report back.😀

    17. März 2020 at 15:32 #48159

    guys,tnx for the answer. i m proceding with the update as bencat said to me with putty. it s five minutes it s going. but i wanna say that yesterday i tried this (not from putty but from max2play plugin) and i had same problems of Slartibartfast.

    i ll wait it finish to update and i ll say you if it s all ok

    17. März 2020 at 15:37 #48160

    and now..during configuration of apache2..it s frozen. i cant go on my page and the shell is frozen by 5 mins…

    UPGRADE: i restarted raspberry, and it works. it seems to have upgrated all but temperature is always the same

    • This reply was modified 4 months, 4 weeks ago by  antonio81le.
    17. März 2020 at 16:27 #48163

    I had the same issue as Slartibartfast in that upgrading the Pi4 just caused Max2Play to crash when booting up. I didn’t play around much after that and went back to pCP.

    I am surprised that your Pi4 is running that hot though, 76 degrees seems excessive. What sort of environment is it in? Is it a hot cupboard, is there a hard drive connected directly to it? Is it running LMS or just working as a player?

    My Pi4 is running LMS but isn’t a player and ticks along at about 48 degrees in a hot cupboard. I’m using a cheap heat sink case which keeps the temperature quite steady. I don’t have a dac attached but I wouldn’t expect it to make that much difference.

    17. März 2020 at 17:25 #48164

    my raspberry is inside a box i built,same place where i had a raspi3 with temperature of 30/40°. now it s out of box,but temperature,without play anything,is 74°. Anything is connected to it..just allo boss dac. it s a player for my hall room

    can u explain me the difference to be a player or just run lms?!

    i have othrs two raspy with max2play:
    – one with display and i use it just to play music in my hall or in bathroom.(maybe u mean this when u asked me about player or running lms). it s a raspi3 and temperature is 30/40°
    – another one in bathroom,and it s a player, it s raspi3 and temperature is 30/40°

    17. März 2020 at 17:37 #48165

    Logitech Media Server (LMS) is what controls the players. I’m assuming you’re using that somewhere?….perhaps not. Where does the music come from that you play?…your own collection or online/Spotify etc

    An RPi3 will run a bit cooler than a RPi4 but 76 degrees suggests that your RPi4 is working quite hard for some reason?

    17. März 2020 at 17:47 #48166

    i have opened lms in each raspberry,but now i m trying to leave opened just that with display…it could be better?

    17. März 2020 at 18:11 #48167

    You will need to install the new kernel to reduce the temperature of your Pi4. It looks like yours is still using the old kernel even after the update. If you are only using it as a player the best way is probably PiCorePlayer but it seems a waste to use a Pi4 purely as a player. I ended up going back to Raspbian Buster and installing LMS but I don’t use mine as a player. Works perfectly and sits at around 42 degrees in a FLIRC case.

    17. März 2020 at 18:51 #48168

    the problem is that,even now,as player,and without play anything,it s 76°. how can i install kernel?i need to install the image again??i need to change sd?!? i did the update as Bencat said..but nothing. have u installed the new kernel then?

    17. März 2020 at 19:06 #48169

    I don’t think you can install the new kernel on Max2Play but for some reason they will not offer a new image based on the new kernel for download. Maybe if enough people complain they might finally update it.
    I was able to install the new kernel because I didn’t use Max2Play. I installed Raspbian Buster instead. If I were you I would try PiCorePlayer until Max2Play sort themselves out. They know about this problem but will not address it.

    17. März 2020 at 20:20 #48170

    maybe i solved. never noticed that in Raspberry Settings there is a flag about the new Kernel. Now temperature is around 60°….

    1. April 2020 at 6:20 #48370

    Hello,

    I’m a big fan of M2P RPi3. Before my question, I would like to share how to cool the Pi4 to 32 degrees Celsius.

    I use a heatsink and fan. The aluminium heatsink is 10mm finned and 3mm larger around the surface area of the cpu device. The epoxy glue is J-B Weld 8280 Original. The fan is a 80 mm Noctua NF-A8 5V. A 10 Ohm thermistor SG42 part# to additionally slow the fan. A jigsaw was used to cut circle out of the top and drilled some holes to mount the fan on a NESPI case. The project was 1.5 hours.

    **My question for RPi4.** On my TV (RPi3 version 2.50 works fine), however for RPi4 Jivelite does not autostart after Exiting KODI. The display is flashing the M2P command prompt. Stop and then Start Jivelite displays the Jivelite GUI again until Start and Exit KODI.

    I’ve tried several combinations of RPi4 versions of OS, KODI, Jivelite, and combinations of autostart for OS, Squeezelite, KODI, and Jivelite.

    I’ve searched the Forum for advice but haven’t found it, but also thinking I’m the only one with this issue because somebody would have posted for support. Thanks for your support.

    Rod

    4. April 2020 at 11:50 #48407

    Ah well after having Max2play work well and without any of the noted issues regarding using a Raspberry pi 4 I now have the same issue as others seem to .

    I have an Allo Digione that was with a Raspberry Pi 3 . This worked using the Max2play install for Allo . I was given a Raspberry Pi 4 2GB unit and decided that i would do two things replace the Digione on to the Raspberry Pi4 and order a metal case for the two .

    Waiting on the metal case but have done the swap of the Pi 4 . Formatted an SD card and did a new clean install of the Beta Raspberry Pi4 download . At first install seemed to be fine but after activation it said that Max2play needed to update did this and rebooted. Went to Audioplayer page and founf that the Digione was not listed even though it showed Digione as the chosen card on the Allo page.

    Tried a reboot and this time the unit just stopped no reboot and no contact with the player . Tried upplugging leaving for five minutes and then powering up but again the same result . So formetted the SD card again and did another clean install this time just loaded Max2play and left the Allo install for later . But the same thing happened again and once the upgrade was completed I changed the R Pi settings and on reboot as instructed the same just stopping working .

    So loaded Picoreplayer 6.0 on the same unit and after setting it up as Allo Digione worked first time and is playing as I type this . There is a flaw in the Rpi 4 download which is preventing units being set up to use Max2play . This is a shame and it would be a good thing if this could be addressed . I enjoy this software and i like the control and GUI it offers . All of my oter players Hatamps and LMS server use the same Max2play software and work without issue . I can use the Digione as Pcp player but would much prefer to have all units working on the same software. Heiner can you please respond and advise if you are going to look at this and address the issue . If you are not able to easily fix this then it is better we all know there is the problem and we then make sensible decisions going forward.

    6. April 2020 at 12:58 #48409

    Heiner sorry but this is not really acceptable . I have paid your license fee for a number of years and used your software during that period . One of the reasons for paying you a fee when there are free software options i could use is that you will be on hand to assist with problems and issues.

    If this problem is complicated or difficult then fair enough please just reply to this thread and say so . If it is somehting that you are not able to fix then again fair enough place your reply here . Both of these are acceptable . What is not acceptable is you not answering or commenting at all . This is your work and you have asked users to pay for it we have done this and we at least desereve to have our questions answered even if we then do not really like those answers .

    Can you please review the problem that a number of people have and respond if there is anythign you can or even we can do to get around the issue.

    7. April 2020 at 15:16 #48415

    Hi Bencat,

    Sorry for the late reply. Did your system work before updating to the latest Max2Play version? Did you update your system via the button on the Settings/Reboot page or via the Raspberry settings?

    8. April 2020 at 20:30 #48424

    Just a suggestion MarioM, for as far as I can determine I switched to the pi4 and the beta image around august 2019 and I can upgrade just fine either from within max2play (r pi settings) or ssh using apt-get upgrade.
    Did the image change since then or maybe the downloadable image got corrupted?

    8. April 2020 at 20:55 #48425

    As far as I can tell the problem arose when Raspbian Buster became stable. Anyone who updated the kernel before that point doesn’t have an issue. Anyone who tries to update the kernel using apt-get dist upgrade since then ends up with a device that will not boot. I can’t understand the reluctance to release a new image based on the latest stable Raspbian Buster.

    9. April 2020 at 14:57 #48430

    My colleague on site will test this again and try to recreate the problem. As soon as he has results and we can offer a possible solution, I will contact you again here.

    I apologize that this topic is dragging on for so long.

    9. April 2020 at 15:33 #48431

    It seems that the problems with the kernel updates are somewhat „normal“. Depending on how extensive the kernel updates are, they can make the system unusable. We have no influence on that.

    Hence the question of what the kernel update is used for. The temperature fix was already included in the update from last summer. It would be good to know what the updates are needed for so that we can offer updated image versions for particular cases if necessary.

    We ask for your understanding that we have no capacity to regularly offer a new image with the latest kernels for download.

    9. April 2020 at 15:52 #48434

    The kernel updates work for Raspbian Buster when using the latest published download as a starting point so I am not sure why you think issues are normal. More than one kernel update has been related to power saving and temperature.

    9. April 2020 at 16:36 #48436

    When updating from an older kernel to a new one and when updating packages, many problems can arise due to changed config files, incompatible versions etc. Since we offer a lot of options with Max2Play, we have to test them all, if we want to support a new kernel. There is a reason why you cannot easily upgrade from jessy to stretch or buster. There are simply too many dependencies. The problem is not the kernel itself, but the update. Nevertheless, we will examine the current kernel and look for a solution, but this may take some time.

    9. April 2020 at 17:44 #48437

    You can see the various stages of temperature improvement here

    Thermal testing Raspberry Pi 4

    11. April 2020 at 17:26 #48470

    Also a question that belongs to the category „it’s unacceptable that I never got an answer – I’m paying a licence fee for this…“:

    Have you planned to make LMS 8 available via the Squeezebox Server tab in max2play (http://max2play/plugins/max2play_settings/controller/Squeezeserver.php)?

    Asked it back in January, never got a reply from the max2play team…

Viewing 30 posts - 61 through 90 (of 124 total)

You must be logged in to reply to this topic.

Register here