[Announce] New Max2Play Image for Raspberry Pi 4

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [Announce] New Max2Play Image for Raspberry Pi 4

This topic contains 134 replies, has 28 voices, and was last updated by  MarioM Moderator 2 weeks, 1 day ago.

Viewing 30 posts - 91 through 120 (of 135 total)
  • 11. April 2020 at 21:47 #48471

    Hi cramcram, under „Squeezebox Server start Installation“ >> „Alternative source from Slimdevices (package must be .deb)“ have you tried directly pasting the path to the lates 8.0 nightly? Located here: http://downloads.slimdevices.com/nightly/index.php?ver=8.0

    Currently the latest would be http://downloads.slimdevices.com/nightly/8.0/lms/aaa663bb569ff4438e25c7e9a361d79b3716502d/logitechmediaserver_8.0.0~1586578181_arm.deb which is dated Apr 10.

    Disclaimer – I am not affiliated with M2P and have not tried this. I would assume this is officially unsupported right now. But if I were to try it, I would first make a full backup image of my SD card before doing so. That being said, if you do give it a shot, do post results.

    15. April 2020 at 13:48 #48485

    Hi cramcram,

    As described by jcu-muc, you can already manually install LMS Version 8.0 on the plugin page of the Squeezebox Server. We will test this version ourselves and, if everything works, add it to the selection.

    15. April 2020 at 15:16 #48497

    Hi MarioM

    Sounds good. I don’t have time for beta-testing, looking forward to the version being officially added by max2play.

    16. April 2020 at 14:19 #48519

    Hi cramcram,

    We have now added LMS 8.0 to our Beta. It will then be officially available in v2.52.

    16. April 2020 at 21:18 #48532

    Hi MarioM,

    Thanks very much for the update, looking forward to the 2.52!

    Looks like it’s going to be significant:

    Changelog Max2Play

    Is a Kernel update foreseen too for the release version?

    Best,
    jcu-muc

    17. April 2020 at 15:25 #48536

    Hi jcu-muc,

    These Max2Play versions always come without a kernel update. We only include kernel updates when we create new download images. However, this update only applies to the Max2Play scripts and the web interface.

    17. April 2020 at 23:30 #48543

    Hi MarioM

    I can select LMS 8.0 in the latest beta in the dropdown, but it actually still installs 7.9.3 – can you check your implementation?

    Edit: Apparently this is due to a flaky behaviour in the frontend of the dropdown (on MacOS, Google Chrome latest). When I select a version in the dropdown the URL int the form is not updated. Only after opening the dropdown again and re-selecting the same version a 2nd time the URL in the form is updated.

    • This reply was modified 6 months, 2 weeks ago by  cramcram.
    • This reply was modified 6 months, 2 weeks ago by  cramcram. Reason: Bug description added
    21. April 2020 at 13:43 #48561

    Hi cramcram,

    Thank you for the tip. On Windows/Chrome there seems to be no such problem. I’ll see if there is anything that can be done here. So far I have not been able to reproduce that bug.

    22. April 2020 at 8:47 #48582

    Thx for trying. It‘s not a critical bug as there is a workaround.

    24. April 2020 at 19:50 #48610

    Hi MarioM, looks like 2.52 is out according to the changelog page. I’m not getting the usual „Update available“ message though on the Settings/Reboot page. I’m running the Beta RPi4 Raspbian Buster image (which updated from 2.50 to 2.51 with aforementioned update notification). Is 2.52 not yet meant for Buster?

    Thanks and best,
    jcu-muc

    28. April 2020 at 13:45 #48633

    Hi jcu-muc,

    Update 2.52 is intended for both the Pi 3/Stretch and the Pi 4/Buster. A corresponding update notification should normally appear on each system. We’ll take a look at this bug.

    29. April 2020 at 18:27 #48666

    Hi all,

    first of all to change the used Debian „Buster“ build from the current state to „stable“ you have to run „sudo apt update –allow-releaseinfo-change“.
    After that upgrade will work again.

    So I tried to run my old IQAudIO Pi-DAC+ on my pi4b on the m2p image to use it with gmediarender DLNA. Setting up the soundcard in m2p in the same way as on Pi2’s and Pi3’s, gmediarender started, but cannot stream music. So I checked DTOverlay, alsamixer, aplay -l asound.conf. Everything seems to be ok. But no progress in time counter.
    I started a different setup with IQAudio’s „0_quicktest_buster.img“ and a fresh compiled gmediarender.resurrect version. That worked fine, streaming music over the soundcard.
    Back in max2play pi4b version I installed that gmediarender.resurrect version in a different directory and started it. It seemmed to be ok until I started streaming.
    See the output:

    gmediarender 0.0.8 started [ gmediarender 0.0.8_git2020-01-09_26d8f7e (libupnp-1.8.4; glib-2.58.3; gstreamer-0.10.36) ].
    Logging switched off. Enable with –logfile=<filename> (or –logfile=stdout for console)
    Ready for rendering.

    ** (gmediarender:8427): WARNING **: 18:24:57.283: cannot set NULL uri
    ERROR [2020-04-29 18:24:57.284101 | gstreamer] play: Error: No URI set (Debug: gstplaybin2.c(3824): setup_next_source (): /GstPlayBin2:play)
    ERROR [2020-04-29 18:24:57.284342 | gstreamer] setting play state failed (2)
    ERROR [2020-04-29 18:24:57.284524 | upnp] upnp_set_error: Playing failed (704)

    ** (gmediarender:8427): WARNING **: 18:24:59.297: cannot set NULL uri
    ERROR [2020-04-29 18:24:59.297855 | gstreamer] setting play state failed (2)
    ERROR [2020-04-29 18:24:59.297899 | gstreamer] play: Error: No URI set (Debug: gstplaybin2.c(3824): setup_next_source (): /GstPlayBin2:play)
    ERROR [2020-04-29 18:24:59.298036 | upnp] upnp_set_error: Playing failed (704)

    ** (gmediarender:8427): WARNING **: 18:25:01.308: cannot set NULL uri
    ERROR [2020-04-29 18:25:01.308351 | gstreamer] play: Error: No URI set (Debug: gstplaybin2.c(3824): setup_next_source (): /GstPlayBin2:play)
    ERROR [2020-04-29 18:25:01.308483 | gstreamer] setting play state failed (2)
    ERROR [2020-04-29 18:25:01.308613 | upnp] upnp_set_error: Playing failed (704)

    ** (gmediarender:8427): WARNING **: 18:25:03.318: cannot set NULL uri
    ERROR [2020-04-29 18:25:03.318774 | gstreamer] setting play state failed (2)
    ERROR [2020-04-29 18:25:03.318803 | upnp] ERROR [2020-04-29 18:25:03.318799 | gstreamer] upnp_set_error: Playing failed (704)
    play: Error: No URI set (Debug: gstplaybin2.c(3824): setup_next_source (): /GstPlayBin2:play)

    An idea what can be the difference between the test-image and m2p? both were updated on latest buster resources.

    BR
    Iwanman

    5. Mai 2020 at 13:52 #48695

    Hi Iwanman,

    sorry for the late reply. The gmediarenderer needs a lot of libraries when compiling. So it may be that it no longer works with Buster. In my tests I didn’t get it to work with Buster either, but it did run with Stretch. Our chief developer will take a closer look at this as soon as he can.

    11. Mai 2020 at 14:21 #48753

    Hi MarioM,

    thanks for your reply; but it did Work on IQAudio‘ Buster test image mentioned above (Link) on this Buster-Image, my Pi4 runs without any problems with a fresh compiled gmrender-resurrect version (with all necessary libraries) from github gmrender-resurrect.
    I compiled this version exactly in same conditions on latest max2play Pi4-buster version and launched it manually without any connection to the pre-installed version except hardware infrastructure within it’s configurations.
    In my opinion there must be a bug in general settings due to the different soundcard and mixer settings, but I cannot find the clue.
    If you have a IQAudio DAC+, try my example build and verify please.
    Are there any similar bugs known for HifiBerry, etc.?

    BR Iwanman

    27. Mai 2020 at 16:34 #48870

    Hi Iwanman,

    We have finally found the time to address the gmediarenderer problem. The gmediarenderer should now work with the buster image (update to beta beforehand).

    31. Mai 2020 at 18:45 #48893

    Hi MarioM,

    finally I tried the new max2play Beta Version „Beta-200527“ based on the V2.50 M2P-Buster-image and I can confirm my IQaudIO DAC+ is working fine with gmediarender now.
    Just for my curiosity what was the clue?

    Thank you for your support,
    BR
    Iwanman

    22. Juni 2020 at 18:48 #49064

    I just migrated from RPI3B+ to RPI4 with the new image for model 4.
    Everything works using the player with my DAC+ pro card.

    Unfortunately using the BT speaker function to connect the smartphone does not produce any sound.

    The BT link seems to be established/connected, max2play is selected as the media output device, the transport of the music player advances but produces no sound.

    Is this issue known in any form for the new max2play image?

    Thanks – Udo

    23. Juni 2020 at 15:56 #49076

    Hi Udo,

    We haven’t encountered this problem so far. I will be back in the office tomorrow and may be able to test that again.

    24. Juni 2020 at 15:02 #49090

    Hi Udo,

    I just tested the Pi 4 with the BT speaker function and was able to stream to the Pi from my smartphone without any problems. What settings did you make in Squeezelite? Which Sound Device did you choose below „Stream directly to Max2Play Soundcard“? And which version of Max2Play is installed on your device?

    24. Juni 2020 at 16:56 #49092

    Hi Mario,

    thanks for the fast response.

    The settings are:

    Soundcard im Squeezelite Setup: sysdefault – snd_rpi_hifiberry_dacplus
    max2Play Version 2.52 for RPI4B 4GB
    BT Settings: sndrpihifiberry – hw:1:0 – Mixer Digital – Hifiberry DAC+ pro

    Sorry, i did not really understand the dependecies of the several audio out options and the possible signal paths.

    27. Juni 2020 at 23:40 #49101

    Hi, habe ein Problem.
    Mein System lief mit der digi+ aus china problemlos auf dem Raspberry Pi 4 2GB.
    Jetzt habe ich die Sound- und SD-Karte in meinen neuen pi4 8GB gesteckt und er findet die Karte nicht mehr. Heute kam eine neue digi+ pro von Hifiberry, aber die funktioniert genauso wenig. Die Karten werden einfach nicht mehr vom System erkannt. Aplay -l sagt keine Soundkarte vorhanden ausser die Headphone (onboard)

    Jemand eine Idee woran das liegen kann?

    Viele Grüße Helge

    28. Juni 2020 at 13:17 #49102

    Going back to rpi3+ and check later on a release version if the problem has been solved.

    Thanks
    Udo

    30. Juni 2020 at 13:01 #49118

    @ UpAtMax2Play

    Your settings look correct. To rule out that something went wrong when setting up Bluetooth, please review our wiki again: https://www.max2play.com/en/wiki/bluetooth-direct-stream/
    Did you update Max2Play after installing Bluetooth? If not and if you are still motivated to test, please try that again. After that uninstall and install Bluetooth and then test the BT Speaker again.

    @helgelino

    Bislang hatte wir noch keine Gelegenheit, den 8GB Pi mit unserem Image zu testen. Deswegen kann es sein, dass beides zusammen noch Probleme macht. Sobald wir ein 8GB Modell da haben, werden wir das Ganze testen und an gegebener Stelle Fixes nachreichen. Allerdings kann ich noch nicht genau sagen, ob und wann wir dazu kommen.

    8. Juli 2020 at 11:26 #49234

    Can you confirm if the Max2play Beta for Raspberry Pi 4 works with the new 8 gb version ? Would I need to do anyhting further to use the extra speed this version is capable of ? I intend to just use this as an LMS server only with no player so as to make the LMS as responsive and smooth as possible . Have you and tips or addons that will help make this work .

    8. Juli 2020 at 12:13 #49237

    Hi Bencat,

    Unfortunately we don’t have a Pi 4 with 8GB RAM yet, so we haven’t been able to test the image with it. So it may be that our Beta Buster Image is causing problems on this system. In itself, the Pi shouldn’t differ much from the 4GB version, but we cannot confirm with certainty that everything works until we have tested it ourselves. Our order was rejected until further notice, so we cannot say when we will receive a delivery with the 8GB version. However, as soon as it is available again, we will of course order it again.
    To use the Pi only as a server, all you really need to do is deactivate the services in the audio player tab and remove them from the autostart. You could also deactivate the build-in audio in the Raspberry settings.

    9. Juli 2020 at 10:12 #49273

    Hi MarioM thank you for the response sorry I was only putting the details about using the Pi as an LMS server for information . I have used one for over nine years in this way updating the Pi versions as they became available I do not need any advice on that part of the work as I think I could set up a new unit in my sleep mainly due to Max2play being easy to use and control .

    Sorry to hear you have supply problems with the 8 gb all of the UK buyers I contacted including rs components had them in stock and available not sure why your supply is difficult

    https://uk.rs-online.com

    I have in fact just put the already set up SD card in to the 8 gb (it was previously in a 4 gb) and it has worked seamlessly and without any issue . The speeds for a full Library scan 53,938 tracks is much quicker and the response is also instant and very smooth . So I can confirm for anyone interested that the current image works . I suspect that there may be even more speed to wrung out of this version but I will be patient until you have one to test adn see what you can do with it . Thank you for the time taken to respond .

    14. Juli 2020 at 15:24 #49311

    As indicated above i have replaced a Pi 4 4gb unit with a new Pi 4 8gb one. Expectation was just that this new unit would be a direct replacement and offer perhaps a little more speed and smoothnes in response . As indicated I use my Pi 4 8gb as a stand alone Music Server running Logitech Media Server and with a USB 2 TB Hard Drive connected to one of of the 3.0 USB inputs. I used the SD card that was previously set up for the old Pi 4 4gb and I was replacing the Pi 4 2gb unit which was acting as a short term replacement and which had also used the SD card as well .

    using the Pi 4 2gb made no real difference except for a very small loss in speed and things were as i expected. However and i know there will be many who will doubt this and I am at a loss to explain it but the Pi 4 8gb sounds som much better than the other units . And I am not saying this lightly . I have been one who has been sceptical about the benefits of using expensive (sometimes very expensive) audio company streamer units made by the likes of Linn , Naim , Melos and others. Given what the unit had to do store and pass on digital files there seemed no way that they could influence sound quality .

    Well I am now left not a little puzzled but very happy . The use of the Pi 4 8gb unit makes the sounds coming form all of my different systems sound better . Better bass , more natural vocals , better imaging and this is from a very lofi kitchen system using a Raspberry Pi 3 + a Justboom Amphat connected to Rodgers Wall speakers , to what I am listening to now which is a fully active system of Raspberry Pi 4 2gb plus a HiFiBerry Digi Pro+ feeding a MiniDSP DDRC 24HD acting as digital crossover , DAC and Pre amp then feeding two x Quad 405 power amplifiers into four (Stacked ) KEF 103 reference speakers one amp for each side . Inj each case and in all of my other systems by only changing the Music Server to a Pi 4 8gb they have become more nautral and detailed in a good way . This is using the Pi 4 8gb with a standard Raspberry pi PSU so no help there and it is just a straight swap of one for the other.

    I have switched back to the Pi 2gb and the drop in quality is very noticable things become just less musical and a swithc back has my partner asking what have I changed . I am delighted with this gain but frankly I have no way of rationalising what is causing the increase in sound quality . All i can be sure of is in my system and with my music and my ears this is real . It may be something that is worht looking at if you are planning to start your own system and having either a standlaone Pi music server or a Player / Server set up . The Pi 4 8gb is more expensive but I for one think it is well worth the extra . Next thing is to make a cheap but quiet Linear Power Supply Unit for the Raspberry Pi 4 8gb and see if that pushed the sound quality a little further .

    15. Juli 2020 at 6:41 #49315

    Hi Bencat57,

    Super interesting and thank you for sharing your experience. I am one of the (probably) few people out there using an RPi with Max2Play to deliver music to my Linn system – setup:

    Raspberry Pi 4B 4GB
    iFi iPower 5V Power Supply (yes it works despite 5V)
    Max2Play (Beta) Buster Image 2.52
    Logitech Media Server 7.9.2
    UPnP/DLNA Bridge Plugin *

    … wireless connection to …

    1. NAS with FLAC/MP3/Playlists
    2. Linn Majik DSM/2 * via UPnP/DLNA Bridge Plugin

    The Pi has no dedicated sound card HAT installed, and serves purely as a streamer/transport to the Linn.

    Given your experience, I am obviously keen to try out an RPi 4 8GB.

    I am wondering, are you using LMS to transcode your music before sending it on its way to the players? If yes, could the transcoding step be where the additional RAM and increased performance make a difference?

    16. Juli 2020 at 9:53 #49341

    Hi it has been many years since I looked at the full settings I have on my LMS so apologies for the delay in answering . I have checked and as I thought my LMS is just sending all files in Native FLAC (all the tracks in my Library are in FLAC) . So the Pi 8gb is doing no rendering itself just acting as the gateway and sending the files to my various netwrok players .

    So again there has been no change other than the direct switch from a 4 gb to an 8 gb which should really given how little use a server I am led to believe is putting on a Pi . I have had many people tell me I was wasting my money using anything bigger than a 2 gb unit and that even the Pi 4 is overkill . However I value the Pi 4 for its increased sommthness and response time and it just makes the use of LMS that bit nicer . Now I have the issue if the 8 gb unit is the exact same board and construction except for the Ram increase which is what I am led to believe is the case then why does that simple addition of more Ram make the sound quality better . I have no idea but as they say take all the gains you can .

    9. August 2020 at 13:20 #49515

    Einige Probleme mit m2m auf dem Raspy4. Habe geraume Zeit m2m als reinen Squeeze Player auf dem 3er ohne Probleme genutzt. DAC ist der Ruby im Creek Evolution. Würde mir bei Squeeze Einstellungen auch immer angezeigt (HW Evolution, plughw Evolution etc.). Soundkarte none.
    Beim 4er (mit 2.50 und 2.52 getestet):
    Evolution wird manchmal kurz angezeigt. Dann sind sie wieder verschwunden. Also die vorhandenen probiert. Plughw Brava funktionierte. Aber auch nur für gewisse Zeit (30-50 min.). Dann läuft die Wiedergabe zwar noch, es kommt aber nichts mehr an. Webinterface ist erreichbar, keine Besonderheiten erkennbar, aber als wäre usb Ausgang auf einmal abgeschaltet. Temperatur geprüft, 47 Grad.2ten 4er versucht, Netzteil und usb ausgetauscht. Andere Sd karte verwendet. Ergebnis ist gleich.
    Dann versucht Über das webinterface alle Pakete upzudaten. Ergebnis: …Sie verwenden keinen Raspberry..und nichts mehr möglich.
    Also wieder neu angefangen mit Image etc

    Irgendeine Idee??

Viewing 30 posts - 91 through 120 (of 135 total)

You must be logged in to reply to this topic.

Register here