Using the input-function of Hifiberry DAC+ ADC Pro

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Using the input-function of Hifiberry DAC+ ADC Pro

This topic contains 7 replies, has 5 voices, and was last updated by  MarioM Moderator 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 1. November 2019 at 12:25 #47460

    I am interested in feeding the squeezebox server with the signal of my analog turntable. The DAC+ ADC Pro has an input-function and I am wondering if there is a way.

    Using 2 Raspberry Pi 3 and 2 Zero W as a Multiroom system.

    Thank you for your feedback.

    5. November 2019 at 16:11 #47472

    Hi hans,

    Your project sounds interesting! Please let us know whether it worked and share your experiences with us! We are always looking forward to new Max2Play projects from our community.

    17. November 2019 at 22:20 #47548

    Hi hans,

    the mentioned link worked for me so far – using the ADC with an „logitech bluetooth adapter“/“direct-line-in“ by mobile phone.

    Be carful about the wavin-favourite-url which has to be namend „wavin:sysdefault“ instead of „wavin:default“ in my case – as this is the name of my card named under „audioplayer/advanced options/soundcard“ in max2play.

    Sound has a lag of up to 5 sec before starting/stopping playback. / Volume-output on mobile-phone has to be very low, otherwise there will be peaks & scratches in the playback – this might be solved in regulating the inputpeak somewhere, but i haven’t found the option yet.

    good luck!

    17. November 2019 at 23:18 #47549

    Well, no luck so far from my side.

    Using the Rpi 3 and a preamp with my turntable and following the procedures of the mentioned link.

    Streaming works fine (spotify, radio etc.) but the analog input does not work. I tried wavin:default and wavin:sysdefault, both are not working.

    Any hints are welcome 🙂

    Hans

    • This reply was modified 11 months, 2 weeks ago by  hans hamburg.
    20. Mai 2020 at 16:47 #48826

    Hi everyone,

    just a quick update on Waveinput with Max2Play: If you use the Waveinput plugin in the LMS, enter „wavin:plughw:1“ as the URL when adding a favorite. The number behind „plughw:“ corresponds to the slot assigned to your sound card. Use the „arecord -l“ command (small L) to find out which one it is.

    25. Mai 2020 at 11:19 #48849

    Hi MarioM

    Thanks for the tip, were you using Raspbian or a M2P build?
    With M2P i have setup a LMS without the player locally installed but I can’t this working; my Squeezelite Player syncs with LMS and plays the waveinput favorite but nothing is playing through.

    Kane

    26. Mai 2020 at 15:08 #48858

    Hi Kane,

    I tested it with the Max2Play distribution and the HiFiBerry DAC+ ADC. For it to work, the LMS must run on the device that has the sound card with input attached.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here