Nojelc

Forum Replies Created

Viewing 30 posts - 1 through 30 (of 41 total)
  • Posted in:
  • 7. Juli 2020 at 11:04 #49189

    I have managed to do this now. I think it would be a very good idea if the standard max2play image had a folder with write permissions as standard. What I was trying to do was not unusual, just a standard Squeezebox addon requirement. I do not think I should have had to spend several hours fighting through various technicalities of Linux without having a clue what I was doing, in order to achieve a standard result.

    If anyone else has similar problems this is what I did :
    – Used Putty to signin with User : Pi and password : max2play
    – sudo su – to get the necessary privilages
    – mkdir /usr/custbrow – to create a new directory
    – chmod ugo+rwx /usr/custbrow – to give the required access permissions
    – exit

    Everything then worked.

    5. Juli 2020 at 22:50 #49188

    I have spent another hour on this, trying to do this with Putty. The trouble is that I do not have a clue what I am doing.

    Please advise :
    – User and password to sign on (I have looked on all the wikis and helps but cannot even sign in yet)
    – Command to create a directory with the necessary write permissions for Custom Browse

    Thanks

    5. Juli 2020 at 11:13 #49187

    I now have a problem with setting things back up as they were. I use the Custom Browse addon to create the menus I want. When I try to save the config file I get the following : Error saving /media/usb1/Custom Browse Config/artists.cb.values.xml:Permission denied

    I do remember having this before, but cannot remember how I solved it. I cannot find a folder I can write to. Even if I try the usb drive as above I get Permission denied

    4. Juli 2020 at 22:57 #49185

    Well I finally got it working. I burnt a new image and set it up as per the above. Having got the new installation working I went back to the old one (on a different SD card) and tried again, removing the DAC, rebooting, reinstalling etc etc. No way could I get Kodi to recognise the DAC. I still have no idea why it did not work before.

    Now I just need to rebuild my system with all my max2play, LMS and Kodi addons, which seems a bit daunting as I installed some of these about 3 years ago and cannot remember what I did to get them working as I want them.

    Still at least I have good quality audio. Thanks for the help.

    2. Juli 2020 at 21:09 #49175

    I have just checked my order # 200005344 Order Date: 22 October 2017

    This specifies that I have a 1 x Raspberry Pi 3 Model B i.e. the same as you used. So why does it work for you but not for me?

    I created a new image of max2play in November, see above, but that did not work either.

    1. Juli 2020 at 20:47 #49171

    Just another thought. The text against that checkbox says „Disable Build-In-Audio (remove HDMI/Headphone Jack and put any other connected audiocard on position 0). This may be necessary to get the HifiBerry AMP+ working.“

    Whatever I do with that checkbox, set or not set, Kodi audio always goes via HDMI to my TV. So it seems that checking that box does nothing, i.e. it is not removing HDMI or putting my audio card on position 0 – hence Kodi cannot see it.

    I do remember that when it was working originally I was instructed to set my sound card in Rasberry settings to Hifi Berry – and that worked for a while. I think it was probably when the list of soundcards in the pull down box in Rasberry settings was extended that it all went wrong and stopped working for me.

    1. Juli 2020 at 20:29 #49170

    OK. Sounds encouraging, but you will have to talk me through that a bit more as I still cannot get it to work.

    I went to Raspberry settings and found this : Disable Build-In-Audio – Which already had a tick in it – I remember from previous efforts to get this going that this was required to be ticked to get my DAC working. Anyway just in case this was wrong I removed the tick, saved and rebooted. Back in Kodi Audio settings this made no difference. Then put the tick back and saved, rebooted, then back to Kodi Audio settings, still no difference.

    Is the „Disable Build-In-Audio“ the setting you were referring to? I cannot see anything else similar in Raspberry settings.

    Also I am accessing Kodi audio settings via Settings/System Settings/Audio/Audio output device – is that correct?

    Just to be clear my DAC and amp work perfectly with Squeezelite.

    1. Juli 2020 at 10:46 #49133

    Oh how I wish it was as simple as that! Squeezelite stops automatically when I start Kodi, and starts again when I stop it. Stopping Squeezelite manually before starting Kodi makes no difference.

    Please note I have had this problem for about 2 years now, and I have spent hours trying to solve it, e.g. downloading a new max2play image and setting everything back from scratch. Whatever I do I simply cannot get Kodi to recognise my DAC as an output device.

    When I fist purchased my Audiophonics DAC from you it did work fine, then with an update it never worked again. This has to be a bug in the system somewhere.

    Please investigate, see if you can get Kodi output to an Audiophonics DAC. If you can tell me how to do it – please.

    30. Juni 2020 at 6:22 #49115

    Sorry if this is a duplicate but I cannot see it in the thread so reposting it :

    Well here we are 6 months later and I still cannot get audio from KODI to go to my Audiophonics DAC and hence my amp. So still getting crappy audio from my TV. Every time a new version of Max2Play is downloaded I eagerly try to get it working again. It never does, everything stays just the same. I just cannot get Kodi to recognise my DAC.

    This did work fine when I first got the DAC, then some update arrived and it has never worked again.

    PLEASE DO TRY TO HELP ME GET THIS WORKING. It is very annoying to have purchased what I thought was a top quality DAC from you only to not have it work propery with your system.

    Debug information from audio player follows :

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    30. Juni 2020 at 6:17 #49113

    I am not sure what has happened here. I posted about my ongoing problems with getting KODI output to go to my Audiophonics DAC and hence Amp. I then spotted an error so edited my message. It then seemed to dissappear ???

    Edit – so see if it happens again ???

    • This reply was modified 1 year, 5 months ago by  Nojelc.
    29. Dezember 2019 at 15:16 #47844

    Just posting in this old thread to advise that Win32 Disk Imager, running on a windows PC, does read an image on an SD card without a problem. I have just done it to create a backup my image, it worked no problem at all

    Note that BalenaEtcher is now recommended, but Win32 Disk Imager has always worked for me.

    29. Dezember 2019 at 15:03 #47843

    Well I finally got around to doing this i.e. I downloaded the latest max2play image and burnt it to another SD card and put it in my Pi.

    It booted up fine albeit as a virgin copy without any of my LMS or Kodi add-ons. I updated to the latest version of Kodi which appeared to go OK.

    Then the big test, could I get audio output from Kodi via my Audiophonics I-Sabre V3 Dac, to my amp. No I could not. Apart from there being just one ALSA setting in the Kodi Audio output options, everything else was just the same. As before audio output only available via HDMI and my TV.

    As I was facing a big task to reload and configure all of my add-ons, without any advantage that I could see I have reverted to my original image, which is working just as I want it with this one exception.

    So how is everyone alse doing with Kodi output? Is it just the Audiophonics DAC that does not work properly? Do other DACs appear as expected in the Kodi Audio output settings options?

    Do I have any other hardware options to to get Kodi output to my amp?

    Any information to help solve this problem would be much appreciated.

    6. Dezember 2019 at 15:52 #47703

    I am using max2play 2.51

    here is debug info from Settings/Reboot

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 15183928 3304848 11237824 23% /
    devtmpfs 435668 0 435668 0% /dev
    tmpfs 440276 72 440204 1% /dev/shm
    tmpfs 440276 6280 433996 2% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 440276 0 440276 0% /sys/fs/cgroup
    /dev/mmcblk0p1 61384 22808 38576 38% /boot
    //192.168.1.1/sda5/music 625121248 292618292 332502956 47% /mnt/share
    tmpfs 88056 8 88048 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.08 0.15 0.17 1/258 10436

    #### KERNEL ####
    Linux max2playPi 4.9.39-v7+ #1020 SMP Sat Jul 22 14:21:01 BST 2017 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 8.0 (jessie)
    Release: 8.0
    Codename: jessie

    I have updated Kodi using the update Kodi button. It seemed to run OK. In Settings/System Info it says Kodi 17.4 compiled Sept 17 so 2 years old?

    On the m2p GUI it says
    Kodi (Video) start installation – Replaces current Version: 2:17.4-2~jessie

    If I hit update Kodi again it runs through and says nothing updated so I must be on the latest version

    Nothing seems to have changed. Still no output from Kodi to my DAC and amp.

    Needless to say when playing audio via squeezelite without Kodi running everything works fine.

    • This reply was modified 1 year, 12 months ago by  Nojelc.
    6. Dezember 2019 at 8:32 #47683

    I have tried the two alsa settings (again), and tweaked every other likely setting that I can see this way and that. Nothing makes a difference. I cannot get Kodi audio settings to show my Audiophonics I-Sabre V3 as an option, and I cannot get audio output from Kodi going to it.

    2 years ago when I got my DAC it did work, you told me to select sysdefault_hifiberry as my DAC. That option has now disappeared. I have tried all of the many other current hifiberry options, none of them work.

    I am OK with speach from Kodi going to my TV, but when it comes to music I much prefer to hear that via my DAC, amp and speakers. Please, how can I get this to work

    19. November 2019 at 17:23 #47551

    OK. I selected none in Audiophonics plugin, rebooted and reselected the Sabre then rebooted again.

    I still cannot see my DAC in the Kodi audio output settings. Just the same 5 options as before.

    Here is the audioplayer debug info .

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    24. Oktober 2019 at 18:05 #47430

    Reviving this 2 year old thread as once again I cannot get audio from Kodi to play through my dacv and amp. It was working fine but now it does not, presumably after a M2P or KODI update

    In Rasberry settings I have Disable Build-In-Audio check box ticked, but I do not see my soundcard or sysdefault_hifiberry listed in Kodi Audio Settings, only 3 x Pi and 2 x ALSA settings. The PI HDMI options send audio to my TV by HDMI as you would expect, no output received with either ALSA option selected.

    n.b. I have my DAC specified in settings as Audiophonics I-Sabre V3, not sysdefault_hifiberry as before. I do not see this option now, just lots of specific hifiberry options.

    How do I enable Kodi audio via my DAC and amp again please?

    • This reply was modified 2 years, 1 month ago by  Nojelc.
    10. März 2019 at 10:47 #44729

    OK I have done all that, my m2p is now activated again. Also if I hit Update Max2Play I get the message „Running Check for Plugin Updates and install if available. Max2Play is up to date – no update required“ So I clearly have a connection to your server. However the Health Checker is still red saying „Internet: NO Connection“. All very strange!

    Perhaps this is also why Kodi is buffering so much?

    I will continue to investigate, if you have any ideas to help me diagnose the problem please advise.

    7. März 2019 at 19:55 #44700

    Let’s ignore the Kodi issue for now. Why does my GUI say there is no internet connection?

    I took this screenshot while internet radio was playing, so there was certainly a connection.

    I have tried connecting with a different network cable, and also via wifi. The result is always the same, I get a connection but the Health checker is always red – No connection.

    Hopefully you should be able to see that image – it is a screenshot of my M2P GUI

    • This reply was modified 2 years, 9 months ago by  Nojelc.
    • This reply was modified 2 years, 9 months ago by  Nojelc.
    17. Oktober 2018 at 7:21 #38648

    I am trying to get around this problem by attaching the drive to my Router (ASUS DSL-AC68U). If I set the drive up on the router with guest access i.e. no user or password required, then I can set up the mountpoint on the M2P GUI and it works fine.

    However I would rather have it password protected. If I set it up on the router without guest access and set the mointpoint on M2P with the suggested syntax i.e. user=name,password=pass,sec=ntlm,iocharset=utf8,vers=1.0
    I get the following error.

    Filesystem – mount network paths (Samba or NFS)
    umount: /mnt/share: not mounted
    Entry deleted
    Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    The error message does not make sense i.e. it says „No such device or address“, when it has been perfectly happy with the device/address when it was not password protected.

    Any ideas? Where do I find the mount.cifs(8) manual page?

    • This reply was modified 3 years, 1 month ago by  Nojelc.
    • This reply was modified 3 years, 1 month ago by  Nojelc.
    16. Oktober 2018 at 10:16 #38635

    My Max USB-Current setting is enabled. My power supply is the Linear Power Supply 6V / 3.5A / 25VA – Audiophonics I-Sabre V4 DAC, purchased from you last year.

    I have tried various combinations but everything is just as it was before.
    – One of my drives never connects. There is an audible tick/ping from the drive every 20/30 seconds. However this drive works perfectly when attached to a PC or my router, and it has previously worked fine with both of my Pi M2P setups.
    – The other drive connects OK, but after a while it disconnects. It connects again with restart of M2P

    14. Januar 2018 at 23:11 #33416

    I have created a backup of my max2play image very easily with my method 3) above. If you already have Win32 Disk Imager, e.g. used to create your Max2play SD card in the first place then this seems by far the easiest method. What I did was the following.
    1) Removed the SD card from my Pi and put it in a card reader attached to my PC.
    2) Used Win32 Disk Imager to read the SD card and write an image file to my PC.
    3) Formatted another SD card with the SD format utility (it had a Rasbian image on it, without a SD format the write fails)
    4) Used Win32 Disk Imager to write the file just created onto the second SD card.
    5) Booted my Pi from the second card. It came up perfectly with all my configuration as on the first card.

    So I now have a duplicate SD card image, and an image file for my max2play configuration stored on my PC. Perfect!

    • This reply was modified 3 years, 10 months ago by  Nojelc.
    • This reply was modified 3 years, 10 months ago by  Nojelc.
    14. Januar 2018 at 8:24 #33400

    At long last I have solved this problem. It was nothing to do with the Pi or max2play. It was a dodgy connection on an Ethernet plug that I used to connect the device to my router. It had been in place and working for over 10 years, but then started to work intermitantly. When it chose to work and when it did not led me down all sorts of pointless routes. e.g. it often did not work on my new Pi, then it always seemed to work on my old Odroid, so I thought the Pi was dodgy. Then I got a new Pi and it always seemed to work again, which confirmed my view that the old Pi was dodgy. Then the new Pi went off line after my wife did some cleaning and moved the wires; that finally led me to diagnose the problem. A quick squeeze with the plug crimping tool and we were back in business.

    Just how many hours have I wasted …..

    8. Januar 2018 at 23:14 #33310

    Not as simple as that unfortunately. It was just not connected, no IP, nothing on the router. It did sometimes connect briefly following a reboot, but then disconnected. After several years of running max2play on Odroid and PI I have never seen this problem before. As per my last posting I decided that it had to be a hardware problem, so I purchased another PI, installed it in my Audiophonics set up, and it connected fine. So I think it must be a hardware problem. I will install Raspbian on it and see how it performs with that.

    But why would plugging a USB optical drive into a Pi cause hardware damage?

    4. Januar 2018 at 11:32 #33224

    OK so I took the SD card out again, formatted it with SD Format utility again and burnt the image again. Then rebooted the PI. M2P desktop came up on my TV but it did not connect to my router (Ethernet cable plugged in), so no GUI

    Something fundamentally wrong here but I do not have a clue what.

    During the boot sequence it does come up with a message in red saying that all dhcpcd services could not be started – perhaps that is relevant?

    Edit:
    Well I have given up on this for now. Sometimes it connects briefly on restart then disconnects, but mostly it just does not bother. This is with a new install of m2p on the SD card, so there cannot be a problem with that.

    I have gone back to my old Odroid m2p and that connects and works with no problem at all. So there is no problem with my network.

    So the only thing I can think is that plugging in a USB optical drive into my Pi3 has caused some hardware damage. That seems most unlikely but I cannot see any other possibility. Can anyone?

    4. Januar 2018 at 11:31 #33223

    Some progress. This was not a permissions problem. It was because the SD card needed to be formatted by the special SD format utility. There were 2 partitions on the card. It needed to be cleaned out completely. Seems like this is a common-ish problem with Win32 Disk Imager, it took me a long time to identify the problem. The solution was here https://www.raspberrypi.org/forums/viewtopic.php?t=4949

    I suggest that in your guide you add something like „If you get „Error 5 Access is denied“, then format the drive with the SD Format utility.“ That would have saved me about 3 hours of effort and frustration.

    Having created the image on the SD card I booted the Pi and the GUI came up no problem. I activated it, set up my sound card and the power button add-on.

    Then the damn thing rebooted and has been inaccessible ever since. I did not expand file system or update m2p. Now I cannot access the GUI.It is up and running, connected to my router, but I cannot access it. http://max2play just takes me to max2play.com after a pause.

    NO GUI !! What did I do wrong? What do I do next?

    3. Januar 2018 at 19:03 #33207

    Well things are not going too well!

    I decided my m2p image must be corrupt so decided to download and re-burn the SD card. I followed all the instructions up to the point where I hit „Write“. I then get a write error „An error occured while attempting to write data to handle. Error 5 Access is denied.

    I think this is a Windows 10 permissions problem, I ran Win32 Disk Imager using „Run as Administrator“ – and my account has administrator status. This made no difference – sill Error 5 Access is denied.

    I formatted the card and it is now available as a drive in Explorer, and I can save files to it.

    What do I do next?

    11. November 2017 at 8:22 #32414

    Problem solved!

    To help me set up Kodi with add-ons, network shares, favorites etc. I had attached a mouse to my Pi. I was also using the mouse to start Kodi from the max2play desktop. Doing it this way caused Squeezelite and Kodi to run concurrently, with the result that I had the problems reported above.

    When I started Kodi from the m2p gui, squeezelite stopped and the hifiberry appeared in my Kodi audio output options, and everything worked as it should do.

    9. November 2017 at 18:53 #32394

    I am still having problems with this. With the Disable Build-In-Audio box unchecked I get Kodi Audio output options of HDMI, Analogue, both of these and ALSA: Default (bcm2835 ALSA ……

    If I check the Disable Build-In-Audio box and reboot the ALSA option disappears but no hifiberry option appears, just the HDMI and analogue options.

    It may be relevant that Squeezelite is not deactivated when I start KODI. I can play music on my amp from Sqeezelight at the same time as KODI audio is on my TV via HDMI ??

    • This reply was modified 4 years ago by  Nojelc.
    7. November 2017 at 18:20 #32335

    Actually I do still have a problem. While output from Squeezelite goes to my amp via the DAC OK, output from Kodi only goes via HDMI to my TV. I have tried various things but I cannot get Kodi audio to go to my amp. How do I do this?

    6. November 2017 at 8:22 #32301

    OK, that fixed it. Audio OK now.
    It would be helpful if this was explained in the documentation, or better on the Audiophonics GUI.
    Perhaps a dummy entry for the Sabre that pointed to – sysdefault_hifiberry, would be best.

Viewing 30 posts - 1 through 30 (of 41 total)