Cannot get audio output from Kody via DAC, only HDMI.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot get audio output from Kody via DAC, only HDMI.

This topic contains 21 replies, has 3 voices, and was last updated by  Nojelc 3 months, 3 weeks ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • 1. November 2019 at 5:57 #47458

    Reposting help request in this new thread as old thread where I originally posted this problem said „SOLVED“in the title, perhaps that is why I did not get an answer? The problem is that I cannot get audio output from Kodi to my DAC and amp, only via HDMI to my TV.

    I have a Audiophonics I-Sabre V3, I have been using it for 2 years. Originally I got audio output from Kodi by setting my DAC type to sysdefault_hifiberry, which was not very intuitive, but it worked. However it stopped working a while ago, presumably with an update.

    In Rasberry settings I have „Disable Build-In-Audio“ check box ticked, and Squeezelite is stopped. However I do not see my soundcard or sysdefault_hifiberry listed in Kodi Audio Settings, only 3 x Pi and 2 x ALSA settings. The PI HDMI options send audio to my TV by HDMI as you would expect, no output received with either ALSA option selected.

    I have my DAC specified in settings as Audiophonics I-Sabre V3, but I cannot get Kodi to recognise it. How do I enable Kodi audio via my DAC and amp again please?

    15. November 2019 at 11:10 #47535

    Hi Nojelc,

    Please try selecting none in Audiophonics plugin, rebooting and reselecting the Sabre and reboot.

    Then you can check the audioplayer debug info to see if slot 0 is occupied by the hifiberry driver.

    19. November 2019 at 17:23 #47551

    OK. I selected none in Audiophonics plugin, rebooted and reselected the Sabre then rebooted again.

    I still cannot see my DAC in the Kodi audio output settings. Just the same 5 options as before.

    Here is the audioplayer debug info .

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    27. November 2019 at 13:07 #47607

    Hi Nojelc,

    The recognition of the snd_hifiberry driver should indicate that the card is at least being recognized by the system.
    Please try the two alsa settings if you haven’t. Perhaps Kodi changed the output options labels.

    6. Dezember 2019 at 8:32 #47683

    I have tried the two alsa settings (again), and tweaked every other likely setting that I can see this way and that. Nothing makes a difference. I cannot get Kodi audio settings to show my Audiophonics I-Sabre V3 as an option, and I cannot get audio output from Kodi going to it.

    2 years ago when I got my DAC it did work, you told me to select sysdefault_hifiberry as my DAC. That option has now disappeared. I have tried all of the many other current hifiberry options, none of them work.

    I am OK with speach from Kodi going to my TV, but when it comes to music I much prefer to hear that via my DAC, amp and speakers. Please, how can I get this to work

    6. Dezember 2019 at 12:41 #47696

    Hi Nojelc,

    Which version of Max2Play (debug from Settings/Reboot) and which version of Kodi do you have?

    Have you tried the upgrading Kodi button yet?

    6. Dezember 2019 at 15:52 #47703

    I am using max2play 2.51

    here is debug info from Settings/Reboot

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 15183928 3304848 11237824 23% /
    devtmpfs 435668 0 435668 0% /dev
    tmpfs 440276 72 440204 1% /dev/shm
    tmpfs 440276 6280 433996 2% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 440276 0 440276 0% /sys/fs/cgroup
    /dev/mmcblk0p1 61384 22808 38576 38% /boot
    //192.168.1.1/sda5/music 625121248 292618292 332502956 47% /mnt/share
    tmpfs 88056 8 88048 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.08 0.15 0.17 1/258 10436

    #### KERNEL ####
    Linux max2playPi 4.9.39-v7+ #1020 SMP Sat Jul 22 14:21:01 BST 2017 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 8.0 (jessie)
    Release: 8.0
    Codename: jessie

    I have updated Kodi using the update Kodi button. It seemed to run OK. In Settings/System Info it says Kodi 17.4 compiled Sept 17 so 2 years old?

    On the m2p GUI it says
    Kodi (Video) start installation – Replaces current Version: 2:17.4-2~jessie

    If I hit update Kodi again it runs through and says nothing updated so I must be on the latest version

    Nothing seems to have changed. Still no output from Kodi to my DAC and amp.

    Needless to say when playing audio via squeezelite without Kodi running everything works fine.

    • This reply was modified 10 months, 4 weeks ago by  Nojelc.
    11. Dezember 2019 at 11:57 #47742

    Hi Nojelc,

    Thanks for the quick update.

    The jessie image upon which your current install is based has by now been replaced by Raspbian Buster (and previously also by Raspbian Stretch). If you have the possibility, please try making a backup of your current install with our image burner and try out the newest Max2Play image based on Buster to make sure the issue is not connected to your hardware and check whether it persists with this newer version. This image also includes a slightly newer version of Kodi.

    29. Dezember 2019 at 15:03 #47843

    Well I finally got around to doing this i.e. I downloaded the latest max2play image and burnt it to another SD card and put it in my Pi.

    It booted up fine albeit as a virgin copy without any of my LMS or Kodi add-ons. I updated to the latest version of Kodi which appeared to go OK.

    Then the big test, could I get audio output from Kodi via my Audiophonics I-Sabre V3 Dac, to my amp. No I could not. Apart from there being just one ALSA setting in the Kodi Audio output options, everything else was just the same. As before audio output only available via HDMI and my TV.

    As I was facing a big task to reload and configure all of my add-ons, without any advantage that I could see I have reverted to my original image, which is working just as I want it with this one exception.

    So how is everyone alse doing with Kodi output? Is it just the Audiophonics DAC that does not work properly? Do other DACs appear as expected in the Kodi Audio output settings options?

    Do I have any other hardware options to to get Kodi output to my amp?

    Any information to help solve this problem would be much appreciated.

    30. Juni 2020 at 6:17 #49113

    I am not sure what has happened here. I posted about my ongoing problems with getting KODI output to go to my Audiophonics DAC and hence Amp. I then spotted an error so edited my message. It then seemed to dissappear ???

    Edit – so see if it happens again ???

    • This reply was modified 4 months ago by  Nojelc.
    30. Juni 2020 at 6:22 #49115

    Sorry if this is a duplicate but I cannot see it in the thread so reposting it :

    Well here we are 6 months later and I still cannot get audio from KODI to go to my Audiophonics DAC and hence my amp. So still getting crappy audio from my TV. Every time a new version of Max2Play is downloaded I eagerly try to get it working again. It never does, everything stays just the same. I just cannot get Kodi to recognise my DAC.

    This did work fine when I first got the DAC, then some update arrived and it has never worked again.

    PLEASE DO TRY TO HELP ME GET THIS WORKING. It is very annoying to have purchased what I thought was a top quality DAC from you only to not have it work propery with your system.

    Debug information from audio player follows :

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dac, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dac, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    30. Juni 2020 at 14:52 #49129

    Hi Nojelc,

    Please try to stop Squeezelite (and maybe disable its autostart) and restart Kodi. Then you should be able to select the sound output in Kodi’s audio settings. Does your soundcard output work with other services such as Squeezelite?

    1. Juli 2020 at 10:46 #49133

    Oh how I wish it was as simple as that! Squeezelite stops automatically when I start Kodi, and starts again when I stop it. Stopping Squeezelite manually before starting Kodi makes no difference.

    Please note I have had this problem for about 2 years now, and I have spent hours trying to solve it, e.g. downloading a new max2play image and setting everything back from scratch. Whatever I do I simply cannot get Kodi to recognise my DAC as an output device.

    When I fist purchased my Audiophonics DAC from you it did work fine, then with an update it never worked again. This has to be a bug in the system somewhere.

    Please investigate, see if you can get Kodi output to an Audiophonics DAC. If you can tell me how to do it – please.

    1. Juli 2020 at 14:45 #49169

    Hi Nojelc,

    I tested the whole thing with a fresh stretch image and the Pi 3B. In fact, I didn’t get the right sound output either. After I deactivated the integrated audio of the Pi in the Raspberry settings and restarted the Pi, the correct sound output was then displayed in Kodi.

    1. Juli 2020 at 20:29 #49170

    OK. Sounds encouraging, but you will have to talk me through that a bit more as I still cannot get it to work.

    I went to Raspberry settings and found this : Disable Build-In-Audio – Which already had a tick in it – I remember from previous efforts to get this going that this was required to be ticked to get my DAC working. Anyway just in case this was wrong I removed the tick, saved and rebooted. Back in Kodi Audio settings this made no difference. Then put the tick back and saved, rebooted, then back to Kodi Audio settings, still no difference.

    Is the „Disable Build-In-Audio“ the setting you were referring to? I cannot see anything else similar in Raspberry settings.

    Also I am accessing Kodi audio settings via Settings/System Settings/Audio/Audio output device – is that correct?

    Just to be clear my DAC and amp work perfectly with Squeezelite.

    1. Juli 2020 at 20:47 #49171

    Just another thought. The text against that checkbox says „Disable Build-In-Audio (remove HDMI/Headphone Jack and put any other connected audiocard on position 0). This may be necessary to get the HifiBerry AMP+ working.“

    Whatever I do with that checkbox, set or not set, Kodi audio always goes via HDMI to my TV. So it seems that checking that box does nothing, i.e. it is not removing HDMI or putting my audio card on position 0 – hence Kodi cannot see it.

    I do remember that when it was working originally I was instructed to set my sound card in Rasberry settings to Hifi Berry – and that worked for a while. I think it was probably when the list of soundcards in the pull down box in Rasberry settings was extended that it all went wrong and stopped working for me.

    2. Juli 2020 at 21:09 #49175

    I have just checked my order # 200005344 Order Date: 22 October 2017

    This specifies that I have a 1 x Raspberry Pi 3 Model B i.e. the same as you used. So why does it work for you but not for me?

    I created a new image of max2play in November, see above, but that did not work either.

    3. Juli 2020 at 15:13 #49179

    Hi Nojelc,

    That’s strange. Just to be sure, here is my setup workflow:

    1. Burn new Stretch Image 2.49 (Download from: https://www.max2play.com/en/max2play-image/ )
    2. Boot, choose manufacturer Audiophonics, within the Audiophonics Plugin choose the V3 DAC, save, reboot
    3. Activate License
    4. Update Max2Play
    5. Disable Built-in-Audio in Raspberry Settings
    6. Start Kodi, go to Settings/System Settings/Audio/Audio output device –> correct audio output is already preselected

    Please try these steps again and see if the problem still persists.

    4. Juli 2020 at 22:57 #49185

    Well I finally got it working. I burnt a new image and set it up as per the above. Having got the new installation working I went back to the old one (on a different SD card) and tried again, removing the DAC, rebooting, reinstalling etc etc. No way could I get Kodi to recognise the DAC. I still have no idea why it did not work before.

    Now I just need to rebuild my system with all my max2play, LMS and Kodi addons, which seems a bit daunting as I installed some of these about 3 years ago and cannot remember what I did to get them working as I want them.

    Still at least I have good quality audio. Thanks for the help.

    5. Juli 2020 at 11:13 #49187

    I now have a problem with setting things back up as they were. I use the Custom Browse addon to create the menus I want. When I try to save the config file I get the following : Error saving /media/usb1/Custom Browse Config/artists.cb.values.xml:Permission denied

    I do remember having this before, but cannot remember how I solved it. I cannot find a folder I can write to. Even if I try the usb drive as above I get Permission denied

    5. Juli 2020 at 22:50 #49188

    I have spent another hour on this, trying to do this with Putty. The trouble is that I do not have a clue what I am doing.

    Please advise :
    – User and password to sign on (I have looked on all the wikis and helps but cannot even sign in yet)
    – Command to create a directory with the necessary write permissions for Custom Browse

    Thanks

    7. Juli 2020 at 11:04 #49189

    I have managed to do this now. I think it would be a very good idea if the standard max2play image had a folder with write permissions as standard. What I was trying to do was not unusual, just a standard Squeezebox addon requirement. I do not think I should have had to spend several hours fighting through various technicalities of Linux without having a clue what I was doing, in order to achieve a standard result.

    If anyone else has similar problems this is what I did :
    – Used Putty to signin with User : Pi and password : max2play
    – sudo su – to get the necessary privilages
    – mkdir /usr/custbrow – to create a new directory
    – chmod ugo+rwx /usr/custbrow – to give the required access permissions
    – exit

    Everything then worked.

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Register here