[SOLVED] Audio output from Audiophonics I-Sabre V3 DAC

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Audio output from Audiophonics I-Sabre V3 DAC

This topic contains 8 replies, has 2 voices, and was last updated by  Nojelc 1 week, 4 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 30. October 2017 at 14:39 #32194

    I have now recieved my new m2p bundle – Audiophonics I-Sabre V3 DAC Bundle with Raspberry Pi and Max2Play
    Everything up and running but I cannot get audio output to my amp via the sound card. I can only get sound via HDMI to my TV.
    On the Audiophonics page of the wab interface the sound card is appearing correctly. I have selected the ‘Advanced’ i.e. multi room config as I use LMS with multiple players.

    However on the Audioplayer tab on the interface I see no reference to my soundcard, so I cannot set it up to output as required. All I see is a load of options in the audio output section under Squeezelight advanced options, but non of these make any sense to me and none seem to refer to my sound card, just various ALSA and hifiberry options.

    Sorry if I am being rather thick – but how do I progress and get this working?

    • This topic was modified 3 weeks, 2 days ago by  Nojelc.
    • This topic was modified 3 weeks, 2 days ago by  Nojelc.
    • This topic was modified 2 weeks, 1 day ago by  Heiner.
    1. November 2017 at 11:26 #32228

    Hi Nojelc,

    Sorry about the confusion. I know it seems counter-intuitive, but the right output device for your Sabre is sysdefault_hifiberry…

    Also, check the command line options and if there’s a “hw:0” in there, make sure to deactivate build-in audio in the Raspberry Settings.

    6. November 2017 at 8:22 #32301

    OK, that fixed it. Audio OK now.
    It would be helpful if this was explained in the documentation, or better on the Audiophonics GUI.
    Perhaps a dummy entry for the Sabre that pointed to – sysdefault_hifiberry, would be best.

    7. November 2017 at 17:25 #32330

    Hi Nojelc,

    Thanks for the input, we will consider adding this to a future release for clarity.

    7. November 2017 at 18:20 #32335

    Actually I do still have a problem. While output from Squeezelite goes to my amp via the DAC OK, output from Kodi only goes via HDMI to my TV. I have tried various things but I cannot get Kodi audio to go to my amp. How do I do this?

    8. November 2017 at 15:09 #32350

    Hi Nojelc,

    You should be able to select the hifiberry output in Kodi’s settings as well. If it is not listed, please deactivate build-in audio in the Raspberry Settings of our web interface, after a reboot it should definitely be listed.

    9. November 2017 at 18:53 #32394

    I am still having problems with this. With the Disable Build-In-Audio box unchecked I get Kodi Audio output options of HDMI, Analogue, both of these and ALSA: Default (bcm2835 ALSA ……

    If I check the Disable Build-In-Audio box and reboot the ALSA option disappears but no hifiberry option appears, just the HDMI and analogue options.

    It may be relevant that Squeezelite is not deactivated when I start KODI. I can play music on my amp from Sqeezelight at the same time as KODI audio is on my TV via HDMI ??

    • This reply was modified 1 week, 6 days ago by  Nojelc.
    10. November 2017 at 11:38 #32401

    Hi Nojelc,

    In this case, the Squeezelite player hogs the output. Usually, Squeezelite should shut down automatically when you start Kodi, allowing the output to be freed up. Please try removing the autostart from Squeezelite, rebooting and starting Kodi.

    11. November 2017 at 8:22 #32414

    Problem solved!

    To help me set up Kodi with add-ons, network shares, favorites etc. I had attached a mouse to my Pi. I was also using the mouse to start Kodi from the max2play desktop. Doing it this way caused Squeezelite and Kodi to run concurrently, with the result that I had the problems reported above.

    When I started Kodi from the m2p gui, squeezelite stopped and the hifiberry appeared in my Kodi audio output options, and everything worked as it should do.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here