[SOLVED] Audio output from Audiophonics I-Sabre V3 DAC

Max2Play Home Forums Max2Play on Raspberry PI [SOLVED] Audio output from Audiophonics I-Sabre V3 DAC

Viewing 11 posts - 1 through 11 (of 11 total)
  • 30. Oktober 2017 at 14:39 #32194

    I have now recieved my new m2p bundle – Audiophonics I-Sabre V3 DAC Bundle with Raspberry Pi and Max2Play
    Everything up and running but I cannot get audio output to my amp via the sound card. I can only get sound via HDMI to my TV.
    On the Audiophonics page of the wab interface the sound card is appearing correctly. I have selected the ‚Advanced‘ i.e. multi room config as I use LMS with multiple players.

    However on the Audioplayer tab on the interface I see no reference to my soundcard, so I cannot set it up to output as required. All I see is a load of options in the audio output section under Squeezelight advanced options, but non of these make any sense to me and none seem to refer to my sound card, just various ALSA and hifiberry options.

    Sorry if I am being rather thick – but how do I progress and get this working?

    • This topic was modified 6 years, 5 months ago by Nojelc.
    • This topic was modified 6 years, 5 months ago by Nojelc.
    • This topic was modified 6 years, 5 months ago by Heiner.
    1. November 2017 at 11:26 #32228

    Hi Nojelc,

    Sorry about the confusion. I know it seems counter-intuitive, but the right output device for your Sabre is sysdefault_hifiberry…

    Also, check the command line options and if there’s a „hw:0“ in there, make sure to deactivate build-in audio in the Raspberry Settings.

    6. November 2017 at 8:22 #32301

    OK, that fixed it. Audio OK now.
    It would be helpful if this was explained in the documentation, or better on the Audiophonics GUI.
    Perhaps a dummy entry for the Sabre that pointed to – sysdefault_hifiberry, would be best.

    7. November 2017 at 17:25 #32330

    Hi Nojelc,

    Thanks for the input, we will consider adding this to a future release for clarity.

    7. November 2017 at 18:20 #32335

    Actually I do still have a problem. While output from Squeezelite goes to my amp via the DAC OK, output from Kodi only goes via HDMI to my TV. I have tried various things but I cannot get Kodi audio to go to my amp. How do I do this?

    8. November 2017 at 15:09 #32350

    Hi Nojelc,

    You should be able to select the hifiberry output in Kodi’s settings as well. If it is not listed, please deactivate build-in audio in the Raspberry Settings of our web interface, after a reboot it should definitely be listed.

    9. November 2017 at 18:53 #32394

    I am still having problems with this. With the Disable Build-In-Audio box unchecked I get Kodi Audio output options of HDMI, Analogue, both of these and ALSA: Default (bcm2835 ALSA ……

    If I check the Disable Build-In-Audio box and reboot the ALSA option disappears but no hifiberry option appears, just the HDMI and analogue options.

    It may be relevant that Squeezelite is not deactivated when I start KODI. I can play music on my amp from Sqeezelight at the same time as KODI audio is on my TV via HDMI ??

    • This reply was modified 6 years, 5 months ago by Nojelc.
    10. November 2017 at 11:38 #32401

    Hi Nojelc,

    In this case, the Squeezelite player hogs the output. Usually, Squeezelite should shut down automatically when you start Kodi, allowing the output to be freed up. Please try removing the autostart from Squeezelite, rebooting and starting Kodi.

    11. November 2017 at 8:22 #32414

    Problem solved!

    To help me set up Kodi with add-ons, network shares, favorites etc. I had attached a mouse to my Pi. I was also using the mouse to start Kodi from the max2play desktop. Doing it this way caused Squeezelite and Kodi to run concurrently, with the result that I had the problems reported above.

    When I started Kodi from the m2p gui, squeezelite stopped and the hifiberry appeared in my Kodi audio output options, and everything worked as it should do.

    24. Oktober 2019 at 18:05 #47430

    Reviving this 2 year old thread as once again I cannot get audio from Kodi to play through my dacv and amp. It was working fine but now it does not, presumably after a M2P or KODI update

    In Rasberry settings I have Disable Build-In-Audio check box ticked, but I do not see my soundcard or sysdefault_hifiberry listed in Kodi Audio Settings, only 3 x Pi and 2 x ALSA settings. The PI HDMI options send audio to my TV by HDMI as you would expect, no output received with either ALSA option selected.

    n.b. I have my DAC specified in settings as Audiophonics I-Sabre V3, not sysdefault_hifiberry as before. I do not see this option now, just lots of specific hifiberry options.

    How do I enable Kodi audio via my DAC and amp again please?

    • This reply was modified 4 years, 6 months ago by Nojelc.
    13. November 2019 at 13:57 #47523

    Hi Nojelc,

    If you haven’t please try selecting none rebooting and reselecting your sound card.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here