Problems with USB drives

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Problems with USB drives

This topic contains 4 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 14. Oktober 2018 at 12:43 #38599

    I have 2 Pi based Max2Play setups in 2 houses. When I travel between then I just take a USB drive with my music and plug it in. Until recently everything has worked fine for quite a while. Recently however I returned to house A after 5 months at house B, I updated M2P from 2.46 to 2.47. When I plugged the USB drive in (Western Digital 1GB) it did not connect. There was an audible tick/ping from the drive every 20/30 seconds. I then plugged the drive into a Windows PC and it worked fine, I scanned for errors and none were found. I plugged it back into the Pi and the same thing happened. It had been working for 5 months in house B with Pi B, with no problem.

    I then tried another drive that holds my backups. That connected and worked fine …. for a while. It then for no apparent reason disconnected. The GUI said no drive connected. I can connect again by rebooting the Pi, then I can use it. However some time later, maybe hours or the next day, it has disconnected again and I have to reboot.

    These seem like to different problems, but perhaps they are connected? Are there any known problems with this version of M2P and USB drives?

    • This topic was modified 1 month ago by  Nojelc.
    15. Oktober 2018 at 9:41 #38614

    Hi Nojelc,

    This might be a power supply issue. Make sure you have max USB current active in RPi settings and make sure your PSU has at least 2.5A.

    16. Oktober 2018 at 10:16 #38635

    My Max USB-Current setting is enabled. My power supply is the Linear Power Supply 6V / 3.5A / 25VA – Audiophonics I-Sabre V4 DAC, purchased from you last year.

    I have tried various combinations but everything is just as it was before.
    – One of my drives never connects. There is an audible tick/ping from the drive every 20/30 seconds. However this drive works perfectly when attached to a PC or my router, and it has previously worked fine with both of my Pi M2P setups.
    – The other drive connects OK, but after a while it disconnects. It connects again with restart of M2P

    17. Oktober 2018 at 7:21 #38648

    I am trying to get around this problem by attaching the drive to my Router (ASUS DSL-AC68U). If I set the drive up on the router with guest access i.e. no user or password required, then I can set up the mountpoint on the M2P GUI and it works fine.

    However I would rather have it password protected. If I set it up on the router without guest access and set the mointpoint on M2P with the suggested syntax i.e. user=name,password=pass,sec=ntlm,iocharset=utf8,vers=1.0
    I get the following error.

    Filesystem – mount network paths (Samba or NFS)
    umount: /mnt/share: not mounted
    Entry deleted
    Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    The error message does not make sense i.e. it says „No such device or address“, when it has been perfectly happy with the device/address when it was not password protected.

    Any ideas? Where do I find the mount.cifs(8) manual page?

    • This reply was modified 1 month ago by  Nojelc.
    • This reply was modified 1 month ago by  Nojelc.
    17. Oktober 2018 at 13:42 #38658

    Hi Nojelc,

    That’s just the general linux manual, the output comes directly from the Raspbian which Max2Play is based on.

    Try setting up a very simple login name and pw, no special characters.
    Make sure the router uses the same protocol for protected shares.

    For reference, you can also follow our wiki articles on mounting, specifically the German Fritz.Box share manual.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here