Corrupt Max2Play – I think – Help

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Corrupt Max2Play – I think – Help

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 8 months, 1 week ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 3. Januar 2018 at 0:49 #33192

    This all appeared to start when I connected a USB CD/DVD Drive to my Audiophonics I-Sabre V3 DAC Bundle with Raspberry Pi and Max2Play.
    I was hoping to play a DVD with Kodi. However it all went wrong.

    My M2P became unresponsive so I did a restart. After starting the M2P desktop was showing on my TV but it was not connected to my Network even though it is connected by Ethernet cable. I could not access the M2P GUI and my Router did not show that the device was connected. After multiple restarts and various efforts to get it connected I did manage to get it connected to my router and the GUI up but it gave me the message

    „Device is started in Automatic Accesspoint Mode. For security, only WiFi configuration is possible to connect Max2Play to your local network“

    Which meant nothing to me but may be a clue as to what the problem is?

    Now there is no way that I can get the unit connected. The M2P desktop and Kodi show on my TV screen, but any attempt to connect to my network in Kodi results in the message „Invalid Argument“ and „Server not found“. My SB players and controllers cannot connect either. My Router is not reporting any connection on that cable/port.

    It looks to me like I have managed to corrupt my Max2Play image. Is there anything I can do to stop it starting in Automatic Accesspoint Mode if that is the problem. Otherwise I guess I have to download and reinstall m2p on the SD card, and then spend ages setting it all up again? – boo hoo.

    • This topic was modified 8 months, 2 weeks ago by  Nojelc.
    3. Januar 2018 at 19:03 #33207

    Well things are not going too well!

    I decided my m2p image must be corrupt so decided to download and re-burn the SD card. I followed all the instructions up to the point where I hit „Write“. I then get a write error „An error occured while attempting to write data to handle. Error 5 Access is denied.

    I think this is a Windows 10 permissions problem, I ran Win32 Disk Imager using „Run as Administrator“ – and my account has administrator status. This made no difference – sill Error 5 Access is denied.

    I formatted the card and it is now available as a drive in Explorer, and I can save files to it.

    What do I do next?

    4. Januar 2018 at 11:31 #33223

    Some progress. This was not a permissions problem. It was because the SD card needed to be formatted by the special SD format utility. There were 2 partitions on the card. It needed to be cleaned out completely. Seems like this is a common-ish problem with Win32 Disk Imager, it took me a long time to identify the problem. The solution was here https://www.raspberrypi.org/forums/viewtopic.php?t=4949

    I suggest that in your guide you add something like „If you get „Error 5 Access is denied“, then format the drive with the SD Format utility.“ That would have saved me about 3 hours of effort and frustration.

    Having created the image on the SD card I booted the Pi and the GUI came up no problem. I activated it, set up my sound card and the power button add-on.

    Then the damn thing rebooted and has been inaccessible ever since. I did not expand file system or update m2p. Now I cannot access the GUI.It is up and running, connected to my router, but I cannot access it. http://max2play just takes me to max2play.com after a pause.

    NO GUI !! What did I do wrong? What do I do next?

    4. Januar 2018 at 11:32 #33224

    OK so I took the SD card out again, formatted it with SD Format utility again and burnt the image again. Then rebooted the PI. M2P desktop came up on my TV but it did not connect to my router (Ethernet cable plugged in), so no GUI

    Something fundamentally wrong here but I do not have a clue what.

    During the boot sequence it does come up with a message in red saying that all dhcpcd services could not be started – perhaps that is relevant?

    Edit:
    Well I have given up on this for now. Sometimes it connects briefly on restart then disconnects, but mostly it just does not bother. This is with a new install of m2p on the SD card, so there cannot be a problem with that.

    I have gone back to my old Odroid m2p and that connects and works with no problem at all. So there is no problem with my network.

    So the only thing I can think is that plugging in a USB optical drive into my Pi3 has caused some hardware damage. That seems most unlikely but I cannot see any other possibility. Can anyone?

    8. Januar 2018 at 10:26 #33289

    Hi Nojelc,

    Sorry about the late reply, I am still catching from the holiday break 😉

    If you are having trouble accessing the device with „max2play“, try entering the IP instead and check your router’s web interface to make sure the device is still recognized and has not gotten a new IP.

    8. Januar 2018 at 23:14 #33310

    Not as simple as that unfortunately. It was just not connected, no IP, nothing on the router. It did sometimes connect briefly following a reboot, but then disconnected. After several years of running max2play on Odroid and PI I have never seen this problem before. As per my last posting I decided that it had to be a hardware problem, so I purchased another PI, installed it in my Audiophonics set up, and it connected fine. So I think it must be a hardware problem. I will install Raspbian on it and see how it performs with that.

    But why would plugging a USB optical drive into a Pi cause hardware damage?

    11. Januar 2018 at 10:41 #33352

    Hi Nojelc,

    If the drive has no autonomous power supply, the Pi might not get enough power. However, this should not result in immediate hardware damage but rather just some dropouts.

    In any case, I am happy to hear your setup is working again. 🙂

    14. Januar 2018 at 8:24 #33400

    At long last I have solved this problem. It was nothing to do with the Pi or max2play. It was a dodgy connection on an Ethernet plug that I used to connect the device to my router. It had been in place and working for over 10 years, but then started to work intermitantly. When it chose to work and when it did not led me down all sorts of pointless routes. e.g. it often did not work on my new Pi, then it always seemed to work on my old Odroid, so I thought the Pi was dodgy. Then I got a new Pi and it always seemed to work again, which confirmed my view that the old Pi was dodgy. Then the new Pi went off line after my wife did some cleaning and moved the wires; that finally led me to diagnose the problem. A quick squeeze with the plug crimping tool and we were back in business.

    Just how many hours have I wasted …..

    15. Januar 2018 at 14:48 #33442

    Hi Nojelc,

    Thanks for the follow-up. I’m happy you found the source of the problems 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here