ErwinB

Forum Replies Created

Viewing 17 posts - 1 through 17 (of 17 total)
  • Posted in:
  • 8. April 2020 at 20:30 #48424

    Just a suggestion MarioM, for as far as I can determine I switched to the pi4 and the beta image around august 2019 and I can upgrade just fine either from within max2play (r pi settings) or ssh using apt-get upgrade.
    Did the image change since then or maybe the downloadable image got corrupted?

    8. Oktober 2019 at 12:39 #47248

    Just out of curiosity, how are you „Manually“ switching between the 7″ display and HDMI?

    I am asking because the only way I found so far is to edit the config.txt file, disable the 7″ display here and reboot.
    Any other way so far results in the PI displaying JiveLite on the 7″ and a desktop on the HDMI. If I then start Kodi, Kodi runs on the 7″ and the HDMI goes black. And there is no other display listed in the Kodi configuration.

    4. Oktober 2019 at 12:12 #47229

    Hi Heiner,

    Late response but I tried with force hotplug. It makes no difference unfortunately.
    When Kodi starts the tv screen goes from the desktop to black (as before) but Kodi displays on the lcd.

    Would it be possible to add a disable LCD option to the RPi Display plugin that adds or removes the ignore_lcd=1 line to the config.txt file?

    30. September 2019 at 22:24 #47203

    Thanks Heiner I will give it a try but I don’t expect much from this. The Pi turns on my tv+receiver when booting and displays the desktop so it’s not like the tv isn’t being detected i guess.
    Last weekend I was able to get it sort of working (Kodi on my tv). Well actually it works but involves modifying the boot/config.txt and rebooting to use Kodi and doing the reverse to get the touchscreen again. So working but not really user friendly 🙂

    I did this by adding:
    display_default_lcd=0
    ignore_lcd=1
    Not sure if the display_default_lcd=0 is still necessary because the ignore_lcd=1 part disables the touchscreen.
    Save the file and reboot and you will only have the hdmi port.

    I also tried to disable the onboard sound with dtparam=audio=off to get my Hifiberry digi+ to work in Kodi (other thread) but that does not work for me. But this is not really a problem for me.

    25. September 2019 at 12:50 #47150

    I was able to install Kodi 18.4. First I got an error during installation but after removing the „old“ Kodi it worked.
    It is running BUT: I cannot get it to display on my tv.
    I have a Raspberry 4/4GB with the 7″ touchscreen. Kodi always loads on the touchscreen and does not detect my tv.
    Also when I disable the rpi display -> lcd as default display setting and reboot.
    When I do this the touchscreen „mouse“ movements are shown on the tv (that is displaying a desktop screen). So dragging on the touchscreen draws a rectangle on the tv’s desktop screen.

    Is there a known (other) way to force Kodi to the TV instead of the touchscreen?

    25. August 2019 at 17:31 #46836

    For others who want to use their pi 4 for more then just max2play at the same time and who do need root access for Winscp and the likes. You can enable root access with „sudo passwd root“ to assign a password to the root user and using „sudo nano /etc/ssh/sshd_config“ to uncomment PermitRootLogin and set it to „yes“. After this restart sshd with „service sshd restart“. I found most of this information here

    I am by no means an linux expert, I have to google for basically everything. I want to use my raspberry 4 for max2play but also for mqtt, homeassistant and mip etc. With the pi user password I was able to install mosquitto mqtt but I could not copy config files from my current 3b using winscp because the mosquitto files are root user files.
    If anybody knows another way to use winscp to edit/overwrite root user files as the pi user I would love to hear it. Setting shell to „sudo su -“ did not work.

    To be clear, the above degrades security for internet connected devices because, probably among others, it opens up the pi to brute password attacks.

    • This reply was modified 2 years, 3 months ago by  ErwinB.
    24. August 2019 at 10:24 #46832

    Thanks Bencat57 tested and works!

    23. August 2019 at 22:38 #46830

    I re-imaged the sd card. After booting I just selected „skip“ in the audiocard selection and selected the „Advanced: A real multiroom audio player that integrates in a Squeezebox environment with powerful options for high-quality audio and a lot of features.“ option and rebooted.
    Again I can’t login using winscp/putty using pi and password raspberry or root with password max2play like I could with the pre raspberry 4 images.
    What am I doing wrong?

    22. August 2019 at 7:29 #46824

    Yesterday I finally received my Raspberry 4/4GB. I installed a fresh copy of this image did an upgrade plus kernal upgrade and installed Squeezebox server.
    Now I am trying to gain access with Winscp but strangly enough it does not work. I can login neither as root nor as pi.
    Anybody else run into this?

    21. Juli 2019 at 11:42 #46434

    Hi Heiner,
    Sorry for the slow response but I did not see your post was edited.
    That did it.
    Strange thing is that this did not stop the hifiberry driver from loading on stretch, but it does probably explain why I never got lirc to work 🙂

    15. Juli 2019 at 22:30 #46325

    Hi Heiner,
    I think I figured out where it goes wrong for me. I tried installing the image again from scratch but this time I wrote down what I did as I went along.
    Turns out that enabling lirc support seems to be the cause. After enabling lirc on the rasberry settings page and rebooting the audioplayer does not start and the jack is selected in the advanced settings. Disable lirc and reboot and the hifiberry is back.
    Below my shorthand notes of what I did.

    – Burn Image
    – First startup
    – On first webpage load select hifiberry
    – Select digi/digi+ and save
    – Reboot
    – Select audioplayer advanced, hifiberry is selected
    – reboot
    – check – ok
    – activate license
    – install squeezebox 7.9 nightly
    – install raspberry pi touch display plugin
    – select 7″ touchdisplay and start install. During this the following is displayed
    W: –force-yes is deprecated, use one of the options starting with –allow instead.
    E: Unable to locate package tslib
    – reboot
    – check – ok
    – select rotate display and hide mouse pointer – save
    – reboot
    – check – ok
    – start jivelite and check autostart and autohide
    – add -v to audioplayer setting
    – map network drive
    – reboot
    – disable bt/wifi and enable lirc
    – reboot
    – check – error, jack is selected

    – disable lirc – save – reboot, hifiberry is back

    13. Juli 2019 at 14:19 #46302

    Hi Heiner,

    The text on the board is Hifiberry Digi-Pro HW1.2.
    Apparently I have a Pro board not a plus sorry about that

    10. Juli 2019 at 11:08 #46250

    Hi Heiner,
    This is a follow up on my „No Hifiberry digi+ card after upgrade to Buster“ post.
    So yesterday evening I installed this beta package on a clean SD card and ran it on my 3B+ with the Hifiberry Digi+ board.
    It installed just fine and everything seemed to be ok and I’m pretty sure (but not 100%) I saw the digi+ was detected by Squeezelite.
    At that moment I could not test the audio output as „the boss“ was using the receiver 😉
    This morning I thought I would do a quick test. Unfortunately now Squeezelite had a status of not started again and the soundcard was on jack again. The PI was not turned off during the night btw.
    I selected none in the Hifiberry interface and restarted, now Squeezelite was auto started but with one of the bcm2815 settings again.
    Selected the Digi+ in hifiberry interface and restarted, again the jack output was selected and no hifiberry choices availablein the list.
    When I re-installed my Stretch SD card the Digi+ was again detected and working.
    Maybe its just me, but I feel something is not 100% for the 3B+ with this image or rather Buster as an upgrade from Stretch to Buster resulted in the same problem for me.

    Is there anybody out there with an older Pi and a HifiBerry board running Buster successfully???

    9. Juli 2019 at 10:40 #46219

    Hi Heiner,

    I know about the beta. The whole idea of using the upgrade path instead was the hope I would not have to reinstall all other programs like musicip, mosquitto (mqtt), homeassistant etc when my PI 4 4GB comes in to replace my Pi 3B+. Not being a linux person reinstalling is a pain in the …
    Maybe I will install the beta tonight on an other sd card just to see if the digi+ works then.

    Thanks for your support.

    8. Juli 2019 at 23:54 #46206

    Well, removed the sd card, made a backup image of the buster install and then restored my stretch backup image.
    Now the digi+ is detected and working so it’s not defective nor a connection problem.
    Now I’m doubting if I will restore the buster image again and try again or just wait a little bit for everything to catch up (with buster)

    8. Juli 2019 at 13:18 #46191

    Digi+ selected in the hifiberry plugin, squeezelite not starting advanced options using the jack option. Here is the debug section.
    #### SQUEEZELITE VERSION ####
    Squeezelite v1.9.0-1105, Copyright 2012-2015 Adrian Smith, 2015-2018 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE VISEXPORT IR GPIO RPI DSD LINKALL

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    usbstream:CARD=ALSA – bcm2835 ALSA – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    #### SOUNDDEVICES IN USE ####
    USER PID ACCESS COMMAND
    /dev/snd/controlC0: root 424 f…. alsactl
    pi 1224 F…. pulseaudio

    8. Juli 2019 at 11:49 #46188

    Hi Heiner,
    The touchscreen seems to have resolved itself somehow fortunately.

    When I set the audiocard from none to digi+ and reboot, squeezelite does not start and in advanced settings „jack-JACK Audio connection kit“ is selected. When I try to start squeezelite it fails. If I change the setting to one of the bcm2835 ALSA options (no digi+ available) I can start squeezelite but no sound out of the digi+ of course.
    The boot/config.txt does contain the dtoverlay=hifiberry-digi line at the bottom but no clue what I can check further

Viewing 17 posts - 1 through 17 (of 17 total)