Kodi on Raspberry pi 4 not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Kodi on Raspberry pi 4 not working

This topic contains 8 replies, has 4 voices, and was last updated by  ErwinB premium 1 year, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 28. Juli 2019 at 5:47 #46507

    hi i am a premium member and using Raspberry Pi 4 – Development Version -250 facing an issue with Kodi. I am unable to play kodi. I have tried from web interface to turn on Kodi but getting an error like kodi not running. Also i tried from desktop by clicking kodi desktop shortcut but faced the same issue. I can see kodi is present in ‚user/share‘ but still not working. Please help me on this. I am using raspberry pi 4 2gb board and ALLO Sound card.

    29. Juli 2019 at 9:42 #46515

    Hi niladridm,

    The currently implemented version of Kodi is a beta based on the current status of Kodi development for Raspbian Buster. It’s running with our testers but with subpar performance and we are currently looking for a better alternative.

    That being said, it should generally start albeit slowly. Do you see the desktop? If so, have you tried starting it from the shortcut there?

    15. September 2019 at 22:01 #47088

    The Kodi 18.4 Leia, Raspbian Buster for Raspberry Pi4 repository is available.

    pipplware.pplware.pt/pipplware/dists/buster/main/binary

    Guide, installation procedure :
    https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=251645

    16. September 2019 at 13:56 #47094

    Thanks for letting us know, mcdrone! Have you tried it yet?

    21. September 2019 at 17:50 #47127

    Well, yes.

    I was able to get Kodi running without having to go through „kodi-standalone“ startup command from the graphical user x environment. Or clicking on the kodi shortcut.

    After that I screwed up the apt sources and I need to try again.

    I was able to install kodi-18.4-leia.

    But the startup crashed.

    I will try again.

    25. September 2019 at 12:50 #47150

    I was able to install Kodi 18.4. First I got an error during installation but after removing the „old“ Kodi it worked.
    It is running BUT: I cannot get it to display on my tv.
    I have a Raspberry 4/4GB with the 7″ touchscreen. Kodi always loads on the touchscreen and does not detect my tv.
    Also when I disable the rpi display -> lcd as default display setting and reboot.
    When I do this the touchscreen „mouse“ movements are shown on the tv (that is displaying a desktop screen). So dragging on the touchscreen draws a rectangle on the tv’s desktop screen.

    Is there a known (other) way to force Kodi to the TV instead of the touchscreen?

    30. September 2019 at 10:35 #47198

    Hi Erwin,

    Have you tried the Raspberry Settings for HDMI yet?

    Try the tick with „Force Hotplug“ and reboot.

    30. September 2019 at 22:24 #47203

    Thanks Heiner I will give it a try but I don’t expect much from this. The Pi turns on my tv+receiver when booting and displays the desktop so it’s not like the tv isn’t being detected i guess.
    Last weekend I was able to get it sort of working (Kodi on my tv). Well actually it works but involves modifying the boot/config.txt and rebooting to use Kodi and doing the reverse to get the touchscreen again. So working but not really user friendly 🙂

    I did this by adding:
    display_default_lcd=0
    ignore_lcd=1
    Not sure if the display_default_lcd=0 is still necessary because the ignore_lcd=1 part disables the touchscreen.
    Save the file and reboot and you will only have the hdmi port.

    I also tried to disable the onboard sound with dtparam=audio=off to get my Hifiberry digi+ to work in Kodi (other thread) but that does not work for me. But this is not really a problem for me.

    4. Oktober 2019 at 12:12 #47229

    Hi Heiner,

    Late response but I tried with force hotplug. It makes no difference unfortunately.
    When Kodi starts the tv screen goes from the desktop to black (as before) but Kodi displays on the lcd.

    Would it be possible to add a disable LCD option to the RPi Display plugin that adds or removes the ignore_lcd=1 line to the config.txt file?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here