No Hiffiberry digi+ card after upgrade to Buster

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions No Hiffiberry digi+ card after upgrade to Buster

This topic contains 8 replies, has 2 voices, and was last updated by  ErwinB premium 1 year, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 7. Juli 2019 at 15:35 #46175

    I upgraded my (Raspberry 3B+) Max2Play Stretch installation to Buster which on its own seems to work on the second try.
    After the upgrade I have one problem and a challenge.

    The problem is my hifiberry digi+. Its not shown in the squeezelite sound card list. I have changed multiple times from hifiberry digi+ to none and back again in both the hifiberry plugin page as well as on the raspberry settings page (rebooting each time), upgraded to the latest max2play beta on the settings/reboot page etc but still no hifiberry choice available in the squeezelite sound card list.
    Does somebody have a clue what might be the problem here?

    The, minor, challenge is that after upgrading the jivelite screen seems to big for the 7″ display I’m using. Both the righthand as the bottom side miss a part of the screen. On the right hand side I miss a piece of the max2play logo and on the bottom I miss the play/pause etc buttons.
    I figured out that the screen resolution was not at 800×480 (for the 7″ screen) but 700 something. I changed this by editing the config.txt file and adding framebuffer_width=800 and framebuffer_height=480. This works but now the calibration of the touchscreen seems off.
    I have found several sites with info on how to calibrate „a“ touchscreen on the PI but I have never needed to do this before so I think something else is causing this?

    8. Juli 2019 at 11:33 #46187

    Hello ErwinB,

    When you set the digi+ and reboot, what is the output device selected in the Audioplayer’s advanced settings afterwards?

    With the touchscreen, you should be able to just run the install of the 7″ and have it calibrated and configured right after.
    Have you tried resetting and reinstalling yet?

    8. Juli 2019 at 11:49 #46188

    Hi Heiner,
    The touchscreen seems to have resolved itself somehow fortunately.

    When I set the audiocard from none to digi+ and reboot, squeezelite does not start and in advanced settings „jack-JACK Audio connection kit“ is selected. When I try to start squeezelite it fails. If I change the setting to one of the bcm2835 ALSA options (no digi+ available) I can start squeezelite but no sound out of the digi+ of course.
    The boot/config.txt does contain the dtoverlay=hifiberry-digi line at the bottom but no clue what I can check further

    8. Juli 2019 at 12:38 #46189

    Hi Erwin,

    Please copy and paste the audioplayer debug info when the Digi+ is selected.

    Your description of the problem seems to indicate that the card is somehow physically not recognized by the Pi anymore.

    8. Juli 2019 at 13:18 #46191

    Digi+ selected in the hifiberry plugin, squeezelite not starting advanced options using the jack option. Here is the debug section.
    #### SQUEEZELITE VERSION ####
    Squeezelite v1.9.0-1105, Copyright 2012-2015 Adrian Smith, 2015-2018 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE VISEXPORT IR GPIO RPI DSD LINKALL

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    usbstream:CARD=ALSA – bcm2835 ALSA – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    #### SOUNDDEVICES IN USE ####
    USER PID ACCESS COMMAND
    /dev/snd/controlC0: root 424 f…. alsactl
    pi 1224 F…. pulseaudio

    8. Juli 2019 at 16:30 #46198

    Yes, it seems the card is not actually recognized by the system, which might mean that it is defective otherwise not connected.

    Please try physically remounting the sound card, to make sure there is not connector problem.

    8. Juli 2019 at 23:54 #46206

    Well, removed the sd card, made a backup image of the buster install and then restored my stretch backup image.
    Now the digi+ is detected and working so it’s not defective nor a connection problem.
    Now I’m doubting if I will restore the buster image again and try again or just wait a little bit for everything to catch up (with buster)

    9. Juli 2019 at 10:20 #46215

    Hi Erwin,

    Glad to hear it. Your best bet is to use our new Buster release and migrate if you prefer to run Buster. So far, the image seems to work with most plugins and we appreciate any feedback to get it out of beta asap.

    9. Juli 2019 at 10:40 #46219

    Hi Heiner,

    I know about the beta. The whole idea of using the upgrade path instead was the hope I would not have to reinstall all other programs like musicip, mosquitto (mqtt), homeassistant etc when my PI 4 4GB comes in to replace my Pi 3B+. Not being a linux person reinstalling is a pain in the …
    Maybe I will install the beta tonight on an other sd card just to see if the digi+ works then.

    Thanks for your support.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here